Subject: [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

From: James N Guichard <[email-masked]>
Date: Sat, 1 Apr 2017 22:06:02 +0000

Greetings WG,

This message begins a two week call for WG adoption of the document https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv/ ending 17th April 2017.

Please respond to the SFC mailing list with any statements of approval or disapproval.

Please note:

  1.  This is not WG last call. The document is not final and the WG is expected to modify the content until there is WG consensus that the content is solid. Therefore, please don't oppose adoption just because you want to see changes to its content.
  2.  If you have objections to adoption of the document, please state your reasons why, and explain what it would take to address your concerns.
  3.  If you have issues with the content, by all means raise those issues and we can begin a dialog about how best to address them.

In addition Sumandra Majee has kindly accepted to shepherd this document should it be accepted as a WG document.

Yours,

Jim & Joel

---

From: James N Guichard <[email-masked]>
Date: Sat, 1 Apr 2017 22:12:49 +0000

Dear WG:

One small correction; Sumandra has accepted to act as editor for the document should it be accepted as a WG document.

Jim

From: sfc [mailto:[email-masked]] On Behalf Of James N Guichard
Sent: Saturday, April 01, 2017 6:06 PM
To: [email-masked]
Subject: [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Greetings WG,

Please note:

Yours,

Jim & Joel

---

From: <[email-masked]>
Date: Mon, 3 Apr 2017 06:05:05 +0000

Hi Jim, all,

I do prefer the call for adoption to be issued on a version that addresses the comments raised during the interim meeting:

·         Many of the TLVs in the document are already defined in other documents (Sections: 2, 3, 5, 11, and 12).

·         The description of some TLVs is really weak. E.g.,

o    Content type (Section 6)

o    Ingress Network Information (Section 7)

o    URI (Section 10)

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de James N Guichard
Envoyé : dimanche 2 avril 2017 00:06
À : [email-masked]
Objet : [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Greetings WG,

Please note:

Yours,

Jim & Joel

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 3 Apr 2017 13:54:17 -0500

On Mon, Apr 3, 2017 at 1:05 AM, <[email-masked]> wrote:

> Hi Jim, all,
>
>
>
> I do prefer the call for adoption to be issued on a version that addresses
> the comments raised during the interim meeting:
>
> ·         Many of the TLVs in the document are already defined in other
> documents (Sections: 2, 3, 5, 11, and 12).
>

Yes, Subscriber/user Information in Section 2 and Host Identifier in
Section 3 are defined elsewhere. Also Application ID in Section 5, and
Metadata 1's in  Sections 11 and 12 need to be removed.

Sumendra, please remove these TLVs.

Regards,

Behcet

> Cheers,
>
> Med
>
>
>
> *De :* sfc [mailto:[email-masked]] *De la part de* James N Guichard
> *Envoyé :* dimanche 2 avril 2017 00:06
> *À :* [email-masked]
> *Objet :* [sfc] Call for adoption of https://datatracker.ietf.org/
> doc/html/draft-quinn-sfc-nsh-tlv
>
>
>
> Greetings WG,
>
>
>
> This message begins a two week call for WG adoption of the document *https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv/
> <https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv/>* ending
> 17th April 2017.
>
>
>
>    1. This is not WG last call. The document is not final and the WG is
>    expected to modify the content until there is WG consensus that the content
>    is solid. Therefore, please don’t oppose adoption just because you want to
>    see changes to its content.
>    2. If you have objections to adoption of the document, please state
>    your reasons why, and explain what it would take to address your concerns.
>    3. If you have issues with the content, by all means raise those
>    issues and we can begin a dialog about how best to address them.
>
>
>
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
>
>

---

From: James N Guichard <[email-masked]>
Date: Mon, 3 Apr 2017 20:02:39 +0000

Hi Med,

As I said this is not a WG last call and it is expected that the WG will modify the content. If this document is adopted by the WG then the editor will make any necessary changes based upon WG consensus.

Jim

From: [email-masked] [mailto:[email-masked]]
Sent: Monday, April 03, 2017 2:05 AM
To: James N Guichard <[email-masked]>; [email-masked]
Subject: RE: Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Hi Jim, all,

o    URI (Section 10)

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de James N Guichard
Envoyé : dimanche 2 avril 2017 00:06
À : [email-masked]<mailto:[email-masked]>
Objet : [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Greetings WG,

Please note:

Yours,

Jim & Joel

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 3 Apr 2017 16:54:00 -0700

Med,

I agree that the changes need to be made, but it’s easier if it becomes a
WG document since the chairs can then appoint the editor and WG consensus
directs the content, not the original author.

Needless to say, I support WG adoption.

Cheers,
Andy

---

From: <[email-masked]>
Date: Tue, 4 Apr 2017 06:00:18 +0000

Hi Jim,

The point is that there was already an agreement to make these changes. Please let's do things in the right order.

Cheers,
Med

De : James N Guichard [mailto:[email-masked]]
Envoyé : lundi 3 avril 2017 22:03
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]
Objet : RE: Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Hi Med,

Jim

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Monday, April 03, 2017 2:05 AM
To: James N Guichard <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Hi Jim, all,

*         Many of the TLVs in the document are already defined in other documents (Sections: 2, 3, 5, 11, and 12).

*         The description of some TLVs is really weak. E.g.,

o    URI (Section 10)

Cheers,
Med

Greetings WG,

Please note:

Yours,

Jim & Joel

---

From: Sumandra Majee <[email-masked]>
Date: Tue, 4 Apr 2017 15:49:49 +0000

Behcet,

>>Yes, Subscriber/user Information in Section 2 and Host Identifier in Section 3 are defined elsewhere.
So basically point to the this f<https://tools.ietf.org/html/draft-sarikaya-sfc-hostid-serviceheader-04>or subscribe/user information.

However why remove the AppID, that is a pretty useful information IMHO.

From: sfc <[email-masked]> on behalf of Behcet Sarikaya <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Monday, April 3, 2017 at 11:54 AM
To: Mohamed Boucadair <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, James N Guichard <[email-masked]>
Subject: Re: [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

On Mon, Apr 3, 2017 at 1:05 AM, <[email-masked]<mailto:[email-masked]>> wrote:
Hi Jim, all,

•         Many of the TLVs in the document are already defined in other documents (Sections: 2, 3, 5, 11, and 12).

•         The description of some TLVs is really weak. E.g.,

o    URI (Section 10)

Yes, Subscriber/user Information in Section 2 and Host Identifier in Section 3 are defined elsewhere. Also Application ID in Section 5, and Metadata 1's in  Sections 11 and 12 need to be removed.

Regards,

Behcet
Cheers,
Med

De : sfc [mailto:[email-masked]<mailto:[email-masked]>] De la part de James N Guichard
Envoyé : dimanche 2 avril 2017 00:06
À : [email-masked]<mailto:[email-masked]>
Objet : [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Greetings WG,

Please note:

  1.  This is not WG last call. The document is not final and the WG is expected to modify the content until there is WG consensus that the content is solid. Therefore, please don’t oppose adoption just because you want to see changes to its content.
  2.  If you have objections to adoption of the document, please state your reasons why, and explain what it would take to address your concerns.
  3.  If you have issues with the content, by all means raise those issues and we can begin a dialog about how best to address them.

Yours,

Jim & Joel

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Tue, 4 Apr 2017 16:58:00 +0000

I support the adoption of the draft.

Paul

On Apr 1, 2017, at 6:12 PM, James N Guichard <[email-masked]<mailto:[email-masked]>> wrote:

Dear WG:

Jim

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Tue, 4 Apr 2017 17:04:13 +0000

There seems to be some confusion.  What we originally discussed is that the TLV draft defines the TLVs themselves.  Optional companion drafts can delve into more specific uses / best practices of a given TLV or TLVs.

On Apr 4, 2017, at 11:49 AM, Sumandra Majee <[email-masked]<mailto:[email-masked]>> wrote:

Behcet,

---

From: Dave Dolson <[email-masked]>
Date: Tue, 4 Apr 2017 17:06:43 +0000

I'd like to understand this position better.
Are you saying this draft is intended to give names to TLVs without providing semantics?
If so, I see no point in that. Standardize TLVs in documents than can fully explain their usage.

From: sfc [mailto:[email-masked]] On Behalf Of Paul Quinn (paulq)
Sent: Tuesday, April 4, 2017 1:04 PM
To: Sumandra Majee
Cc: [email-masked]; James N Guichard
Subject: Re: [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Behcet,

---

From: <[email-masked]>
Date: Wed, 5 Apr 2017 07:07:00 +0000

Hi Sumandra,

AppID falls into this agreement from the interim meeting:

=====
In particular, there is no point in an entry in the common document whose only text is see WFC document X for structure and meaning of this TLV.
=====

Removing the TLV from draft-quinn does not mean that it is not useful. It does only mean that draft-quinn does not provide sufficient information to understand the use case motivating AppID + the meaning of AppID is not specified.

Cheers,
Med

De : Sumandra Majee [mailto:[email-masked]]
Envoyé : mardi 4 avril 2017 17:50
À : [email-masked]; BOUCADAIR Mohamed IMT/OLN
Cc : [email-masked]; James N Guichard
Objet : Re: [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Behcet,

From: sfc <[email-masked]<mailto:[email-masked]>> on behalf of Behcet Sarikaya <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Monday, April 3, 2017 at 11:54 AM
To: Mohamed Boucadair <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, James N Guichard <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

o    URI (Section 10)

Regards,

Behcet
Cheers,
Med

Greetings WG,

Please note:

Yours,

Jim & Joel

---

From: <[email-masked]>
Date: Wed, 5 Apr 2017 07:08:02 +0000

Hi Paul,

There is no confusion at all.

What was agreed is recorded in the SFC interim minutes:

=====
The TLVs with short explanations belong to common TLV doc.; other doc. may define the TLV needing more semantics for a use case. In particular, there is no point in an entry in the common document whose only text is see WFC document X for structure and meaning of this TLV.  In that case, document X should reserve the type code.

Action item:
1.    Editors to remove inappropriate entries
2.    WG to work out mechanism for vendors to create their own MD-2 type codes.
=====

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Paul Quinn (paulq)
Envoyé : mardi 4 avril 2017 19:04
À : Sumandra Majee
Cc : [email-masked]; James N Guichard
Objet : Re: [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Behcet,

---

From: <[email-masked]>
Date: Wed, 5 Apr 2017 08:27:27 +0000

Dear all,
I would second Meds opinion. Why not clean up everything already agreed before (or rather while) moving to next level and upload WG version of the draft?
Best Regards
Dirk

From: sfc [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Dienstag, 4. April 2017 08:00
To: James N Guichard; [email-masked]
Subject: Re: [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Hi Jim,

Cheers,
Med

De : James N Guichard [mailto:[email-masked]]
Envoyé : lundi 3 avril 2017 22:03
À : BOUCADAIR Mohamed IMT/OLN; [email-masked]<mailto:[email-masked]>
Objet : RE: Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Hi Med,

Jim

Hi Jim, all,

o    URI (Section 10)

Cheers,
Med

Greetings WG,

Please note:

Yours,

Jim & Joel

---

From: "Muley, Praveen (Nokia - US/Mountain View)" <[email-masked]>
Date: Wed, 5 Apr 2017 23:11:18 +0000

+1

-Praveen

From: sfc [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, April 05, 2017 1:27 AM
To: [email-masked]; [email-masked]; [email-masked]
Subject: [ALU] Re: [sfc] Call for adoption ofhttps://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Dear all,

From: sfc [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Dienstag, 4. April 2017 08:00
To: James N Guichard; [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] Call for adoption of https://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

Hi Jim,

Cheers,
Med

Hi Med,

Jim

Hi Jim, all,

o    URI (Section 10)

Cheers,
Med

Greetings WG,

Please note:

Yours,

Jim & Joel

---

From: "Van De Velde, Gunter (Nokia - BE/Antwerp)" <[email-masked]>
Date: Thu, 6 Apr 2017 06:22:33 +0000

+1

I would prefer a single location to be used to standardize any type of header and make normative references to those.

Lets do things in the right order please and make sure that there is no intended overlap at all. I am happy to see a WG adoption call on the revised version, but this document is not ready at all.

G/

From: sfc <[email-masked]> on behalf of "Muley, Praveen (Nokia - US)" <[email-masked]>
Date: Thursday, 6 April 2017 at 01:11
To: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: [sfc] [ALU] Re: Call for adoption ofhttps://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv

+1

-Praveen

Dear all,

Hi Jim,

The point is that there was already an agreement to make these changes. Please let’s do things in the right order.

Cheers,
Med

Hi Med,

Jim

Hi Jim, all,

o    URI (Section 10)

Cheers,
Med

Greetings WG,

Please note:

Yours,

Jim & Joel

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 7 Apr 2017 02:48:13 +0000

A WG adoption call is looking for an initial version of a document under control of the WG, not a final perfect all-issues-sorted version. An adopted document does not even need to be full or complete. 

The questions are different — the questions are about whether the problem space is one for which the WG is chartered to solve, and whether the document in question provides an acceptable initial basis for continuing WG efforts on the problem space.

I support adoption of this version of this document.

IMO covers all those criteria (many of which are informationally summarized in the IETF consensus RFC 7221) It is not ready for publication, but it does not need to be.

I believe this document provides a sufficient platform for the WG to continue capturing consensus on the topic. Let’s not let perfect be the enemy of WG progress.

Adopt++.

Thanks,

— Carlos.

> On Apr 6, 2017, at 2:22 AM, Van De Velde, Gunter (Nokia - BE/Antwerp) <[email-masked]> wrote:
> 
> +1
>  
> This message begins a two week call for WG adoption of the documenthttps://datatracker.ietf.org/doc/html/draft-quinn-sfc-nsh-tlv/ ending 17th April 2017.
>  
> 	• This is not WG last call. The document is not final and the WG is expected to modify the content until there is WG consensus that the content is solid. Therefore, please don’t oppose adoption just because you want to see changes to its content.
> 	• If you have objections to adoption of the document, please state your reasons why, and explain what it would take to address your concerns.
> 	• If you have issues with the content, by all means raise those issues and we can begin a dialog about how best to address them.
>