Subject: [sfc] Question About Path Selection in SFC

From: "Boyuan Yan" <[email-masked]>
Date: Mon, 29 May 2017 22:19:27 +0800 (CST)

Hi,
    I'm new here, and have a significant question about SFC actually, that is, how can I execute path selection for specific sfc={vnf1, vnf2, vnf3,...}? Is there any default operation or suggestion?

Thx very much.

--

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 29 May 2017 10:29:22 -0400

I am not sure I understand the question.

The operating model for the SFC Data Plane is that control operations 
decide what paths they wish to have (this can be centralized or 
distributed control).  These paths are then represented by

1) Service Function Path IDs, which are mapped at each SFF, using the 
Service Index, to the specific service functions and the next SFF the 
packet is to be sent to.

2) Initial classifiers (and where needed in-sequence reclassifiers) 
which assign service function path IDs and Indices to packets.

So creating a specific service function path using NSH is done by 
control assigning the needed ID and creating the needed state in SFF and 
classifiers.

Yours,
Joel

On 5/29/17 10:19 AM, Boyuan Yan wrote:
> Hi,
>      I'm new here, and have a significant question about SFC actually, 
> that is, how can I execute path selection for specific sfc={vnf1, vnf2, 
> vnf3,...}? Is there any default operation or suggestion?
> 
> Thx very much.
> 
> 
> 
> --_**_
> 
> 
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
>

---

From: "Boyuan Yan" <[email-masked]>
Date: Mon, 29 May 2017 23:33:58 +0800 (GMT+08:00)

So sorry that I didn't describe it clearly.
As you mentioned above, the paths are decided by control operations. And my question is that how the control plane calculate such paths, which must go through specific nodes where service functions are deployed. I wonder if it is a key problem, because I found little relevant papers. If not, why?

Yours,
Boron

在2017年05月29日 22:29，Joel M. Halpern 写道：
I am not sure I understand the question.

Yours,
Joel