Subject: [sfc] ECN over IP-shim-(L2)-IP Tunnels: New draft-ietf-tsvwg-rfc6040update-shim-03

From: Bob Briscoe <[email-masked]>
Date: Tue, 27 Jun 2017 13:00:01 +0100

David (as doc shepherd),

This is the 3rd revision in the last 2 months. This revision attempts to 
capture all the comments collected thanks to Carlos, Ignacio, Praveen, 
Joe and Alia. It would be useful to have a confirmation from each of you 
that I have addressed your concerns (or not).

I have cross-posted all the lists potentially affected by this draft 
(intended proposed standard).
If you reply concerning a specific point, pls trim the distribution only 
to those interested/relevant.

* tsvwg: owns updates to ECN
* int-area: owns mtce of many tunnelling protocols, particularly GRE?, 
Teredo? GUE
* l2tpext: owns mtce of L2TP
* opsawg: owns mtce of CAPWAP
* nvo3: currently defining Geneve, VXLAN-GPE
* sfc: currently defining NSH

 From my point of view, this draft is now 'finished'. I.e. I am happy 
with it, and it is the first draft where all the ToDo's are done. I 
believe it is on track for the milestone of WGLC before the Nov'17 IETF. 
As I understand it, WGLC will run in tsvwg and in parallel in int-area, 
l2tpext and perhaps opsawg.

Main changes since -02:
* Completely restructured, with definitions of scope before even 
mentioning "tightly coupled shim headers", and new subsections where 
existing text on feasibility and desirability has been re-homed.
* Explanation of the safety problem, and the procedural problem this 
caused when previous ECN RFCs were written (an RFC cannot 
retrospectively set requirements on implementations, so we can only set 
operational requirements - configuration).
* Added NSH, but it doesn't seem to cover encapsulation.
* No longer categorized VXLAN-GPE as intended for standards track
* Added Teredo update text (for safety).

Cheers

Bob

-------- Forwarded Message --------
Subject: 	New Version Notification for 
draft-ietf-tsvwg-rfc6040update-shim-03.txt
Date: 	Tue, 27 Jun 2017 04:13:58 -0700
From: 	[email-masked]
To: 	Bob Briscoe <[email-masked]>

A new version of I-D, draft-ietf-tsvwg-rfc6040update-shim-03.txt
has been successfully submitted by Bob Briscoe and posted to the
IETF repository.

Name:		draft-ietf-tsvwg-rfc6040update-shim
Revision:	03
Title:		Propagating Explicit Congestion Notification Across IP Tunnel Headers Separated by a Shim
Document date:	2017-06-27
Group:		tsvwg
Pages:		16
URL:            https://www.ietf.org/internet-drafts/draft-ietf-tsvwg-rfc6040update-shim-03.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-tsvwg-rfc6040update-shim/
Htmlized:       https://tools.ietf.org/html/draft-ietf-tsvwg-rfc6040update-shim-03
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-tsvwg-rfc6040update-shim-03
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-tsvwg-rfc6040update-shim-03

Abstract:
    RFC 6040 on "Tunnelling of Explicit Congestion Notification" made the
    rules for propagation of ECN consistent for all forms of IP in IP
    tunnel.  This specification updates RFC 6040 to clarify that its
    scope includes tunnels where two IP headers are separated by at least
    one shim header that is not sufficient on its own for wide area
    packet forwarding.  It surveys widely deployed IP tunnelling
    protocols separated by such shim header(s) and updates the
    specifications of those that do not mention ECN propagation (L2TPv2,
    L2TPv3, GRE and Teredo).  This specification also updates RFC 6040
    with configuration requirements needed to make any legacy tunnel
    ingress safe.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: <[email-masked]>
Date: Tue, 27 Jun 2017 14:05:06 +0000

Hi Bob,

NSH is not a transport encapsulation, so I don’t think it makes sense to list it in Section 5 of your draft. Instead of listing NSH I would cite RFC7665. Further, I would replace NSH with RFC7665 in the following text:

OLD:

   The specification of NSH does not currently include the process of
   encapsulation.  It is assumed that ECN propagation will be included
   in whatever encapsulation an NSH implementation uses.

NEW:
   The SFC architecture [RFC7665] does not specify the processing of ECN when handling transport encapsulation.

FWIW, draft-boucadair-sfc-framework that was merged with another document that led to RFC 7665 included the following:

==

8.  ECN (Explicit Congestion Notification) Considerations

   When encapsulating an IP packet, the Ingress Node and each SF Node
   SHOULD follow [RFC6040] for ECN re-marking purposes.
==

There wasn’t an agreement to maintain that text in the sfc architecture because it wasn’t clear at that time whether ECN (and diffserv) marking is “are architectural issues or solution issues”.
Cheers,
Med

De : tsvwg [mailto:[email-masked]] De la part de Bob Briscoe
Envoyé : mardi 27 juin 2017 14:00
À : Black, David; Carlos Pignataro (cpignata); Ignacio Goyret; Alia ATLAS; Praveen Balasubramanian; Joe Touch; [email-masked]; Christian Huitema
Cc : [email-masked]; intarea IETF list; tsvwg IETF list; Service Function Chaining IETF list; l2tp IETF list
Objet : [tsvwg] ECN over IP-shim-(L2)-IP Tunnels: New draft-ietf-tsvwg-rfc6040update-shim-03

David (as doc shepherd),

This is the 3rd revision in the last 2 months. This revision attempts to capture all the comments collected thanks to Carlos, Ignacio, Praveen, Joe and Alia. It would be useful to have a confirmation from each of you that I have addressed your concerns (or not).

I have cross-posted all the lists potentially affected by this draft (intended proposed standard).
If you reply concerning a specific point, pls trim the distribution only to those interested/relevant.

* int-area: owns mtce of many tunnelling protocols, particularly GRE?, Teredo? GUE

From my point of view, this draft is now 'finished'. I.e. I am happy with it, and it is the first draft where all the ToDo's are done. I believe it is on track for the milestone of WGLC before the Nov'17 IETF. As I understand it, WGLC will run in tsvwg and in parallel in int-area, l2tpext and perhaps opsawg.

Main changes since -02:
* Completely restructured, with definitions of scope before even mentioning "tightly coupled shim headers", and new subsections where existing text on feasibility and desirability has been re-homed.
* Explanation of the safety problem, and the procedural problem this caused when previous ECN RFCs were written (an RFC cannot retrospectively set requirements on implementations, so we can only set operational requirements - configuration).
* Added NSH, but it doesn't seem to cover encapsulation.
* No longer categorized VXLAN-GPE as intended for standards track
* Added Teredo update text (for safety).

Cheers

Bob

-------- Forwarded Message --------
Subject:

New Version Notification for draft-ietf-tsvwg-rfc6040update-shim-03.txt

Date:

Tue, 27 Jun 2017 04:13:58 -0700

From:

[email-masked]<mailto:[email-masked]>

To:

Bob Briscoe <[email-masked]><mailto:[email-masked]>

IETF repository.

Revision:     03

Group:        tsvwg

Pages:        16

Abstract:

   ingress safe.

The IETF Secretariat

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 27 Jun 2017 15:07:40 +0000

Hi, Med,

I agree with your assessment of the applicability of rfc6040update to NSH, and in particular also with the changes you are proposing below.

Thanks,

— Carlos.

On Jun 27, 2017, at 10:05 AM, [email-masked]<mailto:[email-masked]> wrote:

Hi Bob,

OLD:

NEW:

==

De : tsvwg [mailto:[email-masked]] De la part de Bob Briscoe
Envoyé : mardi 27 juin 2017 14:00
À : Black, David; Carlos Pignataro (cpignata); Ignacio Goyret; Alia ATLAS; Praveen Balasubramanian; Joe Touch; [email-masked]<mailto:[email-masked]>; Christian Huitema
Cc : [email-masked]<mailto:[email-masked]>; intarea IETF list; tsvwg IETF list; Service Function Chaining IETF list; l2tp IETF list
Objet : [tsvwg] ECN over IP-shim-(L2)-IP Tunnels: New draft-ietf-tsvwg-rfc6040update-shim-03

David (as doc shepherd),

Main changes since -02:

Cheers

Bob

-------- Forwarded Message --------
Subject:

Date:

From:

To:

IETF repository.

Revision:     03

Group:        tsvwg

Pages:        16

Abstract:

   ingress safe.

until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc