Subject: Re: [sfc] Use of Alternate Marking Method in SFC

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 3 Jul 2017 23:58:46 +0000

Hi Greg, Ciao Giuseppe!

Thanks for sharing this document with SFC!

Looking at it, I have three main high-level comments:

  1.  Overall: While clearly I see the usability of this, I wonder if this is too narrow of a solution in presence of things like IOAM that allow to do marking as well as much richer set of performance measurements.
  2.  Syntax: The draft talks about two bits, but their location is not specified! That makes for an IANA Considerations section that is trivial. (or going back to #1, the two bits coulee have easily be placed in IOAM.
  3.  “can be viewed as true example of passive performance” -> The definition from RFC 7799 seems to potentially disagree with this.

Thanks!

Carlos.

On Jun 14, 2017, at 10:53 AM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:

Dear All,
would like to bring your attention to the draft  Performance Measurement (PM) with Alternate Marking Method in Service <https://tools.ietf.org/html/draft-mirsky-sfc-pmamm-00>
Function Chaining (SFC) Domain<https://tools.ietf.org/html/draft-mirsky-sfc-pmamm-00>
we've submitted earlier. Alternate Marking method allows performance measurement performed close to passive measurement methods.
Greatly appreciate your questions, comments, and suggestions.

Regards,
Greg

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

—
Carlos Pignataro, [email-masked]<mailto:[email-masked]>

“Sometimes I use big words that I do not fully understand, to make myself sound more photosynthesis."

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 3 Jul 2017 17:13:07 -0700

Hi Carlos,
we've received the same comment as #2 from Tal and have clarified location
and IANA consideration in version -01.
As for your first question. There are many advantages of Alternate Marking
methods that we will be glad to discuss during our presentation at SFC
meeting in Prague.
We'll improve wording that characterizes alternate marking method as
producing measurement as near passive method according to RFC 7799.

Regards,
Greg

On Mon, Jul 3, 2017 at 4:58 PM, Carlos Pignataro (cpignata) <
[email-masked]> wrote:

>    1. Overall: While clearly I see the usability of this, I wonder if
>    this is too narrow of a solution in presence of things like IOAM that allow
>    to do marking as well as much richer set of performance measurements.
>    2. Syntax: The draft talks about two bits, but their location is not
>    specified! That makes for an IANA Considerations section that is trivial.
>    (or going back to #1, the two bits coulee have easily be placed in IOAM.
>    3. “can be viewed as true example of passive performance” -> The
>    definition from RFC 7799 seems to potentially disagree with this.
>
>
> Thanks!
>
> Carlos.
>
> On Jun 14, 2017, at 10:53 AM, Greg Mirsky <[email-masked]> wrote:
>
> Dear All,
> would like to bring your attention to the draft  Performance Measurement
> (PM) with Alternate Marking Method in Service
> <https://tools.ietf.org/html/draft-mirsky-sfc-pmamm-00> Function Chaining
> (SFC) Domain <https://tools.ietf.org/html/draft-mirsky-sfc-pmamm-00>  we've
> submitted earlier. Alternate Marking method allows performance measurement
> performed close to passive measurement methods.
> [email-masked]
> Carlos Pignataro, [email-masked]
>
> *“Sometimes I use big words that I do not fully understand, to make myself
> sound more photosynthesis."*
>
>

---

From: Tal Mizrahi <[email-masked]>
Date: Tue, 4 Jul 2017 10:02:26 +0300

Hi Carlos,

My perspective regarding #1 (I can't claim to be impartial, since I am
taking part in both IOAM and Alternate Marking :) is that IOAM and
Alternate Marking are not competing technologies, but complementary
technologies. IOAM provides fine-grained measurement with per-packet and
per-hop information, but comes at the cost of extending the data packets.
Alternate Marking, on the other hand, provides very accurate per-flow
measurement, at the cost of 1 or 2 bits per packet. Based on this tradeoff,
some operators may choose to use IOAM, others may use Alternate Marking,
and some may use both.

Cheers,
Tal.

---

From: Dave Dolson <[email-masked]>
Date: Wed, 5 Jul 2017 21:14:14 +0000

(Adding sfc list)
Thanks Greg. I see I reviewed an older document by mistake.
I still feel that the brief theory of operation does a disservice to the document by raising questions, whereas the ippm-alt-mark is much more nuanced and complete.
Having said that, you could pre-amble the theory of operation with, “The following is an over-simplified description for the sake of providing context…”

-Dave

From: Greg Mirsky [mailto:[email-masked]]
Sent: Tuesday, July 4, 2017 7:13 PM
To: Dave Dolson
Subject: Re: [sfc] Use of Alternate Marking Method in SFC

Hi Dave,
many thanks for your interest in this draft and the most helpful comments. I agree that given progress of the Alternate Marking draft at IPPM WG there's no apparent reason to replicate much information in this document (engineers are expected to be able to follow references and links). Couple notes in-line and tagged GIM>>.

Regards,
Greg

On Tue, Jul 4, 2017 at 8:53 AM, Dave Dolson <[email-masked]<mailto:[email-masked]>> wrote:
Greg,
Given that this document doesn’t explain everything—certainly not enough to implement it—consider making this document very simple, and refer to the draft-ietf-ippm-alt-mark for details.
E.g., this document should just contain:
- which NSH bits are used for Single and Double
GIM>> With -01 version that is more specific on Mark field allocation and bit position designation and use.
- which SFC functions are permitted to write the marks (I think just the classifier, but I don’t think you even say this)
GIM>> Very helpful, thank you! Indeed, the Classifier is the most logical function to perform marking for SFC. Though I'd consider making it as strong recommendation thus allowing marking by other functions.
- where should measurements be taken.
GIM>> Measurements may be taken anywhere along the SFP and without any restrictions to packet size, as measurement results been stored locally and may be exported by out-band transport, e.g. YANG notifications (Netconf or Rest), IPFIX, gRPC. That, in my opinion, is advantage of the AM method when compared to, for example, iOAM.

In other words, I suggest removing any intent to describe the theory of operation or algorithm, when draft-ietf-ippm-alt-mark explains it all.

-Dave

From: sfc [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Greg Mirsky
Sent: Wednesday, June 14, 2017 10:54 AM
To: [email-masked]<mailto:[email-masked]>
Cc: Fioccola Giuseppe ([email-masked]<mailto:[email-masked]>)
Subject: [sfc] Use of Alternate Marking Method in SFC

Dear All,

Regards,
Greg

---

From: Stewart Bryant <[email-masked]>
Date: Thu, 6 Jul 2017 19:13:16 +0100

On 04/07/2017 08:02, Tal Mizrahi wrote:
> technologies. IOAM provides fine-grained measurement with per-packet 
> and per-hop information, but comes at the cost of extending the data 
> packets. Alternate Marking, on the other hand, provides very accurate 
> per-flow measurement, at the cost of 1 or 2 bits per packet. Based on 
> this tradeoff, some operators may choose to use IOAM, others may use 
> Alternate Marking, and some may use both.
>
> Cheers,
> Tal.
>

+1

Stewart