
From alberto@it.uc3m.es  Tue Mar  6 09:06:51 2012
Return-Path: <alberto@it.uc3m.es>
X-Original-To: shim6@ietfa.amsl.com
Delivered-To: shim6@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 5C33921F8714; Tue,  6 Mar 2012 09:06:51 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -6.107
X-Spam-Level: 
X-Spam-Status: No, score=-6.107 tagged_above=-999 required=5 tests=[AWL=0.191,  BAYES_00=-2.599, HTML_MESSAGE=0.001, MIME_8BIT_HEADER=0.3, RCVD_IN_DNSWL_MED=-4]
Received: from mail.ietf.org ([12.22.58.30]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id lBllJftbPFNq; Tue,  6 Mar 2012 09:06:44 -0800 (PST)
Received: from smtp02.uc3m.es (smtp02.uc3m.es [163.117.176.132]) by ietfa.amsl.com (Postfix) with ESMTP id 7DE2821F8763; Tue,  6 Mar 2012 09:06:39 -0800 (PST)
X-uc3m-safe: yes
Received: from BOMBO (unknown [163.117.139.62]) (using TLSv1 with cipher AES128-SHA (128/128 bits)) (No client certificate requested) by smtp02.uc3m.es (Postfix) with ESMTP id 4155275ABF1; Tue,  6 Mar 2012 18:06:38 +0100 (CET)
From: =?iso-8859-1?Q?Alberto_Garc=EDa?= <alberto@it.uc3m.es>
To: "'Carsten Bormann'" <cabo@tzi.org>, "'IETF Apps Discuss'" <apps-discuss@ietf.org>, <draft-garcia-shim6-applicability.all@tools.ietf.org>, <shim6@ietf.org>
References: <FDE1C2DB-48CF-42AB-91C3-266C1AAD95F9@tzi.org>
In-Reply-To: <FDE1C2DB-48CF-42AB-91C3-266C1AAD95F9@tzi.org>
Date: Tue, 6 Mar 2012 18:06:38 +0100
Message-ID: <00ac01ccfbbb$7e81e580$7b85b080$@it.uc3m.es>
MIME-Version: 1.0
Content-Type: multipart/alternative; boundary="----=_NextPart_000_00AD_01CCFBC3.E04B0870"
X-Mailer: Microsoft Outlook 14.0
Thread-Index: AQE8Z7u/F1paD1p9UUiMSbxgp70Ic5d4Qc7Q
Content-Language: es
X-TM-AS-Product-Ver: IMSS-7.0.0.3116-6.8.0.1017-18758.000
Cc: 'The IESG' <iesg@ietf.org>
Subject: Re: [shim6] APPSDIR review of draft-garcia-shim6-applicability-03
X-BeenThere: shim6@ietf.org
X-Mailman-Version: 2.1.12
Precedence: list
List-Id: SHIM6 Working Group Mailing List <shim6.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/shim6>, <mailto:shim6-request@ietf.org?subject=unsubscribe>
List-Archive: <http://www.ietf.org/mail-archive/web/shim6>
List-Post: <mailto:shim6@ietf.org>
List-Help: <mailto:shim6-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/shim6>, <mailto:shim6-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 06 Mar 2012 17:06:51 -0000

This is a multipart message in MIME format.


------=_NextPart_000_00AD_01CCFBC3.E04B0870
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Hi Carsten,

Thank you very much for your review

=20

|  -----Mensaje original-----

|  De: shim6-bounces@ietf.org [mailto:shim6-bounces@ietf.org] En nombre

|  de Carsten Bormann

|  Enviado el: mi=E9rcoles, 29 de febrero de 2012 23:13

|  Para: IETF Apps Discuss;
<mailto:draft-garcia-shim6-applicability.all@tools.ietf.org>
draft-garcia-shim6-applicability.all@tools.ietf.org;

|   <mailto:shim6@ietf.org> shim6@ietf.org

|  CC: The IESG

|  Asunto: [shim6] APPSDIR review of draft-garcia-shim6-applicability-03

| =20

|  I have been selected as the Applications Area Directorate reviewer =
for
this

|  draft (for background on APPSDIR, please see

|
<http://trac.tools.ietf.org/area/app/trac/wiki/ApplicationsAreaDirectorat=
e>
http://trac.tools.ietf.org/area/app/trac/wiki/ApplicationsAreaDirectorate=
).

| =20

|  Please resolve these comments along with any other Last Call comments

|  you may receive. Please wait for direction from your document =
shepherd or

|  AD before posting a new version of the draft.

| =20

|  Gruesse, Carsten

|  ---------------------------------

| =20

|  Document: draft-garcia-shim6-applicability-03.txt

|  Title: Applicability Statement for the Level 3 Multihoming Shim =
Protocol

|  (Shim6)

|  Reviewer: Carsten Bormann

|  IETF Last Call Date: 2012-02-15

|  Review Date: 2012-02-29

| =20

|  ** Summary: This draft is ready for publication as an Informational

|     RFC with small changes, but maybe requires a better title.

| =20

|  Note: I reviewed this with the expectation that the intended audience
will

|  read this *before* looking at RFC5533=965535 in detail.

| =20

|  ** Major Issues:

| =20

|  General:

| =20

|  The document provides useful discussion of considerations around the

|  usage of Shim6.  At the end, it leaves the reader confused: What *is* =
the

|  applicability/area of application of Shim6? =20

=20

I assume this comment relates with the expectations created by the =
title, so
I comment below.

=20

|  Who should decide whether

|  Shim6 is activated for a specific connection?  (There is an API in =
RFC
6316,

|  but clearly that is meant for advanced applications.)=20

=20

This issue was partially addressed in the 'Short-Lived Communications'
subsection. However, I think the text would improve by placing this in a
more prominent place, and by making a clearer statement. I have appended =
the
following text just to the end of the '2. Deployment Scenarios' section:

=20

=93To allow nodes to benefit from the capabilities provided by Shim6

   (discussed in Section 5) such as fault tolerance, nodes should be

   configured to initiate a Shim6 session with any peer node if they

   have multiple locators to use.  Note that this configuration can be

   performed transparently to the applications, in the sense that

   applications do not need to be aware of the Shim6 functionality

   provided by the node; iin particular, nodes are not forced to use the

   Shim6 API [RFC6316] to benefit from Shim6.  The Shim6 session should

   be created after the two nodes have been communicating for some time,

   i.e. using the deferred context establishment facility provided by

   Shim6.  Otherwise, the cost of the Shim6 4-way handshake used for

   establishing the session may exceed the benefits provided for short-

   lived communications (see Section 5.1.2).  More advanced node

   configuration may involved configuring different delays for

   initiating the session for different applications, for example, based

   on a per-port configuration.  Nodes being able to use a single

   locator for the communication should not initiate the creation of a

   Shim6 context, but should participate if other node initiates it.

   Note that Shim6-aware applications can overrid this behavior by means

   of the Shim6 API [RFC6316].=94

=20

By the way, I've also merged the 'Short-lived' and 'Long-lived' =
sections,
into a single '5.1.2. Short-lived and long-lived communications', which =
is
referred in the previous paragraph.

Does this address your concern?

=20

|  While the document

|  successfully relates Shim6 to SCTP and HIP, what about other =
approaches
to

|  multi-addressing? =20

In general, all mechanisms which handle different addresses at a higher
level than the network-layer may experience unwanted interactions with
Shim6. This applies to MPTCP, in addition to SCTP. Although there was a
generic comment regarding to this at the end of the SCTP section, I have
make this more explicit for MPTCP, by changing the SCTP section to refer =
to
both SCTP and MPTCP.

=20

=937.3.  Shim6, SCTP and MPTCP
=20
   Both the SCTP [RFC4960] and MPTCP [RFC6182] protocols provide a
   reliable, stream-based communications channel between two hosts which
   provides a superset of the capabilities of TCP.  One notable feature
   of these two protocols is that they allow the exchange of endpoint
   addresses between hosts, in order to recover from the failure of a
   particular endpoint pair, or to benefit from multipath communication
   in the MPTCP case, in a manner which is conceptually similar to
   locator selection in Shim6.
=20
   SCTP and MPTCP are transport-layer protocols, higher in the protocol
   stack than Shim6, and hence there is no fundamental incompatibility
   which would prevent a Shim6-capable host from communicating using
   SCTP or MPTCP.
=20
   However, since either SCTP or MPTCP, and Shim6 aim to exchange
   addressing information between hosts in order to meet the same
   generic goal, it is possible that their simultaneous use might result
   in unexpected behavior, e.g. lead to race conditions.
=20
   The capabilities of these transport protocols with respect to path
   maintenance of a reliable, connection-oriented stream protocol are
   more extensive than the more general layer-3 locator agility provided
   by Shim6.  Therefore, it is recommended that Shim6 is not used for
   SCTP or MPTCP sessions, and that path maintenance is provided solely
   by SCTP or MPTCP.  There are at least two ways to enforce this
   behavior.  One option would be to make the stack, and in particular
   the Shim6 sublayer, aware of the use of SCTP or MPTCP and in this
   case refrain from creating a Shim6 context.  The other option is that
   the upper transport layer, informs using a Shim6-capable API like the
   one proposed in [RFC6316] that no Shim6 context must be created for
   this particular communication.
=20
   In general, the issues described here may also arise for protocols
   which handle different addresses for two communicating nodes at a
   higher level than the network-layer to improve reliability,
   performance, congestion control, etc.=94
=20

=20

|  When is happy-eyeballs enough? =20

Umm. In my opinion, the happy-eyeballs algorithm is not related to =
Shim6.
Happy-eyeballs deals with dual-stack hosts connecting to servers. As
discussed in section =913.1 Protocol Version (IPv4 vs. IPv6)=92, Shim6 =
is just
defined for IPv6.

=20

=20

|  When should MPTCP

|  be used? =20

Now this is included in the new SCTP/MPTCP section commented before.

=20

|  (The introduction to 7 then goes ahead and destroys any

|  remaining hope that this document provides the answers -- maybe this

|  should be split into "Open Issues" and the solid information about =
where

|  Shim6 is not needed.)

| =20

|  The document may have started out as an applicability statement half =
a

|  decade ago, but maybe renaming it to "Considerations on the =
Application
of

|  Shim6" provides a more appropriate title now.

| =20

|  Again, this is meant as a comment on the expectations raised by the =
title

|  and abstract, not as an attempt to belittle the usefulness of the
document's

|  content.

| =20

=20

I think I see your point. For me its ok to change the title to
=91Considerations on the Application of the Level 3 Multihoming Shim =
Protocol
(Shim6)=92

I=92ve also changed the abstract to a less ambitious

=93This document discusses some considerations on the applicability of =
the
Shim6 IPv6 protocol and associated support protocols and mechanisms to
provide site multihoming capabilities in IPv6.=94

=20

Regarding to splitting section 7 into something like =91open issues=92, =
and =91do
not mix=92, this is not evident to me. The =91do not mix=92 is comprised =
of just
two subsections (=91SCTP/MPTCP=92 and =91HIP=92). Besides, the =91open =
issues=92 part is
very heterogeneous: there are things we are pretty confident that should
work (e.g. =91SEND and Shim6=92), complex interactions (eg. NATs will =
work as
long as there are no changes in the locators, which leads to a =
functionality
which is not worse than current IPv6, although not as good as Shim6 =
could
provide=85), things that may work but they should be tested (MIP, NEMO,
firewalls)=85

I prefer the current approach in which each =91Shim6 and other=92 =
combination is
considered separately, without giving further structure to the section
(structure that is difficult for me to find).

=20

|  ** Minor Issues:

| =20

|  (1)

|  I'm not so fond of the DHCP speculation in 3.3.  An applicability
statement

|  should talk about what is, not what could be.  As of today, DHCP is =
not

|  applicable, and that should be clearly stated.  (Work in progress =
can, of

|  course, be pointed to, but it is not clear there is much more than a
problem

|  statement.)

=20

OK. I=92ve changed the section to this:

=20

=933.3.  Address Generation and Configuration
=20
   The security of the Shim6 protocol is based on the use of CGA and HBA
   addresses.
=20
   CGA and HBA generation process can use the information provided by
   the stateless auto-configuration mechanism defined in [RFC4862] with
   the additional considerations presented in [RFC3972] and [RFC5535].
=20
   Stateful address auto-configuration using DHCP [RFC3315] is not
   currently supported, because there is no defined mechanism to convey
   the CGA Parameter Data Structure and other relevant information from
   the DHCP server to the host.  An analysis of the possible
   interactions between DHCPv6 and Cryptographically Generated Addresses
   (CGAs) can be found in [I-D.ietf-csi-dhcpv6-cga-ps].=94

=20

=20

| =20

|  (2)

|  This sentence in 3.4 is opaque, unless it is talking about the state =
of

|  implementations (or is this another piece of DHCP speculation?):

| =20

|             There is no current mechanism designed to allow an
administrator to

|             enforce the configuration of a CGA or an HBA in a host.

Ok, I=92ve removed it, since the comment is implicit in the previous =
section.=20

=20

| =20

|  (3)

|  Section 3.4, 7.2:  The term "hybrid" does not occur in RFC 5535.

|  Adapt the terminology.

OK, I adhere to RFC5535 text. Now the text says:

=20

=93 In the case that a Shim6-capable host is using HBAs to

  protect its locator sets, the host will need to generate

  an address which is both a valid CGA and a valid HBA, as defined in
[RFC5535]=94

=20

| =20

|  (4)

|  Section 5.2:

| =20

|             One such solution is being developed at the MP-TCP Working
Group.

| =20

|  That is not the name of the WG, and referring to ephemeral IETF WGs =
is
not

|  very useful in an archival document such as an RFC.  It is probably =
most

|  appropriate to reference RFC 6182.

Done

=20

| =20

|  More generally speaking, one would expect some more guidance when

|  MPTCP is appropriate and when Shim6 is appropriate.  Oddly, RFC 6181

|  seems to provide more information about Shim6 on this point than the

|  present document.

Well, I think the inclusion of MPTCP along with SCTP provides much more
information.=20

Regarding to the information included in RFC6181, this information has =
not
much to do with this =91application=92 document: RFC6181 describes the =
security
threats involving locator agility in MPTCP, which have some relation to
those faced by Shim6 (that=92s why Shim6 is referred there). These =
threats are
related to the design of the protocol, but not to the application of the
protocol, since once they have been successfully addressed by the =
protocol
itself, the managers deploying it do not need to care about anymore. So
these issues are covered by the Shim6 specification [RFC5533], but do =
not
need to be considered here, in the applicability considerations.

=20

| =20

|  (5)

|  (On a related note, avoid discussion of the Shim6 WG's charter in =
7.5.)

Sure. Changed to

=93Shim6 aimed to provide a solution to =85=94

=20

| =20

|  ** Nits:

| =20

|  [I-D.ietf-mif-problem-statement] is now RFC 6418.

| =20

|  The document will benefit from some micro-editing, e.g.

|  s/different to/different from/g

|  s/specific of/specific to/g

|  s/associated to/associated with/g

|  s/is developed/has been developed/

|  The usage of "suffer" in several places

|  (in particular, should "These problems are suffered by other =
solutions

|              supporting multihoming such as SCTP [RFC4960] or HIP

|              [RFC4423]." in section 4 not be "relevant to" instead?)

|  "Shim6 has no means to enforce neither host nor network =
forwarding..."

Corrected to =93When a locator has been selected by a host to be used as
source address for a Shim6 session, Shim6 has no means to enforce an
appropriate path for that source address neither in the host nor in the
network.=94

=20

|  "does not require also"

|  s/should be review/should be reviewed/

|  "...which security features can expect applications and users of the
Shim6

|  protocol."

|  As this is typically done by the RFC editor, I'm not providing a =
detailed
list

|  here.

| =20

|  Section 4: s/not being used/not be used/

| =20

|  Define "REAP" (I know, RFC5533 doesn't, either).

| =20

|  Section 6: This sentence is hard to read:

|  "As long as the address exchanged, IP_A is the ULID..."

=20

All these nits have been corrected.

=20

Thanks again,

Alberto

=20

| =20

|  _______________________________________________

|  shim6 mailing list

|   <mailto:shim6@ietf.org> shim6@ietf.org

|   <https://www.ietf.org/mailman/listinfo/shim6>
https://www.ietf.org/mailman/listinfo/shim6


------=_NextPart_000_00AD_01CCFBC3.E04B0870
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<html xmlns:v=3D"urn:schemas-microsoft-com:vml" =
xmlns:o=3D"urn:schemas-microsoft-com:office:office" =
xmlns:w=3D"urn:schemas-microsoft-com:office:word" =
xmlns:m=3D"http://schemas.microsoft.com/office/2004/12/omml" =
xmlns=3D"http://www.w3.org/TR/REC-html40"><head><meta =
http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1"><meta name=3DGenerator content=3D"Microsoft Word =
14 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
	{font-family:Calibri;
	panose-1:2 15 5 2 2 2 4 3 2 4;}
@font-face
	{font-family:Tahoma;
	panose-1:2 11 6 4 3 5 4 4 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
	{margin:0cm;
	margin-bottom:.0001pt;
	font-size:11.0pt;
	font-family:"Calibri","sans-serif";
	mso-fareast-language:EN-US;}
a:link, span.MsoHyperlink
	{mso-style-priority:99;
	color:blue;
	text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
	{mso-style-priority:99;
	color:purple;
	text-decoration:underline;}
p.MsoPlainText, li.MsoPlainText, div.MsoPlainText
	{mso-style-priority:99;
	mso-style-link:"Texto sin formato Car";
	margin:0cm;
	margin-bottom:.0001pt;
	font-size:11.0pt;
	font-family:"Calibri","sans-serif";
	mso-fareast-language:EN-US;}
pre
	{mso-style-priority:99;
	mso-style-link:"HTML con formato previo Car";
	margin:0cm;
	margin-bottom:.0001pt;
	font-size:10.0pt;
	font-family:"Courier New";}
p.MsoAcetate, li.MsoAcetate, div.MsoAcetate
	{mso-style-priority:99;
	mso-style-link:"Texto de globo Car";
	margin:0cm;
	margin-bottom:.0001pt;
	font-size:8.0pt;
	font-family:"Tahoma","sans-serif";
	mso-fareast-language:EN-US;}
span.TextosinformatoCar
	{mso-style-name:"Texto sin formato Car";
	mso-style-priority:99;
	mso-style-link:"Texto sin formato";
	font-family:"Calibri","sans-serif";}
span.TextodegloboCar
	{mso-style-name:"Texto de globo Car";
	mso-style-priority:99;
	mso-style-link:"Texto de globo";
	font-family:"Tahoma","sans-serif";}
span.EstiloCorreo21
	{mso-style-type:personal-compose;}
span.HTMLconformatoprevioCar
	{mso-style-name:"HTML con formato previo Car";
	mso-style-priority:99;
	mso-style-link:"HTML con formato previo";
	font-family:"Courier New";
	mso-fareast-language:ES;}
.MsoChpDefault
	{mso-style-type:export-only;
	font-size:10.0pt;
	mso-fareast-language:EN-US;}
@page WordSection1
	{size:612.0pt 792.0pt;
	margin:70.85pt 3.0cm 70.85pt 3.0cm;}
div.WordSection1
	{page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext=3D"edit" spidmax=3D"1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext=3D"edit">
<o:idmap v:ext=3D"edit" data=3D"1" />
</o:shapelayout></xml><![endif]--></head><body lang=3DES link=3Dblue =
vlink=3Dpurple><div class=3DWordSection1><p class=3DMsoPlainText><span =
lang=3DEN-US>Hi Carsten,<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>Thank you very much for your =
review<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText>|=A0 =
-----Mensaje original-----<o:p></o:p></p><p class=3DMsoPlainText>|=A0 =
De: <a href=3D"mailto:shim6-bounces@ietf.org">shim6-bounces@ietf.org</a> =
<a =
href=3D"mailto:[mailto:shim6-bounces@ietf.org]">[mailto:shim6-bounces@iet=
f.org]</a> En nombre<o:p></o:p></p><p class=3DMsoPlainText>|=A0 de =
Carsten Bormann<o:p></o:p></p><p class=3DMsoPlainText>|=A0 Enviado el: =
mi=E9rcoles, 29 de febrero de 2012 23:13<o:p></o:p></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Para: IETF Apps Discuss; =
</span><a =
href=3D"mailto:draft-garcia-shim6-applicability.all@tools.ietf.org"><span=
 =
lang=3DEN-US>draft-garcia-shim6-applicability.all@tools.ietf.org</span></=
a><span lang=3DEN-US>;<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 </span><a =
href=3D"mailto:shim6@ietf.org"><span =
lang=3DEN-US>shim6@ietf.org</span></a><span =
lang=3DEN-US><o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 CC: The IESG<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Asunto: [shim6] APPSDIR =
review of draft-garcia-shim6-applicability-03<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 I have been selected as the =
Applications Area Directorate reviewer for this<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 draft (for background on =
APPSDIR, please see<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 </span><a =
href=3D"http://trac.tools.ietf.org/area/app/trac/wiki/ApplicationsAreaDir=
ectorate"><span =
lang=3DEN-US>http://trac.tools.ietf.org/area/app/trac/wiki/ApplicationsAr=
eaDirectorate</span></a><span lang=3DEN-US>).<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Please resolve these =
comments along with any other Last Call comments<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 you may receive. Please =
wait for direction from your document shepherd =
or<o:p></o:p></span></p><p class=3DMsoPlainText><span lang=3DEN-US>|=A0 =
AD before posting a new version of the draft.<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Gruesse, =
Carsten<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 =
---------------------------------<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Document: =
draft-garcia-shim6-applicability-03.txt<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Title: Applicability =
Statement for the Level 3 Multihoming Shim =
Protocol<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 (Shim6)<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Reviewer: Carsten =
Bormann<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 IETF Last Call Date: =
2012-02-15<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 Review Date: 2012-02-29<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 ** Summary: This draft is =
ready for publication as an Informational<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0=A0=A0=A0 RFC with small =
changes, but maybe requires a better title.<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Note: I reviewed this with =
the expectation that the intended audience will<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 read this *before* looking =
at RFC5533&#8211;5535 in detail.<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 ** Major =
Issues:<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 General:<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 The document provides =
useful discussion of considerations around the<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 usage of Shim6.=A0 At the =
end, it leaves the reader confused: What *is* =
the<o:p></o:p></span></p><p class=3DMsoPlainText><span lang=3DEN-US>|=A0 =
applicability/area of application of Shim6?=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>I assume this comment relates =
with the expectations created by the title, so I comment =
below.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 Who should decide whether<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Shim6 is activated for a =
specific connection?=A0 (There is an API in RFC =
6316,<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 but clearly that is meant for advanced applications.) =
<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>This issue was partially addressed in the 'Short-Lived =
Communications' subsection. However, I think the text would improve by =
placing this in a more prominent place, and by making a clearer =
statement. I have appended the following text just to the end of the '2. =
Deployment Scenarios' section:<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>&#8220;To allow nodes to benefit =
from the capabilities provided by Shim6<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 (discussed in Section 5) =
such as fault tolerance, nodes should be<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 configured to initiate a =
Shim6 session with any peer node if they<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 have multiple locators to =
use.=A0 Note that this configuration can be<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 performed transparently =
to the applications, in the sense that<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 applications do not need =
to be aware of the Shim6 functionality<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 provided by the node; iin =
particular, nodes are not forced to use the<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 Shim6 API [RFC6316] to =
benefit from Shim6.=A0 The Shim6 session should<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 be created after the two =
nodes have been communicating for some time,<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 i.e. using the deferred =
context establishment facility provided by<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 Shim6.=A0 Otherwise, the =
cost of the Shim6 4-way handshake used for<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 establishing the session =
may exceed the benefits provided for short-<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 lived communications (see =
Section 5.1.2).=A0 More advanced node<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 configuration may =
involved configuring different delays for<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 initiating the session =
for different applications, for example, based<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>=A0=A0 on a per-port =
configuration.=A0 Nodes being able to use a =
single<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>=A0=A0 locator for the communication should not initiate =
the creation of a<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>=A0=A0 Shim6 context, but should participate if other node =
initiates it.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>=A0=A0 Note that Shim6-aware applications can overrid this =
behavior by means<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>=A0=A0 of the Shim6 API =
[RFC6316].&#8221;<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>By the way, I've also merged the 'Short-lived' and =
'Long-lived' sections, into a single '5.1.2. Short-lived and long-lived =
communications', which is referred in the previous =
paragraph.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>Does this address your concern?<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 While the =
document<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 successfully relates Shim6 to SCTP and HIP, what about =
other approaches to<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 multi-addressing?=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>In general, all mechanisms which =
handle different addresses at a higher level than the network-layer may =
experience unwanted interactions with Shim6. This applies to MPTCP, in =
addition to SCTP. Although there was a generic comment regarding to this =
at the end of the SCTP section, I have make this more explicit for =
MPTCP, by changing the SCTP section to refer to both SCTP and =
MPTCP.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><pre><span lang=3DEN-US =
style=3D'color:black'>&#8220;7.3.=A0 Shim6, SCTP and =
MPTCP<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'><o:p>&nbsp;</o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 Both the SCTP [RFC4960] and =
MPTCP [RFC6182] protocols provide a<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 reliable, stream-based =
communications channel between two hosts =
which<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 provides a superset of the capabilities of =
TCP.=A0 One notable feature<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 of these two protocols is that =
they allow the exchange of endpoint<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 addresses between hosts, in =
order to recover from the failure of a<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 particular endpoint pair, or =
to benefit from multipath =
communication<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 in the MPTCP case, in a manner which is =
conceptually similar to<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 locator selection in =
Shim6.<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'><o:p>&nbsp;</o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 SCTP and MPTCP are =
transport-layer protocols, higher in the =
protocol<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 stack than Shim6, and hence there is no =
fundamental incompatibility<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 which would prevent a =
Shim6-capable host from communicating =
using<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 SCTP or =
MPTCP.<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'><o:p>&nbsp;</o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 However, since either SCTP or =
MPTCP, and Shim6 aim to exchange<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 addressing information between =
hosts in order to meet the same<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 generic goal, it is possible =
that their simultaneous use might =
result<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 in unexpected behavior, e.g. lead to race =
conditions.<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'><o:p>&nbsp;</o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 The capabilities of these =
transport protocols with respect to =
path<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 maintenance of a reliable, =
connection-oriented stream protocol =
are<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 more extensive than the more general =
layer-3 locator agility provided<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 by Shim6.=A0 Therefore, it is =
recommended that Shim6 is not used for<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 SCTP or MPTCP sessions, and =
that path maintenance is provided =
solely<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 by SCTP or MPTCP.=A0 There are at least two =
ways to enforce this<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 behavior.=A0 One option would be to make =
the stack, and in particular<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 the Shim6 sublayer, aware of =
the use of SCTP or MPTCP and in this<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 case refrain from creating a =
Shim6 context.=A0 The other option is =
that<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 the upper transport layer, informs using a =
Shim6-capable API like the<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 one proposed in [RFC6316] that =
no Shim6 context must be created for<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 this particular =
communication.<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'><o:p>&nbsp;</o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 In general, the issues =
described here may also arise for =
protocols<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 which handle different addresses for two =
communicating nodes at a<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 higher level than the network-layer to =
improve reliability,<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 </span><span =
style=3D'color:black'>performance, congestion control, =
etc.&#8221;<o:p></o:p></span></pre><pre><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></pre><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 When is happy-eyeballs enough?=A0 =
<o:p></o:p></span></p><p class=3DMsoPlainText><span lang=3DEN-US>Umm. In =
my opinion, the happy-eyeballs algorithm is not related to Shim6. =
Happy-eyeballs deals with dual-stack hosts connecting to servers. As =
discussed in section &#8216;3.1 Protocol Version (IPv4 vs. IPv6)&#8217;, =
Shim6 is just defined for IPv6.<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 When should =
MPTCP<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 be used?=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>Now this is included in the new =
SCTP/MPTCP section commented before.<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 (The introduction to 7 then =
goes ahead and destroys any<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 remaining hope that this =
document provides the answers -- maybe this<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 should be split into =
&quot;Open Issues&quot; and the solid information about =
where<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 Shim6 is not needed.)<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 The document may have =
started out as an applicability statement half a<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 decade ago, but maybe =
renaming it to &quot;Considerations on the Application =
of<o:p></o:p></span></p><p class=3DMsoPlainText><span lang=3DEN-US>|=A0 =
Shim6&quot; provides a more appropriate title =
now.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 Again, this is meant as a comment on the expectations =
raised by the title<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 and abstract, not as an attempt to belittle the =
usefulness of the document's<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 =
content.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>I think I see your point. For me its ok to change the title =
to &#8216;Considerations on the Application of the Level 3 Multihoming =
Shim Protocol (Shim6)&#8217;<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>I&#8217;ve also changed the =
abstract to a less ambitious<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>&#8220;This document discusses =
some considerations on the applicability of the Shim6 IPv6 protocol and =
associated support protocols and mechanisms to provide site multihoming =
capabilities in IPv6.&#8221;<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoNormal><span lang=3DEN-US>Regarding to splitting section 7 =
into something like &#8216;open issues&#8217;, and &#8216;do not =
mix&#8217;, this is not evident to me. The &#8216;do not mix&#8217; is =
comprised of just two subsections (&#8216;SCTP/MPTCP&#8217; and =
&#8216;HIP&#8217;). Besides, the &#8216;open issues&#8217; part is very =
heterogeneous: there are things we are pretty confident that should work =
(e.g. &#8216;SEND and Shim6&#8217;), complex interactions (eg. NATs will =
work as long as there are no changes in the locators, which leads to a =
functionality which is not worse than current IPv6, although not as good =
as Shim6 could provide&#8230;), things that may work but they should be =
tested (MIP, NEMO, firewalls)&#8230;<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>I prefer the current approach in =
which each &#8216;Shim6 and other&#8217; combination is considered =
separately, without giving further structure to the section (structure =
that is difficult for me to find).<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 ** Minor =
Issues:<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 (1)<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 I'm not so fond of the DHCP speculation in 3.3.=A0 An =
applicability statement<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 should talk about what is, =
not what could be.=A0 As of today, DHCP is not<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 applicable, and that should =
be clearly stated.=A0 (Work in progress can, of<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 course, be pointed to, but =
it is not clear there is much more than a =
problem<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 statement.)<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>OK. I&#8217;ve changed the =
section to this:<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US style=3D'color:red'><o:p>&nbsp;</o:p></span></p><pre><span =
lang=3DEN-US style=3D'color:black'>&#8220;3.3.=A0 Address Generation and =
Configuration<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'><o:p>&nbsp;</o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 The security of the Shim6 =
protocol is based on the use of CGA and =
HBA<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 =
addresses.<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'><o:p>&nbsp;</o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 CGA and HBA generation process =
can use the information provided by<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 the stateless =
auto-configuration mechanism defined in [RFC4862] =
with<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 the additional considerations presented in =
[RFC3972] and [RFC5535].<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'><o:p>&nbsp;</o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 Stateful address =
auto-configuration using DHCP [RFC3315] is =
not<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 currently supported, because there is no =
defined mechanism to convey<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 the CGA Parameter Data =
Structure and other relevant information =
from<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 the DHCP server to the host.=A0 An analysis =
of the possible<o:p></o:p></span></pre><pre><span lang=3DEN-US =
style=3D'color:black'>=A0=A0 interactions between DHCPv6 and =
Cryptographically Generated Addresses<o:p></o:p></span></pre><pre><span =
lang=3DEN-US style=3D'color:black'>=A0=A0 (CGAs) can be found in =
[I-D.ietf-csi-dhcpv6-cga-ps].&#8221;<o:p></o:p></span></pre><p =
class=3DMsoPlainText><span lang=3DEN-US =
style=3D'color:red'><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 (2)<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 This sentence in 3.4 is =
opaque, unless it is talking about the state of<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 implementations (or is this =
another piece of DHCP speculation?):<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span =
lang=3DEN-US>|=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 There is no current =
mechanism designed to allow an administrator to<o:p></o:p></span></p><p =
class=3DMsoPlainText><span =
lang=3DEN-US>|=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 enforce the =
configuration of a CGA or an HBA in a host.<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>Ok, I&#8217;ve removed it, since =
the comment is implicit in the previous section. =
<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 (3)<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 Section 3.4, 7.2:=A0 The term &quot;hybrid&quot; does =
not occur in RFC 5535.<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Adapt the =
terminology.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>OK, I adhere to RFC5535 text. Now the text =
says:<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>&#8220; In the case that a Shim6-capable host is using HBAs =
to<o:p></o:p></span></p><p class=3DMsoPlainText><span lang=3DEN-US>=A0 =
protect its locator sets, the host will need to =
generate<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>=A0 an address which is both a valid CGA and a valid HBA, =
as defined in [RFC5535]&#8221;<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 (4)<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 Section =
5.2:<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 One such solution is =
being developed at the MP-TCP Working Group.<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 That is not the name of the =
WG, and referring to ephemeral IETF WGs is not<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 very useful in an archival =
document such as an RFC.=A0 It is probably most<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 appropriate to reference =
RFC 6182.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>Done<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 More generally speaking, one would expect some more =
guidance when<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 MPTCP is appropriate and when Shim6 is appropriate.=A0 =
Oddly, RFC 6181<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 seems to provide more information about Shim6 on this =
point than the<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 present document.<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>Well, I think the inclusion of =
MPTCP along with SCTP provides much more information. =
<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>Regarding to the information included in RFC6181, this =
information has not much to do with this &#8216;application&#8217; =
document: RFC6181 describes the security threats involving locator =
agility in MPTCP, which have some relation to those faced by Shim6 =
(that&#8217;s why Shim6 is referred there). These threats are related to =
the design of the protocol, but not to the application of the protocol, =
since once they have been successfully addressed by the protocol itself, =
the managers deploying it do not need to care about anymore. So these =
issues are covered by the Shim6 specification [RFC5533], but do not need =
to be considered here, in the applicability =
considerations.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 (5)<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 (On a related note, avoid discussion of the Shim6 WG's =
charter in 7.5.)<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>Sure. Changed to<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>&#8220;Shim6 aimed to provide a =
solution to &#8230;&#8221;<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 <o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 ** =
Nits:<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 [I-D.ietf-mif-problem-statement] is now RFC =
6418.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 The document will benefit from some micro-editing, =
e.g.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 s/different to/different =
from/g<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 s/specific of/specific to/g<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 s/associated to/associated =
with/g<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 s/is developed/has been =
developed/<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 The usage of &quot;suffer&quot; in several =
places<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 (in particular, should &quot;These problems are =
suffered by other solutions<o:p></o:p></span></p><p =
class=3DMsoPlainText><span =
lang=3DEN-US>|=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 supporting =
multihoming such as SCTP [RFC4960] or HIP<o:p></o:p></span></p><p =
class=3DMsoPlainText><span =
lang=3DEN-US>|=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0=A0 [RFC4423].&quot; =
in section 4 not be &quot;relevant to&quot; =
instead?)<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 &quot;Shim6 has no means to enforce neither host nor =
network forwarding...&quot;<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>Corrected to &#8220;When a =
locator has been selected by a host to be used as source address for a =
Shim6 session, Shim6 has no means to enforce an appropriate path for =
that source address neither in the host nor in the =
network.&#8221;<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 &quot;does not require =
also&quot;<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 s/should be review/should be =
reviewed/<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 &quot;...which security features can expect =
applications and users of the Shim6<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 =
protocol.&quot;<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 As this is typically done by the RFC editor, I'm not =
providing a detailed list<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 =
here.<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 Section 4: s/not being used/not be =
used/<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 Define &quot;REAP&quot; (I know, RFC5533 doesn't, =
either).<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 Section 6: This sentence is hard to =
read:<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 &quot;As long as the address exchanged, IP_A is the =
ULID...&quot;<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>All these nits have been corrected.<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>Thanks =
again,<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>Alberto<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US><o:p>&nbsp;</o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 <o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 =
_______________________________________________<o:p></o:p></span></p><p =
class=3DMsoPlainText><span lang=3DEN-US>|=A0 shim6 mailing =
list<o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 </span><a href=3D"mailto:shim6@ietf.org"><span =
lang=3DEN-US>shim6@ietf.org</span></a><span =
lang=3DEN-US><o:p></o:p></span></p><p class=3DMsoPlainText><span =
lang=3DEN-US>|=A0 </span><a =
href=3D"https://www.ietf.org/mailman/listinfo/shim6"><span =
lang=3DEN-US>https://www.ietf.org/mailman/listinfo/shim6</span></a><span =
lang=3DEN-US><o:p></o:p></span></p></div></body></html>
------=_NextPart_000_00AD_01CCFBC3.E04B0870--

