Subject: [sidr] WG adoption call for draft-ymbk-rpki-rtr-impl-01.txt

From: "Murphy, Sandra" <[email-masked]>
Date: Sat, 21 Jan 2012 00:19:15 +0000

The working group has been requested to adopt draft-ymbk-rpki-rtr-impl-01.txt as a working group draft.

The draft is available at http://tools.ietf.org/html/draft-ymbk-rpki-rtr-impl.

Please respond to the list to say whether you accept this draft as a working group draft and are willing to work on it. Remember that you do not need to accept all content in a draft to adopt, as draft editors are required to reflect the consensus of the working group.

This call will end 3 Feb 2012.

--Sandy, speaking as wg co-chair

---

From: Warren Kumari <[email-masked]>
Date: Sun, 22 Jan 2012 17:26:22 -0500

> Please respond to the list to say whether you accept this draft as a working group draft and are willing to work on it. Remember that you do not need to accept all content in a draft to adopt, as d…

Support adoption.

I think that this is a *really* useful document as it provides evidence of the "running code" bit of rough consensus and running code.

Knowing what / how far along the various implementations are is useful as it provides insight into what parts of the protocols / documentation are well developed and which need more work. Also, the fact that the vendors are supporting it this much means this will actually be deployable, and so (to my mind) makes all the time and effort worthwhile…

Comments:
It is unclear (to me) what exactly was mean by "YES" vs "UNIT TEST" vs "SYS TEST" -- I could make some guesses, but a definition would be nice.

W

> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
> 

--
Don't be impressed with unintelligible stuff said condescendingly.
    -- Radia Perlman.

---

From: Tim Bruijnzeels <[email-masked]>
Date: Mon, 23 Jan 2012 10:46:43 +0100

Hi,

> It is unclear (to me) what exactly was mean by "YES" vs "UNIT TEST" vs "SYS TEST" -- I could make some guesses, but a definition would be nice.

Speaking for my contribution; the one that mentions "Unit Test":

Our 'production' implementation is just the validator, so the cache that is the server side of the protocol. It is tested using automated unit and functional testing as well as interop-testing with different client implementations.

We also have test client code that we use for the unit tests. This client is able to parse and understand PDUs in the table in section 3, but it's not released as a real production stand-alone, interop-tested, client. Hence I say "Unit Test". I can live with "Not Applicable" or N/A instead though.

I thought it might be useful to mention "unit test", because fwiw we don't see problems in the PDU format for these 'client' PDUs.

Tim

---

From: Andrew Chi <[email-masked]>
Date: Mon, 23 Jan 2012 10:17:28 -0500

I support adoption.

-Andrew

---

From: Andrew Chi <[email-masked]>
Date: Mon, 23 Jan 2012 10:22:44 -0500

On 1/23/2012 4:46 AM, Tim Bruijnzeels wrote:
> We also have test client code that we use for the unit tests. This
> client is able to parse and understand PDUs in the table in section 3,
> but it's not released as a real production stand-alone, interop-tested,
> client. Hence I say "Unit Test". I can live with "Not Applicable" or N/A
> instead though.

Our "SYS TEST" is equivalent to Tim's "UNIT TEST", so we can just adopt 
the same terminology (or N/A).

-Andrew

---

From: Randy Bush <[email-masked]>
Date: Tue, 24 Jan 2012 00:23:14 +0900

> Support adoption.

thank you

> Comments:
> It is unclear (to me) what exactly was mean by "YES" vs "UNIT TEST" vs
> "SYS TEST" -- I could make some guesses, but a definition would be
> nice.

while i share your puzzlement (and i am an author!:-), shouldn't this
be deferred until we have agreed it is a wg document?

[ not meaning to pick on you warren.  but i have been shocked at some
  wgs (e.g. v6ops) months of nit picking of a document which the wg has
  not even agreed to accept as a work item. ]

randy

---

From: Stephen Kent <[email-masked]>
Date: Mon, 23 Jan 2012 10:33:48 -0500

At 12:19 AM +0000 1/21/12, Murphy, Sandra wrote:
>The working group has been requested to adopt 
>draft-ymbk-rpki-rtr-impl-01.txt as a working group draft.
>
>Please respond to the list to say whether you accept this draft as a 
>working group draft and are willing to work on it. Remember that you 
>do not need to accept all content in a draft to adopt, as draft 
>editors are required to reflect the consensus of the working group.
>

I support adoption of this doc as a WG draft, and am prepared to review it,
if it adopted.

Steve

---

From: Tim Bruijnzeels <[email-masked]>
Date: Mon, 23 Jan 2012 17:05:06 +0100

> The working group has been requested to adopt draft-ymbk-rpki-rtr-impl-01.txt as a working group draft.

I contributed to the document, so my support is kind of implied I would expect. I am not sure about the rules, I am not an author...

In any case: if it needs to be explicit: I support.

Tim

---

From: "Balaji Pitta Venkatachalapathy (bvenkata)" <[email-masked]>
Date: Mon, 23 Jan 2012 22:30:22 -0600

Support adoption of this doc as work group draft.

Regards,
Balaji

------ Forwarded Message
From: "Murphy, Sandra" <[email-masked]>
Date: Sat, 21 Jan 2012 00:19:15 +0000
To: "[email-masked]" <[email-masked]>
Subject: [sidr] WG adoption call for draft-ymbk-rpki-rtr-impl-01.txt

The draft is available at
http://tools.ietf.org/html/draft-ymbk-rpki-rtr-impl.

Please respond to the list to say whether you accept this draft as a
working
group draft and are willing to work on it. Remember that you do not need
to
accept all content in a draft to adopt, as draft editors are required to
reflect the consensus of the working group.

------ End of Forwarded Message

---

From: Bhavani Parise <[email-masked]>
Date: Mon, 23 Jan 2012 23:56:05 -0800

support adoption.

regards,
Bhavani

---

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Tue, 24 Jan 2012 09:13:11 +0100

Support adoption as WG doc.

Bert

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Tue, 24 Jan 2012 08:33:37 +0000

I support adoption and I am willing to be a reviewer.

Roque.

---

From: Ed Kern <[email-masked]>
Date: Tue, 24 Jan 2012 09:56:58 -0800

Support adoption of this document into the wg.

Happy to review as well.  

Although clarifying sys test vs unit test vs beta will be about as much fun as defining a "route leak".

Ed

---

From: "John G. Scudder" <[email-masked]>
Date: Thu, 26 Jan 2012 14:17:29 -0800

Support.

--John

---

From: Sean Turner <[email-masked]>
Date: Thu, 26 Jan 2012 19:41:12 -0500

> --Sandy, speaking as wg co-chair

I support adoption and will review it.

spt

---

From: "Murphy, Sandra" <[email-masked]>
Date: Fri, 27 Jan 2012 16:04:48 +0000

A suggestion was made at the last wg call, that reminders should be sent out for approaching deadlines.

You are hereby reminded that there is an active wg call for adoption, which ends a week from today.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Murphy, Sandra
> Sent: Friday, January 20, 2012 7:19 PM
> To: [email-masked]
> working group draft and are willing to work on it. Remember that you do
> not need to accept all content in a draft to adopt, as draft editors are
> required to reflect the consensus of the working group.
>