Subject: [sidr] additional interim meetings

From: "Murphy, Sandra" <[email-masked]>
Date: Thu, 22 Mar 2012 16:07:52 +0000

As the last few day's email explosion has shown, this is a complex topic, covering routing, security, operations, governance, policy, etc.  

The complexities mean more energy and time for debate is needed than is possible in IETF meetings.  Progress so far in the working group has been aided by intense lengthy discussions in-between the IETF meetings.  Those involved in the discussions were wg members, including half-a-dozen draft authors and individuals from IETF, ops, vendor, academic, research, etc.  

But the ADs were concerned about the effect on the open IETF process.

To continue the energy and continue to promote progress, several options were considered.  The ADs' eventual decision was that organizing frequent open interim meetings would be best, so that the entire wg could participate as they wished.

Interim meetings would be face-face meetings co-located with venues of communities of interest to this work (ie nanog, ripe, arin, etc.) when facilities are volunteered, or virtual meetings when volunteer hosts can not be found.

The idea is to meet to discuss thorny topics at length.  Agendas announced ahead of time, remote participation always available, minutes reported to the wg, proceedings published.  When webex is used, recordings will be taken.

This should function like regular IETF sidr meetings (but more often and with more remote participation).

Here is a suggested semi-schedule for the next several months.

30 April (chosen so as not to conflict with RIPE or ARIN in the preceding weeks)  (Likely important topic - the government oversight concerns at RIPE and mitigating possibilities, impacts of the ARIN and RIPE meeting)

6 Jun, co-located with NANOG (that is the Wed after NANOG ends - there are indications that nanog may be able to lend a room after noon.)

the last part of June: 25 Jun - 3 July

at one end or the other of the IETF (sort of like iegp meets at IETFs) in July

(not likely people will want to try to meet in August)

Then further out: mid-Sep, mid-October (maybe NANOG/ARIN, as a community of interest), IETF in November.

Interim meetings are not supported by the secretariat, so for face-face meetings we have to rely on volunteer organizations or hosts.  That will mean that some meetings will have no hosts (virtual) or will have hosts but be space bounded (limited face-face).  Remote participation will always be available.

Comments?

--Sandy, speaking as wg co-chair

(I begin traveling in a few hours, so replies to responses will be delayed)

---

From: Arturo Servin <[email-masked]>
Date: Thu, 22 Mar 2012 13:49:43 -0300

Sandy,

	I offer (well LACNIC) a room and all the facilities required for the second week of May (LACNIC XVII) or the last week of October in 2012 (LACNIC XVII - LACNOG 2012). The meeting in May is in Quito Ecuador and the one in October is in Montevideo.

	Just let me know and I would do the arrangements.

Regards,
as

On 22 Mar 2012, at 13:07, Murphy, Sandra wrote:

> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr

---

From: Eric Osterweil <[email-masked]>
Date: Thu, 22 Mar 2012 14:43:15 -0400

My 0.02 below:

> Interim meetings would be face-face meetings co-located with venues of communities of interest to this work (ie nanog, ripe, arin, etc.) when facilities are volunteered, or virtual meetings when vo…

So, for those that make special plans to attend IETF meetings, we now must _also_ make plans to attend a lot more meetings (re: the f2f comment).  I understand that the hope here is to increase the rate of progress that the wg makes.  However, I fear the effect would be that those who can travel more will develop more context and influence more decisions than others.  If I'm not mistaken, the mailing list is open 24/7, IDs are processed during those same hours, so (wrt trying to increase some rate of progress) why is there a special case being made for sidr, as opposed to other ietf wgs?

> The idea is to meet to discuss thorny topics at length.  Agendas announced ahead of time, remote participation always available, minutes reported to the wg, proceedings published.  When webex is us…

Why is this an exceptional case?  Have there not been other wgs w/ these issues before?

> Interim meetings are not supported by the secretariat, so for face-face meetings we have to rely on volunteer organizations or hosts.  That will mean that some meetings will have no hosts (virtual)…

This is a large amount of travel and I think it unduly reduces the ability of many of the wg's members to participate at the same level as they do today.  I think this is a bad idea.

Eric

---

From: Terry Manderson <[email-masked]>
Date: Thu, 22 Mar 2012 16:56:51 -0700

On 23/03/12 4:43 AM, "Eric Osterweil" <[email-masked]> wrote:
>> 
>> Comments?
> 
> This is a large amount of travel and I think it unduly reduces the ability of
> many of the wg's members to participate at the same level as they do today.  I
> think this is a bad idea.
> 

I predict travel related to a particular work focus a full 13-15 months in
advance of going somewhere, there is generally some contingency, but not to
these levels - as I exist as a part of a healthy budget process. I expect
many others would be in a similar or worse situation as to their travel
flexibility.

I accept that the drivers/authors of the BGPSEC work along with chairs and
ADs want to maintain momentum - but given the importance of this topic and
the many many layers it crosses (in some cases without meaning to), both
breadth and depth of participation to produce the best effort (including
palatability) result is needed over trying to meet WG milestones. I expect
that can only be satisfied with ML participation and IETF attendance.

So I also think adding interim meetings is bad.

Cheers
Terry

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 22 Mar 2012 21:05:48 -0400

> So I also think adding interim meetings is bad.

significant progress has been made on the topics here because of
frequent (monthly about) face-to-face meetings, focused meetings even.
Would making the f2f meetings have virtual capabilities be acceptable?
(webex or the like, or maybe meeting rooms at diverse locations with
that fancy cisco meeting-room thing? or other of the same ilk?)

Are there enough central locations to where the folks who want to
participate to make more network connected office conversations
workable? (sunnyvale/pao/etc + washington + london + ???)

-chris

---

From: Terry Manderson <[email-masked]>
Date: Thu, 22 Mar 2012 18:21:49 -0700

Hi Chris,

> frequent (monthly about) face-to-face meetings, focused meetings even.

Wow.. that is news to me. Are those meetings under the guise of something
other than SIDR? Do the SIDR WG chairs attend as WG chairs?  How does one
get invited to such a meeting? (it appears not to be self selected) and are
there minutes/transcripts to those meetings? ok they are in the past, but it
would help to read minutes/trasnscripts and thus maybe get a finer
understanding about why decisions have been made in regard to the solutions
presented thus far.

> that fancy cisco meeting-room thing? or other of the same ilk?)

it depends. bad answer I know. but that's what you get without knowing the
agenda, number of participants, history of past meetings etc etc...

> workable? (sunnyvale/pao/etc + washington + london + ???)

T.

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 22 Mar 2012 21:39:14 -0400

> other than SIDR? Do the SIDR WG chairs attend as WG chairs?  How does one

<http://www.potaroo.net/iepg/2011-03-ietf80/110327.iepg-bgpsec.pdf>

people attend as people, not as roles, in an attempt to get some
progress made. Traditionally these have been all-day-affairs
(slog-fests?)

> there minutes/transcripts to those meetings? ok they are in the past, but it

i believe there are some minutes, I've not read them :(

> understanding about why decisions have been made in regard to the solutions

actually the sriram doc was an attempt at documenting that... it seems
some of the reasoning (looking at some of brian.dickson's comments, I
think it was him...) could use some fleshing out. It may actually be
useful to corner sriram at the next meeting and see if he could expand
context where necessary.

> it depends. bad answer I know. but that's what you get without knowing the

suspected as much :)

> agenda, number of participants, history of past meetings etc etc...

so... number of participants probably would flex some, eh? and I
suspect the agendas could be figured out in advance of each meeting. I
also suspect that some of the agenda stuff would have to get done
serially? (or that's been the case so far) I suspect (example):
  april - route-leaks, what/where/how?
           beaconing, yes? no? impact (with/without?)
           cpe signing? impacts? costs? need?

  may - cpe impacts?
           without beaconing how's that cpe doing?

  june - route leaks, again, with progress on docs and maths

my point I suppose is, nailing down a 13-15month set of agendas
doesn't seem practical either... or fanciful at the very least :(
You'd probably either end up: "This meeting is coincident with
something else I have to be at, extend 1 day == win!" and some cases
of: "Yea, I can't go to arctic-nog...skip"

>> workable? (sunnyvale/pao/etc + washington + london + ???)

is the idea of showing up in 3 locations close to a majority of
participants and participating over video conference laughable or
possibly doable? (not just for terry the question here is meant for)

-chris

---

From: Tim Bruijnzeels <[email-masked]>
Date: Fri, 23 Mar 2012 10:43:47 +0100

Hi,

On 22 Mar 2012, at 17:07, Murphy, Sandra wrote:
> .....

I do see the point of keeping and improving momentum.

Is the biggest problem though that 1 slot providing 2 hours f2f during a regular IETF is not enough, or is the 4 month interval between f2f meetings the major issue?

I share people's concerns about additional travel, so I would prefer to go for 2 or even 3 slots at the upcoming IETFs instead. I don't know what IETF policy is on this, but it's quite clear that there is enough on the agenda that needs f2f.

Tim

---

From: Henk Uijterwaal <[email-masked]>
Date: Fri, 23 Mar 2012 14:01:19 +0100

Hi Tim,

> I share people's concerns about additional travel, so I would prefer to go for 2
> or even 3 slots at the upcoming IETFs instead. I don't know what IETF policy is
> on this, but it's quite clear that there is enough on the agenda that needs f2f.

The IETF has a limited number of slots (150 or so) and about as many working
groups.  That gives about 1 slot to each WG, a second slot is only granted after
all requests for a 1st slot have been met.  That makes it hard to plan for
multiple slots during the week, as it isn't clear that the 2nd slot will
be available.

The solution is to have a meeting the day before or after the meeting, like the
meeting that was cancelled.  Then a slot is guaranteed, the additional costs
are small for the participants.  This is allowed if the request is made on time.
 In the past we have done this, with a friendly RIR footing the bill for the
room and the coffee.

Henk

-- 
------------------------------------------------------------------------------
Henk Uijterwaal                           Email: henk(at)uijterwaal.nl
                                          http://www.uijterwaal.nl
                                          Phone: +31.6.55861746
------------------------------------------------------------------------------

There appears to have been a collective retreat from reality that day.
                                 (John Glanfield, on an engineering project)

---

From: "George, Wes" <[email-masked]>
Date: Fri, 23 Mar 2012 10:21:11 -0400

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Murphy, Sandra
> Sent: Thursday, March 22, 2012 12:08 PM
> To: [email-masked]
> Subject: [sidr] additional interim meetings
>
> Interim meetings would be face-face meetings co-located with venues of
> communities of interest to this work (ie nanog, ripe, arin, etc.) when
> facilities are volunteered, or virtual meetings when volunteer hosts can not
> be found.
>
[WEG] I think I'd rather see these be planned as solely virtual meetings when they are not collocated with another event which contains an audience we'd like to engage (either current SIDR participants or "tourists" whose input would be valuable). Personally, I'm already approaching the maximum amount of travel that I can do and still keep my happy home, well, happy, so carving out time for separate trips even for short-duration things like this is less than preferable. Finances are a consideration as well. I'm responding with some ideas about virtual meetings in another reply.

> The idea is to meet to discuss thorny topics at length.  Agendas announced
> ahead of time, remote participation always available, minutes reported to the
> wg, proceedings published.  When webex is used, recordings will be taken.
[WEG] Generally, I think that the topics proposed are important, and would benefit from discussion beyond the typical few hours at IETF meetings or 200+ message threads, so I support the idea of some focused time outside of IETF meetings. However, I'm not convinced that monthly is necessary. It may be that they are scheduled with that frequency and we do some agenda bashing to make sure that people can attend the things that they have opinions about without needing to commit one full day a month to this. When one considers keeping up with the rest of IETF + $day_job, that starts to get difficult in a hurry.

> 30 April (chosen so as not to conflict with RIPE or ARIN in the preceding
> weeks)  (Likely important topic - the government oversight concerns at RIPE
> and mitigating possibilities, impacts of the ARIN and RIPE meeting)
[WEG] prefer virtual
>
> 6 Jun, co-located with NANOG (that is the Wed after NANOG ends - there are
> indications that nanog may be able to lend a room after noon.)
[WEG] Makes sense, please publicize WELL (6wks+) in advance on NANOG so that people in the operations community who aren't paying attention to SIDR can make plans to attend, focus the agenda on operational considerations.

> the last part of June: 25 Jun - 3 July
[WEG] I'm not convinced we need this one, and summer scheduling is problematic due to vacation. We may have to wait and see what comes of the previous few before determining if we need another one prior to IETF.
> at one end or the other of the IETF (sort of like iegp meets at IETFs) in July
[WEG] Manageable as long as the date is set before people make travel plans, probably at least 6 weeks out, preferably 8.

Thanks,
Wes George

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "George, Wes" <[email-masked]>
Date: Fri, 23 Mar 2012 10:36:22 -0400

> possibly doable?
[WEG] well, I think that videoconf would be an acceptable option, assuming we can cobble together the right set of multi-location supporting gear among the candidate locations. Other than those pesky timezones, the problem we run into with coordinated virtual meetings of this type is usually one of poor execution of the technology - e.g. systems that can only talk to other identical systems within the company network (no external/interwork support), huge rooms without appropriate mics/speakers to make a video or audio conf anything other than frustrating, or systems that aren't capable of managing a presentation + a speaker video at the same time, etc.
We won't know unless we try it, and I think that we should. The worst that happens is that we decide it's not worth the hassle in the future and simply rely on the built-in support for webcams in things like Webex in lieu of videoconf. The benefit of having it in a physical location is that it helps to reduce distractions and let us focus on what we're actually there to do.

I would assume that if Cisco is willing to volunteer the resources for its customers' use, there are likely telepresence rooms in the Cisco offices convenient to nearly all of us, and that's a system that I know from personal experience would work for this type of thing. The challenges are that there is an 8-10 person limit to the rooms, meaning that some of the areas with larger clusters of folks might need multiple rooms, and it's typically difficult to schedule that many simultaneous rooms for any length of time without doing so months in advance.

Thanks
Wes George

---

From: "George, Wes" <[email-masked]>
Date: Fri, 23 Mar 2012 11:08:47 -0400

> From: [email-masked] [mailto:[email-masked]] On Behalf Of Henk
> Uijterwaal
> Sent: Friday, March 23, 2012 9:01 AM
> To: [email-masked]
> Subject: Re: [sidr] additional interim meetings
>
>
[WEG] One point to make here... I think you're overselling the difficulty of requesting and receiving additional slots when they are all requested at the same time, rather than retroactively as was done this time. Yes by strict math you're correct, but rarely do all of the WGs meet. Once the agenda is set, you know how many sessions you have, it's not like the add'l sessions are scheduled after the agenda is set. V6ops has consistently had 2 sessions per IETF, and was up to 3 sessions in one IETF before a number of folks told the chairs that this was excessive and that we needed to better manage what was actually getting agenda time. So it can be done.

Really, the problem with multiple sessions is that they are opposite 7 other WG meetings no matter what their timeslot, meaning that it becomes increasingly difficult to deconflict time for those who need to attend.

Wes George

---

From: Henk Uijterwaal <[email-masked]>
Date: Mon, 26 Mar 2012 08:16:19 +0200

On 23/03/2012 16:08, George, Wes wrote:

> [WEG] One point to make here... I think you're overselling the difficulty of
> requesting and receiving additional slots when they are all requested at the
> same time, rather than retroactively as was done this time. Yes by strict
> math you're correct, but rarely do all of the WGs meet. 

For Paris, the agenda was overloaded and all WG chairs were specifically asked
to review the agenda for their WG, check if the discussions they had planned for
the meeting needed face-2-face discussion and return the slot if not.

Henk