Subject: Re: [sidr] WGLC: draft-ietf-sidr-bgpsec-pki-profiles

From: Stephen Kent <[email-masked]>
Date: Tue, 3 Jul 2012 11:31:15 -0400

At 8:49 PM +0000 6/28/12, Murphy, Sandra wrote:
>This last call has ended.  There were only three comments during the wglc. 
>
>Two noted that the document was solid, but that it was premature to 
>advance the draft when the protocols spec was still undergoing 
>changes and might produce new required features for the router 
>certificates.
>
>So what is the desire of the working group:
>
>- put the document on hold, refreshing versions numbers as necessary 
>to keep it on the secretariat list of current drafts, until we are 
>more certain no further features will be needed
>
>- publish the draft now and amend if new features should pop up
>
>If the later, more support for publication is needed.
>
>--Sandy, speaking as wg co-chair

I'll advocate for a "publish it now and fix it later if needed"
strategy.

Steve

---

From: Randy Bush <[email-masked]>
Date: Wed, 04 Jul 2012 05:42:37 +0900

> I'll advocate for a "publish it now and fix it later if needed"

the hidden tao of the ietf

<aol>

---

From: Warren Kumari <[email-masked]>
Date: Tue, 3 Jul 2012 16:50:54 -0400

On Jun 28, 2012, at 4:49 PM, Murphy, Sandra wrote:

> Two noted that the document was solid, but that it was premature to advance the draft when the protocols spec was still undergoing changes and might produce new required features for the router certificates.
> 
> - put the document on hold, refreshing versions numbers as necessary to keep it on the secretariat list of current drafts, until we are more certain no further features will be needed
> 

This one please!

W

> ________________________________________
> From: [email-masked] [[email-masked]] on behalf of Christopher Morrow [[email-masked]]
> Sent: Friday, April 13, 2012 4:16 PM
> To: [email-masked]; [email-masked]
> Subject: [sidr] WGLC: draft-ietf-sidr-bgpsec-pki-profiles
> 
> Helo WG peoples,
> The following update posted today. Sean and Tom have come to agreement
> on their differences, I believe this closes the last open items on
> this document.
> 
> Let's start a WGLC for this, ending: 4/27/2012 or 27/4/2012
> 
> Thanks!
> -Chris
> <co-chair>
> 
> On Fri, Apr 13, 2012 at 3:03 PM,  <[email-masked]> wrote:
>> 
>> A New Internet-Draft is available from the on-line Internet-Drafts directories. This draft is a work item of the Secure Inter-Domain Routing Working Group of the IETF.
>> 
>>       Title           : A Profile for BGPSEC Router Certificates, Certificate Revocation Lists, and Certification Requests
>>       Author(s)       : Mark Reynolds
>>                         Sean Turner
>>                         Steve Kent
>>       Filename        : draft-ietf-sidr-bgpsec-pki-profiles-03.txt
>>       Pages           : 11
>>       Date            : 2012-04-13
>> 
>>  This document defines a standard profile for X.509 certificates for
>>  the purposes of supporting validation of Autonomous System (AS) paths
>>  in the Border Gateway Protocol (BGP), as part of an extension to that
>>  protocol known as BGPSEC.  BGP is a critical component for the proper
>>  operation of the Internet as a whole.  The BGPSEC protocol is under
>>  development as a component to address the requirement to provide
>>  security for the BGP protocol.  The goal of BGPSEC is to design a
>>  protocol for full AS path validation based on the use of strong
>>  cryptographic primitives.  The end-entity (EE) certificates specified
>>  by this profile are issued under Resource Public Key Infrastructure
>>  (RPKI) Certification Authority (CA) certificates, containing the AS
>>  Identifier Delegation extension, to routers within the Autonomous
>>  System (AS).  The certificate asserts that the router(s) holding the
>>  private key are authorized to send out secure route advertisements on
>>  behalf of the specified AS.  This document also profiles the
>>  Certificate Revocation List (CRL), profiles the format of
>>  certification requests, and specifies Relying Party certificate path
>>  validation procedures.  The document extends the RPKI; therefore,
>>  this documents updates the RPKI Resource Certificates Profile (RFC
>>  6487).
>> 
>> 
>> A URL for this Internet-Draft is:
>> http://www.ietf.org/internet-drafts/draft-ietf-sidr-bgpsec-pki-profiles-03.txt
>> 
>> Internet-Drafts are also available by anonymous FTP at:
>> ftp://ftp.ietf.org/internet-drafts/
>> 
>> This Internet-Draft can be retrieved at:
>> ftp://ftp.ietf.org/internet-drafts/draft-ietf-sidr-bgpsec-pki-profiles-03.txt
>> 
>> _______________________________________________
>> sidr mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sidr
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
> 

--
"Working the ICANN process is like being nibbled to death by ducks,
it takes forever, it doesn't make sense, and in the end we're still dead in the water." 
    -- Tom Galvin, VeriSign's vice president for government relations.

---

From: Sean Turner <[email-masked]>
Date: Tue, 10 Jul 2012 12:15:24 -0400

>> - publish the draft now and amend if new features should pop up

For what it's worth I like this one too, but I'm one of the editors.

spt

---

From: Warren Kumari <[email-masked]>
Date: Tue, 10 Jul 2012 16:30:27 -0400

> For what it's worth I like this one too, but I'm one of the editors.

Fair 'nuff…

>>> If the later, more support for publication is needed.

So, is this sufficinet support for publication? If not, how much more is needed? And by when?

W

--
She'd even given herself a middle initial - X - which stood for "someone who has a cool and exciting middle name".

    -- (Terry Pratchett, Maskerade)