Subject: Re: [sidr] WG acceptance call for draft-ymbk-rpki-grandparenting

From: Christopher Morrow <[email-masked]>
Date: Thu, 8 Nov 2012 00:04:21 -0500

On Mon, Oct 15, 2012 at 1:36 AM, Byron Ellacott <[email-masked]> wrote:
> Hi Chris,
>
> When did the WG reach consensus on adopting this draft?

when it spent ~50 mesasages discussing it?
it seems that, even if we abandon it in the end, discussing this over
a draft is a good thing to do.

> Thanks,
>   Byron
>
> On 13/10/2012, at 12:53 AM, Christopher Morrow <[email-masked]> wrote:
>
>> Helo,
>> Since we've been through this for a while (originally) and this has
>> been quiet for ~1 month... let's call this done and move to the next
>> step.
>>
>> 1) there was lots of discussion on the topic at hand
>> 2) lots of that discussion was not about acceptance/rejection of the
>> idea into the WG
>> 3) lots of people contributed
>>
>> I do think we should continue to have this discussion more officially
>> around a draft, the wg discussion leads me to believe this is the
>> right course... can the authors spin a newly named version and we can
>> start discussing the topic / changes?
>>
>> I think if, in the end, the wg decides to abandon the work that's also
>> fine, but we should have a more structured chat about the topic, that
>> happens around a draft.
>>
>> -chris
>> co-chair
>>
>> On Wed, Aug 29, 2012 at 5:06 PM, Murphy, Sandra
>> <[email-masked]> wrote:
>>> Speaking as wg co-chair
>>>
>>> Of course revision and new request for acceptance is possible.
>>>
>>> Even arguing some more leading to acceptance of draft as is is a possibility.
>>>
>>> Some commentors specifically requested that the discussion be added to some existing draft.
>>>
>>> Trying to judge wg desire of a way to proceed.
>>>
>>>
>>> --Sandy
>>>
>>>
>>> From: [email-masked] [[email-masked]] on behalf of Andy Newton [[email-masked]]
>>>
>>> Sent: Wednesday, August 29, 2012 4:56 PM
>>>
>>> To: Murphy, Sandra; Alexey Melnikov; [email-masked]
>>>
>>> Subject: Re: [sidr] WG acceptance call for draft-ymbk-rpki-grandparenting
>>>
>>>
>>>
>>>
>>>
>>>
>>> Are the chairs not allowing the draft authors to address the issues and try again?
>>>
>>>
>>>
>>> -andy
>>>
>>>
>>>
>>>
>>>
>>> From: <Murphy>, Sandra <[email-masked]>
>>>
>>> Date: Wednesday, August 29, 2012 12:10 PM
>>>
>>> To: Alexey Melnikov <[email-masked]>, "[email-masked]"
>>> <[email-masked]>
>>>
>>> Subject: Re: [sidr] WG acceptance call for draft-ymbk-rpki-grandparenting
>>>
>>>
>>>
>>>
>>>
>>>
>>> <!--
>>> p
>>>        {margin-top:0;
>>>        margin-bottom:0}
>>> -->
>>> BODY {direction: ltr;font-family: Arial;color: #000000;font-size: 10pt;}P {margin-top:0;margin-bottom:0;}
>>>
>>> Speaking as wg co-chair:
>>>
>>>
>>>
>>> Certainly a very lively acceptance call!
>>>
>>>
>>>
>>> The chairs do not see that there was consensus that the wg should adopt this draft.
>>>
>>>
>>>
>>> But there was ample evidence that the wg was interested in the issue - by the wg spending lots of time discussing the issue.
>>>
>>>
>>>
>>> So that leaves the chairs with an ambivalent message.  The wg is very interested in the topic but not in adopting a draft that would record any decisions about the topic.
>>>
>>>
>>>
>>> What would the wg like to do now?  Particularly those who disagreed with the content of the draft - if you would dislike the recommendations, are you OK with no recommendations instead?
>>>
>>>
>>>
>>> --Sandy, speaking as wg co-chair
>>>
>>>
>>>
>>>
>>>
>>> From:
>>>
>>> [email-masked] [[email-masked]] on behalf of Alexey Melnikov [[email-masked]]
>>>
>>> Sent: Saturday, August 04, 2012 2:12 PM
>>>
>>> To:
>>> [email-masked]
>>>
>>> Subject: [sidr] WG acceptance call for draft-ymbk-rpki-grandparenting
>>>
>>>
>>>
>>>
>>>
>>> Hi,
>>>
>>> On behalf of SIDR WG chairs I would like to initiate 2 weeks acceptance call for draft-ymbk-rpki-grandparenting starting from today, August 4th. Please
>>> send your positive or negative feedback to the mailing list or directly to chairs.
>>>
>>>
>>>
>>>
>>> Thank you,
>>> Alexey
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>>
>>> _______________________________________________
>>> sidr mailing list
>>> [email-masked]
>>> https://www.ietf.org/mailman/listinfo/sidr
>> _______________________________________________
>> sidr mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/sidr
>

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 8 Nov 2012 00:09:26 -0500

On Mon, Oct 15, 2012 at 9:21 AM, Andy Newton <[email-masked]> wrote:
> On 10/12/12 10:53 AM, "Christopher Morrow" <[email-masked]> wrote:
>
> As the person who specifically asked of the chairs that the draft authors
> be allowed to address the issues raised, I'd like specifics on this more
> structured chat. I ask because it is not apparent that the normal means of

I hope (and I think co-chairs hope) that the authors and commentors
can discuss what the problem attempting to be documented is, add the
right words to the document and then we can all decide if documenting
something in an informational RFC that describes a capability that
exists in the system today (and the downsides of executing that
capability) is appropriate.

it'd be nice, really, to know at the end if there is a reason to NOT
publish something along those lines as well, and if the wg things not
publishing is best, then we'll just wander off and leave the kitten by
the lake on it's own.

> IETF discussion were attempted. Of the 38 messages regarding the draft
> directly, the draft author only responded 3 times, nor did the author
> engage in any of the side discussions. And the draft submitted as a
> working group document addresses NONE of the issues raised (it is just a
> re-spin with the dates and file name changed). If normal IETF discourse is

that's fine though, right? the author and commentors can work out the details.

> being set aside especially when it was not fully engaged, we should also
> be given the exception criteria under which this scenario qualifies when
> others do not.

don't think there's anything special going on, there was a bunch of
discussion, keep on discussing and if this ends up being publishable
'ok', if not 'ok'.

Some of the discussion was along the lines of 'you shouldn't do this
because its bad' or 'doing this circumvents the point of the
system'... that's also fine to document. the system seems to have the
capabilities, it'd be nice to know when not to pull the trigger (while
aimed at foot) and when TO pull trigger (downrange is clear).

---

From: Byron Ellacott <[email-masked]>
Date: Thu, 8 Nov 2012 15:53:27 +1000

Hi Chris,

> a draft is a good thing to do.

When that discussion happened, the chairs declared a lack of consensus for adoption: http://www.ietf.org/mail-archive/web/sidr/current/msg05015.html

Have the chairs reconsidered that declaration of lack of WG consensus, or adopted the draft despite a lack of WG consensus?

Perhaps there's a problem to be addressed, and if a discussion should happen around that problem, a document describing the problem might be a more useful way forward.

  Byron

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 8 Nov 2012 01:00:35 -0500

> When that discussion happened, the chairs declared a lack of consensus for adoption: http://www.ietf.org/mail-archive/web/sidr/current/msg05015.html

ok, i suppose my point here is that there's a bunch of discussion,
there's a draft that got chattered about quite a bit. having the wg
talk about it a bit more formally (which could just wither away to
nothing in the end) doesn't seem to hurt.

> Have the chairs reconsidered that declaration of lack of WG consensus, or adopted the draft despite a lack of WG consensus?

yes, apparently.

> Perhaps there's a problem to be addressed, and if a discussion should happen around that problem, a document describing the problem might be a more useful way forward.

that was the thought. again, maybe in the end it ends up not getting
published... like:
http://tools.ietf.org/html/draft-ietf-sidr-bogons

it happens somewhat often, no harm though, near as I can tell.

-chris

---

From: Byron Ellacott <[email-masked]>
Date: Thu, 8 Nov 2012 16:26:38 +1000

Hi Chris,

> nothing in the end) doesn't seem to hurt.

I think I understand this somewhat better now, thanks.  There's a wealth of discussion that happened previously, I don't think there's a lot of value in re-iterating those comments now, since they're all still there in the archive - or do you think it would be constructive to list some of those discussion points again?

  Byron

---

From: Christopher Morrow <[email-masked]>
Date: Thu, 8 Nov 2012 01:41:53 -0500

> I think I understand this somewhat better now, thanks.  There's a wealth of discussion that happened previously, I don't think there's a lot of value in re-iterating those comments now, since they'…

i hope that after the current hub-bub dies down (meeting hub-bub) we
can get back to this document, wrangle the comments into feedback the
authors can use and see where the discussion goes from there.

-chris

---

From: Randy Bush <[email-masked]>
Date: Thu, 08 Nov 2012 17:08:21 +0900

> authors can use and see where the discussion goes from there.

i suspect that the authors would greatly appreciate a concise list of
improvements to the document.  rumor is that they don't have the copious
spare time to sift through hub-bub, process noise, etc.

randy

---

From: Andy Newton <[email-masked]>
Date: Thu, 8 Nov 2012 11:49:31 +0000

>publishing is best, then we'll just wander off and leave the kitten by

As I stated before, the author of the document did not engage in the
discussion nor has the author done any work to the document to address any
of the concerns raised.

So I'll ask again, what specifically do you, the chairs, intend to do to
facilitate a more "structured" discussion?

>that's fine though, right? the author and commentors can work out the

No, it is not fine as the author has not engaged in the discussion.

>aimed at foot) and when TO pull trigger (downrange is clear).

So then, any document that comes before the working group shall be
accepted? Is that the new criteria?

-andy

---

From: "Murphy, Sandra" <[email-masked]>
Date: Thu, 8 Nov 2012 13:21:39 +0000

>the author of the document did not engage in the
>discussion

As Yakov was fond of saying, "send text".  Authors of wg drafts are supposed to represent consensus.   

>nor has the author done any work to the document to address any
>of the concerns raised.

Ironically, there was a recent discussion on the wgchairs list about ensuring that a recently adopted draft was submitted with NO changes from its individual draft form.

Calls for adoption are not calls for acceptance of the draft content, just a call to work on the topic.  Certainly the discussion demonstrated that people thought this was important.

>accepted?

A topic that generates a fire storm of discussion has a good chance.  Nothing like actively working on a topic to demonstrate interest in working on the topic.

--Sandy
________________________________________
From: Andy Newton [[email-masked]]
Sent: Thursday, November 08, 2012 6:49 AM
To: Christopher Morrow
Cc: Murphy, Sandra; Alexey Melnikov; [email-masked]
Subject: Re: [sidr] WG acceptance call for draft-ymbk-rpki-grandparenting

-andy

---

From: Danny McPherson <[email-masked]>
Date: Thu, 8 Nov 2012 08:39:58 -0500

> A topic that generates a fire storm of discussion has a good chance.  Nothing like actively working on a topic to demonstrate interest in working on the topic.

I do NOT support adoption of this.  It creates the opportunity for collisions in the system that a relying party has no capability to resolve.  

AS0-esque hacks make this even worse.

If the CA or some "grandparent" wants to provide this capability there are ways they can do this.

Quite frankly, this is why I like delegation models where you can't do this (e.g., DNS-esque).

-danny

---

From: Andy Newton <[email-masked]>
Date: Thu, 8 Nov 2012 14:38:12 +0000

>supposed to represent consensus.

If this is true, then the current document should be blank since it does
not represent consensus.

Also are you now saying that the author does not need to participate in
the discussion since he can now only represent consensus decisions? If so,
that would mean the author of this draft has been able to completely avoid
addressing any of the issues raised. That strikes me as not being the IETF
way.

>
>A topic that generates a fire storm of discussion has a good chance.
>Nothing like actively working on a topic to demonstrate interest in
>working on the topic.

Thank you for clarifying this. For confirmation, in the future any draft
put forward to SIDR that generates "interest" but not necessarily rough
consensus will be admitted as a working group document. Is that correct?

-andy

---

From: "Murphy, Sandra" <[email-masked]>
Date: Thu, 8 Nov 2012 14:57:12 +0000

>consensus will be admitted as a working group document. Is that correct?

The point of a call for adoption is to see if the working group is interested in working on a topic, not to achieve consensus on content.  Calls for adoption are not (supposed) to discuss content.  

Are you sure you are not thinking of wglc, where consensus on the content is needed?

And I said it generated "a first storm of discussion", not "interest".

--Sandy
________________________________________
From: Andy Newton [[email-masked]]
Sent: Thursday, November 08, 2012 9:38 AM
To: Murphy, Sandra; Christopher Morrow
Cc: Alexey Melnikov; [email-masked]
Subject: Re: [sidr] WG acceptance call for draft-ymbk-rpki-grandparenting

-andy

---

From: Andy Newton <[email-masked]>
Date: Thu, 8 Nov 2012 15:41:45 +0000

On 11/8/12 9:57 AM, "Murphy, Sandra" <[email-masked]> wrote:

>>Calls for adoption are not (supposed) to discuss content.

Thanks for that clarification. The IETF is a deliberative body, and I was
under the impression that discussion at any point in the process, though
not optimal, was acceptable. I did not realize SIDR had deviated.

>Are you sure you are not thinking of wglc, where consensus on the content

I'm pretty sure I understand the difference between WGLC and wg document
acceptance. What I am uncertain about is the criteria for working group
document acceptance in SIDR.

>And I said it generated "a first storm of discussion", not "interest".

So, is "a fire storm of discussion" the threshold for document acceptance?
If a document fails to generate such a storm, will it not be accepted?
Since ROVER did generate a storm, will you be accepting it as a working
group document? Again, I'm trying to determine the criteria upon which the
chairs accept a document as a working group item. I do find "a fire storm
of discussion" to be a unique threshold.

I'll note that you did say, "Nothing like actively working on a topic to
demonstrate interest in working on the topic." Hence my confusion.

-andy

---

From: "Murphy, Sandra" <[email-masked]>
Date: Thu, 8 Nov 2012 15:54:15 +0000

>not optimal, was acceptable. I did not realize SIDR had deviated.

I did not say discussion was prohibited.  That "supposed" is as in "supposedly".

Calls for adoption are to indicate interest in working on a topic.  The intent of a call for adoption is not consensus on the content.  Review of the content is not the purpose of a call for adoption.

I know I've said something like this before in calls for adoption.  This should not be a surprise.

--Sandy
Sent: Thursday, November 08, 2012 10:41 AM

-andy

---

From: Arturo Servin <[email-masked]>
Date: Thu, 08 Nov 2012 13:29:11 -0500

Discussion != want-to-work-on-the-topic

/as

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 09 Nov 2012 16:15:00 +0000

> When that discussion happened, the chairs declared a lack of consensus for adoption: http://www.ietf.org/mail-archive/web/sidr/current/msg05015.html
Byron and others,
I think WG chairs (collectively) dropped the ball here: 3 of us have 
discussed the acceptance call a couple of times. We would like to 
apologize for sending inconsistent messages.

After talking to various people this week, it looks like the best way 
forward is for the chairs to redo the acceptance call and ask very 
specific questions to keep everybody unconfused and hopefully happy.

---

From: Brian Dickson <[email-masked]>
Date: Fri, 9 Nov 2012 11:42:15 -0500

On Fri, Nov 9, 2012 at 11:15 AM, Alexey Melnikov
<[email-masked]>wrote:

>> When that discussion happened, the chairs declared a lack of consensus
>> for adoption: http://www.ietf.org/mail-**archive/web/sidr/current/**
>> msg05015.html<http://www.ietf.org/mail-archive/web/sidr/current/msg05015.html>
>>
> Byron and others,
> discussed the acceptance call a couple of times. We would like to apologize
> for sending inconsistent messages.
>
> forward is for the chairs to redo the acceptance call and ask very specific
> questions to keep everybody unconfused and hopefully happy.
>

I'd like to note that in general, WG acceptance processes are a critical
part of IETF processes.

In particular, the WG consensus on adoption, is the one critical place in
preventing "gaming the system".

An adoption call should have three (or four) responses:

Ready for Adoption
Needs more work BEFORE Adoption
Should not (never) be adopted
Abstain/don't care

The "needs more work" is the way that WG participants can hold
authors/editors accountable for making requested changes.

If a draft is accepted in its current state, then any promises by the
authors to make changes are much like promises by politicians during
election campaigns - not worth the paper they are written on.

However, if the WG insists on changes BEFORE adoption, the reliance on
promises goes away - which is a good thing.

Any discussion on the content of a draft, which is prompted by a WG
adoption request, SHOULD be taken by chairs as "Needs more work BEFORE
Adoption".

Since this does not seem to have been the case, please ask the WG to answer
one of the four ways, explicitly.

BTW:

I believe that this draft should not be adopted in its current form (if
ever).

Brian

---

From: Arturo Servin <[email-masked]>
Date: Fri, 09 Nov 2012 11:53:54 -0500

Brian,

	Thanks for the clarification, very very useful.

Regards,
as

On 09/11/2012 11:42, Brian Dickson wrote:

> In particular, the WG consensus on adoption, is the one critical place
> in preventing "gaming the system".
> 
> Since this does not seem to have been the case, please ask the WG to
> answer one of the four ways, explicitly.
> 
> BTW:
>

---

From: Andy Newton <[email-masked]>
Date: Fri, 9 Nov 2012 17:41:17 +0000

>specific questions to keep everybody unconfused and hopefully happy.

Alexey,

Thanks for addressing this issue. Much appreciated.

-andy

---

From: SM <[email-masked]>
Date: Sat, 10 Nov 2012 10:04:19 -0800

Hi Brian,
>authors/editors accountable for making requested changes.

If people agree that the problem is worth solving and people agree to 
help with the "needs more work", the adoption is like saying "we are 
ok to do this work".

>If a draft is accepted in its current state, then any promises by 
>the authors to make changes are much like promises by politicians 
>during election campaigns - not worth the paper they are written on.

Not really, as you have the WGLC.

There is also an option to submit an alternative proposal.

The real question is actually about how to facilitate a more 
"structured" discussion.

Regards,
-sm

---

From: John Leslie <[email-masked]>
Date: Sat, 10 Nov 2012 17:14:49 -0500

Brian Dickson <[email-masked]> wrote:
>...
 Date: Fri, 9 Nov 2012 11:42:15 -0500
> election campaigns - not worth the paper they are written on.

   While technically true:

1) if the WGCs let this happen, it's an abuse of power. At adoption as a
   WG draft, authors "relinquish change control" and different persons
   must be appointed document editors if authors aren't OK with that.

2) nothing goes to IESG without consensus at WG LastCall.

--
John Leslie <[email-masked]>

---

From: "George, Wes" <[email-masked]>
Date: Fri, 16 Nov 2012 09:08:33 -0500

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Alexey Melnikov
> >
[WEG] Chris, I realize that every WG and WG Chair has a different interpretation of the discuss/adoption/refinement/WGLC lifecycle, but IMO, discussion != "should adopt". There are plenty of drafts that get lots of discussion because lots of people say "stop, no, this is a bad idea" or there is controversy over a specific part of the draft along with some back-and-forth with the authors as they defend or refine their idea. In some WGs (which shall remain nameless to protect the clueless), 50 messages can show up in *one day* on a draft that is never going to be adopted.

> specific questions to keep everybody unconfused and hopefully happy.

I see two questions the WG needs to answer:
1) Is the problem described/solved by this draft actually a problem that we need to address?
2) Does this need to be in a standalone draft, or can it be incorporated into another existing draft

If #1 is yes, even if people don't agree with the solution proposed, that's a decent starting point for refinement.

As to the need to have refinement discussions over a document: I posed question #2 during the adoption call, and the reasoning for having it as a separate draft was never really discussed, so I think that's still outstanding. Personally I think the answer to #1 is probably yes, so I'm not opposed to the *content* and think it's worthwhile to refine it, but I'm not convinced it needs to be separate.

With apologies to Wheeler/Henney - all problems can be solved with another IETF draft, except the problem of too many IETF drafts.

Wes George

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.