Subject: Re: [sidr] http://tools.ietf.org/html/draft-ietf-sidr-rpki-rtr-protocol-mib-04

From: "Bert Wijnen (IETF)" <[email-masked]>
Date: Tue, 04 Dec 2012 17:25:16 +0100

Not sure why you send this to authors/editors.

The document is in IETF Last Call.
So comments need to to got to IETF or IESG list.

Your comments seem to be comments that get responded
to a WG or IETF Last Call. Those comments need to
go to WG and/or IESG or IETF list.

On 12/4/12 5:15 PM, heasley wrote:
> rpkiRtrCacheServerPreference doesnt indicate which is more preferred, 0 or
> 255, but should imo.
>
Since it is an Unsigned 32, I think that this text:

                     A lower value means more preferred. If two
                     entries have the same preference, then the
                     order is arbitrary.

Which is present in the DESCRIPTION clause clearly explains
that 0 is more preferred than 255.

> shouldnt rpkiRtrCacheServerV4ActiveRecords et al be in an afi/safi table?
> in theory, other afis may be supported.
>
not sure I can properly answer this one.
possibly you'd like to see them there too?

But I don't think this is a fatal flaw is it?

Bert

---

From: heasley <[email-masked]>
Date: Wed, 5 Dec 2012 07:18:38 +0000

> that 0 is more preferred than 255.

grumble; the mib import tool is truncating descriptions.  sorry for the noise.

> But I don't think this is a fatal flaw is it?

you tell me; seems like afi/safi tables are common now and other rpki pairs
are possible.

---

From: Randy Bush <[email-masked]>
Date: Wed, 05 Dec 2012 03:06:08 -0500

> in theory, other afis may be supported.

the rpki and rfc 3779 support only ipv6 and ipv6.  so i think there is
an issue here.

randy