Subject: [sidr] Poll: WG acceptance of draft-ymbk-rpki-grandparenting-02

From: Alexey Melnikov <[email-masked]>
Date: Wed, 12 Dec 2012 19:56:45 +0000

Dear WG participants,

I would like to initiate 2+ weeks poll (ending on December 31st 2012) 
regarding acceptance of draft-ymbk-rpki-grandparenting-02.txt. Please 
reply to questions listed below. Send your replies to the mailing list 
or directly to WG chairs <[email-masked]>. I would like to 
avoid extended discussions of technical issues at this time, as I think 
people already made up their minds. However including pointers to 
earlier discussions is fine.

Alexey,
on behald of SIDR chairs.

----------------

1) Is the problem described/solved by draft-ymbk-rpki-grandparenting-02 
actually a problem that the WG needs to address? (Answer: yes or no. 
Additional information is welcomed, but I don't want people to repeat 
the whole discussion.)

2) If you answered "yes" to the question #1, please also answer the 
following question:

Is draft-ymbk-rpki-grandparenting-02 a reasonable starting point to 
become a WG document? Please choose one of the following:

a) Ready for Adoption (whether or not you have some specific issues with 
it. Also, this answer is unrelated to whether this should be a separate 
draft or a part of an existing draft).

b) Needs more work BEFORE Adoption

c) Should not be adopted. In particular this mean that you don't believe 
any amount of work on the proposed draft will address your issues. So 
any solution to this problem should be a new draft written from scratch.

d) Abstain/don't care

3) If you answered "a" or "b" above, please also answer the following 
question:

Does this need to be in a standalone draft, or can it be incorporated 
into another existing WG draft? When answering this question please only 
base your answer on technical reasons, in particular please leave the 
decision on who is going to edit the document (if it is standalone) to 
WG chairs.

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 12 Dec 2012 20:05:36 +0000

> I would like to initiate 2+ weeks poll (ending on December 31st 2012)
BTW, if people think that this date should be postponed due to holiday 
season, that would be fine with me.
> regarding acceptance of draft-ymbk-rpki-grandparenting-02.txt.
  [...]

---

From: Warren Kumari <[email-masked]>
Date: Wed, 12 Dec 2012 16:08:33 -0500

On Dec 12, 2012, at 2:56 PM, Alexey Melnikov <[email-masked]> wrote:

> Dear WG participants,
> 
> I would like to initiate 2+ weeks poll (ending on December 31st 2012) regarding acceptance of draft-ymbk-rpki-grandparenting-02.txt. Please reply to questions listed below. Send your replies to the mailing list or directly to WG chairs <[email-masked]>. I would like to avoid extended discussions of technical issues at this time, as I think people already made up their minds. However including pointers to earlier discussions is fine.
> 
> Alexey,
> 1) Is the problem described/solved by draft-ymbk-rpki-grandparenting-02 actually a problem that the WG needs to address? (Answer: yes or no. Additional information is welcomed, but I don't want people to repeat the whole discussion.)

Yes, it is a problem that I believe the WG should address….
I don't think it is the most important issue on our plate but I do think it is worth addressing.

> 2) If you answered "yes" to the question #1, please also answer the following question:
> 
> Is draft-ymbk-rpki-grandparenting-02 a reasonable starting point to become a WG document? Please choose one of the following:
> 
> 
> a) Ready for Adoption (whether or not you have some specific issues with it. Also, this answer is unrelated to whether this should be a separate draft or a part of an existing draft).

A. I believe that 1: starting from somewhere is useful (and this is somewhere) and 2: once the WG owns the doc it can make whatever changes it wants (well, is able to reach consensus on :-P)

> c) Should not be adopted. In particular this mean that you don't believe any amount of work on the proposed draft will address your issues. So any solution to this problem should be a new draft written from scratch.
> 
> d) Abstain/don't care
> 
> 
> 3) If you answered "a" or "b" above, please also answer the following question:
> 
> Does this need to be in a standalone draft, or can it be incorporated into another existing WG draft? When answering this question please only base your answer on technical reasons, in particular please leave the decision on who is going to edit the document (if it is standalone) to WG chairs.

What? There is no "Abstain/don't care" option for 3? ;-)

W

> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr
> 

-- 
"Does Emacs have the Buddha nature? Why not? It has bloody well everything else..."

---

From: Byron Ellacott <[email-masked]>
Date: Thu, 13 Dec 2012 02:55:20 +0000

Hi Alexey & WG,

> 1) Is the problem described/solved by draft-ymbk-rpki-grandparenting-02 actually a problem that the WG needs to address? (Answer: yes or no. Additional information is welcomed, but I don't want peo…

No (with a 'but' under q.2).

The draft itself points out why the problem does not need to be addressed by the WG: "Managing RPKI data in such relationships is simple, but should be done carefully."  RPKI reflects records of current INR holdings.  If a CA recognises that INR holdings have changed, they may issue certificates to reflect that.  If they do not recognise changed INR holdings, they may not issue certificates (RFC 6484 4.2.2.)  Thus, if there is a business practice to recognise grandchildrens' rights to use resources, the RPKI can already match that practice.

IOW, there IS a problem, but it's not one for a technical working group to resolve, it's one for bilateral business relationships to resolve.

Hopefully that falls under 'additional information' rather than 'repeating the whole discussion'. :-)

> c) Should not be adopted. In particular this mean that you don't believe any amount of work on the proposed draft will address your issues. So any solution to this problem should be a new draft wri…

(c)

While I answered 'No' for (1), recognising the "carefully" part above may allow for a draft describing where in their CPS a CA can provide assurance to both children and grandchildren that they will act responsibly around these relationships, such as grace periods on revocation.  It would be possible to convert the current draft to do that, but the amount of change would make that effectively a new draft, I think.

> Does this need to be in a standalone draft, or can it be incorporated into another existing WG draft? When answering this question please only base your answer on technical reasons, in particular p…

n/a

Thanks,
  Byron

---

From: Terry Manderson <[email-masked]>
Date: Wed, 12 Dec 2012 21:51:30 -0800

Alexey and WG,

> I would like to initiate 2+ weeks poll (ending on December 31st 2012)

I think you should extend this by 2 weeks.

> Additional information is welcomed, but I don't want people to repeat

Yes.

> become a WG document? Please choose one of the following:

No.

> any solution to this problem should be a new draft written from scratch.

C.

Happy holidays and best wishes for the new year!

Cheers
Terry

---

From: Stephen Kent <[email-masked]>
Date: Thu, 13 Dec 2012 15:14:11 -0500

> ----------------
>
> 1) Is the problem described/solved by 
> draft-ymbk-rpki-grandparenting-02 actually a problem that the WG needs 
> to address? (Answer: yes or no. Additional information is welcomed, 
> but I don't want people to repeat the whole discussion.)
yes.
> a) Ready for Adoption (whether or not you have some specific issues 
> with it. Also, this answer is unrelated to whether this should be a 
> separate draft or a part of an existing draft).
NO
> b) Needs more work BEFORE Adoption
X
>
> c) Should not be adopted. In particular this mean that you don't 
> believe any amount of work on the proposed draft will address your 
> issues. So any solution to this problem should be a new draft written 
> from scratch.
>
> d) Abstain/don't care
>
>
> into another existing WG draft? When answering this question please 
> only base your answer on technical reasons, in particular please leave 
> the decision on who is going to edit the document (if it is 
> standalone) to WG chairs.

I don't recall another, extant WG draft with which this might be combined.

Steve

---

From: "George, Wes" <[email-masked]>
Date: Wed, 19 Dec 2012 11:08:55 -0500

> Additional information is welcomed, but I don't want people to repeat
[WEG] yes, but I tend to agree that it's not a technical problem.
> any solution to this problem should be a new draft written from scratch.
[WEG] b. The text itself is ok, but we need to resolve #3 before adoption.
> decision on who is going to edit the document (if it is standalone) to
[WEG] It needs to be incorporated into an existing draft.
This text is covering a very specific gotcha with some helpful recommendations and no actual requirements. It currently reads like an orphaned section of another draft, probably the operational considerations (origin-ops) draft.

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Andy Newton <[email-masked]>
Date: Fri, 21 Dec 2012 15:44:03 +0000

>Additional information is welcomed, but I don't want people to repeat

At present, I think not. While this is interesting, I don't think the IETF
is the venue for this document as the subject is not technical.

>decision on who is going to edit the document (if it is standalone) to

Should it be adopted, I think it should be standalone.

-andy