Subject: [sidr] I-D Action: draft-ietf-sidr-slurm-03.txt

From: [email-masked]
Date: Sat, 11 Feb 2017 18:50:11 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Secure Inter-Domain Routing of the IETF.

        Title           : Simplified Local internet nUmber Resource Management with the RPKI
        Authors         : David Mandelberg
                          Di Ma
                          Tim Bruijnzeels
	Filename        : draft-ietf-sidr-slurm-03.txt
	Pages           : 17
	Date            : 2017-02-11

Abstract:
   The Resource Public Key Infrastructure (RPKI) is a global
   authorization infrastructure that allows the holder of Internet
   Number Resources (INRs) to make verifiable statements about those
   resources.  Network operators, e.g., Internet Service Providers
   (ISPs), can use the RPKI to validate BGP route origination
   assertions.  In the future, ISPs also will be able to use the RPKI to
   validate the path of a BGP route.  However, ISPs may want to
   establish a local view of the RPKI to control its own network while
   making use of RPKI data.  The mechanisms described in this document
   provide a simple way to enable INR holders to establish a local,
   customized view of the RPKI, overriding global RPKI repository data
   as needed.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sidr-slurm/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-sidr-slurm-03

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sidr-slurm-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Declan Ma <[email-masked]>
Date: Mon, 13 Feb 2017 11:02:28 +0800

Hi, all,

We authors just updated the SLURM by adding a new ingredient JSON, offered by Tim,  to describe the SLURM configuration file format. 

Looking forwards to seeing your reviews and comments.

Thanks very much indeed.

Di 

ZDNS

> 下面是被转发的邮件：
> 
> 发件人: [email-masked]
> 主题: [sidr] I-D Action: draft-ietf-sidr-slurm-03.txt
> 日期: 2017年2月12日 GMT+8 10:50:11
> 收件人: <[email-masked]>
> 抄送: [email-masked]
> 
> 
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr

---

From: Tim Bruijnzeels <[email-masked]>
Date: Wed, 22 Feb 2017 10:00:52 +0100

Hi WG, Rob A. in particular :)

Can you please have a look at this version? If we don't hear any objections we plan to ask for WG LC one week from today.

See below for some small things that I already shared with co-authors and that are in our edit buffer. Just repeating here to save double work.

Cheers
Tim

---

@3.2:

current:

  o  One or more slurmTarget (Section 3.3) lines:

     *  In this version of SLURM, there are two types of values for the
        target: ASN or FQDN.  If more than one target line is present,
        all targets must be acceptable to the RP.

I believe this is somewhat unclear and incorrect for json. I think we should say instead:

  o  A slurmTarget element (Section 3.3), consisting of:

     *  Zero or more target elements. In this version of SLURM, there are
        two types of values for the target: ASN or FQDN.  If more than one
        target line is present, all targets must be acceptable to the RP.

So there has to be a slurmTarget:" element in the file, but it can have an empty list as its value. Which would mean "applies to all".

@3.3:

There is no 'header'. So I think we should say that "slurmTarget:" can have zero or more elements.

To be overly complete (if you want), we could give four examples:

empty:

"slurmTarget": []

asn only:

 "slurmTarget": [
      {
        "asn": 65536
      }
    ]

hostname only:

 "slurmTarget": [
      {
        "hostname": "rpki.example.com <http://rpki.example.com/>"
      }
    ]

both:

 "slurmTarget": [
      {
        "asn": 65536
      },
      {
        "hostname": "rpki.example.com <http://rpki.example.com/>"
      }
    ]

@3.4.1:

The grammar in the text that I provided for the numbered list seems in need of a little love..

So, rather than:

  1.  A Prefix Filter contains an IPv4 or IPv6 Prefix only, a VRP is
      considered to match the filter if the VRP Prefix is equal to or
      subsumed by the Prefix Filter.

maybe:

  1.  A Prefix Filter contains an IPv4 or IPv6 Prefix only and a VRP
      has a VRP Prefix that is equal to or subsumed by the Prefix Filter.

and similar in other places.. but we can also leave it to the RFC editor to fix this.

> On 13 Feb 2017, at 04:02, Declan Ma <[email-masked]> wrote:
> 
> Hi, all,
> 
>> 发件人: [email-masked] <mailto:[email-masked]>
>> 收件人: <[email-masked] <mailto:[email-masked]>>
>> 抄送: [email-masked] <mailto:[email-masked]>
>> 
>> 
>> https://datatracker.ietf.org/doc/draft-ietf-sidr-slurm/ <https://datatracker.ietf.org/doc/draft-ietf-sidr-slurm/>
>>