Subject: Re: [sidr] Protocol Action: 'BGP Prefix Origin Validation State Extended Community' to Proposed Standard (draft-ietf-sidr-origin-validation-signaling-11.txt)

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Thu, 23 Feb 2017 21:26:47 +0000

What happens if a BGP speaker validates a route in its own RPKI database
and finds it to be either Valid or Invalid (not NotFound) and also receives
the extended community that specifies a different validation state?

I don't see that condition covered in the draft.
I would say to ignore the extended community.

Thanks,
Jakob.

> -----Original Message-----
> From: sidr [mailto:[email-masked]] On Behalf Of The IESG
> Sent: Wednesday, January 11, 2017 7:25 AM
> To: IETF-Announce <[email-masked]>
> Cc: [email-masked]; [email-masked]; [email-masked]; The IESG
> <[email-masked]>; [email-masked]; [email-masked]
> Subject: [sidr] Protocol Action: 'BGP Prefix Origin Validation State Extended Community' to Proposed Standard
> (draft-ietf-sidr-origin-validation-signaling-11.txt)
> 
> The IESG has approved the following document:
> - 'BGP Prefix Origin Validation State Extended Community'
>   (draft-ietf-sidr-origin-validation-signaling-11.txt) as Proposed
> Standard
> 
> This document is the product of the Secure Inter-Domain Routing Working
> Group.
> 
> The IESG contact persons are Alvaro Retana, Alia Atlas and Deborah
> Brungard.
> 
> A URL of this Internet Draft is:
> https://datatracker.ietf.org/doc/draft-ietf-sidr-origin-validation-signaling/
> 
> 
> 
> 
> 
> Technical Summary
> 
>    This document defines a new BGP opaque extended community to carry
>    the origination AS validation state inside an autonomous system.
>    IBGP speakers that receive this validation state can configure local
>    policies allowing it to influence their decision process.
> 
> Working Group Summary
> 
>   This document has had consistent interest from the working group.
>   Because it defines a new BGP community, it was reviewed by the idr
>   working group as well.
> 
> Document Quality
> 
>   The document has been implemented by major router vendors.
>   It is known to be in use in two large IXPs, AMS-IX and DE-CIX.
> 
> Personnel
> 
>   Document Shepherd: Sandra Murphy
>   Responsible Area Director: Alvaro Retana
> 
> _______________________________________________
> sidr mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidr

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Thu, 23 Feb 2017 21:55:32 +0000

[Took the IESG, ietf-announce and rfc-editor lists off.]

Jakob:

Hi!

This document is already in AUTH48.  I don’t think we need to make any changes to the document, but if we do, we need to decide very soon.

The document doesn’t say anything about what should be done with this extended community, except to say that “speakers that receive this validation state can configure local policies allowing it to influence their decision process.”  IOW, there is no expected default processing of the validation state.

If the community is received and the router also has validation information, then I agree that the extended community is not needed…but I think that action is outside the scope of this document.

Thanks!

Alvaro.

On 2/23/17, 4:26 PM, "iesg on behalf of Jakob Heitz (jheitz)" <[email-masked] on behalf of [email-masked]> wrote:

    
    Thanks,
    Jakob.