Subject: [sidr] [Editorial Errata Reported] RFC7115 (4973)

From: RFC Errata System <[email-masked]>
Date: Sat, 18 Mar 2017 01:11:57 -0700 (PDT)

The following errata report has been submitted for RFC7115,
"Origin Validation Operation Based on the Resource Public Key Infrastructure (RPKI)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=7115&eid=4973

--------------------------------------
Type: Editorial
Reported by: Tassos Chatzithomaoglou <[email-masked]>

Section: 3 & 5

Original Text
-------------
section 3
---------
For example, if, instead of 10.0.0.0/16-24, one issues
   10.0.0.0/16 and 10.0.42.0/24, a forged origin attack cannot succeed
   against 10.0.666.0/24. 

section 5
---------
Consider having a ROA for AS 42 for prefix
   10.0.0.0/16-24.  A BGP announcement for 10.0.666.0/24 from AS 666
   would be Invalid

Corrected Text
--------------
section 3
---------
For example, if, instead of 10.0.0.0/16-24, one issues
   10.0.0.0/16 and 10.0.42.0/24, a forged origin attack cannot succeed
   against 10.0.66.0/24. 

section 5
---------
Consider having a ROA for AS 42 for prefix
   10.0.0.0/16-24.  A BGP announcement for 10.0.66.0/24 from AS 666
   would be Invalid

Notes
-----
666 is not a valid octet for an ipv4 address

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC7115 (draft-ietf-sidr-origin-ops-23)
--------------------------------------
Title               : Origin Validation Operation Based on the Resource Public Key Infrastructure (RPKI)
Publication Date    : January 2014
Author(s)           : R. Bush
Category            : BEST CURRENT PRACTICE
Source              : Secure Inter-Domain Routing
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: Randy Bush <[email-masked]>
Date: Sat, 18 Mar 2017 05:38:34 -0500

666 was not accidental.

randy