Subject: [Sidrops] WGLC comments on draft-ietf-sidrops-bgpsec-rollover-02

From: Sean Turner <[email-masked]>
Date: Thu, 5 Oct 2017 13:29:58 -0700

I read this draft way back when it was a SIDR WG draft, but reviewed it again today.  I think this document is ready to be pushed out of the WG and I only have the following nits that can be addresses now or later at the WG chair/author’s discretion:

0. Abstract as per RFC5280: r/Certificate Authority (CA)/Certification Authority (CA)

1. Abstract: Not sure I can parse this: "But the rollover of CA and EE certificates BGPsec router certificates” is there a missing word before “BGPsec”?

2. s1: r/router's key/router's BGPsec key

3. s1:/[RFC7030])/[RFC7030]

4. s3: r/Emergency router key rollover/Emergency router key rollover:

5. s3: r/OLD/old (?) unless you’re also going to change the new to NEW earlier in the paragraph

6. s3.1, Item 1: This item describes a "the new public key in a new certificate”, but the previous paragraph in s3 mentioned issuing a new certificate with an old key so I’m not sure “new” is needed before public key.  I guess “new” is also mention at the end of Item 2.  Basically, I just think you need to look at the wording to make sure that it doesn’t imply the key actually has to be new ;). Hope this comment makes sense.

7. s3.1, step 4: r/invalidate updates/invalidate BGPsec updates
and
r/OLD updates/OLD BGPsec updates

8. s2, s3.1, s4 for consistency: r/roll-over/rollover

Cheers,

spt

---

From: "Brian Weis (bew)" <[email-masked]>
Date: Tue, 10 Oct 2017 00:22:17 +0000

Hi Sean,

Thanks for the review. I’ve resolved the nits. A couple of issues have a response below.

> On Oct 5, 2017, at 1:29 PM, Sean Turner <[email-masked]> wrote:
> 

BEW: Oops, there are too many words. It should be "But the rollover of BGPsec router certificates have additional considerations ….”.

> 5. s3: r/OLD/old (?) unless you’re also going to change the new to NEW earlier in the paragraph

BEW: Reviewing the usage of NEW and OLD, I’m not sure there’s any value in making these stand out at all. I’ll change them all to “new” and “old”.

> 6. s3.1, Item 1: This item describes a "the new public key in a new certificate”, but the previous paragraph in s3 mentioned issuing a new certificate with an old key so I’m not sure “new” is neede…

BEW: Good catch. I've changed the text make it clearer that a new key pair is generated only if required.

Thanks,
Brian

> _______________________________________________
> Sidrops mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sidrops

-- 
Brian Weis
Security, CSG, Cisco Systems
Telephone: +1 408 526 4796
Email: [email-masked]