Subject: [Sidrops] Document on HTTPS on TALs (update to RFC7730) - seeking adoption

From: Tim Bruijnzeels <[email-masked]>
Date: Thu, 30 Nov 2017 14:02:11 +0100

Dear working group,

As discussed at IETF99, and in informal talks with some of you, we would like to update the TAL format (RFC7730) to allow HTTPS.

I worked with George Michaelson on an update. Because RFC7730 contains quite a few references to ‘rsync’ we felt that a new document updating 7730 would be more readable and appropriate then document updating many small bits of text. The -00 version of this document is here: https://tools.ietf.org/id/draft-tbruijnzeels-sidrops-https-tal-00.txt

We would like to ask the co-chairs to make a call to the working group for adoption.

In short this update will allow the use of HTTPS instead of, or in addition to, rsync on TALs. Other than that it contains a section on TLS verification similar to the one that is included in the delta protocol (RFC8182) - essentially saying that TLS verification is done on a best effort basis - and warnings should be uttered in case of issues - but because the TA certificate can still be validated cryptographically it MUST still be downloaded. Note that it is a matter of local policy whether an RP chooses to use different locations if they are present, but we may want to add some text here recommending the use of HTTPS URIs that have no TLS verification issues over ones that do - at this point I am not sure that this is needed, or would need to be normative text, but I think it would be good to have some discussion on this.

For the record, I am not sure what is customary in these cases of relatively small updates to existing standards. But, I tried to approach the other authors of RFC7730 (George is already one of them) and ask them whether they want to remain authors on this new document. Geoff Huston indicated that he does not need to be on the list, but has no objections to us doing this work. I have not seen responses from Sam Weiler or Stephen Kent - it is also possible that they missed my message. In any case we have no objections if they do wish to stay on as authors, but for now they are not on the list of the document linked above.

Kind regards,

Tim

---

From: "Roque Gagliano (rogaglia)" <[email-masked]>
Date: Thu, 30 Nov 2017 13:31:35 +0000

Hi Tim,

Not sure I understand why you are “updates” RFC 7730 and not “obsoletes” RFC7730. Could you please elaborate on this decision?

Regards,
Roque

On 30/11/17 14:02, "Sidrops on behalf of Tim Bruijnzeels" <[email-masked] on behalf of [email-masked]> wrote:

    Dear working group,

    

    
    Kind regards,
    
    Tim 

    
    _______________________________________________
    Sidrops mailing list
    [email-masked]
    https://www.ietf.org/mailman/listinfo/sidrops

---

From: Tim Bruijnzeels <[email-masked]>
Date: Thu, 30 Nov 2017 14:39:38 +0100

> On 30 Nov 2017, at 14:31, Roque Gagliano (rogaglia) <[email-masked]> wrote:
> 
> Hi Tim,
> 

I believe you’re right and it should indeed say ‘obsoletes’ - as in replaces - rather than updates (parts) of it. That said, most of the text is a straight copy of the text in 7730.

Tim