Subject: [Sidrops] Alexey Melnikov's Discuss on draft-ietf-sidrops-bgpsec-algs-rfc8208-bis-04: (with DISCUSS)

From: Alexey Melnikov via Datatracker <[email-masked]>
Date: Wed, 10 Apr 2019 10:48:07 -0700

Alexey Melnikov has entered the following ballot position for
draft-ietf-sidrops-bgpsec-algs-rfc8208-bis-04: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-sidrops-bgpsec-algs-rfc8208-bis/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

This is a fine document and sorry for nit-picking, but why is this document
"Updates: 8208" instead of "Obsolete: 8208"?

---

From: "Borchert, Oliver (Fed)" <[email-masked]>
Date: Wed, 10 Apr 2019 18:48:47 +0000

Alexey,

As I currently work through the feedback and comments which I will reply to in each respective comment soon, the question of Update vs Obsolete was raised in another comment as well.
As I see it now, this document might be a better fit for the "Obsoletes" category rather the "Updates" category.
The reasoning for that is that this document is re-write of 8208 containing all of 8208 with some important corrections we did not catch during the final stages of 8208. 
Also it extends 8208 with the ID space for Experimentation and Documentation which we forgot and I restructured the document to be easier to understand by implementers. 
A previous comment mentioned the "Special-ID" it should be split into "Experimentation" and "Documentation" which I did already but did not post my response yet.

So to answer your question I believe it should be changed into "Obsoletes" rather than "Updates" which makes it cleaner.

Thanks,
Oliver 

-----Original Message-----
From: Alexey Melnikov via Datatracker <[email-masked]> 
Sent: Wednesday, April 10, 2019 1:48 PM
To: The IESG <[email-masked]>
Cc: [email-masked]; Chris Morrow <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Subject: Alexey Melnikov's Discuss on draft-ietf-sidrops-bgpsec-algs-rfc8208-bis-04: (with DISCUSS)
Importance: High

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

Please refer to https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fiesg%2Fstatement%2Fdiscuss-criteria.html&amp;data=02%7C01%7Coliver.borchert%40nist.gov%7C3d199c9189874498718808d6bddcb638%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636905152992003877&amp;sdata=uPILjMMg9SZIiXxm4QyznthiBIjWdEILBuUhzmJDJf4%3D&amp;reserved=0
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://gcc01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ietf-sidrops-bgpsec-algs-rfc8208-bis%2F&amp;data=02%7C01%7Coliver.borchert%40nist.gov%7C3d199c9189874498718808d6bddcb638%7C2ab5d82fd8fa4797a93e054655c61dec%7C1%7C0%7C636905152992013882&amp;sdata=L5yT56fkLdCegqmo%2Bp2dsZMbJffDr8h2xbrakDWqdxQ%3D&amp;reserved=0

---

From: Warren Kumari <[email-masked]>
Date: Wed, 10 Apr 2019 14:48:53 -0400

Thanks an excellent question -- I suspect that the answer is simply
"Whoops, that was a mistake" -- is that correct?
W

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: Sean Turner <[email-masked]>
Date: Wed, 10 Apr 2019 17:27:50 -0400

> On Apr 10, 2019, at 14:48, Warren Kumari <[email-masked]> wrote:
> 
> 
> 
> On Wed, Apr 10, 2019 at 1:48 PM Alexey Melnikov via Datatracker <[email-masked]> wrote:
> Thanks an excellent question -- I suspect that the answer is simply "Whoops, that was a mistake" -- is that correct?
> W

Nope this draft is an updates because it’s just adding some things to 8208 not replacing it entirely.

spt

---

From: Benjamin Kaduk <[email-masked]>
Date: Wed, 10 Apr 2019 16:30:26 -0500

> Nope this draft is an updates because it’s just adding some things to 8208 not replacing it entirely.

Er, what is left in 8208 that's not being replaced?
The diff seems pretty indicative that all the content is present in the new
doc, to me.

-Ben

---

From: Sean Turner <[email-masked]>
Date: Wed, 10 Apr 2019 17:33:02 -0400

> On Apr 10, 2019, at 17:30, Benjamin Kaduk <[email-masked]> wrote:
> 

I have always thought ot this an updates.  I am also willing to change it to be an obsoletes.

spt

---

From: Sean Turner <[email-masked]>
Date: Thu, 11 Apr 2019 07:52:40 -0400

> On Apr 11, 2019, at 06:00, Alexey Melnikov <[email-masked]> wrote:
> 
> On Wed, Apr 10, 2019, at 10:30 PM, Benjamin Kaduk wrote:
> Exactly. This document doesn't just update the IANA registration process, it incorporates the whole RFC 8208 content. After it is published as an RFC, there would never be any need for people to read RFC 8208. This means it is obsolete relationship.

No argument whatsoever from me about whether this is an obsoletes/updates.  am looking forward to the finalized IESG statement on updates vs obsoletes ;).

spt

---

From: Randy Bush <[email-masked]>
Date: Fri, 12 Apr 2019 14:57:51 -0700

> No argument whatsoever from me about whether this is an
> obsoletes/updates.  am looking forward to the finalized IESG statement
> on updates vs obsoletes ;).

tenterhooks

---

From: "Alexey Melnikov" <[email-masked]>
Date: Thu, 11 Apr 2019 06:00:47 -0400

---

From: "Borchert, Oliver (Fed)" <[email-masked]>
Date: Mon, 15 Apr 2019 21:39:39 +0000

From IESG evaluation record:
> Alvaro Retana Yes
> Comment (2019-04-11)
> I support Alexey's DISCUSS: this document should be marked as Obsoleting rfc8208.

I modified the draft to "Obsoletes" and uploaded draft-ietf-sidrops-bgpsec-algs-rfc8208-bis-05 with the latest changes.

Oliver

On 4/11/19, 7:52 AM, "Sean Turner" <[email-masked]> wrote:

    
    
    spt