Subject: [Simple] question on presence callflow

From: Torrey Searle <[email-masked]>
Date: Thu, 22 Nov 2001 02:51:54 -0800

In the callflow example 8.2 of the presence document 04, there is a call flow for the presentity changing state, however there are afew strange things about it

1. the presentity state doesn't change, it both notifies indicate the state as open/available

2. upon the state change, the PUA sends a register to the PA, persumably to update it's presence info using the REGISTER method, however, aside from stating support for SUBSCRIBE (which it also did in the inital invite) there is no presence state information contained in the register)

I notice that in older versions on the draft, this example used to show a transition from open/available to closed/busy and the register updating the presence info using the description parameter defined in the caller preferences extension, since section 6.2 of the 04 presence document still recommends the use of the caller preferences extension to update state of the presentity, why was this parameter dropped from the current call flow?

Does this call flow still make sense in the current version of the draft? Can it be updated to show an actual change of state?

Torrey
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 26 Nov 2001 16:10:28 -0500

> -----Original Message-----
> From: Torrey Searle [mailto:[email-masked]]
> Sent: Thursday, November 22, 2001 5:52 AM
> To: [email-masked]
> Subject: [Simple] question on presence callflow
> 
> 
> In the callflow example 8.2 of the presence document 04, 
> there is a call flow for the presentity changing state, 
> however there are afew strange things about it
> 

Good point. I will fix this.

> 
> 2. upon the state change, the PUA sends a register to the PA, 
> persumably to update it's presence info using the REGISTER 
> method, however, aside from stating support for SUBSCRIBE 
> (which it also did in the inital invite) there is no presence 
> state information contained in the register)

Same error as above.

> 
> 
> I notice that in older versions on the draft, this example 
> used to show a transition from open/available to closed/busy 
> and the register updating the presence info using the 
> description parameter defined in the caller preferences 
> extension, since section 6.2 of the 04 presence document 
> still recommends the use of the caller preferences extension 
> to update state of the presentity, why was this parameter 
> dropped from the current call flow?

Description is really not quite the right thing to set the note in the
presence document. However, there should be some kind of state change here,
driven by caller preferences. 

-Jonathan R.
---
Jonathan D. Rosenberg, Ph.D.                72 Eagle Rock Ave.
Chief Scientist                             First Floor
dynamicsoft                                 East Hanover, NJ 07936
[email-masked]                     FAX:   (973) 952-5050
http://www.jdrosen.net                      PHONE: (973) 952-5000
http://www.dynamicsoft.com
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple