Subject: RE: [Simple] Expires in MESSAGE

From: Robert Sparks <[email-masked]>
Date: Mon, 12 Nov 2001 16:49:41 -0500

I'm not sure I understand your point.

Yes, MESSAGE is a SIP method.

There are no "same rules" to be considered. The core
spec provides meaning to Expires for REGISTER, and
(somewhat loosely) for INVITE, and those are different!
It has no meaning for the other core methods (Expires
is meaningless for BYE). New methods must specify meaning
(if any) on their own.

For MESSAGE, I hold that the Expire header contains the
period for which the content of the message should be
considered valid, and it should be up to the applications
involved to decide what to do with expired messages, not
the transport mechanism. Different applications are likely
to need to make different choices. I may have a service where
it is useful for me to know you invited me to lunch, even
though I didn't see your invitation until it was too late to
accept.

RjS

> -----Original Message-----
> From: Roy, Radhika R, ALCTA [mailto:[email-masked]]
> Sent: Monday, November 12, 2001 3:08 PM
> To: Robert Sparks; Sean Olson; [email-masked]'
> Cc: [email-masked]
> Subject: RE: [Simple] Expires in MESSAGE
> 
> 
> Hi, Roberts:
>  
> Is not that "MESSAGE" another method in SIP like INVITEs, 
> etc.? If so, why
> do we not use the same rules (e.g., the interpretations can 
> be made in the
> SIP layer)?
>  
> Radhika
> 
> -----Original Message-----
> From: Robert Sparks [mailto:[email-masked]]
> Sent: Monday, November 12, 2001 3:57 PM
> To: Sean Olson; [email-masked]'
> Cc: [email-masked]
> Subject: RE: [Simple] Expires in MESSAGE
> 
> 
> Interpreting Expires to put bounds on the validity of the content
> of the message is the correct thing to do. 
>  
> This is, however, information for the applications (or people) using
> the message, not for the routing fabric. In particular, I don't think
> it will make sense to reject "expired" messages at, say, a proxy. 
> Even at an endpoint, it should be up the the application running
> above SIP to decide if it wants to process the "expired" message.
> Taking that decision away (by requiring the SIP implementation
> itself to reject the expired message) will do harm.
>  
> RjS
>  
> -----Original Message-----
> From: Sean Olson (EUS) [mailto:[email-masked]]
> Sent: Monday, November 12, 2001 1:25 PM
> To: [email-masked]'
> Cc: [email-masked]
> Subject: RE: [Simple] Expires in MESSAGE
> 
> 
> 
> Hi, 
> 
> I see what you are saying. Should the "Expires: 0" be 
> interpreted as in a REGISTER or as in an INVITE? I was 
> thinking it would be treated the same as in an INVITE. 
> If you receive a MESSAGE with an Expires: that has passed 
> (or is literally zero), you return a 400 response and 
> "drop" the MESSAGE. 
> 
> /sean 
> 
> >Hi Sean, 
> > 
> >> This seems like the most logical interpretation for MESSAGE. 
> >> This would also seem to encompass the application you have in 
> >> mind below. 
> > 
> >I assumed the zero expiry is only defined for REGISTER and 
> >SUBSCRIBE, and 
> >maybe similar definitions for its semantics for MESSAGE would 
> >be needed? 
> > 
> >Cheers, 
> >Aki 
> > 
> 
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Tue, 13 Nov 2001 21:56:36 -0600

Do you think the (rather imprecise) definition in bis-05 22.19 is 
sufficient? Or do we need to add more to the message draft?