Subject: [Simple] AW: [Sipping] Immediate NOTIFIES change in sip-events-01

From: Brazier Lachlan <[email-masked]>
Date: Fri, 9 Nov 2001 14:57:59 +0100

> >
> > Sorry for being unclear; I did'nt say to use the ACK like
> > with the INVITE.
> > Because of the SUBSCRIBE request, only one 2xx response will
> > be carried
> > upstream. The the ACK will be forked from the proxy to every
> > endpoint (=
> > presentity). This way every endpoint will know wheter it's
> > response was
> > received or not (because only the right tag in the To header
> > will match).
> > I thought this was what we wanted.
> > General I don't see why the ACK request should be "untouchable".
> 
> The problem is unreliable transport and specfically 
> retransmission in this
> case. You'd have to alter ACK behaviour to cope with 
> non-INVITE requests,
> this is ugly.

Ok, agreed, and I received other reasons why ACK won't work in a neat way. 
But this also means, that every draft which depends on a 3-way handshake,
has to invent it new from the beginning.

Lachlan
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Brian Stucker" <[email-masked]>
Date: Fri, 9 Nov 2001 11:38:19 -0600

Well that depends. They could copy what SUBSCRIBE/NOTIFY does if that's good
enough for their use.

Brian

-----Original Message-----
From: Brazier Lachlan [mailto:[email-masked]]
Sent: Friday, November 09, 2001 7:58 AM
To: 'James Undery'; Brazier Lachlan; 'Fairlie-Cuninghame, Robert'; 'Bob
Penfield'; [email-masked]
Cc: [email-masked]; [email-masked]'
Subject: AW: [Sipping] Immediate NOTIFIES change in sip-events-01

Lachlan

_______________________________________________
Sipping mailing list  http://www1.ietf.org/mailman/listinfo/sipping
This list is for NEW development of the application of SIP
Use [email-masked] for questions on current sip
Use [email-masked] for new developments of core SIP