Subject: RE: [Simple] Expires in MESSAGE

From: [email-masked]
Date: Tue, 13 Nov 2001 18:09:20 +0200

> I agree with Robert here. Proxies should ignore Expires in 
> MESSAGE. If a UA
> wants to use it in some way, for example to limit the display 
> of an IM on
> the screen, that is reasonable.

I agree, for non-zero expirys. 

I'm looking for some extended meaning for the "Expires: 0" in MESSAGE. Like
the "fetch" in SUBSCRIBE, or "remove contact" in REGISTER, it could have
some added value for IM applications as well. 

For example, having zero expiry mean "don't store and forward me" sounds
like something an IM inbox might find useful.

Cheers,
Aki
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: [email-masked]
Date: Tue, 13 Nov 2001 11:29:26 -0600

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
>

Please, don't special case zero.

I agree 100% with Robert and Jonathan: Expires should be treated
exactly like it is for e-mail. In other words, the client may
(or may not) choose to render this content in some special fashion
to indicate to the user that the message is no longer relevant.

Expires for MESSAGE should not have transport semantics.

/a