Subject: [Simple] problem: how upload presence document?

From: "sal" <[email-masked]>
Date: Fri, 2 Nov 2001 10:59:45 +0100

i think that this question: "upload presence document" is a critical issue.

there isn't a standard procedure to upload and to modify the presence document, but it is the source of the presence status ... 
if the UA... if the PUA change its media capability, or change its status, it MUST refresh the presence document.

the upload must be made through the protocol sip!!!
and not push the presence doc via another protocol, such as HTTP POST.

I agree with Steven Donovan when he says in the draft
"Requirement for Pubblication of SIP related service data"
: "... it is felt that the SIP REGISTER request is NOT the appropriate mechanisme for handing this loading od SIP service information..."
but i'm not sure that a generalization of the REGISTER function,
as proposed in the draft, is a good idea

The use of the method REGISTER, for the upload,introduces one series of problems, just one example:
the expiration of the Presence document and the expiration of the current communication addresses (i.e. Contact Addres) are different...

I have instead a proposed other:
the use of method NOTIFY...
this method is already used for send the presence state to
a particular subscriber... 
the its generalization for the upload or refresh of Presence Document is very simple and has the advantage of not modify/generalization
a very important message for sip as REGISTER...

which is your opinion ?
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Håkan Jonsson <[email-masked]>
Date: Fri, 2 Nov 2001 12:05:13 +0100

I think that the letting the PA subscribe to the PUAs presence document
is a nice approach, since you can use it as it is. One thing you would
need to add to the NOTIFY is an Expires header and interpret that as the
expiration time for a soft state, to satisfy the requirements in
draft-donovan..., but I think that is allowed by the current sip-events
draft.

The PUA can manipulate presence information in a number of ways, which
is good. For presence documents I don't think we should limit ourselves
to one way, but specifying a mechanism to upload service data using SIP
in general as suggested in Donovan's draft is desirable, and should be
one of the ways to upload presence documents.

As Donovan suggests in his draft, the actions to be taken using the
uploaded data could be put in the body or in an extension of SIP
methods, headers etc. I think defining a new event type for each type of
data would result in a lot of event types. Using NOTIFY, SUBSCRIBE with
one new event type: servicedata, and letting the actual body contain the
specific data manipulation actions to be done in a service specific
language, is the most general and clear-cut way to do it. On the other
hand, if there only a few service data types needed, we could define
specific event types for these. Donovan mentions presence documents and
CPL scripts; what other types are needed?

Håkan
-----------------
Håkan Jonsson              Drottninggatan 18
BlueLabs South AB          21189 Malmö
http://www.bluelabs.se     Sweden

> -----Ursprungligt meddelande-----
> Från: [email-masked] 
> [mailto:[email-masked]] För sal
> Skickat: den 2 november 2001 11:00
> Till: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]
> Kopia: [email-masked]
> Ämne: [Simple] problem: how upload presence document?
> 
> 
> there isn't a standard procedure to upload and to modify the 
> presence document, but it is the source of the presence status ... 
> if the UA... if the PUA change its media capability, or 
> change its status, it MUST refresh the presence document.
> 
> 
> : "... it is felt that the SIP REGISTER request is NOT the 
> appropriate mechanisme for handing this loading od SIP 
> service information..." but i'm not sure that a 
> generalization of the REGISTER function, as proposed in the 
> draft, is a good idea
> 
> 
> The use of the method REGISTER, for the upload,introduces one 
> series of problems, just one example: the expiration of the 
> Presence document and the expiration of the current 
> communication addresses (i.e. Contact Addres) are different...
> 
> the its generalization for the upload or refresh of Presence 
> Document is very simple and has the advantage of not 
> modify/generalization a very important message for sip as REGISTER...
> 
> 
> which is your opinion ? 
> http://mailman.dynamicsoft.com/mailman/listinf> o/simple
>