Subject: AW: [Simple] RE: Question regarding NOTIFY messages using UDP.

From: Brazier Lachlan <[email-masked]>
Date: Tue, 4 Dec 2001 17:31:31 +0100

Hello,

> 
> >Great. 
> >So, we'll have the ability to specify application/url-list 
> in the SUBSCRIBE
> for presence 
> >events in the -05 draft? 
> 
> Well, we need to decide whether thats really a separate 
> package, or just a
> different data format for an existing package.
> 
> We also need a few more opinions on this subject, since the 
> list has been
> faily quiet of late.
> 

does this mean that in the NOTIFY there is no cpim-xpidf+xml document but a
URI or a list of URI's where the client can get the cpim-xpidf+xml document
with HTTP or whatever is specified?

I this correct?
If yes, sounds beautiful. Haven't thought about the packages yet.

Lachlan
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Henning G. Schulzrinne" <[email-masked]>
Date: Tue, 04 Dec 2001 11:39:40 -0500

Brazier Lachlan wrote:

> If yes, sounds beautiful. Haven't thought about the packages yet.

As long as you consider the practical problems. For example, you now
need to have the ability to "reach back" to the web server of the
notifier. You need to coordinate authentication. If you used hop-by-hop
transitive trust, that won't work any more and you'll have to resort to
a shared secret, either via TLS from the notified party or standard HTTP
Digest, making sure that the passwords are properly aligned. Also, how
long is the URL valid? Forever? Until the subscription expires?

I'm not against coupling protocols, but one shouldn't ignore the
practical complications that arise.
-- 
Henning Schulzrinne   http://www.cs.columbia.edu/~hgs
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple