Subject: RE: [Simple] Duration of URIs in application/uri-list for Presenc e

From: [email-masked]
Date: Tue, 18 Dec 2001 11:44:11 +0200

Hi All,

> I agree with Ben. Although you raise good points Paul. 
> Can we all agree to: 
> 1. The URL is good for the interval expressed in the EXPIRES 
> header of the notification which contained the presence 
> document URL, or the Subscription-Expires (soon to be 
> Subscription-State), whichever is shorter.

Overall, I like the sound of this proposal. However, a distinct linking like
this between the Subscription-Expires and Expires assumes that subscriptions
always establish a session. This assumption makes a fetch of event state
impossible using the URL mechanism.

> 2. If another notification is received during the interval 
> identified in (1), then the previous URL should be considered 
> stale. The most recent notification always takes precedence.
> 3. If the subscription ends, any presence URLs associated 
> with that subscription should be considered stale. 
> 4. If a notify is received with an EXPIRES set to zero, the 
> URL is considered dead-on-arrival. 
> 5. If a notify is received without an EXPIRES header, the URL 
> is good for the duration of the subscription. 

Cheers,
Aki
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Sean Olson <[email-masked]>
Date: Tue, 18 Dec 2001 06:39:22 -0800 (PST)

> always establish a session. 

For presence at least, they do.

>This assumption makes a
> fetch of event state

Why?

/sean

=====
--
Sean Olson <[email-masked]>
This is from me. Assume nothing else.

__________________________________________________
Do You Yahoo!?
Check out Yahoo! Shopping and Yahoo! Auctions for all of
your unique holiday gifts! Buy at http://shopping.yahoo.com
or bid at http://auctions.yahoo.com
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple