Subject: RE: [Simple] Status summary

From: Adam Roach <[email-masked]>
Date: Mon, 6 May 2002 20:01:29 -0400

I've been using XP Messenger with my own SIP-based IM client
for some time now. As I'm currently on an airplane (and without
a network), I can't include a packet trace. If you really want
me to ferret one out, let me know and I'll send you one.

/a

-----Original Message-----
From: Avshalom Houri [mailto:[email-masked]]
Sent: Tuesday, April 16, 2002 14:03
To: Tom Karlo
Cc: Henning Schulzrinne; [email-masked]; [email-masked];
[email-masked]; Peter Saint-Andre; Tony Hansen
Subject: RE: [Simple] Status summary

What is sip based in the XP Windows messenger is in the VOIP part. The PIM
part is still using the MSN protocol (VER 119) as can be seen if you look at
the packets it sends. 

Avshalom Houri
Presence and Instant Messaging Architect
Lotus Sametime, IBM Software Group
[email-masked]

Tom  Karlo <[email-masked]> 
Sent by: [email-masked] 
16/04/2002 16:23 
Please respond to Tom  Karlo 
        
        To:        Avshalom Houri/Haifa/IBM@IBMIL, Henning Schulzrinne
<[email-masked]> 
        cc:        [email-masked], [email-masked], Peter
Saint-Andre <[email-masked]>, Tony Hansen <[email-masked]> 
        Subject:        RE: [Simple] Status summary 

Actually, the latest Windows Messenger has been SIP-based for a while now (6
months?) My company is one of the carriers providing support. You might have
to check the XP messenger, although I do believe 4.6 would be the right one.
If you get the version where when making a phone call, you’re given a list
of services to choose from, then that’s the SIP one. The old one only
allowed you to use the Net2Phone protocol. 
 
Tom Karlo 
Net2Phone 
 
-----Original Message-----
From: Avshalom Houri [mailto:[email-masked]] 
Sent: Tuesday, April 16, 2002 6:39 AM
To: Henning Schulzrinne
Cc: [email-masked]; [email-masked]; Peter Saint-Andre;
Tony Hansen
Subject: Re: [Simple] Status summary 

I was checking the Windows messenger version 4.6. As far as I know: 
       * This version is based on the MSN protocol and not SIP. 
       * The SIP client is not publically available yet. 

Avshalom Houri
Presence and Instant Messaging Architect
Lotus Sametime, IBM Software Group
[email-masked]

  Henning Schulzrinne <[email-masked]> 
16/04/2002 00:26 
Please respond to Henning Schulzrinne         
       To:        Peter Saint-Andre <[email-masked]> 
       cc:        Tony Hansen <[email-masked]>,
[email-masked], [email-masked], Avshalom
Houri/Haifa/IBM@IBMIL 
       Subject:        Re: [Simple] Status summary 

I'm curious: Windows Messenger, supposedly using SIP and IMPP presence,
has a bunch of status indications, similar to the ones mentioned on the
list (lunch, do not disturb, etc.). How are they encoded?

Peter Saint-Andre wrote:
> 
> FWIW, we provide the following statuses (stati?) in Jabber:
> 
> 1. Unavailable (maps to CLOSED)
> 
> 2. Available (maps to OPEN) with sub-statuses:
>    - away
>    - extended away
>    - do not disturb
>    - free/desiring to chat
> 
> 3. Invisible
> 
> Any status can be extended with a natural-language description of the
> status.
> 
> More information at
> http://www.jabber.org/ietf/draft-miller-jabber-00.html#common-presence
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: "Avshalom Houri" <[email-masked]>
Date: Tue, 14 May 2002 19:21:00 +0300

Lotus Sametime has DND and users use it a lot. It is like closing the door 
and putting do not disturb on the door. People know that you are there but 
will not disturb you. In DND you can open an IM session with someone that 
you wish to talk to but you are not bothered by IMs.

Avshalom

Tony Hansen <[email-masked]>
Sent by: [email-masked]
14/05/2002 19:06
Please respond to Tony Hansen

        To:        [email-masked]
        cc: 
        Subject:        Re: [Simple] Status summary

All of the statuses that Henning and I proposed were OPEN statuses. That
is, they were all to be used when messages were allowed to be sent.

That is, to our list you'd add CLOSED, which equates to the Offline
status for most services.

Now, Closed but active (your DND/Do Not Disturb) is an interesting
status. I don't think the rfc2778 model supports that. Do we need
annotated CLOSED statuses? Do we need a way of saying "I'm around, but
don't bother me"?

(AT&T's IM Anywhere service once supported the equivalent to annotated
CLOSED statuses. We eventually got rid of the concept.)

                 Tony

Avshalom Houri wrote:
 >
 > I understood busy as an hint that means that I am busy so please 
disturb
 > me only if it is a urgent issue. So it is Open-Active while DND is
 > Closed-Active.
 >
 > Avshalom
 >
 > Michael Hammer <[email-masked]>
 >
 > Avshalom,
 >
 > So what is the difference between a busy and a DND?  Some of this seems
 > to boil down to the explicit not available (Busy, DND) and the implicit
 > (Away).  So essentially there is:
 >
 > Closed-permanent (Explicit:  De-registration)
 > Closed-temporary (Explicit:  Busy, DND, Out to lunch, etc.)
 > Open-Active      (Implicit:  Actively using)
 > Open-Inactive    (Implicit:  Away so Maybe).
 >
 > One last comment:  Since some of this may reveal presence, it may be a
 > good idea to recommend a default that must be manually over-ridden to
 > allow that type of information to be sent (protect privacy).
 >
 > Mike
 >
 > At 11:20 AM 5/14/2002 +0300, Avshalom Houri wrote:
 >
 > It seems that there is a place for another state - Do Not Disturb 
(DND).
 > DND means that although I am online messages sent to me will not 
reach me.
 > Thus, the blocking of the messages can be done in the client of the
 > originator.
 >
 > So the states that we will have are:
 > * Free (Available)
 > * Busy (Open but I am busy)
 > * DND (Closed for communication)
 > * Away, for an
 >   indeterminate amount of time (used also by automatic away sensed by
 > the client)
 >   short time (set manually)
 >   long time (set manually)
 >
 > Avshalom Houri
 > 14/05/2002 03:52
 >        To:        Tony Hansen <[email-masked]>
 >        cc:        [email-masked]
 >  > Your "on the phone" is just another version of Busy.
 >
 > Agreed; the only reason I kept it separate is that a SIP device may 
know
 > this condition specifically. It might be useful to have a two-level
 > hierarchy of labels, as in busy.phone and busy.meeting.
 >
 >  >
 >  > I see the following set:
 >  >
 >  >     Free (Available)
 >  >     Busy
 >  >     Away, for an
 >  >         indeterminate amount of time
 >  >         short time
 >  >         long time
 >  >
 >  > Each could also be annotated with additional text.
 >  >
 >  > Busy means "I'm doing stuff, so may not respond right away. 
Annotations
 >  > for Busy would be things such as "On the phone" and "In a meeting".
 >  >
 >  > The time based settings are purely subjective values, not concrete
 >  > values. The indeterminate time would be appropriate for use by an 
idle
 >  > timer.
 >
 > It would be nice to be able to provide an explicit time of return. With
 > calendar integration, this wouldn't be too hard. Obviously, this would
 > be optional.

---

From: "Liscano, Ramiro" <[email-masked]>
Date: Tue, 14 May 2002 12:45:47 -0400

It seems to me that DND behaves much like a Closed Permanent since the watchers
cannot commence a communication session with the Presentity. If the primary purpose
of presence is to enable communications then if you cannot communicate then
you should not be available.

Busy on the other hand still allows a Watcher to communicate with a Presentity.
The reality is that it carries many meanings that depend on the relationship with
other persons. It seems to me that there are only 3 accurate states:

 Closed-permanent (Explicit:  De-registration, DND)
 Open-Active      (Implicit:  Actively using, context is sent to watchers)
 Open-Inactive    (Implicit:  Away, Out to lunch, etc.).

It is relatively difficult to define these states unless you define an Ontology
based on a context.

Ramiro Liscano
Mitel Networks
350 Legget Dr. PO Box 13089
Kanata, Ontario, Canada K2K 2W7
tel: (613) 592-2122 x4966
fax: (613) 592-7836

-----Original Message-----
From: Tony Hansen [mailto:[email-masked]]
Sent: Tuesday, May 14, 2002 12:06 PM
To: [email-masked]
Subject: Re: [Simple] Status summary

	Tony

Avshalom Houri wrote:
 >
 > I understood busy as an hint that means that I am busy so please disturb
 > It seems that there is a place for another state - Do Not Disturb (DND).
reach me.
 > Agreed; the only reason I kept it separate is that a SIP device may know
Annotations
 >  > values. The indeterminate time would be appropriate for use by an idle
 >  > timer.
 >

---

From: Michael Hammer <[email-masked]>
Date: Tue, 14 May 2002 13:22:05 -0400

Ramiro,

Would there ever be a distinction between:

Closed-permanent as in unreachable
Closed-temporary as in reachable, but does not want to communicate.

I am also wondering if it is possible to have an emergency 
over-ride.  Closed may mean that messages are dumped if received.  But, if 
you are open to receiving emergency broadcast IMs, they could be 
accepted.  Thus you may be closed to some grade of messages, but open to 
others from the same sender.

Mike

---

From: "Boyer, David G (Dave)" <[email-masked]>
Date: Wed, 15 May 2002 11:37:52 -0400

Christian -

There are really 3 states - present (available for communication), not present
(closed - unavailable for communication, unknown (presentity has denied watcher
access to their information, network problem, client down, user agent problem,
etc.).  The subfield of a closed status can be "unknown" covering the third
case, but I do think there are really 3 states.

Dave Boyer

> From: Christian Huitema [mailto:[email-masked]]
> Sent: Tuesday, May 14, 2002 9:08 PM
> To: [email-masked]; Tony Hansen; [email-masked]
> Short summary: closed is closed; everything else ought to be 
> a variation
> of "open".
> 
> I have the impression that we are trying to overload two different
> concepts in the "status" field: on one hand, information on 
> what we know
> about the person, e.g. busy or not, ready to take a phone call or not,
> and on the other hand information about the presence agent, i.e.
> connected to the network or not. Obviously, there is some relation: in
> the absence of any presence agent, the best we can state is some
> variation of "off-line" -- i.e. "closed". On the other hand, every
> information about the status of a person is a shade of gray: 
> I may be on
> the phone but still willing to read your IM; I may be out to 
> lunch, but
> my agent is capable of filling up for me; I may have placed a
> do-not-disturb sign on my door, but my agent may me authorize to still
> disturb me if some really important event happens.
> 
> -- Christian Huitema

---

From: "Boyer, David G (Dave)" <[email-masked]>
Date: Wed, 15 May 2002 12:24:59 -0400

> From: Liscano, Ramiro [mailto:[email-masked]]
> Sent: Tuesday, May 14, 2002 12:46 PM
> To: 'Tony Hansen'; [email-masked]

The inverse of this is also useful - Person not available but
communication (at least to a messaging system) is available.  It
can be useful to see that someone is not present, you may just
want to leave them a message and would rather not talk with them.