Subject: RE: [Simple] Status summary

From: "Boyer, David G (Dave)" <[email-masked]>
Date: Mon, 20 May 2002 16:21:09 -0400

Ben,

I think this gets at the notion I was trying to express when 
someone may not allow you to receive their presence info (temporarily
or permanently).  You
may not be able to receive a presentities presence info but
you still can communicate with them (this applies equally for
IM and phone based communications).

Dave

> -----Original Message-----
> From: Ben Campbell [mailto:[email-masked]]
> Sent: Monday, May 20, 2002 4:14 PM
> To: [email-masked]; Tony Hansen
> Cc: [email-masked]
> Subject: RE: [Simple] Status summary
> 
> 
> Invisible isn't a status in the sense that you communicate an 
> invisible
> status to a watcher. Invisible really means that, while you 
> are online, able
> to send IMs, and possibly able to receive them, you choose 
> not to provide
> presence status to that effect.
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Debi Jones
> > Sent: Wednesday, May 15, 2002 8:50 PM
> > To: Tony Hansen
> > Cc: [email-masked]
> > Subject: Re: [Simple] Status summary
> >
> >
> > Where does "invisible" fit?  Invisible defined as presence info
> > not viewable by
> > others on the network.
> > It certainly isn't a status indicator for OPEN.  Multiple cases
> > for CLOSED is
> > intrinsically a bad idea.
> >
> > ...Debi
> >
> > Tony Hansen wrote:
> >
> > > Since Jonathan reopened this thread a couple of days ago, 
> no one has
> > > advocated changing the set of OPEN and CLOSED.
> > >
> > > All we've been talking about is those additional hints to 
> add to the
> > > Presence Status.
> > >
> > > In fact, my suggestion a couple of days ago (and 
> clarified in subsequent
> > > messages) was somewhat similar to what you stated, that 
> OPEN should be
> > > annotated by:
> > >
> > >      Available
> > >      Busy (but still able to receive messages)
> > >      Away, for various subjective time values
> > >         (unknown, short time, long time),
> > >         but still able to receive messages
> > >
> > > I feel that additional text can be added that gives additional
> > > information, such as "Out to lunch" and "In a meeting".
> > >
> > > One suggestion is that the hint for OPEN should be a 
> freeform string
> > > whose first word is one of the 3 words "Available", 
> "Busy", and "Away",
> > > and each of which can optionally have the string "/Short-Time",
> > > "/Long-Time" and "/Unknown-Time" attached. Anything after that is
> > > totally up to the client and the user.
> > >
> > >         Tony Hansen
> > >         [email-masked]
> > >
> > > Sriram Parameswar wrote:
> > >
> > > > This has been a long thread - and as I stated in 
> Minneapolis, 3GPP
> > > > argued long and hard on the same point.
> > > >
> > > > I would like to reiterate that we should stick with the only
> > two values
> > > > guaranteed to interoperate - from RFC 2778 "OPEN" and "CLOSED".
> > > > Everything else is simply additional hints about my 
> Presence status -
> > > > these may include:
> > > >
> > > > * time based (when I expect to be back to OPEN or CLOSE as
> > the case may be)
> > > > * contextual status hints (Out to lunch, Busy - meeting etc.)
> > > >
> > > > Thanks,
> > > > Sriram
> > > >
> > > > __________________________________________
> > > > Sriram Parameswar              Phone: 972-685-8540
> > > > Interactive Multimedia Server (IMS) Fax: 972-684-3986
> > > > Nortel Networks, Richardson USA  Email: 
> [email-masked]
> > > >
> > > >
> > > > -----Original Message-----
> > > > From: Boyer, David G (Dave) [mailto:[email-masked]]
> > > > Sent: Wednesday, May 15, 2002 10:38 AM
> > > > To: Christian Huitema; [email-masked]; Tony Hansen;
> > > > [email-masked]
> > > > Subject: RE: [Simple] Status summary
> > > >
> > > >
> > > > Christian -
> > > >
> > > > There are really 3 states - present (available for 
> communication), not
> > > > present
> > > > (closed - unavailable for communication, unknown (presentity
> > has denied
> > > > watcher
> > > > access to their information, network problem, client 
> down, user agent
> > > > problem,
> > > > etc.).  The subfield of a closed status can be "unknown"
> > covering the third
> > > > case, but I do think there are really 3 states.
> > > >
> > > > Dave Boyer
> > > >
> > > >  > -----Original Message-----
> > > >  > From: Christian Huitema 
[mailto:[email-masked]]
> > >  > Sent: Tuesday, May 14, 2002 9:08 PM
> > >  > To: [email-masked]; Tony Hansen; [email-masked]
> > >  > Subject: RE: [Simple] Status summary
> > >  >
> > >  >
> > >  > Short summary: closed is closed; everything else ought to be
> > >  > a variation
> > >  > of "open".
> > >  >
> > >  > I have the impression that we are trying to overload two different
> > >  > concepts in the "status" field: on one hand, information on
> > >  > what we know
> > >  > about the person, e.g. busy or not, ready to take a phone
> call or not,
> > >  > and on the other hand information about the presence agent, i.e.
> > >  > connected to the network or not. Obviously, there is some
> relation: in
> > >  > the absence of any presence agent, the best we can state is some
> > >  > variation of "off-line" -- i.e. "closed". On the other hand, every
> > >  > information about the status of a person is a shade of gray:
> > >  > I may be on
> > >  > the phone but still willing to read your IM; I may be out to
> > >  > lunch, but
> > >  > my agent is capable of filling up for me; I may have placed a
> > >  > do-not-disturb sign on my door, but my agent may me
> authorize to still
> > >  > disturb me if some really important event happens.
> > >  >
> > >  > -- Christian Huitema
> > >  > _______________________________________________
> > >  > simple mailing list
> > >  > [email-masked]
> > >  > http://mailman.dynamicsoft.com/mailman/listinfo/simple
> > >  >
> > > _______________________________________________
> > > simple mailing list
> > > [email-masked]
> > > http://mailman.dynamicsoft.com/mailman/listinfo/simple
> > >
> >
> > _______________________________________________
> > simple mailing list
> > [email-masked]
> > http://mailman.dynamicsoft.com/mailman/listinfo/simple
>
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Debi Jones <[email-masked]>
Date: Mon, 20 May 2002 13:22:11 -0700

Right David.

If compared to say caller id information, there are two states of identity
information unavailable: blocked or service not available in the user's service
area.  One can't tell whether the information is "unavailable" due to blocking
or the absence of the service.

This applies to mobile users in a possible backwards compatibility situation or
intentional blocking of presence status.  Exactly as Dave said.