Subject: Re: [Simple] Status summary

From: Jonathan Rosenberg <[email-masked]>
Date: Mon, 13 May 2002 17:06:12 -0400

This thread stalled, but I think we need to pick it up again.

The main issue we have to answer with status values are what kinds of
things would an automata do with them, which would require that they
have some kind of standardized meaning, as opposed to just a freeform
note meant for human consumption. Some things that have come up on the
lists:

* map to an icon (mapping is a local matter)
* present to the user in their language (could alternatively be done by
translating the note value, but I think its more robust if there is a
defined set of values)
* decide whether or not to forward a call to the user
* decide whether or not the user is available for an automatically
created conference call

all of the above are either impossible without, or much enhanced by,
well defined meanings for a set of attributes. Of course you can always
define more later on, but I still feel that a reasonably well defined
set is a useful thing.

-Jonathan R.

Ben Campbell wrote:
> 
> It seems to me this concept is still more intended for _human_
> consumption.
> It would be dangerous to provide any protocol semantic or other
> automatic
> processing based on the assumption that I will be back at a certain
> time,
> unless we build in explicit expiration times for the piece of state.
> 
> So, all of the following can be handled by some sort of "away" status
> that
> contains a human readable comment (or some other indicator for user
> display
> purposes only).
> 
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Tony Hansen
> > Sent: Wednesday, April 17, 2002 1:15 PM
> > Cc: [email-masked]; [email-masked]
> > Subject: Re: [Simple] Status summary
> >
> >
> > One aspect that hasn't come up yet in this conversation is something
> > someone said at the ad-hoc mtg in MN: the temporal aspect of the
> various
> > types of OPEN status messages. Why do you choose to use one message
> over
> > another? Usually it's to give the others an idea of how quickly you'll
> > respond.
> >
> > Some of them mean "I'm doing stuff, but will probably respond to your
> > message pretty quickly." (T = a couple minutes) Examples: Busy, On the
> > Phone.
> >
> > Some of them mean "I'm going to be gone for a while." (T = 1/2 - 1
> hour)
> > Example: Out to Lunch.
> >
> > Some of them mean "Don't expect me to respond for hours." (T = 2-4
> > hours) Example: Away, In Meetings.
> >
> > Some of them mean "Don't expect me back for a long time." (T > 4
> hours)
> > Example: Out for the weekend.
> >
> > When you go international, Out to Lunch doesn't mean a whole lot to
> > anyone but English speakers. But specifying an expected time to be
> gone
> > set at .5-1 hour certainly does translate well. Time is a pretty
> > universal concept, and might be worth codifying as part of the status
> > information.
> >
> >       Tony Hansen
> >       [email-masked]
> >
> > _______________________________________________
> > simple mailing list
> > [email-masked]
> > http://mailman.dynamicsoft.com/mailman/listinfo/simple
> 
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple

-- 
Jonathan D. Rosenberg, Ph.D.            72 Eagle Rock Avenue
Chief Scientist                         First Floor
dynamicsoft                             East Hanover, NJ 07936
[email-masked]                 FAX: (973) 952-5050
http://www.jdrosen.net                  PH:  (973) 952-5000
http://www.dynamicsoft.com
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 13 May 2002 19:15:23 -0400

Is there a candidate set that we can draw on? One additional 
consideration is that it would be nice if there were trivial mappings to 
existing widely-used systems, as gatewaying will presumably be common 
until SIMPLE remains the only protocol in existence :-)

 From the survey of existing systems, we have:

Busy (MSN, Yahoo)
Away (AT&T, MSN, Jabber, AOL)
Be right back (AT&T, MSN)
Do not disturb (Jabber, AT&T)
on the phone (AT&T, MSN, Yahoo)
out to lunch (MSN, Yahoo)
Extended away (Jabber)
Not at home/desk/office (Yahoo)
Stepped out (Yahoo)
Idle (AOL)
Be right back (Yahoo)
Free (presumably all of them)

"Busy" and "do not disturb" seem to be similar.

Once you have "out to lunch", you probably need the other meals, too, 
with suitable locale reflecting siesta, afternoon Kaffee, and similar 
activities. This is also not likely to translate well.

"Away", "extended away", "not at my X" also appear difficult to 
distinguish, unless you have some indication as to how long this status 
has been in effect. (Classical residual waiting time problem.)

I can't quite figure out the difference between "Idle" and "Away". AOL 
sets the status to Idle if somebody hasn't been typing for 10 minutes, 
so maybe this is just an automated "Away".

Thus, this seems like a pretty simple exercise for a minimal set:
- Away (with suitable textual indication, as to lunch, dinner, vacation, 
prison, afterlife, or whatever)
- Idle (maybe)
- Busy
- On the phone
- Free

---

From: Tony Hansen <[email-masked]>
Date: Mon, 13 May 2002 20:42:51 -0400

> so maybe this is just an automated "Away".

AT&T, MSN and Yahoo all have the option of automatically setting the 
option to a status such as Away or Idle after a certain amount of 
idleness has passed.

> - Free

Your "on the phone" is just another version of Busy.

I see the following set:

	Free (Available)
	Busy
	Away, for an
		indeterminate amount of time
		short time
		long time

Each could also be annotated with additional text.

Busy means "I'm doing stuff, so may not respond right away. Annotations 
for Busy would be things such as "On the phone" and "In a meeting".

The time based settings are purely subjective values, not concrete 
values. The indeterminate time would be appropriate for use by an idle 
timer.

	Tony Hansen
	[email-masked]

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 13 May 2002 20:52:55 -0400

> Your "on the phone" is just another version of Busy.

Agreed; the only reason I kept it separate is that a SIP device may know 
this condition specifically. It might be useful to have a two-level 
hierarchy of labels, as in busy.phone and busy.meeting.

> values. The indeterminate time would be appropriate for use by an idle 

It would be nice to be able to provide an explicit time of return. With 
calendar integration, this wouldn't be too hard. Obviously, this would 
be optional.