Subject: Re: [Simple] I-D on IM transport proposal

From: Vasilis Polychronidis <[email-masked]>
Date: Mon, 20 May 2002 12:07:08 -0700

>
>
>
>Uh, what do you mean when you say that "the UA is not a trusted entity"?
>One of the elements of the security architecture is precisely to ensure
>that only the UA is trusted with the content of the payload of the SIP
>message -- this include the possibility to encrypt and sign that
>payload.
>
Ok as long as the UA is authenticated i.e. security architecture.
So I think we are in agreement.

>-- Christian Huitema

---

From: "Christian Huitema" <[email-masked]>
Date: Mon, 20 May 2002 12:03:09 -0700

> About Christian's idea of having the UA inserting the hops I think it
is a 
> good one too however this should only happen after the UA is
authenticated 
> with the proxy. The UA is not a trusted entity and should not be
allowed 
> to do such things as adding hops without prior authentication with the

> proxy.

-- Christian Huitema
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple