Subject: RE: [Simple] collection template

From: [email-masked]
Date: Thu, 19 Sep 2002 15:35:03 +0300

Hi,

I still feel uneasy with the template package approach. It should be possible to subscribe to presence.collection.collection and get some sort of notification back. It doesn't seem obvious to me that the collection can work as a template package. 

Cheers,
Aki

> -----Original Message-----
> From: ext Paul Kyzivat [mailto:[email-masked]]
> Sent: Thursday, September 19, 2002 3:51 AM
> To: Adam Roach
> Cc: 'Torrey Searle'; [email-masked]
> Subject: Re: [Simple] collection template
> 
> 
> This suggestion might also address one issue I had. When you 
> first establish the subscription, or refresh it, or do a 
> one-time poll for status, the event mechanism requires that a 
> single notification be returned immediately, containing the 
> current state of the resource (in this case the contact 
> list). This is hard to do if the only notifications are 
> relays of notifications from individual members of the collection.
> 
> This idea would begin to solve that problem. But other 
> problems remain. For instance there is then still no way to 
> poll for the current state of everything in the collection.
> 
> Also, the kind of response you are describing doesn't seem to 
> fit within the current definition of PIDF. PIDF only permits 
> you to mention one presentity. You could get creative, and 
> make a pidf document that uses the address of the collection 
> as the presentity, and describes all of the collection 
> members as separate tuples, with the address of the member as 
> a contact address. Or you could consider extending pidf to 
> permit inclusion of multiple presentities. I had some 
> discussions about those kinds of approaches a few months ago, 
> with Jonathan or Adam I think. But since then things seem to 
> have gone a different direction.
> 
> Without some kind of change I don't see how to make a 
> collection conform to all the rules of an event package.
> 
> 	Paul
> 
> Adam Roach wrote:
> > 
> > I think that's a really good suggestion. Thanks.
> > 
> > /a
> > 
> > (nit: s/people/resources/)
> > 
> > > -----Original Message-----
> > > From: Torrey Searle [mailto:[email-masked]]
> > > Sent: Wednesday, September 18, 2002 5:22
> > > To: [email-masked]
> > > Subject: [Simple] collection template
> > >
> > >
> > > For the inital subscribe to a Template, would it be 
> possible to just
> > > send the list of people in the collection w/o the actuall
> > > state?  IE a
> > > presence-list of presence elements w/o tuples.  It would 
> seem like an
> > > appropriate time to get the "collection list" from the server, w/o
> > > having to guess it from subsquent partial notifies.
> > >
> > > Torrey Searle
> > > Indigo Software
> > _______________________________________________
> > simple mailing list
> > [email-masked]
> > http://mailman.dynamicsoft.com/mailman/listinfo/simple
> _______________________________________________
> simple mailing list
> [email-masked]
> http://mailman.dynamicsoft.com/mailman/listinfo/simple
> 
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Torrey Searle <[email-masked]>
Date: Thu, 19 Sep 2002 14:56:42 +0200

Couldn't presence.collection.collection still be interesting? Suppose 
that I want to have a "presence list" organized into groups, I.E. so I 
have a collection that subscribse to the Collection of all the people 
who work at my company (with that list being maintained by the system 
administrator of the company) and a Family group, and maybe a Group for 
the members of Community Service I am a member of.  Each collection 
could be updated w/o me needing to modifiy my collection.

Any thoughts on this?

Torrey Searle
Indigo Software