Subject: RE: [Simple] collection template

From: Adam Roach <[email-masked]>
Date: Wed, 18 Sep 2002 12:53:26 -0500

I think that's a really good suggestion. Thanks.

/a

(nit: s/people/resources/)

> -----Original Message-----
> From: Torrey Searle [mailto:[email-masked]]
> Sent: Wednesday, September 18, 2002 5:22
> To: [email-masked]
> Subject: [Simple] collection template
> 
> 
> For the inital subscribe to a Template, would it be possible to just 
> send the list of people in the collection w/o the actuall 
> state?  IE a 
> presence-list of presence elements w/o tuples.  It would seem like an 
> appropriate time to get the "collection list" from the server, w/o 
> having to guess it from subsquent partial notifies.
> 
> Torrey Searle
> Indigo Software
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Wed, 18 Sep 2002 20:50:40 -0400

This suggestion might also address one issue I had. When you first establish the subscription, or refresh it, or do a one-time poll for status, the event mechanism requires that a single notification be returned immediately, containing the current state of the resource (in this case the contact list). This is hard to do if the only notifications are relays of notifications from individual members of the collection.

This idea would begin to solve that problem. But other problems remain. For instance there is then still no way to poll for the current state of everything in the collection.

Also, the kind of response you are describing doesn't seem to fit within the current definition of PIDF. PIDF only permits you to mention one presentity. You could get creative, and make a pidf document that uses the address of the collection as the presentity, and describes all of the collection members as separate tuples, with the address of the member as a contact address. Or you could consider extending pidf to permit inclusion of multiple presentities. I had some discussions about those kinds of approaches a few months ago, with Jonathan or Adam I think. But since then things seem to have gone a different direction.

Without some kind of change I don't see how to make a collection conform to all the rules of an event package.

	Paul

---

From: Torrey Searle <[email-masked]>
Date: Thu, 19 Sep 2002 10:16:29 +0200

>Also, the kind of response you are describing doesn't seem to fit within the current definition of PIDF. PIDF only permits you to mention one presentity. You could get creative, and make a pidf docu…
Section 4 of draft-ieft-simple-presencelist-package-00 describes a 
document format called PLIDF, which essentially is a list of PIDF 
documents.  So using that format, it should be possible to list all the 
contact addresses without problems.

Torrey Searle
Indigo Software

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 19 Sep 2002 08:05:38 -0400

> contact addresses without problems.

That draft is what started this discussion. The current discussion has drifted away from that proposal. 

That defined a new event package, different than presence, but related to presence. With that approach, every time you want to define a collection of some event type, you need to define another document format to go with it. People didn't seem very happy with that.

So the talk has moved to more generalized ways of defining collections. But what I think has been lost in that discussion is the need to have some format that permits returning the immediate response to a subscription.

One way to achieve that would be to define a document format for collections. Then subscribers to collections could expect to receive both that format, and the formats for elements of the collection. But the PLIDF format wouldn't be the right format for that.

	Paul