Subject: [Simple] Error when sending NOTIFY to MSN messenger (RTC)

From: "Seonman Kim" <[email-masked]>
Date: Wed, 25 Sep 2002 15:48:30 -0700

Hi,
I am implementing SIMPLE protocol and testing with MSN messenger (Windows
RTC).
I successfully subscribed to a buddy (named "temin") with SUBSCRIBE request
to our presence server.
But when our presence servere notifies to the watcher using NOTIFY message,
I got a "415 Unsupported Media Type" error. I guess I have wrong information
in PIDF document in NOTIFY message, but I could not figure out the problem.
Will anyone of you teach me what the problem is?
I attached the SUBSCRIBE and NOTIFY message, and 415 error returned by MSN
Messenger.

And if someone knows the format of  content body for NOTIFY message used
Windows RTC, please let me know.

----
SUBSCRIBE sip:[email-masked] SIP/2.0
Via: SIP/2.0/TCP 172.xxx.xxx.64:12559
From: "seonman"
<sip:[email-masked]>;tag=85842f8e-b074-487f-a3d5-a6da1abdc648
To: <sip:[email-masked]>
Call-ID: [email-masked]
CSeq: 1 SUBSCRIBE
Contact: <sip:172.xxx.xxx.64:12559;transport=tcp>
User-Agent: Windows RTC/1.0
Expires: 1800
Content-Length: 0

NOTIFY sip:[email-masked] SIP/2.0
Via: SIP/2.0/UDP 206.xxx.xxx.205:5070
To: <sip:[email-masked]>;tag=85842f8e-b074-487f-a3d5-a6da1abdc648
From: <sip:[email-masked]>;tag=90693859
Call-ID: [email-masked]
CSeq: 1 NOTIFY
Max-Forwards: 70
Route: <sip:172.xxx.xxx.64:12559;transport=tcp>
Subscription-State: active;expires=1800
Content-Type: application/cpim-pidf+xml
Content-Length: 273

<?xml version="1.0" encoding="UTF-8"?>
<presence xmlns="urn:ietf:params:xml:ns:cpim-pidf"
entity="pres:[email-masked]">
<tuple id="sip-phone">
<status>
<basic>open</basic>
</status>
<contact priority="0.500000">sip:[email-masked]</contact>
</tuple>
</presence>

----------------
SIP/2.0 415 Unsupported Media Type
Via: SIP/2.0/TCP
206.xxx.xxx.203:5060;branch=z9hG4bKdba1f899bbbec7f2d301db4f58404563.2
Via: SIP/2.0/UDP 206.xxx.xxx.205:5070
From: <sip:[email-masked]>;tag=90693859
To: <sip:[email-masked]>;tag=85842f8e-b074-487f-a3d5-a6da1abdc648
Call-ID: [email-masked]
CSeq: 1 NOTIFY
User-Agent: Windows RTC/1.0
Content-Length: 0

Thanks,
Seonman

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Pekka Pessi <[email-masked]>
Date: 30 Sep 2002 21:17:20 +0300

>Windows RTC, please let me know.

	They use a malformed (or embraced & extended, if you like it
	that way) version of xpidf.

	You can easily find out their presence format by sending a
	SUBSCRIBE to a Windows Messenger, then using same shstuff when
	sending to Messenger.

					Pekka