Subject: [Simple] uploading of Presence docs to PA

From: Deepankar <[email-masked]>
Date: Wed, 30 Oct 2002 14:19:16 +0800

To upload a presence document form a PUA to the PA, presence-07 says, there could be two methods. one is, constructing a presence doc using registrations, and the other is, to explicitly upload the document. This is implementation choice, I believe. 
If I manipulate REGISTER to carry a body with a presence doc, then backward compatibility will be a problem, and in the other case, an explicit out of band connection is needed to achieve it. The spec says , manipulation of REGISTER's is not recommended. 

Any thoughts worked on lately !!

Deeps

---

From: Ben Campbell <[email-masked]>
Date: Wed, 30 Oct 2002 08:37:54 -0600

Deepankar wrote:
> To upload a presence document form a PUA to the PA, presence-07 says, 
> there could be two methods. one is, constructing a presence doc using 
> registrations, and the other is, to explicitly upload the document. This 
> is implementation choice, I believe.
> If I manipulate REGISTER to carry a body with a presence doc, then 
> backward compatibility will be a problem, and in the other case, an 
> explicit out of band connection is needed to achieve it. The spec says , 
> manipulation of REGISTER's is not recommended.
>  

Look at draft-olson-simple-publish-01 that was published last week.

Thanks!

Ben.

_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple

---

From: Deepankar <[email-masked]>
Date: Thu, 31 Oct 2002 08:35:44 +0800

Hey thanks Ben ! I was dying to look at some work done on this. Somehow, I
was out of context on this one.

Thanks again, and would be in loop for the 01.

Deeps