Subject: [Simple] FW: I-D ACTION:draft-lonnfors-simple-prescaps-ext-00.txt

From: [email-masked]
Date: Tue, 29 Oct 2002 08:43:26 +0200

Hi,

New draft is now available. Basically draft presents a solution for the requirements presented in draft-kyzivat-simple-prescaps-reqts-00.txt. 
All comments are welcome.

- Mikko

> -----Original Message-----
> From: ext [email-masked] [mailto:[email-masked]]
> Sent: 28 October, 2002 13:27
> Subject: I-D ACTION:draft-lonnfors-simple-prescaps-ext-00.txt
> 
> 
> A New Internet-Draft is available from the on-line 
> Internet-Drafts directories.
> 
> 
> 	Title		: SIMPLE PIDF presence capabilities extension
> 	Author(s)	: M. Lonnfors, K. Kiss
> 	Filename	: draft-lonnfors-simple-prescaps-ext-00.txt
> 	Pages		: 14
> 	Date		: 2002-10-25
> 	
> Interoperation of Instant Messaging and Presence systems has been
> defined in IMPP Working Group.  IMPP WG has come up with baseline
> interoperable operations and formats for Presence and Instant
> Messaging systems.  However, these base formats might need
> standardized extensions in order to enable building rational
> applications using Presence and Instant Messaging.  This memo
> proposes an extension to PIDF presence document format to be used in
> SIMPLE based Presence systems [1] but may also be applied to other
> protocols as well.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-lonnfors-simple-pres
caps-ext-00.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-lonnfors-simple-prescaps-ext-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-lonnfors-simple-prescaps-ext-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 29 Oct 2002 10:05:56 -0500

> All comments are welcome.

Obviously Mikko and I have been cooperating on this. We were both interested in the subject. I thought it would be helpful to be clear about the requirements rather than jumping directly to a proposed solution, so I posted a requirements draft last week. Since then I have been waiting for Mikko to submit this in order to have more fodder for discussion.

There is already a work item to produce a SIP-specific profile for PIDF. I consider these drafts to be a *partial* response to that work item. I realize there is a desire for some addition generalized status values beyond open/closed, such as busy. That is a minefield, and we have chosen not to address it. Instead, we are focusing on some attributes that should be less controversial because they are drawn from the callerprefs draft, whose basic concepts have been accepted for a long time. (I am open to discussion about whether these specific drafts should be expanded to cover the more general requirement, or whether that should be left separate.)

The assertion of these drafts is that capabilities a UAS can specify when registering are information that is equally important in a presence document. I believe Mikko is most concerned with supported media. I also consider that to be of major importance, but I also believe all the others are of potential value in a presence document.

The callerprefs draft is still itself in a state of flux. The work here should remain dependent on the outcome of that work. But I believe it would be helpful to begin progressing these documents now.

	Paul
_______________________________________________
simple mailing list
[email-masked]
http://mailman.dynamicsoft.com/mailman/listinfo/simple