Subject: [Simple] Some XML Schema issues in RPID-05

From: Boehmer Bernhard Com Berlin <[email-masked]>
Date: Fri, 1 Apr 2005 13:01:16 +0200

Hi,
I found some issues/bugs in the XML schemas defined
with RPID-05 I would like to share/discuss with you.

1) schema rpid-status: the tokenlist type is no more defined,
   seems have to been lost since RPID-03. Since it's also used
   in rpid-person I solved it ad-hoc including a schema defining
   the type. Possibly there's a better way...
2) schema rpid-person: 
   - same with tokenlist as above.
   - substitutionGroup "activity-value" has been used but no head
    for this substitutionGroup has been defined. I added ad-hoc the head
    "<element name="activity-value"/>" with type "any" to resolve
    the issue. Possibly there's a better way...
   - element <activities> didn't work. Don't know yet how to deal with it.
   - following issue arose for <sphere> but this may apply to other elements,
     too: if <sphere> shall appear under person:status as defined in the
     presence data model, the definition of sphere must be a member of
     the substitutionGroup "personStatus". This means that sphere must
     be an extension of the type "personStatusAbstractType". One possible
     way to so is:
     <element name="sphere" substitutionGroup="ps:personStatus">
     <complexType>
      <complexContent>
        <extension base="ps:personStatusAbstractType">
            <attribute name="value" type="token"/>
        </extension>
      </complexContent>
      </complexType>
     </element>

3) schema rpid-device: Eventually I missed something but why is the
   element <device-id> needed if the presence data model defines already
   <deviceID>? Is the more general type "string" needed here?
   The definition via substitutionGroup
   given in rpid-device doesn't work and seems to be in contrast to the definition
   in the presence data model where deviceID is not under "deviceCharacteristic".
      		
			Regards Bernhard

P.S: I haven't used/checked all elements defined in RPID. 

___________________________
 Dr. Bernhard Böhmer
 Systems Engineering
 Siemens AG Communications,
 Mobile Networks AS BD C
 Siemensdamm 50, Berlin
 Fon: +49-30-386-22756
 Mobile: +49-178-7700119

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 01 Apr 2005 08:33:16 -0500

Thank you for the feedback. Please be advised that a design team is in 
the process of completely re-doing the schemas, in particular to align 
the various SIMPLE schemas with the data model and each other, both in 
style and content. Thus, I would suggest you hold off on detailed 
comments until that revision appears, hopefully within the next few weeks.