Subject: [Simple] reachibility information for services in current presence data mo del

From: Boehmer Bernhard Com Berlin <[email-masked]>
Date: Fri, 1 Apr 2005 11:48:05 +0200

Hi,
the current presence data model discusses nicely reachability
information. Maximum openess concerning the definition of
a service is maintained. However, in the actual definition 
of the <tuple> - being the legacy of pidf - reachability information
is restricted to one entry, the <contact> element. Thus, within
one <tuple> element the possibility that a service may be reachable
via different, e.g., addresses cannot be reflected. The only way I
see currently is to send two <tuple> elements with basically the same
information but the <contact>/reachability information.

>From my perspective this introduces quite some redundancy in the presence
doc (a point which is especially relevant for mobile networks) and 
is furthermore asymmetric to possibility to introduce several device ids
into one <tuple> element (the latter, however, not being made explicit
by the XML schema).

So, my question is: Have you once considered to add more than one piece
of reachability information and you have rejected this possibility or
do you share the view that this means should be introduced?
			Regards Bernhard

___________________________
 Dr. Bernhard Böhmer
 Systems Engineering
 Siemens AG Communications,
 Mobile Networks AS BD C
 Siemensdamm 50, Berlin
 Fon: +49-30-386-22756
 Mobile: +49-178-7700119

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Henning Schulzrinne <[email-masked]>
Date: Fri, 01 Apr 2005 08:35:34 -0500

I doubt that anybody has the desire at this point to change PIDF in a 
non-backward-compatible way. Can you spell out what kind of information 
you see as being duplicated unnecessarily across several <tuple> 
elements? In the cases I can picture, things like prescaps would likely 
differ for each contact.