Subject: [Simple] how the presence come to know changes in xcap ???

From: Allen Allen <[email-masked]>
Date: Fri, 14 Sep 2007 16:17:56 +0100 (BST)

Dear All,
  I am facing one problem in Presence server design. Any one please help me..
  Problem:
  userA subscribes to Presence server . Presence server sends watcher info notify to user B containing watcher as userA status pending. Now the userB changes authorizaion policy such that it allows or denies userA. Now the question is how presence server comes to know whether userB done changes or not. is there any interface between xcap server and presence server ?
  userB can do changes in authorization policy any time. how it triggers presence server such that presence server sends notify to userA with userB presentity.

  Thanks in advance..
  Regards
  Allen

---------------------------------
 Travelling to a new city? Search for ATMs in that city. Click here.

_______________________________________________
Simple mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/simple

---

From: Adrian Georgescu <[email-masked]>
Date: Fri, 14 Sep 2007 19:53:41 +0200

Hi Allen,

Your XCAP server must communicate the changes of policy to the  
Presence agent, by using some out of band  mechanism and the Presence  
agent must update all watchers statuses and send Notify to qualified  
recipients.

See an example of such implementation between OpenXCAP server and  
OpenSER Presence agent, the refreshWathers() management interface  
implementation:

OpenSER

http://www.openser.org/docs/modules/1.3.x/presence.html#AEN306

OpenXCAP

http://www.openxcap.org/browser/xcap/interfaces/openser.py

Regards,
Adrian

> From: Allen Allen <[email-masked]>
> Subject: [Simple] how the presence come to know changes in xcap ???
> To: [email-masked]
> Message-ID: <[email-masked]>
> Content-Type: text/plain; charset="iso-8859-1"
>
> Dear All,
>   userA subscribes to Presence server . Presence server sends  
> watcher info notify to user B containing watcher as userA status  
> pending. Now the userB changes authorizaion policy such that it  
> allows or denies userA. Now the question is how presence server  
> comes to know whether userB done changes or not. is there any  
> interface between xcap server and presence server ?
>   userB can do changes in authorization policy any time. how it  
> triggers presence server such that presence server sends notify to  
> userA with userB presentity.
>
>
>   Thanks in advance..
>   Regards
>   Allen

---

From: [email-masked]
Date: Sat, 15 Sep 2007 03:02:12 -0700

Hi,

Just to add on this, my understanding is that the standard way of sending XCAP resource change notifications will be based in:

http://www.ietf.org/internet-drafts/draft-ietf-simple-xcap-diff-06.txt

once this mechanism gets approved... Am I right? This way the Presence Server will be able to subscribe to receive a notification when the Presence policy of the Presentity changes.

Are the OpenSER and OpenXCAP functions based already on a similar mechanism?

Regards,

David

-------- Original Message --------
Subject: Re: [Simple] how the presence come to know changes in xcap ???
From: Adrian Georgescu <[email-masked]>
Date: Fri, September 14, 2007 7:53 pm
To: [email-masked]

Hi Allen,

OpenSER

OpenXCAP

Regards,
Adrian