Subject: [Simple] draft-macdonald-simple-msrp-opaque-path

From: "Derek MacDonald" <[email-masked]>
Date: Tue, 8 Jul 2008 09:39:12 -0700

This draft describes an extension to MSRP  which allow efficient topology
hiding. It defines a mechanism to have an MSRP URI which is a pointer to an
IP address which is not itself contained in the MSRP messages.

-Derek

---------- Forwarded message ----------
From: IETF I-D Submission Tool <[email-masked]>
Date: Mon, Jul 7, 2008 at 3:12 PM
Subject: New Version Notification for
draft-macdonald-simple-msrp-opaque-path-00
To: [email-masked]
Cc: [email-masked]

A new version of I-D, draft-macdonald-simple-msrp-opaque-path-00.txt has
been successfuly submitted by Derek MacDonald and posted to the IETF
repository.

Filename:        draft-macdonald-simple-msrp-opaque-path
Revision:        00
Title:           Opaque MSRP Path Uri
Creation_date:   2008-07-07
WG ID:           Independent Submission
Number_of_pages: 10

Abstract:
The Message Session Relay Protocol(MSRP) does not allow efficient
topology hiding, such that MSRP users can hide the IP Address of
their systems.  This limitation is due to the fact that MSRP Path
headers contain physical IP addresses.  This document describes a
mechanism which adds a level of indirection to allow topology hiding.
It defines the option tag msrp-opaque.

The IETF Secretariat.
_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple

---

From: Hadriel Kaplan <[email-masked]>
Date: Tue, 8 Jul 2008 13:57:42 -0400

A direct URL for the opaque-path draft is:
http://www.ietf.org/internet-drafts/draft-macdonald-simple-msrp-opaque-path-00.txt

And to give some more context to this draft, it also addresses the problem discussed in Staffan Blau and Christer's msrp-acm draft, by removing the dependency on the path attribute address usage.  To do this it uses the SDP c/m-lines for transport addressing instead, as msrp-acm and Remi's msrp-comedia draft do.  Therefore there is a sort of Venn diagram of partial overlap for the problems that need to be solved and their solutions in all 3 of these drafts.

-hadriel

________________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Derek MacDonald
Sent: Tuesday, July 08, 2008 12:39 PM
To: [email-masked]
Subject: [Simple] draft-macdonald-simple-msrp-opaque-path

This draft describes an extension to MSRP  which allow efficient topology hiding. It defines a mechanism to have an MSRP URI which is a pointer to an IP address which is not itself contained in the MSRP messages.

-Derek
---------- Forwarded message ----------
From: IETF I-D Submission Tool <[email-masked]>
Date: Mon, Jul 7, 2008 at 3:12 PM
Subject: New Version Notification for draft-macdonald-simple-msrp-opaque-path-00
To: [email-masked]
Cc: [email-masked]

A new version of I-D, draft-macdonald-simple-msrp-opaque-path-00.txt has been successfuly submitted by Derek MacDonald and posted to the IETF repository.

Abstract:

The IETF Secretariat.

---

From: Salvatore Loreto <[email-masked]>
Date: Thu, 17 Jul 2008 16:48:05 +0300

Hi,

I have just finished the read the draft and I have a doubt in my mind.
It is not clear to me how using the SDP c/m-lines for transport addressing
is still possible to MSRP allows multiple session to share the same TCP 
connection.
maybe I am missing something.

/sal