Subject: [Simple] How to Publish an icon/photo resource

From: Adrian Georgescu <[email-masked]>
Date: Mon, 7 Jul 2008 19:54:15 +0200

Hello,

A SIMPLE publisher would want to publish its own photo so that others  
can retrieve it in the context of presence notifications.

The closest reference I could find for such scenario is the icon  
element in PIDF but a standard way to upload a picture to an URL I  
could not. A proprietary xcap application would probably work but  
maybe there is something already defined for this functionality.

Is there an IETF document that explains how to upload the photo of a  
buddy?

Regards,
Adrian
_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple

---

From: Jonathan Rosenberg <[email-masked]>
Date: Tue, 08 Jul 2008 23:15:55 -0400

Plain old HTTP allows you to upload a file:

PUT http://www.myfiles.com/joe/images/mypic.jpg

-Jonathan R.

Adrian Georgescu wrote:
> The closest reference I could find for such scenario is the icon element 
> in PIDF but a standard way to upload a picture to an URL I could not. A 
> proprietary xcap application would probably work but maybe there is 
> something already defined for this functionality.
> 
> Is there an IETF document that explains how to upload the photo of a buddy?
> 
> Regards,
> Adrian

-- 
Jonathan D. Rosenberg, Ph.D.                   499 Thornall St.
Cisco Fellow                                   Edison, NJ 08837
Cisco, Voice Technology Group
[email-masked]
http://www.jdrosen.net                         PHONE: (408) 902-3084
http://www.cisco.com
_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple