Subject: [Simple] New version of draft-blau-simple-msrp-acm

From: "Christer Holmberg" <[email-masked]>
Date: Fri, 12 Sep 2008 13:57:08 +0200

Hi,

I've submited a new version of the msrp-acm draft.

Since nobody indicated on the list (I did ask twice :) that he/she wants
to be able to use only the comedia part of the draft, I haven't changed
that. Instead the draft still specifies the usage of comedia and the SDP
c/m routing, and that allowed me to remove the a=msrp-acm attribute,
since the a=setup attribute is enough to indicate support of the
mechanism in the draft.

The draft can also be found at:

(http://users.piuha.net/cholmber/drafts/draft-blau-simple-msrp-acm-01.tx
t)

Regards,

Christer
_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple

---

From: Ben Campbell <[email-masked]>
Date: Wed, 17 Sep 2008 15:43:40 -0500

Apologies--I thought I responded to your earlier email, but I can find  
no evidence that I actually did so.

I would still prefer, unless we can site significant technical reasons  
preventing it, to have a COMEDIA or similar mechanism for the  
negotiation of connection direction that otherwise uses the MSRP URI  
path approach.

On Sep 12, 2008, at 6:57 AM, Christer Holmberg wrote:

> Since nobody indicated on the list (I did ask twice :) that he/she  
> wants to be able to use only the comedia part of the draft, I  
> haven't changed that. Instead the draft still specifies the usage of  
> comedia and the SDP c/m routing, and that allowed me to remove the  
> a=msrp-acm attribute, since the a=setup attribute is enough to  
> indicate support of the mechanism in the draft.
>
> (http://users.piuha.net/cholmber/drafts/draft-blau-simple-msrp-acm-01.txt 
> )
>
> Regards,
>
> Christer
>

---

From: "Christer Holmberg" <[email-masked]>
Date: Thu, 18 Sep 2008 13:46:23 +0200

Hi Ben,
 
I cannot think of any technical reason to prevent using only the COMEDIA
part. It only means that the a=msrp-acm attribute has to be put back,
since we need an explicit indication for the SDP routing part.
 
Would anyone object to such approach?
 
Regards,
 
Christer

________________________________

	From: Ben Campbell [mailto:[email-masked]] 
	Sent: 17. syyskuuta 2008 23:44
	To: Christer Holmberg
	Cc: [email-masked]; Robert Sparks
	Subject: Re: [Simple] New version of draft-blau-simple-msrp-acm

	Apologies--I thought I responded to your earlier email, but I
can find no evidence that I actually did so.

	I would still prefer, unless we can site significant technical
reasons preventing it, to have a COMEDIA or similar mechanism for the
negotiation of connection direction that otherwise uses the MSRP URI
path approach.

		Hi, 

		Since nobody indicated on the list (I did ask twice :)
that he/she wants to be able to use only the comedia part of the draft,
I haven't changed that. Instead the draft still specifies the usage of
comedia and the SDP c/m routing, and that allowed me to remove the
a=msrp-acm attribute, since the a=setup attribute is enough to indicate
support of the mechanism in the draft.

(http://users.piuha.net/cholmber/drafts/draft-blau-simple-msrp-acm-01.tx
t
<http://users.piuha.net/cholmber/drafts/draft-blau-simple-msrp-acm-01.tx
t> ) 

		Regards, 

		Christer

---

From: "Hisham Khartabil" <[email-masked]>
Date: Fri, 19 Sep 2008 10:32:40 +1000

I don't believe we want 2 mechanisms to a path between the 2 parties. What
Ben is saying that is we can use the COMEDIA mechanism to determine the
path, but not necessarily the SDP extensions used for comedia. The path is
then communicated between the 2 parties using the existing MSRP SDP
extensions.

Regards,
Hisham

On 18/09/2008, Christer Holmberg <[email-masked]> wrote:
> part. It only means that the a=msrp-acm attribute has to be put back, since
> we need an explicit indication for the SDP routing part.
>
>  ------------------------------
> *From:* Ben Campbell [mailto:[email-masked]]
> *Sent:* 17. syyskuuta 2008 23:44
> *To:* Christer Holmberg
> *Cc:* [email-masked]; Robert Sparks
> *Subject:* Re: [Simple] New version of draft-blau-simple-msrp-acm
>
>
>  Apologies--I thought I responded to your earlier email, but I can find no
> evidence that I actually did so.
>
>
> preventing it, to have a COMEDIA or similar mechanism for the negotiation of
> connection direction that otherwise uses the MSRP URI path approach.
>
>
>
>
> Since nobody indicated on the list (I did ask twice :) that he/she wants to
> be able to use only the comedia part of the draft, I haven't changed that.
> Instead the draft still specifies the usage of comedia and the SDP c/m
> routing, and that allowed me to remove the a=msrp-acm attribute, since the
> a=setup attribute is enough to indicate support of the mechanism in the
> draft.
>
> (*http://users.piuha.net/cholmber/drafts/draft-blau-simple-msrp-acm-01.txt
> *<http://users.piuha.net/cholmber/drafts/draft-blau-simple-msrp-acm-01.txt>
> )
>
> Regards,
>
> Christer

---

From: Ben Campbell <[email-masked]>
Date: Thu, 18 Sep 2008 20:51:34 -0500

I suspect Hisham meant to say to use COMEDIA to  "determine the  
connection direction" rather than "determine the path". If I am  
correct, then he has summarized my opinion perfectly.

On Sep 18, 2008, at 7:32 PM, Hisham Khartabil wrote:

> I don't believe we want 2 mechanisms to a path between the 2  
> parties. What Ben is saying that is we can use the COMEDIA mechanism  
> to determine the path, but not necessarily the SDP extensions used  
> for comedia. The path is then communicated between the 2 parties  
> using the existing MSRP SDP extensions.
>
> Regards,
> Hisham
>
>
> I cannot think of any technical reason to prevent using only the  
> COMEDIA part. It only means that the a=msrp-acm attribute has to be  
> put back, since we need an explicit indication for the SDP routing  
> part.
>
> Apologies--I thought I responded to your earlier email, but I can  
> find no evidence that I actually did so.
>
>
> reasons preventing it, to have a COMEDIA or similar mechanism for  
> the negotiation of connection direction that otherwise uses the MSRP  
> URI path approach.
>
>
>
>
>> haven't changed that. Instead the draft still specifies the usage  
>> of comedia and the SDP c/m routing, and that allowed me to remove  
>> the a=msrp-acm attribute, since the a=setup attribute is enough to

---

From: "Christer Holmberg" <[email-masked]>
Date: Fri, 19 Sep 2008 06:39:00 +0200

Hi,

>I suspect Hisham meant to say to use COMEDIA to  "determine the
connection direction" rather than "determine the path". If I am correct,
then he has summarized my opinion perfectly.

I think that is what I am trying to say also: COMEDIA is used to
determine the TCP connection direction. The SDP c/m/a=msrp-acm method,
OR the existing MSRP URI method, is then used for the actual routing of
the MSRP messages. 

Regards,

Christer

		I don't believe we want 2 mechanisms to a path between
the 2 parties. What Ben is saying that is we can use the COMEDIA
mechanism to determine the path, but not necessarily the SDP extensions
used for comedia. The path is then communicated between the 2 parties
using the existing MSRP SDP extensions.
		 
		Regards,
		Hisham

		On 18/09/2008, Christer Holmberg
<[email-masked]> wrote: 

			Hi Ben,
			 
			I cannot think of any technical reason to
prevent using only the COMEDIA part. It only means that the a=msrp-acm
attribute has to be put back, since we need an explicit indication for
the SDP routing part.

			Regards,
			 
			Christer

				From: Ben Campbell
[mailto:[email-masked]] 
				Sent: 17. syyskuuta 2008 23:44
				To: Christer Holmberg
				Cc: [email-masked]; Robert Sparks
				Subject: Re: [Simple] New version of
draft-blau-simple-msrp-acm

				I would still prefer, unless we can site
significant technical reasons preventing it, to have a COMEDIA or
similar mechanism for the negotiation of connection direction that
otherwise uses the MSRP URI path approach.

				On Sep 12, 2008, at 6:57 AM, Christer
Holmberg wrote:

					Hi, 

					I've submited a new version of
the msrp-acm draft. 

					Since nobody indicated on the
list (I did ask twice :) that he/she wants to be able to use only the
comedia part of the draft, I haven't changed that. Instead the draft
still specifies the usage of comedia and the SDP c/m routing, and that
allowed me to remove the a=msrp-acm attribute, since the a=setup
attribute is enough to indicate support of the mechanism in the draft.

					Regards, 

					Christer

---

From: "Hisham Khartabil" <[email-masked]>
Date: Fri, 19 Sep 2008 14:55:27 +1000

No OR. COMEDIA is used to determine the TCP connection direction. The
existing MSRP URI method, is then used for the actual routing of
the MSRP messages.

Hisham

---

From: "Christer Holmberg" <[email-masked]>
Date: Fri, 19 Sep 2008 07:12:09 +0200

Yes OR. The new routing method MAY be used, but one can also choose to
use the existing method.
 
I don't thin Ben ever said one MUST use the existing method, but that it
should be allowed to use the existing method.
 
Regards,
 
Christer

	From: Hisham Khartabil [mailto:[email-masked]] 
	Sent: 19. syyskuuta 2008 7:55
	To: Christer Holmberg
	Cc: Ben Campbell; [email-masked]; Robert Sparks
	Subject: Re: [Simple] New version of draft-blau-simple-msrp-acm

	No OR. COMEDIA is used to determine the TCP connection
direction. The existing MSRP URI method, is then used for the actual
routing of
	the MSRP messages.
	 
	Hisham

	On 19/09/2008, Christer Holmberg
<[email-masked]> wrote: 

		Hi,
		
		>I suspect Hisham meant to say to use COMEDIA to
"determine the
		connection direction" rather than "determine the path".
If I am correct,
		then he has summarized my opinion perfectly.
		
		I think that is what I am trying to say also: COMEDIA is
used to
		determine the TCP connection direction. The SDP
c/m/a=msrp-acm method,
		OR the existing MSRP URI method, is then used for the
actual routing of
		the MSRP messages.
		
		Regards,
		
		Christer

		
		       On Sep 18, 2008, at 7:32 PM, Hisham Khartabil
wrote:

		               I don't believe we want 2 mechanisms to a
path between
		the 2 parties. What Ben is saying that is we can use the
COMEDIA
		mechanism to determine the path, but not necessarily the
SDP extensions
		used for comedia. The path is then communicated between
the 2 parties
		using the existing MSRP SDP extensions.
		
		               Regards,
		               Hisham

		                       Hi Ben,
		
		                       I cannot think of any technical
reason to
		prevent using only the COMEDIA part. It only means that
the a=msrp-acm
		attribute has to be put back, since we need an explicit
indication for
		the SDP routing part.
		
		                       Would anyone object to such
approach?
		
		                       Regards,
		
		                       Christer

		                               From: Ben Campbell
		[mailto:[email-masked]]
		                               Sent: 17. syyskuuta 2008
23:44
		                               To: Christer Holmberg
		                               Cc: [email-masked];
Robert Sparks
		                               Subject: Re: [Simple] New
version of
		draft-blau-simple-msrp-acm

		Apologies--I thought I responded to your earlier email,
but I can find
		no evidence that I actually did so.

		                               I would still prefer,
unless we can site
		significant technical reasons preventing it, to have a
COMEDIA or
		similar mechanism for the negotiation of connection
direction that
		otherwise uses the MSRP URI path approach.

		
		                               On Sep 12, 2008, at 6:57
AM, Christer
		Holmberg wrote:

		                                       Hi,
		
		                                       I've submited a
new version of
		the msrp-acm draft.
		
		                                       Since nobody
indicated on the
		list (I did ask twice :) that he/she wants to be able to
use only the
		comedia part of the draft, I haven't changed that.
Instead the draft
		still specifies the usage of comedia and the SDP c/m
routing, and that
		allowed me to remove the a=msrp-acm attribute, since the
a=setup
		attribute is enough to indicate support of the mechanism
in the draft.
		
		                                       The draft can
also be found at:

	
		
		                                       Regards,
		
		                                       Christer

		                                       Simple mailing
list
		                                       [email-masked]

---

From: Ben Campbell <[email-masked]>
Date: Fri, 19 Sep 2008 08:19:00 -0500

To clarify my position:

I very much prefer to be able to use the existing method. I also  
prefer, but not quite as strongly, not to have two methods.

On Sep 19, 2008, at 12:12 AM, Christer Holmberg wrote:

>
> Yes OR. The new routing method MAY be used, but one can also choose  
> to use the existing method.
>
> I don't thin Ben ever said one MUST use the existing method, but  
> that it should be allowed to use the existing method.
>

To clarify my position:

I very much prefer to be able to use the existing method. I also  
prefer, but not _quite_ as strongly, not to have two methods.

> No OR. COMEDIA is used to determine the TCP connection direction.  
> The existing MSRP URI method, is then used for the actual routing of
> the MSRP messages.
>
> Hisham
>
>
> correct,

---

From: "Christer Holmberg" <[email-masked]>
Date: Sat, 20 Sep 2008 14:25:20 +0200

Hi,
 
>I very much prefer to be able to use the existing method. I also
prefer, but not quite as 
>strongly, not to have two methods.

I wouldn't mind having a single method - if it was the method in the
draft :)

The main reason we are proposing this new method in the first place is
because the current one is very "expensive" to deploy. You cannot use
generic NAT traversal mechanism (people who are e.g. deploying ICE and
are buying TURN servers do not want to spend extra on MSRP relays just
for a single media type), and it doesn't work with media-unaware ALGs
(they are out there, no matter if we want or not). 

The new mechanism allows MSRP to be routed and NATted like any other
type of media, and we think it's essential for the success of MSRP.

Success is also based on backward compability, and the new method does
consider that.

However, I have no problem if people want to only be able to use the
COMEDIA part of the draft, together with the existing routing mechanism.

Regards,

Christer

	 
	Yes OR. The new routing method MAY be used, but one can also
choose to use the existing method.

To clarify my position:

I very much prefer to be able to use the existing method. I also prefer,
but not _quite_ as strongly, not to have two methods.

	Regards,
	 
	Christer

		From: Hisham Khartabil
[mailto:[email-masked]] 

		Hisham

			Hi,
			
			>I suspect Hisham meant to say to use COMEDIA to
"determine the
			connection direction" rather than "determine the
path". If I am correct,
			then he has summarized my opinion perfectly.
			
			I think that is what I am trying to say also:
COMEDIA is used to
			determine the TCP connection direction. The SDP
c/m/a=msrp-acm method,
			OR the existing MSRP URI method, is then used
for the actual routing of
			the MSRP messages.
			
			Regards,
			
			Christer

			
			       On Sep 18, 2008, at 7:32 PM, Hisham
Khartabil wrote:

			               I don't believe we want 2
mechanisms to a path between
			the 2 parties. What Ben is saying that is we can
use the COMEDIA
			mechanism to determine the path, but not
necessarily the SDP extensions
			used for comedia. The path is then communicated
between the 2 parties
			using the existing MSRP SDP extensions.
			
			               Regards,
			               Hisham

			                       Hi Ben,
			
			                       I cannot think of any
technical reason to
			prevent using only the COMEDIA part. It only
means that the a=msrp-acm
			attribute has to be put back, since we need an
explicit indication for
			the SDP routing part.
			
			                       Would anyone object to
such approach?
			
			                       Regards,
			
			                       Christer

			                               From: Ben
Campbell
			[mailto:[email-masked]]
			                               Sent: 17.
syyskuuta 2008 23:44
			                               To: Christer
Holmberg
			                               Cc:
[email-masked]; Robert Sparks
			                               Subject: Re:
[Simple] New version of
			draft-blau-simple-msrp-acm

			Apologies--I thought I responded to your earlier
email, but I can find
			no evidence that I actually did so.

			                               I would still
prefer, unless we can site
			significant technical reasons preventing it, to
have a COMEDIA or
			similar mechanism for the negotiation of
connection direction that
			otherwise uses the MSRP URI path approach.

			
			                               On Sep 12, 2008,
at 6:57 AM, Christer
			Holmberg wrote:

			                                       Hi,
			
			                                       I've
submited a new version of
			the msrp-acm draft.
			
			                                       Since
nobody indicated on the
			list (I did ask twice :) that he/she wants to be
able to use only the
			comedia part of the draft, I haven't changed
that. Instead the draft
			still specifies the usage of comedia and the SDP
c/m routing, and that
			allowed me to remove the a=msrp-acm attribute,
since the a=setup
			attribute is enough to indicate support of the
mechanism in the draft.
			
			                                       The draft
can also be found at:

	
			
			                                       Regards,
			
			                                       Christer

			                                       Simple
mailing list
	
[email-masked]