Subject: [Simple] XMPP vs SIMPLE

From: [email-masked]
Date: Wed, 1 Oct 2008 00:26:35 +0200 (SAST)

Hi,

I am a Masters in Computer Science student working on a project that
compares XMPP and SIMPLE as presence protocols. Specifically, I am looking
at Rich Presence, the aggregation of presence information from various
assorted devices belonging to the same individual to provide a single and
consistent user presence. I want to determine which is the better protocol
for Rich Presence.

My question is: Is it possible that the UDP version of SIMPLE could be
more bandwidth efficient than XMPP over TCP for the conveyance of presence
information? Evidently SIMPLE is more verbose than XMPP, however UDP is a
much lighter transport layer protocol than TCP.

Thanks.

Anisa Ragalo,
MSc Student,
Department of Computer Science,
University of Cape Town.

Email: [email-masked]
Cellphone: +27760335309

_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 30 Sep 2008 18:54:58 -0400

> much lighter transport layer protocol than TCP.

Its quite likely that the UDP form of SIMPLE isn't viable for presence, 
for a couple of reasons:
- if the presence document is big enough to push the NOTIFY
   message over the PDU size, then you can't use UDP

- you probably want the security of TLS for presence.

So arguing for SIP over XMPP based on use of UDP isn't a great argument.

	Good Luck,
	Paul

---

From: "Winterbottom, James" <[email-masked]>
Date: Tue, 30 Sep 2008 18:06:54 -0500

I might throw in a bit of heresy here too.
XMPP over BOSH works just great through my corporate firewall and
web-proxy and the IS guys are none-the-wiser. If I were to move to SIP,
well.....

*8)...

I know this isn't a composition comment, but it is an access to the
service issue.

Cheers
James

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
Behalf
> Of Paul Kyzivat
> Sent: Wednesday, 1 October 2008 8:55 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: [Simple] XMPP vs SIMPLE
> 
> 
> 
> > assorted devices belonging to the same individual to provide a
single
> and
> > information? Evidently SIMPLE is more verbose than XMPP, however UDP
is
> a

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]