Subject: Re: [Simple] simple-chat status

From: Adrian Georgescu <[email-masked]>
Date: Thu, 30 Jul 2009 18:57:12 +0200

There is at least one implementation for the draft in open source  
domain:

http://chatserver.ag-projects.com/

It would take little effort to just go through with it as I do not see  
any need to make changes in this document. In the unfortunate case the  
draft is dropped I would much like to see its content not lost and if  
XCON is the resting place for its content then so be it.

Adrian

On Jul 30, 2009, at 3:56 PM, [email-masked] wrote:

> From:
> Ben Campbell <[email-masked]>
> To:
> Simple WG <[email-masked]>
> Date:
> 30/07/2009 03:45 PM
> Subject:
> Re: [Simple] simple-chat status
> Sent by:
> [email-masked]
>
>
>
> (As chair)
>
> The sense of the room in Stockholm was that we no longer needed the
> simple-chat as it currently exists, but that we did need to make sure
> we preserved the information in it that describes how a focus works
> with MSRP and message/cpim, whether as a scaled down version of  
> simple-
> chat or as an addition to the XCON documents.
>
> I'd like to make a consensus call on the list to confirm or deny that
> approach. (I just saw Hisham's email--what do other's think?)
>
> Thanks!
>
> ben.
>

---

From: "Mary Barnes" <[email-masked]>
Date: Fri, 31 Jul 2009 04:01:04 -0500

Adrian,

A few comments inline [MB].

Mary.

-----Original Message-----
From: [email-masked] on behalf of Adrian Georgescu
Sent: Thu 7/30/2009 11:57 AM
To: [email-masked]
Subject: Re: [Simple] simple-chat status

It would take little effort to just go through with it as I do not see  
any need to make changes in this document. 
[MB] Well, there are some changes that MUST be made before the document is progressed, per the detailed review I did some time ago:
http://www.ietf.org/mail-archive/web/simple/current/msg08371.html

I honestly don't care if SIMPLE wants to put the cycles in to complete the document.    I agreed at the last meeting and thus did the document review. I do have concerns in that It does burn WG cycles. And, since it's a subset of the capabilities you get with XCON framework - another concern is that it's wasted effort to implement an MSRP switch if the more generic XCON framework - i.e., conference server & focus model is not considered.  

The primary protocol differences between implementing simple-chat vs using the XCON framework for this functionality is the normative changes to MSRP in the simple-chat document (e.g., NICKNAME) are naturally handled with the CCMP protocol document - i.e., you don't need to change MSRP if you implement this with CCMP.  [/MB]

In the unfortunate case the  
draft is dropped I would much like to see its content not lost and if  
XCON is the resting place for its content then so be it.

Adrian

> approach. (I just saw Hisham's email--what do other's think?)

_______________________________________________
Simple mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/simple