Subject: [Simple] MSRP-ACM: Suggestion to allow a=setup:passive in SDP offer

From: Christer Holmberg <[email-masked]>
Date: Mon, 12 Apr 2010 10:02:24 +0200

Hi,

I have received an off-line comment regarding a statement in section 4.2, saying that an offerer MUST NOT use "a=setup:passive".

The suggestion is to allow "passive" in cases where the offerer knows that the answerer is located behind a NAT, and where it won't be possible to establish a session unless the answerer supports acm and becomes "active". There are cases where the answerer does not know whether it's behind a NAT, so if the offer contains "actpass" there is a risk that the answerer uses "passive".

So, the text could be modified to:

"The UA SHOULD NOT use the a=setup "passive" attribute value in an SDP offer, unless it knows that the SDP answerer is located behind a NAT and is required to become active in order to be able to establish the TCP connection."

So, unless anyone objects, my intention is to do that change.

Regards,

Christer

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 12 Apr 2010 13:51:57 +0200

Hi,

I had missunderstood the comment that was given to me, so I don't think we need to change anything. The existing text is fine.

Sorry for the mess.

Regards,

Christer

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Christer Holmberg
> Sent: 12. huhtikuuta 2010 11:02
> To: [email-masked]
> Subject: [Simple] MSRP-ACM: Suggestion to allow 
> a=setup:passive in SDP offer
> 
> 
> Hi,
> 
> I have received an off-line comment regarding a statement in 
> section 4.2, saying that an offerer MUST NOT use "a=setup:passive".
> 
> The suggestion is to allow "passive" in cases where the 
> offerer knows that the answerer is located behind a NAT, and 
> where it won't be possible to establish a session unless the 
> answerer supports acm and becomes "active". There are cases 
> where the answerer does not know whether it's behind a NAT, 
> so if the offer contains "actpass" there is a risk that the 
> answerer uses "passive".
> 
> "The UA SHOULD NOT use the a=setup "passive" attribute value 
> in an SDP offer, unless it knows that the SDP answerer is 
> located behind a NAT and is required to become active in 
> order to be able to establish the TCP connection."
> 
> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple
>