Subject: [Simple] Hi, can you give me some help

From: Guangzuo Zheng <[email-masked]>
Date: Mon, 19 Apr 2010 09:29:13 +0100

Hi:

Now I am working on an IM, it should handle multiple protocols, including
XMPP and SIMPLE. By now we have searched for months to find an open source
product based on SIMPLE, but got nothing.
Would you give me some advices? Can you tell me any open source product
based on SIMPLE and if you know some java libs for SIMPLE is better.

Many thanks,
Best Regards
Zara

---

From: Hisham Khartabil <[email-masked]>
Date: Tue, 20 Apr 2010 13:54:18 +1000

http://www.ag-projects.com/content/blogcategory/31/96/

Regards,
Hisham

On 19 April 2010 18:29, Guangzuo Zheng <[email-masked]> wrote:

> _______________________________________________
> Simple mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/simple
>
>

---

From: Emil Ivov <[email-masked]>
Date: Tue, 20 Apr 2010 09:30:22 +0200

Hey Guangzuo,

На 19.04.10 10:29, Guangzuo Zheng написа:
> Now I am working on an IM, it should handle multiple protocols,
> including XMPP and SIMPLE. By now we have searched for months to find an
> open source product based on SIMPLE, but got nothing.

You may want to try SIP Communicator: http://sip-communicator.org. It is
multi-platform (including Windows, Mac OS X, and Windows) and
multiprotocol (including SIP/SIMPLE and XMPP among many others). It's
also written in Java which seems to be of interest to you.

> based on SIMPLE and if you know some java libs for SIMPLE is better.

SIP Communicator uses JAIN SIP:
http://jain-sip.dev.java.net

Hope this helps!
Emil

-- 
Emil Ivov, Ph.D.                               67000 Strasbourg,
Project Lead                                   France
SIP Communicator
[email-masked]                     PHONE: +33.1.77.62.43.30
http://sip-communicator.org                    FAX:   +33.1.77.62.47.31

---

From: Adrian Georgescu <[email-masked]>
Date: Tue, 20 Apr 2010 09:40:17 +0200

If you want to program in Python try SIP SIMPLE client SDK from:

http://sipsimpleclient.com/

If you like Java, try SIP communicator from http://sip- 
communicator.org it also supports XMPP

Adrian

On Apr 19, 2010, at 10:29 AM, Guangzuo Zheng wrote:

> including XMPP and SIMPLE. By now we have searched for months to  
> find an open source product based on SIMPLE, but got nothing.
> Would you give me some advices? Can you tell me any open source  
> product based on SIMPLE and if you know some java libs for SIMPLE is  
> better.
>
> Many thanks,
> Best Regards
> Zara _______________________________________________
> Simple mailing list
> [email-masked]

---

From: Guangzuo Zheng <[email-masked]>
Date: Tue, 20 Apr 2010 18:32:05 +0100

Thanks very much, these are what I am searching for!

Best Regards
Zara