Subject: [sipcore] draft-barnes-sipcore-rfc4244bis

From: Cullen Jennings <[email-masked]>
Date: Thu, 11 Nov 2010 02:41:47 -0700

The draft has a lot well specified procedures about how to write tags to a message, and it discusses that the tags could be used in lots of ways. However, I would like to see some text added to section 8 that allowed implementers to use this specification to implemented some of the use cases it is designed to meet. Specifically I would like to see normative language on how a voicemail system can use the tags found in an incoming invite to determined which mailbox the call should be delivered too. 

People have suggested to me this information is in the call flows document. I like call flows, I think they help people, but this is an information document with no normative language describing how to do this. I'm not a huge fan of people implementing things off call flows. I rather have the procedures for this specified in 4244bis and then have example call flows that illustrated this in the call flow draft. 

Overall, this draft fixes many of the fundamental problems of RFC 4244.

Cullen

PS - Sorry this was sent right before the meeting. Normally I would try and discuss something like this in the meeting but given the audio latencies we have been having today, I don't think that would work out ver well so decide to send this.

---

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 11 Nov 2010 05:39:46 -0500

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Cullen Jennings [[email-masked]]

Specifically I would like to see normative language on how a voicemail system can use the tags found in an incoming invite to determined which mailbox the call should be delivered too.
_______________________________________________

I don't think we should (or even can) make such an algorithm normative, but the draft should include example algorithms to demonstrate how applications can do the things that we want to support.

Dale