Subject: Re: [sipcore] Yet more comments on rfc4244bis-02

From: Ian Elz <[email-masked]>
Date: Mon, 8 Nov 2010 18:17:07 +0000 (GMT)

Hadriel,

Roland missed one other case in his reply.

If I divert a call I may want my identity to be private even if the original caller allows his identity to be presented; i.e. I don't want the final destination of the call to know the identity of the diverting party.

Ian Elz

----- Original Message -----
From: "Hadriel Kaplan" <[email-masked]>
To: "Shida Schubert" <[email-masked]>
Cc: [email-masked]
Sent: Monday, 8 November, 2010 3:01:39 PM
Subject: Re: [sipcore] Yet more comments on rfc4244bis-02

On Nov 8, 2010, at 6:01 AM, Shida Schubert wrote:

> Privacy:none is used when caller (UAC) wants his/her identity delivered
> to the destination (callee) despite the existence of privacy service, but
> with regards to H-I, when does it ever contain the URI that identifies the
> caller (UAC) ?
> I agree that privacy:none will be valid if we can find a situation where
> URI of UA will be one of the hi-entry but my imagination is not strong
> enough to see this.

But that also begs the question of why we need a Privacy header of "history" to begin with. (I mean a real Privacy header in the message, not an embedded one in a particular HI URI)

The only case I could imagine for such things is that the caller doesn't want their domain known about.  I.e., I make an anonymous call from my SIP phone through my corporate SIP proxy, and my SIP phone sets "Privacy: history" so that Acme Packet's anonymization proxy removes "acmepacket.com" from any H-Is, before sending it out our SIP trunk, etc.

-hadriel

---

From: Hadriel Kaplan <[email-masked]>
Date: Mon, 8 Nov 2010 17:04:27 -0500

Right but isn't that done with the _embedded_ Privacy header in the H-I URI?  I was talking about the Privacy header of the request message itself - that's what I meant by "(I mean a real Privacy header in the message, not an embedded one in a particular HI URI)".  Sorry for the confusion.

-hadriel

---

From: Paul Kyzivat <[email-masked]>
Date: Mon, 08 Nov 2010 19:10:46 -0500

> If I divert a call I may want my identity to be private even if the original caller allows his identity to be presented; i.e. I don't want the final destination of the call to know the identity of…

Won't your identity still be present in the To URI?

	Thanks,
	Paul

> From: "Hadriel Kaplan"<[email-masked]>
> To: "Shida Schubert"<[email-masked]>
> Cc: [email-masked]
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>