Subject: Re: [sipcore] Bypassing out-of-service intermediate Proxy

From: "Worley, Dale R (Dale)" <[email-masked]>
Date: Thu, 2 Dec 2010 12:19:46 -0500

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of Christer Holmberg [[email-masked]]

Not exactly the same case that Youssef is talking about, but every now and then I have had discussions that it would be useful to be able to re-negotiate the route set (not only the local/remote targets, but also the record-routes) during a dialog. E.g. in Outbound cases it could be used to move ongoing dialogs from a failed flow to another (it is not always possible to achieve it by using domain names and DNS).

No, I did not suggest that we start work on such functionality :)
_______________________________________________

You mean that the renegotiation would be initiated by an *intermediate* proxy.  That is extremely ugly!

Dale

---

From: Christer Holmberg <[email-masked]>
Date: Thu, 2 Dec 2010 21:33:46 +0100

Hi,

>>Not exactly the same case that Youssef is talking about, but every now and then I have had discussions that it would be useful to be able to re-negotiate the route set (not only the local/remote targets, but also the record-routes) during a dialog. E.g. in Outbound cases it could be used to move ongoing dialogs 
>>from a failed flow to another (it is not always possible to achieve it by using domain names and DNS).
>>

I agree. I later said that it would be good to have a response code which the proxy could send in order to trigger a renegotiation by the UA.

Regards,

Christer