Subject: Re: [sipcore] draft-explicit-subscription-00: URI SHOULD be sent using TLS or DTLS

From: Robert Sparks <[email-masked]>
Date: Mon, 02 Mar 2015 12:31:06 -0600

So, I think the thing to do here is to point to RFC3261.

I've made this modification:

For instance, SIP messages containing this URI SHOULD be sent
using TLS or DTLS (see the security considerations section of <xref
target="RFC3261"/> for considerations when using other security mechanisms).

Does that cover your concern?

RjS

On 2/5/15 10:05 AM, Andrew Allen wrote:
>
> +1
>
> What Christer propose is what we quite normally have. We know there 
> are many deployments that use other security mechanisms other than TLD 
> or DTLS.
>
> *From:*sipcore [mailto:[email-masked]] *On Behalf Of 
> *Christer Holmberg
> *Sent:* Thursday, February 05, 2015 10:17 AM
> *To:* [email-masked]
> *Subject:* [sipcore] draft-explicit-subscription-00: URI SHOULD be 
> sent using TLS or DTLS
>
> Hi,
>
> The text in section 8 (Security Considerations) of 
> draft-ietf-sipcore-refer-explicit-subscription-00 says:
>
> “For instance, SIP messages containing this URI SHOULD be sent using 
> TLS or DTLS.”
>
> Now, while I realize that a “SHOULD” does allow for other mechanisms, 
> I think it would be good to explicitly say that other mechanisms, 
> providing similar protection, can also be used.
>
> Regards,
>
> Christer
>
>
>
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 3 Mar 2015 08:25:33 +0000

Hi Robert,

I am happy with your suggested modification.

Thanks!

Regards,

Christer

From: sipcore [mailto:[email-masked]] On Behalf Of Robert Sparks
Sent: 2. maaliskuuta 2015 20:31
To: [email-masked]
Subject: Re: [sipcore] draft-explicit-subscription-00: URI SHOULD be sent using TLS or DTLS

RjS

What Christer propose is what we quite normally have. We know there are many deployments that use other security mechanisms other than TLD or DTLS.

From: sipcore [mailto:[email-masked]] On Behalf Of Christer Holmberg
Sent: Thursday, February 05, 2015 10:17 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [sipcore] draft-explicit-subscription-00: URI SHOULD be sent using TLS or DTLS

Hi,

The text in section 8 (Security Considerations) of draft-ietf-sipcore-refer-explicit-subscription-00 says:

"For instance, SIP messages containing this URI SHOULD be sent using TLS or DTLS."

Now, while I realize that a "SHOULD" does allow for other mechanisms, I think it would be good to explicitly say that other mechanisms, providing similar protection, can also be used.

Regards,

Christer

sipcore mailing list

[email-masked]<mailto:[email-masked]>