Subject: [sipcore] SIP authentication using EC-SRP5 protocol

From: lfw_frank <[email-masked]>
Date: Tue, 10 Mar 2015 14:28:47 +0800 (CST)

hi, all

We have just uploaded a draft regarding SIP authentication, which can be seen at the link

http://www.ietf.org/staging/draft-liu-sipcore-ec-srp-00.txt

It is known that SIP authentication suffers from off-line dictionary attacks due to the use of weak authentication scheme (HTTP digest authentication). Our proposal is to apply the strong password authentication scheme EC-SRP5  to SIP authentication. SIP Client and server perform mutual authenticate by using the modern 'zero knowledge' method without disclosing the password in the process. It is resilient to various kinds of attacks, including off-line dictionary attacks. Moreover,  it has low computation complexity and low bandwidth consumption due to the use of elliptical curve cryptography.

This is the first version of our proposal. It is unavoidable that there are errors in the document.  Any comments and suggestions are highly desired.

Best regards

Dr. Fuwen Liu

Chinamobile

---

From: Paul Kyzivat <[email-masked]>
Date: Tue, 10 Mar 2015 11:10:19 -0400

Dr. Liu,

I just now quickly reviewed your draft. Let me first say that I am *not* 
expert in security and encryption. Since that is the primary focus of 
this draft I will be looking for comments from experts on that.

I did not see any mention of how you propose to integrate this approach 
into SIP. Is it your intent to reuse the Authorization and 
Authentication-Info header fields? Or do you intend to introduce some 
other mechanism to exchange the information you use?

	Thanks,
	Paul

On 3/10/15 2:28 AM, lfw_frank wrote:
> It is known that SIP authentication suffers from off-line dictionary
> attacks due to the use of weak authentication scheme (HTTP digest
> authentication). Our proposal is to apply the strong password
> authentication scheme EC-SRP5  to SIP authentication. SIP Client and
> server perform mutual authenticate by using the modern 'zero knowledge'
> method without disclosing the password in the process. It is resilient
> to various kinds of attacks, including off-line dictionary attacks.
> Moreover,  it has low computation complexity and low bandwidth
> consumption due to the use of elliptical curve cryptography.
>
> This is the first version of our proposal. It is unavoidable that there
> are errors in the document.  Any comments and suggestions are highly
> desired.
>
> Best regards
>
> Dr. Fuwen Liu
>
> Chinamobile
>
>
>
>
>
>
>
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>