Subject: Re: [sipcore] Concluded: WGLC / Call for Adoption: REFER-related work

From: Ivo Sedlacek <[email-masked]>
Date: Tue, 3 Mar 2015 16:36:07 +0000

Hello,

draft-ietf-sipcore-6665-clarification-00 nearly resolves the issue I raised before. Thanks for taking my comment into consideration.

However, reading draft-ietf-sipcore-6665-clarification-00, "subscription requests (implicit or explicit)" in the following text is rather hard to understand. 
------------
Notifiers MUST use a GRUU as their
   local target for all dialog-forming methods and all target-refresh
   methods, except for those dialogs for which they will reject all
   >>subscription requests (implicit or explicit)<<.
------------

It would be more appropriate to state "requests that might create an (implicit or explicit) subscription" similarly as used in the later text:
------------
For clarity: an
   implementation that uses a non-GRUU local contact under the exception
   described above MUST reject a >>request that might create a
   subscription<< to the associated dialog, regardless of whether such
   subscription would be created by a SUBSCRIBE or a REFER message.
------------

Kind regards

Ivo Sedlacek

---

From: Ivo Sedlacek <[email-masked]>
Date: Wed, 4 Mar 2015 08:11:11 +0000

Hello,

I reviewed draft-ietf-sipcore-refer-clarifications-03 and draft-ietf-sipcore-refer-explicit-subscription-00  and found no issues. OK to progress those drafts.

I reviewed draft-ietf-sipcore-6665-clarification-00 and sent a comment to the SIPCORE list yesterday (http://www.ietf.org/mail-archive/web/sipcore/current/msg06561.html). I prefer the comment being addressed before progressing the draft.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: 28. února 2015 1:08
To: Christer Holmberg; 'SIPCORE'; Ivo Sedlacek; Brett Tate
Subject: Concluded: WGLC / Call for Adoption: REFER-related work

[as chair]

The adoption and WGLC period for the three documents has ended. Given the expressed support (meager as it was) and lack of objection, we're going to consider the 6665-clarifications draft adopted.

There were no additional comments on refer-clarifications or refer-explicit-subscription, so we will begin preparing them for IESG review.

[as author]

A new version that I believe addresses the outstanding comments on the

6665 clarification document is available here:

https://datatracker.ietf.org/doc/draft-ietf-sipcore-6665-clarification/

Ivo / Brett: as you were the people who provided the feedback that I've incorporated, please look over this latest text to let me know whether it addresses the specific concern that had been raised. Thanks!

/a

---

From: Christer Holmberg <[email-masked]>
Date: Tue, 17 Mar 2015 17:25:21 +0000

Hi,

What is the status of this? Has Ivo's comment been addressed?

Regards,

Christer

Sent from my Windows Phone
________________________________
From: Ivo Sedlacek<mailto:[email-masked]>
Sent: ‎04/‎03/‎2015 10:11
To: Adam Roach<mailto:[email-masked]>; Christer Holmberg<mailto:[email-masked]>; 'SIPCORE'<mailto:[email-masked]>; Brett Tate<mailto:[email-masked]>
Subject: RE: Concluded: WGLC / Call for Adoption: REFER-related work

Hello,

Kind regards

Ivo Sedlacek

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: 28. února 2015 1:08
To: Christer Holmberg; 'SIPCORE'; Ivo Sedlacek; Brett Tate
Subject: Concluded: WGLC / Call for Adoption: REFER-related work

[as chair]

[as author]

/a

---

From: Ivo Sedlacek <[email-masked]>
Date: Thu, 19 Mar 2015 08:36:38 +0000

Hello,

my comment (http://www.ietf.org/mail-archive/web/sipcore/current/msg06561.html) has not been addressed yet.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>
From: Christer Holmberg
Sent: 17. března 2015 18:25
To: Ivo Sedlacek; Adam Roach; 'SIPCORE'; Brett Tate
Subject: RE: Concluded: WGLC / Call for Adoption: REFER-related work

Hi,

Regards,

Christer

Hello,

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: 28. února 2015 1:08
To: Christer Holmberg; 'SIPCORE'; Ivo Sedlacek; Brett Tate
Subject: Concluded: WGLC / Call for Adoption: REFER-related work

[as chair]

[as author]

/a

---

From: Adam Roach <[email-masked]>
Date: Fri, 20 Mar 2015 11:49:29 -0700

[as chair]

On 3/17/15 10:25, Christer Holmberg wrote:
> What is the status of this?

The current plan is to progress all three documents at once.

We got some late comments on the explicit subscription document. The 
document author has responded, and I'm giving potentially interested 
parties a few more days to weigh in on the topic.

Due to the upcoming busier-than-normal week, I plan to assign a shepherd 
to the three documents shortly after the Dallas meeting. Barring any 
surprises, I expect that all three documents will be sent to the IESG in 
early April.

/a

---

From: Adam Roach <[email-masked]>
Date: Fri, 20 Mar 2015 16:06:53 -0500

[as document editor]

Thanks. I've seen the feedback, but don't currently plan to incorporate 
it. The comment is strictly editorial (an area over which document 
editors are given significant latitude), and -- in my opinion -- is not 
an improvement. It says the same thing, with equivalent clarity, using 
more words.

/a

On 3/19/15 01:36, Ivo Sedlacek wrote:
>
> Hello,
>
> my comment 
> (http://www.ietf.org/mail-archive/web/sipcore/current/msg06561.html) 
> has not been addressed yet.
>
> Kind regards
>
> Ivo Sedlacek
>
> This Communication is Confidential. We only send and receive email on 
> the basis of the terms set out at www.ericsson.com/email_disclaimer 
> <http://www.ericsson.com/email_disclaimer>
>
> *From:*Christer Holmberg
> *Sent:* 17. března 2015 18:25
> *To:* Ivo Sedlacek; Adam Roach; 'SIPCORE'; Brett Tate
> *Subject:* RE: Concluded: WGLC / Call for Adoption: REFER-related work
>
> Hi,
>
> ------------------------------------------------------------------------
>
> *From: *Ivo Sedlacek <mailto:[email-masked]>
> *Sent: *‎04/‎03/‎2015 10:11
> *To: *Adam Roach <mailto:[email-masked]>; Christer Holmberg 
> <mailto:[email-masked]>; 'SIPCORE' 
> <mailto:[email-masked]>; Brett Tate <mailto:[email-masked]>
> *Subject: *RE: Concluded: WGLC / Call for Adoption: REFER-related work
>
> Hello,
>
> I reviewed draft-ietf-sipcore-refer-clarifications-03 and 
> draft-ietf-sipcore-refer-explicit-subscription-00  and found no 
> issues. OK to progress those drafts.
>
> I reviewed draft-ietf-sipcore-6665-clarification-00 and sent a comment 
> to the SIPCORE list yesterday 
> (http://www.ietf.org/mail-archive/web/sipcore/current/msg06561.html). 
> I prefer the comment being addressed before progressing the draft.
>
> Kind regards
>
> Ivo Sedlacek
>
> This Communication is Confidential. We only send and receive email on 
> the basis of the terms set out at www.ericsson.com/email_disclaimer 
> <http://www.ericsson.com/email_disclaimer>
>
> The adoption and WGLC period for the three documents has ended. Given 
> the expressed support (meager as it was) and lack of objection, we're 
> going to consider the 6665-clarifications draft adopted.
>
> There were no additional comments on refer-clarifications or 
> refer-explicit-subscription, so we will begin preparing them for IESG 
> review.
>
> [as author]
>
> Ivo / Brett: as you were the people who provided the feedback that 
> I've incorporated, please look over this latest text to let me know 
> whether it addresses the specific concern that had been raised. Thanks!
>
> /a
>

---

From: Ivo Sedlacek <[email-masked]>
Date: Mon, 23 Mar 2015 06:59:31 +0000

Hello,

> The comment is strictly editorial (an area over which document editors are given significant latitude), and -- in my opinion -- is not an improvement.
> It says the same thing, with equivalent clarity, using more words.

Is there any definition of what "subscription requests (implicit or explicit)" are?

if no, then wording "requests that might create an (implicit or explicit) subscription" is more precise.

In any case, the wording ("request that might create a subscription") is used elsewhere in the document so change would make the text consistent.

Kind regards

Ivo Sedlacek

This Communication is Confidential. We only send and receive email on the basis of the terms set out at www.ericsson.com/email_disclaimer<http://www.ericsson.com/email_disclaimer>
From: Adam Roach [mailto:[email-masked]]
Sent: 20. března 2015 22:07
To: Ivo Sedlacek; Christer Holmberg; 'SIPCORE'; Brett Tate
Subject: Re: Concluded: WGLC / Call for Adoption: REFER-related work

[as document editor]

Thanks. I've seen the feedback, but don't currently plan to incorporate it. The comment is strictly editorial (an area over which document editors are given significant latitude), and -- in my opinion -- is not an improvement. It says the same thing, with equivalent clarity, using more words.

/a

Kind regards

Ivo Sedlacek

Hi,

Regards,

Christer

Hello,

Kind regards

Ivo Sedlacek

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: 28. února 2015 1:08
To: Christer Holmberg; 'SIPCORE'; Ivo Sedlacek; Brett Tate
Subject: Concluded: WGLC / Call for Adoption: REFER-related work

[as chair]

[as author]

/a

---

From: Brett Tate <[email-masked]>
Date: Mon, 23 Mar 2015 06:03:32 -0400

Hi,

I have not received a reply concerning my March 4 comments.

http://www.ietf.org/mail-archive/web/sipcore/current/msg06565.html

Are any them going to be addressed?

Thanks,
Brett

---

From: Christer Holmberg <[email-masked]>
Date: Mon, 23 Mar 2015 14:00:20 +0000

Hi,

I support having consistent terminology, and the suggested change seems very straight forward, so…

Regards,

Christer

From: Ivo Sedlacek
Sent: 23 March 2015 09:00
To: Adam Roach; Christer Holmberg; 'SIPCORE'; Brett Tate
Subject: RE: Concluded: WGLC / Call for Adoption: REFER-related work

Hello,

Kind regards

Ivo Sedlacek

[as document editor]

/a

Kind regards

Ivo Sedlacek

Hi,

Regards,

Christer

Hello,

Kind regards

Ivo Sedlacek

-----Original Message-----
From: Adam Roach [mailto:[email-masked]]
Sent: 28. února 2015 1:08
To: Christer Holmberg; 'SIPCORE'; Ivo Sedlacek; Brett Tate
Subject: Concluded: WGLC / Call for Adoption: REFER-related work

[as chair]

[as author]

/a