Subject: Re: [sipcore] A new SIP header fields with "P-" name

From: Paul Kyzivat <[email-masked]>
Date: Tue, 1 Dec 2015 09:35:04 -0500

On 12/1/15 2:00 AM, Ivo Sedlacek wrote:
> Hello,
>
> in the last 3GPP CT1 WG meeting, 3GPP CT1 WG was unable to conclude
> whether it is possible to define and to use a new "P-"header field.
>
> Some believed that IANA registration of a new "P-" header field is not
> possible any more due to RFC5727. Others believed that IANA registration
> of a new "P-" header field is possible as long as someone already
> implemented and deployed such header field  (even if it was done recently).

My understanding of 5727 is that when it refers to "existing", it means 
those existing prior to the publication of 5727. Anybody starting to use 
a new P- header after that time should have known they were doing 
something wrong.

	Thanks,
	Paul

> Can you please provide guidance whether IANA registration of a new "P-"
> header field is likely? Thanks.
>
> RFC5727 states:
>
> ---------------------------
>
> New
>
>     proposals to document SIP header fields of an experimental or private
>
>     nature, however, shall not use the "P-" prefix (unless existing
>
>     deployments or standards use the prefix already, in which case they
>
>     may be admitted as grandfathered cases at the discretion of the
>
>     Designated Expert).
>
> ---------------------------
>
> Kind regards
>
> Ivo Sedlacek
>
>
>
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore
>

---

From: Adam Roach <[email-masked]>
Date: Tue, 1 Dec 2015 08:41:17 -0600

[as participant]

On 12/1/15 8:35 AM, Paul Kyzivat wrote:
> My understanding of 5727 is that when it refers to "existing", it 
> means those existing prior to the publication of 5727. Anybody 
> starting to use a new P- header after that time should have known they 
> were doing something wrong.

That matches my understanding as well. The timeframe for "already" in 
the sentence "existingdeployments or standards use the prefix already" 
is March of 2010. Any other interpretation of this clause is pretty 
meaningless.

/a

---

From: "Ben Campbell" <[email-masked]>
Date: Tue, 01 Dec 2015 13:01:09 -0600

Hi,

Can you offer context around the question? That is, why would someone be 
contemplating a new header starting with "P-"? Or is this something old?

Thanks!

Ben.

On 1 Dec 2015, at 1:00, Ivo Sedlacek wrote:

> possible any more due to RFC5727. Others believed that IANA 
> registration of a new "P-" header field is possible as long as someone 
> already implemented and deployed such header field  (even if it was 
> done recently).
>
>
>
> Can you please provide guidance whether IANA registration of a new 
> "P-" header field is likely? Thanks.
>
>
>
> RFC5727 states:
>

---

From: Christer Holmberg <[email-masked]>
Date: Wed, 2 Dec 2015 08:18:05 +0000

Hi,

I have the same understanding as Adam and Paul.

Regards,

Christer

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Paul Kyzivat
Sent: 1. joulukuuta 2015 16:35
To: [email-masked]
Subject: Re: [sipcore] A new SIP header fields with "P-" name

On 12/1/15 2:00 AM, Ivo Sedlacek wrote:
> already implemented and deployed such header field  (even if it was done recently).

My understanding of 5727 is that when it refers to "existing", it means those existing prior to the publication of 5727. Anybody starting to use a new P- header after that time should have known they were doing something wrong.

	Thanks,
	Paul

---

From: Ivo Sedlacek <[email-masked]>
Date: Wed, 2 Dec 2015 08:36:36 +0000

Hello,

> Can you offer context around the question? That is, why would someone be contemplating a new header starting with "P-"? Or is this something old?

3GPP has a requirement to transport parameters of the last recently seen 3GPP radio network cell (and how old this information is) when sending a SIP request over wireless LAN. This gives coarse location of the wireless LAN access point. This 3GPP requirement was agreed in September 2015.

One proposed solution is to define and use P-Cellular-Network-Info header field.

I do not represent company providing this proposal.

I do not know whether P-Cellular-Network-Info header field has been deployed yet and if so, when. In any case, the 3GPP requirement was agreed long after RFC5727 was published.

The purpose of my mail was to verify whether the proposal above is feasible or not, so that this is clear in future CT1 discussions.

Kind regards

Ivo Sedlacek

---

From: James Cloos <[email-masked]>
Date: Thu, 03 Dec 2015 11:07:56 -0500

>>>>> "IS" == Ivo Sedlacek <[email-masked]> writes:

IS> One proposed solution is to define and use P-Cellular-Network-Info
IS> header field.

The proper solution is to drop the 'P-' from the proposed header name;
call it Cellular-Network-Info instead of P-Cellular-Network-Info.

All 5727 says wrt P- is don't bother with a P- prefix on new headers.

-JimC
-- 
James Cloos <[email-masked]>         OpenPGP: 0x997A9F17ED7DAEA6

---

From: Paul Kyzivat <[email-masked]>
Date: Thu, 3 Dec 2015 12:47:52 -0500

> All 5727 says wrt P- is don't bother with a P- prefix on new headers.

Yes. I *think* that this header field would qualify as "informational". 
  (Pending review of its specification.) In that case the criterion for 
registration is expert review. (I don't know who the expert is for this.)

	Thanks,
	Paul

---

From: Mary Barnes <[email-masked]>
Date: Thu, 3 Dec 2015 11:42:17 -0600

On Thu, Dec 3, 2015 at 10:07 AM, James Cloos <[email-masked]>
> call it Cellular-Network-Info instead of P-Cellular-Network-Info.

[MB] And, the proper standard's process is to bring the problem that is
being solved to the DISPATCH WG for discussion and determination as to
whether a new header is the best option to solve that problem or whether
existing headers, extensions thereof, header field parameters, etc. are
workable options.
 [/MB]

> All 5727 says wrt P- is don't bother with a P- prefix on new headers.

[MB] Related to my comment above, folks might want to read RFC 5727 in its
entirety.[/MB]

---

From: Adam Roach <[email-masked]>
Date: Thu, 3 Dec 2015 16:07:02 -0600

On 12/3/15 11:47, Paul Kyzivat wrote:
> Yes. I *think* that this header field would qualify as 
> "informational".  (Pending review of its specification.) In that case 
> the criterion for registration is expert review. (I don't know who the 
> expert is for this.) 

That'd be me.

/a

---

From: Ivo Sedlacek <[email-masked]>
Date: Fri, 4 Dec 2015 09:13:14 +0000

Just to give you the complete picture - the other alternative discussed in 3GPP was to extend P-Access-Network-Info header field with a new parameter with value containing the information on the last recently seen 3GPP radio network cell and another parameter indicating how old this information is.

Kind regards

Ivo Sedlacek

---

From: Paul Kyzivat <[email-masked]>
Date: Fri, 4 Dec 2015 09:12:55 -0500

> Just to give you the complete picture - the other alternative discussed in 3GPP was to extend P-Access-Network-Info header field with a new parameter with value containing the information on the la…

That seems fine if this new information is really access network info. 
Generally I would recommend doing whichever is "cleanest". Obviously the 
semantics are the same either way.

	Thanks,
	Paul

---

From: "Ben Campbell" <[email-masked]>
Date: Fri, 04 Dec 2015 09:52:46 -0600

(as individual)

On 4 Dec 2015, at 8:12, Paul Kyzivat wrote:

>> Just to give you the complete picture - the other alternative 
>> discussed in 3GPP was to extend P-Access-Network-Info header field 
>> with a new parameter with value containing the information on the 
>> last recently seen 3GPP radio network cell and another parameter 
>> indicating how old this information is.
>
> Generally I would recommend doing whichever is "cleanest". Obviously 
> the semantics are the same either way.

Are there privacy considerations here? It seems like the information as 
described can (and maybe is intended to) imply geolocation.

Ben.

---

From: Mary Barnes <[email-masked]>
Date: Fri, 4 Dec 2015 12:04:32 -0600

On Fri, Dec 4, 2015 at 8:12 AM, Paul Kyzivat <[email-masked]> wrote:

>> Just to give you the complete picture - the other alternative discussed
>> in 3GPP was to extend P-Access-Network-Info header field with a new
>> parameter with value containing the information on the last recently seen
>> 3GPP radio network cell and another parameter indicating how old this
>> information is.
>>
>
[MB] My personal opinion is that an extension is a better option.  We do
that all the time for other information that we need to transport rather
than define new SIP headers.    And, back to my previous process point, we
ought first start with a clear problem description, which is probably
pretty close in this case, barring Ben's point about privacy (which needs
to be addressed independent of the solution chosen).   [/MB]

---

From: "DRAGE, Keith (Keith)" <[email-masked]>
Date: Mon, 7 Dec 2015 12:32:36 +0000

At the moment I think there are privacy concerns over and above the existing content of the P-Access-Network-Info. 

I am still investigating how we should deal with this, but currently my view is that a different "trust" domain will need to operate to meet data protection requirements in many countries (i.e. some screening entities will need to screen out this historical information but allow current information to pass through), and therefore these need to be in a different header field.

Keith

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Ben Campbell
Sent: 04 December 2015 15:53
To: Paul Kyzivat
Cc: [email-masked]
Subject: Re: [sipcore] A new SIP header fields with "P-" name

(as individual)

> the semantics are the same either way.

Are there privacy considerations here? It seems like the information as described can (and maybe is intended to) imply geolocation.

Ben.

---

From: Ivo Sedlacek <[email-masked]>
Date: Mon, 7 Dec 2015 13:47:14 +0000

I agree that the information is sensitive and a trust domain is needed.

IMO, the trust domain includes the sending UA, the home domain of the sending UA, networks between sending UA and the home domain, PSAP, networks between sending UA and the PSAP. 

This is the same as the trust domain for the P-Access-Network-Info header field.

Kind regards

Ivo Sedlacek

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of DRAGE, Keith (Keith)
Sent: Monday, December 07, 2015 1:33 PM
To: Ben Campbell; Paul Kyzivat
Cc: [email-masked]
Subject: Re: [sipcore] A new SIP header fields with "P-" name

Keith

-----Original Message-----
From: sipcore [mailto:[email-masked]] On Behalf Of Ben Campbell
Sent: 04 December 2015 15:53
To: Paul Kyzivat
Cc: [email-masked]
Subject: Re: [sipcore] A new SIP header fields with "P-" name

(as individual)

Ben.