Subject: [sipcore] Secdir last call review of draft-ietf-sipcore-locparam-04

From: Rich Salz via Datatracker <[email-masked]>
Date: Mon, 20 Jan 2020 09:19:26 -0800

Reviewer: Rich Salz
Review result: Has Nits

This is the security directorate (secdir) review for the sipcore-locparam
draft. Secdir tries to review all documents. The primary intended recipient of
this review if the security AD's; all others should consider this to be like
any other last-call review.

Summary: ready with nits.

End of Sec 1 has a quote-based typo.

In Sec 3, "This document does not comment..." paragraph is a beautiful
acceptance of reality.

In Sec 6, do proxies normally add themselves to the Record-Route field?  If so,
that might be worth mentioning explicitly.

In Sec 7, looks good.  A couple of typo's "multiple*S* locations" and
"hop-<SPACE>by-hop" and "an<SPACE>other domain."

---

From: <[email-masked]>
Date: Wed, 22 Jan 2020 07:42:00 +0000

Hello,
Thank you for your comments which I have incorporated into the draft.

For section 6: SIP proxies do add themselves into the Record-Route only when they want to stay within the SIP signalling path beyond the SIP INVITE. So it is not a usual procedure done in each use case. This is used when the proxy provide mid-call features.

Best Regards

Roland

-----Ursprüngliche Nachricht-----
Von: Rich Salz via Datatracker <[email-masked]> 
Gesendet: Montag, 20. Januar 2020 18:19
An: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Betreff: Secdir last call review of draft-ietf-sipcore-locparam-04

Reviewer: Rich Salz
Review result: Has Nits

This is the security directorate (secdir) review for the sipcore-locparam draft. Secdir tries to review all documents. The primary intended recipient of this review if the security AD's; all others should consider this to be like any other last-call review.

In Sec 3, "This document does not comment..." paragraph is a beautiful acceptance of reality.

In Sec 6, do proxies normally add themselves to the Record-Route field?  If so, that might be worth mentioning explicitly.

In Sec 7, looks good.  A couple of typo's "multiple*S* locations" and "hop-<SPACE>by-hop" and "an<SPACE>other domain."