Subject: [sipcore] I-D Action: draft-ietf-sipcore-callinfo-rcd-02.txt

From: [email-masked]
Date: Mon, 22 Feb 2021 15:23:07 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Session Initiation Protocol Core WG of the IETF.

        Title           : SIP Call-Info Parameters for Rich Call Data
        Authors         : Chris Wendt
                          Jon Peterson
	Filename        : draft-ietf-sipcore-callinfo-rcd-02.txt
	Pages           : 20
	Date            : 2021-02-22

Abstract:
   This document describes a SIP Call-Info header field usage defined to
   include rich data associated with the identity of the calling party
   that can be rendered to a called party for providing more useful
   information about the caller or the specific reason for the call.
   This includes extended comprehensive information about the caller
   such as what a jCard object can represent for describing the calling
   party or other call specific information such as describing the
   reason or intent of the call.  The elements defined for this purpose
   are intended to be extensible to accommodate related information
   about calls that helps people decide whether to pick up the phone and
   additionally, with the use of jCard and other elements, to be
   compatible with the STIR/PASSporT Rich Call Data framework.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-sipcore-callinfo-rcd/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-sipcore-callinfo-rcd-02
https://datatracker.ietf.org/doc/html/draft-ietf-sipcore-callinfo-rcd-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-sipcore-callinfo-rcd-02

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Chris Wendt <[email-masked]>
Date: Tue, 23 Feb 2021 09:49:18 -0500

Hi All,

This new update to this document which includes the following major changes:

5.1 - added a new rule that there can only be one level of URI, we believe there is no jCard properties that actually would incorporate multiple levels of URI (other than “url” which is a little different and specifically addressed in the document), so we thought this was a safe rule to apply.  It ends up making the integrity ‘rcdi’ rules easier for the rcd draft.

5.2 - added specific rules around the use of multi-media specifically around some conventions of putting the resolution of the image in the file name and a few other things.  This is in the effort to allow for multiple resolutions/file types for different end clients.  Also made the rule that the image should conform to being a square which seems to be conventional for photos/logos anyway.

5.3 added Cardinality which is already defined for jCard/vCard but thought it would be convenient to have in this document (and goes to the ability to include multiple photos or logos, etc)

I also removed all MUST/SHOULD language on properties vs just simply sticking with the strategy of including only properties from jCard that seem to apply to SIP/RCD types of communications applications.

Please review and let me know your comments.

Note: i will likely review this in the STIR session at IETF110 in conjunction with the changes made to the RCD draft as well, if you would like to join.

Thanks!

-Chris

> On Feb 22, 2021, at 6:23 PM, [email-masked] wrote:
> 
> 
> _______________________________________________
> sipcore mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sipcore