
From nobody Mon Mar 19 03:30:52 2018
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 2A578126DED; Mon, 19 Mar 2018 03:30:38 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.21
X-Spam-Level: 
X-Spam-Status: No, score=-4.21 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, T_RP_MATCHES_RCVD=-0.01, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id dh1YxJ2lEu6g; Mon, 19 Mar 2018 03:30:35 -0700 (PDT)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id E1E54127010; Mon, 19 Mar 2018 03:30:24 -0700 (PDT)
Received: by rfc-editor.org (Postfix, from userid 30) id 1A493B80C26; Mon, 19 Mar 2018 03:30:18 -0700 (PDT)
To: nmalykh@gmail.com, lse@cryptopro.ru, chudov@cryptopro.ru
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: Kathleen.Moriarty.ietf@gmail.com, iesg@ietf.org, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20180319103018.1A493B80C26@rfc-editor.org>
Date: Mon, 19 Mar 2018 03:30:18 -0700 (PDT)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/ImxynUoAaWQXjLohd4XLEpJykq0>
Subject: [smime] [Errata Held for Document Update] RFC4490 (5099)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 19 Mar 2018 10:30:38 -0000

The following errata report has been held for document update 
for RFC4490, "Using the GOST 28147-89, GOST R 34.11-94, GOST R 34.10-94, and GOST R 34.10-2001 Algorithms with Cryptographic Message Syntax (CMS)". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5099

--------------------------------------
Status: Held for Document Update
Type: Editorial

Reported by: Nikolai Malykh <nmalykh@gmail.com>
Date Reported: 2017-08-28
Held by: Kathleen Moriarty (IESG)

Section: 12.1

Original Text
-------------
   [GOST3431004] "Information technology. Cryptographic Data Security.
                 Formation and verification processes of (electronic)
                 digital signature based on Asymmetric Cryptographic
                 Algorithm.", GOST 34.310-2004, Council for
                 Standardization, Metrology and Certification of the
                 Commonwealth of Independence States (EASC), Minsk,
                 2004. (In Russian)


Corrected Text
--------------
   [GOST3431004] "Information technology. Cryptographic Data Security.
                 Formation and verification processes of [electronic]
                 digital signature.", GOST 34.310-2004, Council for
                 Standardization, Metrology and Certification of the
                 Commonwealth of Independence States (EASC), Minsk,
                 2004. (In Russian)


Notes
-----
Incorrect standard name.

--------------------------------------
RFC4490 (draft-ietf-smime-gost-07)
--------------------------------------
Title               : Using the GOST 28147-89, GOST R 34.11-94, GOST R 34.10-94, and GOST R 34.10-2001 Algorithms with Cryptographic Message Syntax (CMS)
Publication Date    : May 2006
Author(s)           : S. Leontiev, Ed., G. Chudov, Ed.
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG


From nobody Mon Mar 19 03:36:11 2018
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id D7D32126E64; Mon, 19 Mar 2018 03:36:09 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.21
X-Spam-Level: 
X-Spam-Status: No, score=-4.21 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, T_RP_MATCHES_RCVD=-0.01, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id gks9s9Zxvhr9; Mon, 19 Mar 2018 03:36:08 -0700 (PDT)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id D8893126FB3; Mon, 19 Mar 2018 03:36:06 -0700 (PDT)
Received: by rfc-editor.org (Postfix, from userid 30) id 13CA8B80C90; Mon, 19 Mar 2018 03:36:00 -0700 (PDT)
To: quannguyen@google.com, housley@vigilsec.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: Kathleen.Moriarty.ietf@gmail.com, iesg@ietf.org, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20180319103600.13CA8B80C90@rfc-editor.org>
Date: Mon, 19 Mar 2018 03:36:00 -0700 (PDT)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/MfPALyuxrNUR-_-okNL91wxuFPU>
Subject: [smime] [Errata Rejected] RFC5084 (4774)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 19 Mar 2018 10:36:10 -0000

The following errata report has been rejected for RFC5084,
"Using AES-CCM and AES-GCM Authenticated Encryption in the Cryptographic Message Syntax (CMS)".

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid4774

--------------------------------------
Status: Rejected
Type: Technical

Reported by: QUAN NGUYEN <quannguyen@google.com>
Date Reported: 2016-08-11
Rejected by: Kathleen Moriarty (IESG)

Section: 3.2

Original Text
-------------
aes-ICVlen       AES-GCM-ICVlen DEFAULT 12

A length of 12 octets is RECOMMENDED.

Corrected Text
--------------
aes-ICVlen       AES-GCM-ICVlen DEFAULT 16

A length of 16 octets is RECOMMENDED.

Notes
-----
Many JCE providers including OpenJDK, BouncyCastle, Conscrypt have a bug to use 12 bytes authentication tag (aes-ICVlen) as default if the code path [1] uses CMS. According to Ferguson's attack (http://csrc.nist.gov/groups/ST/toolkit/BCM/documents/comments/CWC-GCM/Ferguson2.pdf), if a user encrypts 2^32 block length message, then 12 bytes authentication tag length has only 96 - 32 = 64 bits security which is not good enough nowadays. Furthermore, once a forgery happens then authentication is leaked.

[1] In other code paths, all providers use 16 bytes authentication tag as default.

------
AD Note: through on list discussions, it is clear this errata should be rejected.

The first half of this errata must be rejected.  We do not change the ASN.1
for something like this under just about any circumstances.

Changing the recommendation of a value should probably not be done by an
erratum but by publishing a new document.  We could make discuss and make
the recommendation change in the new S/MIME document in the LAMPS group
rather than in this document.

A possible way forward is a short draft that updates RFC 5084 to recommend the use of 16 octet authentication tags in all situations.
 --VERIFIER NOTES-- 
   AD Note: through on list discussions, it is clear this errata should be rejected.

The first half of this errata must be rejected. We do not change the ASN.1
for something like this under just about any circumstances.

Changing the recommendation of a value should probably not be done by an
erratum but by publishing a new document. We could make discuss and make
the recommendation change in the new S/MIME document in the LAMPS group
rather than in this document.

A possible way forward is a short draft that updates RFC 5084 to recommend the use of 16 octet authentication tags in all situations.

--------------------------------------
RFC5084 (draft-ietf-smime-cms-aes-ccm-and-gcm-03)
--------------------------------------
Title               : Using AES-CCM and AES-GCM Authenticated Encryption in the Cryptographic Message Syntax (CMS)
Publication Date    : November 2007
Author(s)           : R. Housley
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG


From nobody Mon Mar 19 03:52:36 2018
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 2C143126E64; Mon, 19 Mar 2018 03:52:36 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.21
X-Spam-Level: 
X-Spam-Status: No, score=-4.21 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, T_RP_MATCHES_RCVD=-0.01, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Oc9eDcp7FZAc; Mon, 19 Mar 2018 03:52:34 -0700 (PDT)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id C903D126DEE; Mon, 19 Mar 2018 03:52:34 -0700 (PDT)
Received: by rfc-editor.org (Postfix, from userid 30) id 038E4B81B74; Mon, 19 Mar 2018 03:52:28 -0700 (PDT)
To: jsoref@gmail.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: Kathleen.Moriarty.ietf@gmail.com, iesg@ietf.org, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20180319105228.038E4B81B74@rfc-editor.org>
Date: Mon, 19 Mar 2018 03:52:28 -0700 (PDT)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/Kuco37dtH-_18IRTyNezW0YoJhY>
Subject: [smime] [Errata Held for Document Update] RFC2633 (5019)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 19 Mar 2018 10:52:36 -0000

The following errata report has been held for document update 
for RFC2633, "S/MIME Version 3 Message Specification". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata/eid5019

--------------------------------------
Status: Held for Document Update
Type: Editorial

Reported by: Josh Soref <jsoref@gmail.com>
Date Reported: 2017-05-14
Held by: Kathleen Moriarty (IESG)

Section: 5

Original Text
-------------
id-aa-encrypKeyPref OBJECT IDENTIFIER ::= {id-aa 11}


Corrected Text
--------------
id-aa-encrypKeyPref [sic] OBJECT IDENTIFIER ::= {id-aa 11}

Notes
-----
encryp isn't a word, it's a typo. Unfortunately, like http's (rfc1945) referer [sic] before it, this is now part of the API.

This error should be highlighted (as rfc2068 does for referer [sic]) so that people are aware that the natural spelling doesn't apply.

If it's possible for a revised RFC to be published suggesting the correct spelling w/ a way for clients/servers to handle the old spelling, that would be nice, but based on precedent, that seems unlikely.

---
As AD, this discussion needs to be continued and possibly with a different draft.  As such, I am marking this as hold for document update and listing it as editorial so that there are no n the wire changes at this time with this errata.
----
There was quite a bit of on list discussion that should be reviewed for any future changes.

One summary from the discussion:
he mailing list participants are copied on these errata to get their opinion in order to inform the AD how to dispose of the errata.  Most folks are just making their opinions known.

1) The next thing that folks look at is whether it’s technical or not.  Debate ensues, but generally technical errata are those that affect interoperability.  This one I don’t think does because there are no changes to the bits on the wire.

2) And, well folks want to get lots of changes, but the change has to run through the consensus process (back to mailing list input).

So to the import bit:

As I see it, there are two ways to get the note incorporated:

1. Write a draft that adds the note; this seems a bit heavy weight for what you are trying to do.

2. Apply the note to the latest RFC/draft that obsoletes RFC 2633; I guess you went for upstream, but generally the IETF applies changes to the latest/greatest RFC/draft.  That obsoletes chain is: RFC 3851 obsoleted RFC 2633, RFC 3851 was obsoleted by RFC 5751, and draft-ietf-lamps-rfc5751-bis is about to obsolete RFC 5751.  Luckily, draft-ietf-lamps-rfc5751-bis isn’t yet an RFC so there’s an option to have the note added there.

Any objections to adding a note in draft-ietf-lamps-rfc5751-bis along the same lines as the note for receipentKeyId?

--------------------------------------
RFC2633 (draft-ietf-smime-msg-08)
--------------------------------------
Title               : S/MIME Version 3 Message Specification
Publication Date    : June 1999
Author(s)           : B. Ramsdell, Ed.
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG


From nobody Mon Mar 19 06:19:20 2018
Return-Path: <hallam@gmail.com>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 0B1CB1242F5; Mon, 19 Mar 2018 06:19:13 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.399
X-Spam-Level: 
X-Spam-Status: No, score=-1.399 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, FREEMAIL_FORGED_FROMDOMAIN=0.25, FREEMAIL_FROM=0.001, HEADER_FROM_DIFFERENT_DOMAINS=0.249, HTML_MESSAGE=0.001, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=no autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 6bX5dzmf4qB0; Mon, 19 Mar 2018 06:19:11 -0700 (PDT)
Received: from mail-ot0-x232.google.com (mail-ot0-x232.google.com [IPv6:2607:f8b0:4003:c0f::232]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id D9DA0127735; Mon, 19 Mar 2018 06:19:10 -0700 (PDT)
Received: by mail-ot0-x232.google.com with SMTP id l12-v6so17294122otj.7; Mon, 19 Mar 2018 06:19:10 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025;  h=mime-version:sender:in-reply-to:references:from:date:message-id :subject:to:cc; bh=caCXI2uf0bcOQXY/OnS2qwRWL83zAFTvBhKI3pnlEB0=; b=sSJbzzLRUKWtfewmdx41kNQ9yRdC4Sxjm828/j26e+Mrn+POQ8DAaamJI6US5cL8pT bwyRyMdmzZrKFSChtWDN8toEF0wBQrE59j5n9rekV0JmOhNPauV/Fdte3vMcPn/Ui9+h E4QO7MagzsLQt0kgKvFJZHzAV5cKs+anShxvYRuL0EyAUHx8ngP+GCnQl3nUn/FPmm93 ayTmD9f3Gd8+ghYHWTSMHmxDQDsP/yogoSAcV3+rIptTy3hOJBOwAYXR4Q5iJaJMo8Uk rLAUfmBAVlRpvj1G1dSsfSICxW2t4Ih5DKVToOaekO8S1Gm6TUjlwbswwcm+W+hLX+16 Vg0Q==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:sender:in-reply-to:references:from :date:message-id:subject:to:cc; bh=caCXI2uf0bcOQXY/OnS2qwRWL83zAFTvBhKI3pnlEB0=; b=MyrCznIr1DToR+0Qt971vC60LQK5SYVSAXnao4aIYkp/QiySotr2uND+7KjHytUmhc cWfZCOh1vBWr+hGxdMh7R1BLpdOam3Gkw57aOeg6XmcjWU9bP61T0Kr3OGZJI1WMCO42 JLQnFFFCT/MehNzn0UAFcmFIZJb1OeLK8wGTx+1lY/sOxN1UQvbBYk9zcCAkCne9VTCh VSW03AyRFKZ78k1XpBRNDIqnwbrU7r49eBQkSS5f/HbGKz23RvjViamV8UnrOwa60Avb 89DAP33Xy5P7TnCB+PtNB0WSeLtugq5U1i8uANWgMnxIqOJF1wK8x57L5JfkwZjeZbYQ mBkQ==
X-Gm-Message-State: AElRT7ExM7Rdw0hqG1ZPHdN5w8SC3kTnMxicHCA01lohJPvujIWzb65V e0LQFkCbzWpYa1bcRnzZMBDSLCjx42HarGz0gzI=
X-Google-Smtp-Source: AG47ELt7aC+zgLAOIJ5VsODVBGkrVd76+CMsUmeJTNt4Tt8oyolk2hX6aGRunYs6rus8ng5DRHfvWsQpoWewy5n6qgE=
X-Received: by 2002:a9d:5a09:: with SMTP id v9-v6mr8160991oth.380.1521465548041;  Mon, 19 Mar 2018 06:19:08 -0700 (PDT)
MIME-Version: 1.0
Sender: hallam@gmail.com
Received: by 2002:a9d:233c:0:0:0:0:0 with HTTP; Mon, 19 Mar 2018 06:19:07 -0700 (PDT)
In-Reply-To: <20180319105228.038E4B81B74@rfc-editor.org>
References: <20180319105228.038E4B81B74@rfc-editor.org>
From: Phillip Hallam-Baker <phill@hallambaker.com>
Date: Mon, 19 Mar 2018 09:19:07 -0400
X-Google-Sender-Auth: WjXHYu9dd6ldr8LEPsMr1oFwMkk
Message-ID: <CAMm+Lwip-1tvae6=fQCTwHqvFm=GL1LB11wnPx6YF4B=0c-2=w@mail.gmail.com>
To: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: jsoref@gmail.com, Kathleen Moriarty <Kathleen.Moriarty.ietf@gmail.com>, iesg@ietf.org, IETF SMIME <smime@ietf.org>
Content-Type: multipart/alternative; boundary="0000000000008773fa0567c3cd4a"
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/DL_1nLVe0Dt9kVITwL57fvMIou8>
Subject: Re: [smime] [Errata Held for Document Update] RFC2633 (5019)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 19 Mar 2018 13:19:13 -0000

--0000000000008773fa0567c3cd4a
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

I agree it would be useful to highlight. But this is an ASN.1 code fragment
and I am not sure it will parse with the comment there.

On Mon, Mar 19, 2018 at 6:52 AM, RFC Errata System <
rfc-editor@rfc-editor.org> wrote:

> The following errata report has been held for document update
> for RFC2633, "S/MIME Version 3 Message Specification".
>
> --------------------------------------
> You may review the report below and at:
> http://www.rfc-editor.org/errata/eid5019
>
> --------------------------------------
> Status: Held for Document Update
> Type: Editorial
>
> Reported by: Josh Soref <jsoref@gmail.com>
> Date Reported: 2017-05-14
> Held by: Kathleen Moriarty (IESG)
>
> Section: 5
>
> Original Text
> -------------
> id-aa-encrypKeyPref OBJECT IDENTIFIER ::=3D {id-aa 11}
>
>
> Corrected Text
> --------------
> id-aa-encrypKeyPref [sic] OBJECT IDENTIFIER ::=3D {id-aa 11}
>
> Notes
> -----
> encryp isn't a word, it's a typo. Unfortunately, like http's (rfc1945)
> referer [sic] before it, this is now part of the API.
>
> This error should be highlighted (as rfc2068 does for referer [sic]) so
> that people are aware that the natural spelling doesn't apply.
>
> If it's possible for a revised RFC to be published suggesting the correct
> spelling w/ a way for clients/servers to handle the old spelling, that
> would be nice, but based on precedent, that seems unlikely.
>
> ---
> As AD, this discussion needs to be continued and possibly with a differen=
t
> draft.  As such, I am marking this as hold for document update and listin=
g
> it as editorial so that there are no n the wire changes at this time with
> this errata.
> ----
> There was quite a bit of on list discussion that should be reviewed for
> any future changes.
>
> One summary from the discussion:
> he mailing list participants are copied on these errata to get their
> opinion in order to inform the AD how to dispose of the errata.  Most fol=
ks
> are just making their opinions known.
>
> 1) The next thing that folks look at is whether it=E2=80=99s technical or=
 not.
> Debate ensues, but generally technical errata are those that affect
> interoperability.  This one I don=E2=80=99t think does because there are =
no changes
> to the bits on the wire.
>
> 2) And, well folks want to get lots of changes, but the change has to run
> through the consensus process (back to mailing list input).
>
> So to the import bit:
>
> As I see it, there are two ways to get the note incorporated:
>
> 1. Write a draft that adds the note; this seems a bit heavy weight for
> what you are trying to do.
>
> 2. Apply the note to the latest RFC/draft that obsoletes RFC 2633; I gues=
s
> you went for upstream, but generally the IETF applies changes to the
> latest/greatest RFC/draft.  That obsoletes chain is: RFC 3851 obsoleted R=
FC
> 2633, RFC 3851 was obsoleted by RFC 5751, and draft-ietf-lamps-rfc5751-bi=
s
> is about to obsolete RFC 5751.  Luckily, draft-ietf-lamps-rfc5751-bis isn=
=E2=80=99t
> yet an RFC so there=E2=80=99s an option to have the note added there.
>
> Any objections to adding a note in draft-ietf-lamps-rfc5751-bis along the
> same lines as the note for receipentKeyId?
>
> --------------------------------------
> RFC2633 (draft-ietf-smime-msg-08)
> --------------------------------------
> Title               : S/MIME Version 3 Message Specification
> Publication Date    : June 1999
> Author(s)           : B. Ramsdell, Ed.
> Category            : PROPOSED STANDARD
> Source              : S/MIME Mail Security
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
>
> _______________________________________________
> smime mailing list
> smime@ietf.org
> https://www.ietf.org/mailman/listinfo/smime
>

--0000000000008773fa0567c3cd4a
Content-Type: text/html; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable

<div dir=3D"ltr"><div class=3D"gmail_default" style=3D"font-size:small">I a=
gree it would be useful to highlight. But this is an ASN.1 code fragment an=
d I am not sure it will parse with the comment there.</div></div><div class=
=3D"gmail_extra"><br><div class=3D"gmail_quote">On Mon, Mar 19, 2018 at 6:5=
2 AM, RFC Errata System <span dir=3D"ltr">&lt;<a href=3D"mailto:rfc-editor@=
rfc-editor.org" target=3D"_blank">rfc-editor@rfc-editor.org</a>&gt;</span> =
wrote:<br><blockquote class=3D"gmail_quote" style=3D"margin:0 0 0 .8ex;bord=
er-left:1px #ccc solid;padding-left:1ex">The following errata report has be=
en held for document update<br>
for RFC2633, &quot;S/MIME Version 3 Message Specification&quot;.<br>
<br>
------------------------------<wbr>--------<br>
You may review the report below and at:<br>
<a href=3D"http://www.rfc-editor.org/errata/eid5019" rel=3D"noreferrer" tar=
get=3D"_blank">http://www.rfc-editor.org/<wbr>errata/eid5019</a><br>
<br>
------------------------------<wbr>--------<br>
Status: Held for Document Update<br>
Type: Editorial<br>
<br>
Reported by: Josh Soref &lt;<a href=3D"mailto:jsoref@gmail.com">jsoref@gmai=
l.com</a>&gt;<br>
Date Reported: 2017-05-14<br>
Held by: Kathleen Moriarty (IESG)<br>
<br>
Section: 5<br>
<br>
Original Text<br>
-------------<br>
id-aa-encrypKeyPref OBJECT IDENTIFIER ::=3D {id-aa 11}<br>
<br>
<br>
Corrected Text<br>
--------------<br>
id-aa-encrypKeyPref [sic] OBJECT IDENTIFIER ::=3D {id-aa 11}<br>
<br>
Notes<br>
-----<br>
encryp isn&#39;t a word, it&#39;s a typo. Unfortunately, like http&#39;s (r=
fc1945) referer [sic] before it, this is now part of the API.<br>
<br>
This error should be highlighted (as rfc2068 does for referer [sic]) so tha=
t people are aware that the natural spelling doesn&#39;t apply.<br>
<br>
If it&#39;s possible for a revised RFC to be published suggesting the corre=
ct spelling w/ a way for clients/servers to handle the old spelling, that w=
ould be nice, but based on precedent, that seems unlikely.<br>
<br>
---<br>
As AD, this discussion needs to be continued and possibly with a different =
draft.=C2=A0 As such, I am marking this as hold for document update and lis=
ting it as editorial so that there are no n the wire changes at this time w=
ith this errata.<br>
----<br>
There was quite a bit of on list discussion that should be reviewed for any=
 future changes.<br>
<br>
One summary from the discussion:<br>
he mailing list participants are copied on these errata to get their opinio=
n in order to inform the AD how to dispose of the errata.=C2=A0 Most folks =
are just making their opinions known.<br>
<br>
1) The next thing that folks look at is whether it=E2=80=99s technical or n=
ot.=C2=A0 Debate ensues, but generally technical errata are those that affe=
ct interoperability.=C2=A0 This one I don=E2=80=99t think does because ther=
e are no changes to the bits on the wire.<br>
<br>
2) And, well folks want to get lots of changes, but the change has to run t=
hrough the consensus process (back to mailing list input).<br>
<br>
So to the import bit:<br>
<br>
As I see it, there are two ways to get the note incorporated:<br>
<br>
1. Write a draft that adds the note; this seems a bit heavy weight for what=
 you are trying to do.<br>
<br>
2. Apply the note to the latest RFC/draft that obsoletes RFC 2633; I guess =
you went for upstream, but generally the IETF applies changes to the latest=
/greatest RFC/draft.=C2=A0 That obsoletes chain is: RFC 3851 obsoleted RFC =
2633, RFC 3851 was obsoleted by RFC 5751, and draft-ietf-lamps-rfc5751-bis =
is about to obsolete RFC 5751.=C2=A0 Luckily, draft-ietf-lamps-rfc5751-bis =
isn=E2=80=99t yet an RFC so there=E2=80=99s an option to have the note adde=
d there.<br>
<br>
Any objections to adding a note in draft-ietf-lamps-rfc5751-bis along the s=
ame lines as the note for receipentKeyId?<br>
<br>
------------------------------<wbr>--------<br>
RFC2633 (draft-ietf-smime-msg-08)<br>
------------------------------<wbr>--------<br>
Title=C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0: S/MIME Versio=
n 3 Message Specification<br>
Publication Date=C2=A0 =C2=A0 : June 1999<br>
Author(s)=C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0: B. Ramsdell, Ed.<br>
Category=C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 : PROPOSED STANDARD<br>
Source=C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 : S/MIME Mail Securi=
ty<br>
Area=C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 : Security<br>
Stream=C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 =C2=A0 : IETF<br>
Verifying Party=C2=A0 =C2=A0 =C2=A0: IESG<br>
<br>
______________________________<wbr>_________________<br>
smime mailing list<br>
<a href=3D"mailto:smime@ietf.org">smime@ietf.org</a><br>
<a href=3D"https://www.ietf.org/mailman/listinfo/smime" rel=3D"noreferrer" =
target=3D"_blank">https://www.ietf.org/mailman/<wbr>listinfo/smime</a><br>
</blockquote></div><br></div>

--0000000000008773fa0567c3cd4a--


From nobody Tue Mar 20 03:14:18 2018
Return-Path: <sean@sn3rd.com>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id BD096126B6D for <smime@ietfa.amsl.com>; Tue, 20 Mar 2018 03:14:12 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.001
X-Spam-Level: 
X-Spam-Status: No, score=-2.001 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, SPF_PASS=-0.001] autolearn=unavailable autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=sn3rd.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id zBEizzjhk7qY for <smime@ietfa.amsl.com>; Tue, 20 Mar 2018 03:14:11 -0700 (PDT)
Received: from mail-pl0-x22d.google.com (mail-pl0-x22d.google.com [IPv6:2607:f8b0:400e:c01::22d]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 3A9E1126CD8 for <smime@ietf.org>; Tue, 20 Mar 2018 03:14:11 -0700 (PDT)
Received: by mail-pl0-x22d.google.com with SMTP id b7-v6so680405plr.8 for <smime@ietf.org>; Tue, 20 Mar 2018 03:14:11 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=sn3rd.com; s=google; h=mime-version:subject:from:in-reply-to:date:cc :content-transfer-encoding:message-id:references:to; bh=W/IVbf53Glx884NC9ISVcU6DfK62Y/YtT6c+SNMBvT0=; b=kPfgOIFFGiggj+d6YKdyuY4WoJhcc7NXvKIoI+8NBBGKuPZgq4PpxWrQaY9q9Ov1wy oVq9vkcjcwwlTrEwqziVkY6BTeBtH6hIonCs77MHqr5Hhf2UAn/+5J3RNcRYACBR8fs+ cThLAomi4iMdy6Kd6DHmYmvRYPLNWppcD56CA=
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:subject:from:in-reply-to:date:cc :content-transfer-encoding:message-id:references:to; bh=W/IVbf53Glx884NC9ISVcU6DfK62Y/YtT6c+SNMBvT0=; b=TitDX21IP3AntKYxKuqEbR2G+qCOyRG+OgJFJYzaBd8Yz1fzpk/KnlKwTZ0W29lxCW eV85Opjz4Hh5uWMs1ckmP7mFPUZmzvL/xG5oT1RIWJMt1rf0rcmmLUvo8/EYEkOT2uDG s3rwCQ4rzYVD7mI0asMqXndMcE/D1E2IEqWIxLmNbrULdUhMW/j48ZvQrSYs2jJ6Av/o QTa10S3+1P9vBvINReGHYqsupKcyD91SgUygoYtPmJrESbx1aWWWzhaZEomTgpZjDx/V d4nB5IhnJEEP/aLIVm7+khgCL832MDOYAfOwkyY+kNrkHeRZkpunnz95A9QJVFPBu8nl AcSA==
X-Gm-Message-State: AElRT7FYAOqLRyYO3QR3qcBZpo82WQ7+IY3FkU3TlNjBrMXRRWjVnneL dQMDwU42j0tGugy/qkOyH1GVug==
X-Google-Smtp-Source: AG47ELtIMTN4VxOaF0nt8dZif8ll3MOiXG6ky1Xk1jHpPdazK7ERSXOo4UcxFwNw1oT1Td3w3HIEqg==
X-Received: by 2002:a17:902:bc88:: with SMTP id bb8-v6mr4153553plb.214.1521540850738;  Tue, 20 Mar 2018 03:14:10 -0700 (PDT)
Received: from ?IPv6:2001:67c:370:1998:d91e:da89:fabf:9e56? ([2001:67c:370:1998:d91e:da89:fabf:9e56]) by smtp.gmail.com with ESMTPSA id y18sm2593976pfe.67.2018.03.20.03.14.07 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Tue, 20 Mar 2018 03:14:10 -0700 (PDT)
Content-Type: text/plain; charset=utf-8
Mime-Version: 1.0 (Mac OS X Mail 11.2 \(3445.5.20\))
From: Sean Turner <sean@sn3rd.com>
In-Reply-To: <20180319105228.038E4B81B74@rfc-editor.org>
Date: Tue, 20 Mar 2018 10:14:03 +0000
Cc: Josh Soref <jsoref@gmail.com>, The IESG <iesg@ietf.org>, IETF SMIME <smime@ietf.org>
Content-Transfer-Encoding: quoted-printable
Message-Id: <A49F52BF-FD29-4E8A-86DA-D50A0F80614F@sn3rd.com>
References: <20180319105228.038E4B81B74@rfc-editor.org>
To: Kathleen Moriarty <Kathleen.Moriarty.ietf@gmail.com>
X-Mailer: Apple Mail (2.3445.5.20)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/Q9bpef_u-ITeUD4WD8JFOavUY1c>
Subject: Re: [smime] [Errata Held for Document Update] RFC2633 (5019)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 20 Mar 2018 10:14:13 -0000

> On Mar 19, 2018, at 10:52, RFC Errata System =
<rfc-editor@rfc-editor.org> wrote:
>=20
> Any objections to adding a note in draft-ietf-lamps-rfc5751-bis along =
the same lines as the note for receipentKeyId?

It=E2=80=99s slightly different than renaming receipentKeyId because =
this is an OID so you could also do this:

id-aa-encryptKeyPref OBJECT IDENTIFIER ::=3D id-aa-encrypKeyPref=20

But I also don=E2=80=99t have an issue with just adding the note.

spt=


From nobody Wed Mar 21 00:29:39 2018
Return-Path: <ietf@augustcellars.com>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 1A7E01250B8; Wed, 21 Mar 2018 00:29:32 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.91
X-Spam-Level: 
X-Spam-Status: No, score=-1.91 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, SPF_PASS=-0.001, T_RP_MATCHES_RCVD=-0.01, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 0S3r1NAXqqFf; Wed, 21 Mar 2018 00:29:30 -0700 (PDT)
Received: from mail2.augustcellars.com (augustcellars.com [50.45.239.150]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id EEF8B1243F3; Wed, 21 Mar 2018 00:29:29 -0700 (PDT)
Received: from Jude (79.173.164.218) by mail2.augustcellars.com (192.168.0.56) with Microsoft SMTP Server (TLS) id 15.0.1347.2; Wed, 21 Mar 2018 00:27:17 -0700
From: Jim Schaad <ietf@augustcellars.com>
To: 'Sean Turner' <sean@sn3rd.com>, 'Kathleen Moriarty' <Kathleen.Moriarty.ietf@gmail.com>
CC: 'Josh Soref' <jsoref@gmail.com>, 'The IESG' <iesg@ietf.org>, 'IETF SMIME' <smime@ietf.org>
References: <20180319105228.038E4B81B74@rfc-editor.org> <A49F52BF-FD29-4E8A-86DA-D50A0F80614F@sn3rd.com>
In-Reply-To: <A49F52BF-FD29-4E8A-86DA-D50A0F80614F@sn3rd.com>
Date: Wed, 21 Mar 2018 07:29:19 +0000
Message-ID: <049b01d3c0e6$558f1d90$00ad58b0$@augustcellars.com>
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: quoted-printable
X-Mailer: Microsoft Outlook 16.0
Thread-Index: AQI6/F7956nMG8iJO9XzuTgmZhBE8QFZvNglowEFnYA=
Content-Language: en-us
X-Originating-IP: [79.173.164.218]
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/ueWY4775zW504Vn8OXIOQYuFfcA>
Subject: Re: [smime] [Errata Held for Document Update] RFC2633 (5019)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 21 Mar 2018 07:29:32 -0000

It would be

id-aa-encrypKeyPref -- sic -- OBJECT IDENTIFIER ::=3D ...

Jim


> -----Original Message-----
> From: smime <smime-bounces@ietf.org> On Behalf Of Sean Turner
> Sent: Tuesday, March 20, 2018 10:14 AM
> To: Kathleen Moriarty <Kathleen.Moriarty.ietf@gmail.com>
> Cc: Josh Soref <jsoref@gmail.com>; The IESG <iesg@ietf.org>; IETF =
SMIME
> <smime@ietf.org>
> Subject: Re: [smime] [Errata Held for Document Update] RFC2633 (5019)
>=20
>=20
>=20
> > On Mar 19, 2018, at 10:52, RFC Errata System =
<rfc-editor@rfc-editor.org>
> wrote:
> >
> > Any objections to adding a note in draft-ietf-lamps-rfc5751-bis =
along the
> same lines as the note for receipentKeyId?
>=20
> It=E2=80=99s slightly different than renaming receipentKeyId because =
this is an OID so
> you could also do this:
>=20
> id-aa-encryptKeyPref OBJECT IDENTIFIER ::=3D id-aa-encrypKeyPref
>=20
> But I also don=E2=80=99t have an issue with just adding the note.
>=20
> spt
> _______________________________________________
> smime mailing list
> smime@ietf.org
> https://www.ietf.org/mailman/listinfo/smime


From nobody Wed Mar 21 01:37:35 2018
Return-Path: <kathleen.moriarty.ietf@gmail.com>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id B34FC126D05; Wed, 21 Mar 2018 01:37:28 -0700 (PDT)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2.699
X-Spam-Level: 
X-Spam-Status: No, score=-2.699 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, FREEMAIL_FROM=0.001, RCVD_IN_DNSWL_LOW=-0.7, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=gmail.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id tpUasmWa4jY8; Wed, 21 Mar 2018 01:37:27 -0700 (PDT)
Received: from mail-it0-x22a.google.com (mail-it0-x22a.google.com [IPv6:2607:f8b0:4001:c0b::22a]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 3D09212DA00; Wed, 21 Mar 2018 01:37:06 -0700 (PDT)
Received: by mail-it0-x22a.google.com with SMTP id z143-v6so15441937itc.0; Wed, 21 Mar 2018 01:37:06 -0700 (PDT)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025;  h=mime-version:in-reply-to:references:from:date:message-id:subject:to :cc:content-transfer-encoding; bh=o14EdtP+VmTRkwww6QE0bJgZMxOxuetDR1zrTbU0WDQ=; b=kgJgMIicA4spEcCQxVXYKA15H+BFd2Su99x+Sc4xrqIr97N3uOnIcBBaIANahUZ3Ch r2ZpVUF2/UQ0g1BCnAehrGqAVpqP4eI5ub0AZ82t5fyRj6z7ikmUr7a30SMMozpvplV/ 9qEcY4o6xY1T8K4jY1ZLisHqlsicMll26yjqQ6iFwYXBPVuVQ6SzAyFIad2u4kC9rpGF YQ5Y7G1hbNfeJ1NKC2U6XKdmlC0cnj5zUgrC+7tNTnTC71eH7gHdwKFf3ICGMwlgqicW D2YSbp7NjtfowWQxr2S/DacMTG8/7Xp32E1D/+ROU0VZXpzAkn8vsRJ3eOkXEyQalV7l B7QQ==
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:in-reply-to:references:from:date :message-id:subject:to:cc:content-transfer-encoding; bh=o14EdtP+VmTRkwww6QE0bJgZMxOxuetDR1zrTbU0WDQ=; b=aXPE0MOue3ItMpiRF5Uu0T91FJmXPQrhRpQ2zPN+UW8h3mayMyT4STQYTZ/tEGx2XN Y7aVkR4+aodQqBKGNL/Z4dh/ztHIcZQqTke0vPmEUtYJk2Wk+0sr8cxUPLkooeo+ILog al18wRFN03+XC/s8qssD0bzXh1e/V+XFEj2uQp+ZkPazj7La+1tBJgjbtG8VfuDKNTWJ oUGelLPHvRE7SC0KUuF8U7FoK/LMU0QN4MeCnDamT8bKWw24ELhv3NBGwalXaHt4rHC4 XM8uJwAdYaVG7zHsS/pqy+4gEgH16aw53n8IEsCZq5nqritLV8U5f9fufjBvMbz23Nny aDfg==
X-Gm-Message-State: AElRT7E+zWSAXhlxtJGFdYIH3FbBd2fhFS/5gS+e6sOH7rGfjJXqPVHs lk1dQ4YZwV2rccYNleZpbIFEVqfqBhZ6VPm+fDA=
X-Google-Smtp-Source: AG47ELu3WEWsaPa/Y65Vtgqv2xm6g8ibwBZbjFjW6H/o68rGdNnO2yJif7y4+Z5heR3RkiW4+e8w1k4AO8yTEyswS4Y=
X-Received: by 2002:a24:6b93:: with SMTP id v141-v6mr3097885itc.38.1521621425579;  Wed, 21 Mar 2018 01:37:05 -0700 (PDT)
MIME-Version: 1.0
Received: by 10.192.156.137 with HTTP; Wed, 21 Mar 2018 01:36:25 -0700 (PDT)
In-Reply-To: <049b01d3c0e6$558f1d90$00ad58b0$@augustcellars.com>
References: <20180319105228.038E4B81B74@rfc-editor.org> <A49F52BF-FD29-4E8A-86DA-D50A0F80614F@sn3rd.com> <049b01d3c0e6$558f1d90$00ad58b0$@augustcellars.com>
From: Kathleen Moriarty <kathleen.moriarty.ietf@gmail.com>
Date: Wed, 21 Mar 2018 04:36:25 -0400
Message-ID: <CAHbuEH7LD82Co9HpABfMDDBthK4cZ84YmaSrckgEf2X-ebUohA@mail.gmail.com>
To: Jim Schaad <ietf@augustcellars.com>
Cc: Sean Turner <sean@sn3rd.com>, Josh Soref <jsoref@gmail.com>, The IESG <iesg@ietf.org>, IETF SMIME <smime@ietf.org>
Content-Type: text/plain; charset="UTF-8"
Content-Transfer-Encoding: quoted-printable
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/rDawmqdKye7BKvy1kafRNv73zbU>
Subject: Re: [smime] [Errata Held for Document Update] RFC2633 (5019)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.22
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 21 Mar 2018 08:37:29 -0000

Thank you.  I have sent a follow up message to the secretariat to
correct the text in the errata marked as HFDU.

Best regards,
Kathleen

On Wed, Mar 21, 2018 at 3:29 AM, Jim Schaad <ietf@augustcellars.com> wrote:
> It would be
>
> id-aa-encrypKeyPref -- sic -- OBJECT IDENTIFIER ::=3D ...
>
> Jim
>
>
>> -----Original Message-----
>> From: smime <smime-bounces@ietf.org> On Behalf Of Sean Turner
>> Sent: Tuesday, March 20, 2018 10:14 AM
>> To: Kathleen Moriarty <Kathleen.Moriarty.ietf@gmail.com>
>> Cc: Josh Soref <jsoref@gmail.com>; The IESG <iesg@ietf.org>; IETF SMIME
>> <smime@ietf.org>
>> Subject: Re: [smime] [Errata Held for Document Update] RFC2633 (5019)
>>
>>
>>
>> > On Mar 19, 2018, at 10:52, RFC Errata System <rfc-editor@rfc-editor.or=
g>
>> wrote:
>> >
>> > Any objections to adding a note in draft-ietf-lamps-rfc5751-bis along =
the
>> same lines as the note for receipentKeyId?
>>
>> It=E2=80=99s slightly different than renaming receipentKeyId because thi=
s is an OID so
>> you could also do this:
>>
>> id-aa-encryptKeyPref OBJECT IDENTIFIER ::=3D id-aa-encrypKeyPref
>>
>> But I also don=E2=80=99t have an issue with just adding the note.
>>
>> spt
>> _______________________________________________
>> smime mailing list
>> smime@ietf.org
>> https://www.ietf.org/mailman/listinfo/smime
>



--=20

Best regards,
Kathleen

