
From nobody Thu Nov  7 14:04:24 2019
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 9A27C12086C for <smime@ietfa.amsl.com>; Thu,  7 Nov 2019 14:04:22 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.2
X-Spam-Level: 
X-Spam-Status: No, score=-4.2 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id USeAM1bIKGAv for <smime@ietfa.amsl.com>; Thu,  7 Nov 2019 14:04:21 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 19D0212011C for <smime@ietf.org>; Thu,  7 Nov 2019 14:04:21 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id 521BBF40741; Thu,  7 Nov 2019 14:04:01 -0800 (PST)
To: ekr@rtfm.com, rdd@cert.org, kaduk@mit.edu, paul.hoffman@vpnc.org, blaker@gmail.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: housley@vigilsec.com, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20191107220401.521BBF40741@rfc-editor.org>
Date: Thu,  7 Nov 2019 14:04:01 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/QkJsPFgETsK3ruPpmW0HIvBFz0M>
Subject: [smime] [Technical Errata Reported] RFC2631 (5897)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 07 Nov 2019 22:04:23 -0000

The following errata report has been submitted for RFC2631,
"Diffie-Hellman Key Agreement Method".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5897

--------------------------------------
Type: Technical
Reported by: Russ Housley <housley@vigilsec.com>

Section: 2.1.2

Original Text
-------------
     KeySpecificInfo ::= SEQUENCE {
       algorithm OBJECT IDENTIFIER,
       counter OCTET STRING SIZE (4..4) }

Corrected Text
--------------
     KeySpecificInfo ::= SEQUENCE {
       algorithm OBJECT IDENTIFIER,
       counter OCTET STRING (SIZE (4..4)) }

Notes
-----
The addition of '(' and ')' are needed for an ASN.1 compiler to accept the syntax without raising an error.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2631 (draft-ietf-smime-x942-07)
--------------------------------------
Title               : Diffie-Hellman Key Agreement Method
Publication Date    : June 1999
Author(s)           : E. Rescorla
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG


From nobody Thu Nov  7 14:21:46 2019
Return-Path: <fluffy@iii.ca>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 8D3D5120959 for <smime@ietfa.amsl.com>; Thu,  7 Nov 2019 14:21:41 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.899
X-Spam-Level: 
X-Spam-Status: No, score=-1.899 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=g001.emailsrvr.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id vIpJA1y7E5r3 for <smime@ietfa.amsl.com>; Thu,  7 Nov 2019 14:21:40 -0800 (PST)
Received: from smtp82.iad3b.emailsrvr.com (smtp82.iad3b.emailsrvr.com [146.20.161.82]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id E03011209F0 for <smime@ietf.org>; Thu,  7 Nov 2019 14:21:39 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/simple; d=g001.emailsrvr.com; s=20190322-9u7zjiwi; t=1573165299; bh=YxpFKaUvWm+HQf2kZj9fmidJR+/QlDivRyl/vrDUjbY=; h=Subject:From:Date:To:From; b=IHrhTtz2H8dIyVKrK5wkR8/f65fkZX4J+rPxH5OzUcoA9W8ZbtGAbJ+gj5Zmmoimx vdqp9a3w1T3DK7VPnBpCC4+AI5UivikPX9EVcjR83Nmd0nxOC72ydnEJfcPGmoSrOh hcViyi9DG0MeIveesKxlFLOsQhDfWGwxVgNKOi6s=
X-Auth-ID: fluffy@iii.ca
Received: by smtp11.relay.iad3b.emailsrvr.com (Authenticated sender: fluffy-AT-iii.ca) with ESMTPSA id 8A31A40247;  Thu,  7 Nov 2019 17:21:30 -0500 (EST)
X-Sender-Id: fluffy@iii.ca
Received: from [172.19.131.145] ([UNAVAILABLE]. [199.167.24.152]) (using TLSv1.2 with cipher DHE-RSA-AES256-GCM-SHA384) by 0.0.0.0:25 (trex/5.7.12); Thu, 07 Nov 2019 17:21:39 -0500
Content-Type: text/plain; charset=us-ascii
Mime-Version: 1.0 (Mac OS X Mail 12.4 \(3445.104.11\))
From: Cullen Jennings <fluffy@iii.ca>
In-Reply-To: <20191107220401.521BBF40741@rfc-editor.org>
Date: Thu, 7 Nov 2019 14:21:22 -0800
Cc: Eric Rescorla <ekr@rtfm.com>, rdd@cert.org, kaduk@mit.edu, Paul Hoffman <paul.hoffman@vpnc.org>, blaker@gmail.com, smime@ietf.org
Content-Transfer-Encoding: quoted-printable
Message-Id: <55A81408-6571-4EC9-A403-FC9ECCECBBA4@iii.ca>
References: <20191107220401.521BBF40741@rfc-editor.org>
To: RFC Editor <rfc-editor@rfc-editor.org>
X-Mailer: Apple Mail (2.3445.104.11)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/_cGhkA0Ac4OZLGNUbphfkq6w_wo>
Subject: Re: [smime] [Technical Errata Reported] RFC2631 (5897)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 07 Nov 2019 22:21:44 -0000

I reviewed this and believe this errata is correct and should be =
approved.=20


> On Nov 7, 2019, at 2:04 PM, RFC Errata System =
<rfc-editor@rfc-editor.org> wrote:
>=20
> The following errata report has been submitted for RFC2631,
> "Diffie-Hellman Key Agreement Method".
>=20
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid5897
>=20
> --------------------------------------
> Type: Technical
> Reported by: Russ Housley <housley@vigilsec.com>
>=20
> Section: 2.1.2
>=20
> Original Text
> -------------
>     KeySpecificInfo ::=3D SEQUENCE {
>       algorithm OBJECT IDENTIFIER,
>       counter OCTET STRING SIZE (4..4) }
>=20
> Corrected Text
> --------------
>     KeySpecificInfo ::=3D SEQUENCE {
>       algorithm OBJECT IDENTIFIER,
>       counter OCTET STRING (SIZE (4..4)) }
>=20
> Notes
> -----
> The addition of '(' and ')' are needed for an ASN.1 compiler to accept =
the syntax without raising an error.
>=20
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party =20
> can log in to change the status and edit the report, if necessary.=20
>=20
> --------------------------------------
> RFC2631 (draft-ietf-smime-x942-07)
> --------------------------------------
> Title               : Diffie-Hellman Key Agreement Method
> Publication Date    : June 1999
> Author(s)           : E. Rescorla
> Category            : PROPOSED STANDARD
> Source              : S/MIME Mail Security
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
>=20
> _______________________________________________
> smime mailing list
> smime@ietf.org
> https://www.ietf.org/mailman/listinfo/smime


From nobody Tue Nov 12 08:05:32 2019
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id A0048120074 for <smime@ietfa.amsl.com>; Tue, 12 Nov 2019 08:05:30 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.2
X-Spam-Level: 
X-Spam-Status: No, score=-4.2 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id MBCjTYJUgpqH for <smime@ietfa.amsl.com>; Tue, 12 Nov 2019 08:05:29 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 346BF12006F for <smime@ietf.org>; Tue, 12 Nov 2019 08:05:29 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id 0BA7FF4072C; Tue, 12 Nov 2019 08:05:25 -0800 (PST)
To: harri.rasilainen@etsi.fr, ross@secstan.com, Denis.Pinkas@bull.net, pope@secstan.com, rdd@cert.org, kaduk@mit.edu, paul.hoffman@vpnc.org, blaker@gmail.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: housley@vigilsec.com, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20191112160525.0BA7FF4072C@rfc-editor.org>
Date: Tue, 12 Nov 2019 08:05:25 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/py0ZzIYe3cKahff6TD4Iu5l_D-k>
Subject: [smime] [Technical Errata Reported] RFC3125 (5901)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 12 Nov 2019 16:05:31 -0000

The following errata report has been submitted for RFC3125,
"Electronic Signature Policies".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5901

--------------------------------------
Type: Technical
Reported by: Russ Housley <housley@vigilsec.com>

Section: Appendix A.1

Original Text
-------------
CommitmentType ::= SEQUENCE {
        identifier                      CommitmentTypeIdentifier,
        fieldOfApplication      [0] FieldOfApplication OPTIONAL,
        semantics                       [1] DirectoryString OPTIONAL }

Corrected Text
--------------
CommitmentType ::= SEQUENCE {
        identifier                      CommitmentTypeIdentifier,
        fieldOfApplication      [0] FieldOfApplication OPTIONAL,
        semantics                       [1] DirectoryString OPTIONAL }

CommitmentTypeIdentifier ::= OBJECT IDENTIFIER

Notes
-----
The definition of CommitmentTypeIdentifier is missing from the ASN.1 module.  RFC 3126 shows that it is an object identifier.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3125 (draft-ietf-smime-espolicies-00)
--------------------------------------
Title               : Electronic Signature Policies
Publication Date    : September 2001
Author(s)           : J. Ross, D. Pinkas, N. Pope
Category            : EXPERIMENTAL
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG


From nobody Tue Nov 12 08:08:03 2019
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 4307412009C for <smime@ietfa.amsl.com>; Tue, 12 Nov 2019 08:08:01 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.2
X-Spam-Level: 
X-Spam-Status: No, score=-4.2 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id REpOVd7PklYZ for <smime@ietfa.amsl.com>; Tue, 12 Nov 2019 08:07:57 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id B932212006F for <smime@ietf.org>; Tue, 12 Nov 2019 08:07:56 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id 8C845F4070D; Tue, 12 Nov 2019 08:07:52 -0800 (PST)
To: harri.rasilainen@etsi.fr, ross@secstan.com, Denis.Pinkas@bull.net, pope@secstan.com, rdd@cert.org, kaduk@mit.edu, paul.hoffman@vpnc.org, blaker@gmail.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: housley@vigilsec.com, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20191112160752.8C845F4070D@rfc-editor.org>
Date: Tue, 12 Nov 2019 08:07:52 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/2isuP8K3Pmc6yZQ184fVOfQpx_w>
Subject: [smime] [Technical Errata Reported] RFC3125 (5902)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 12 Nov 2019 16:08:01 -0000

The following errata report has been submitted for RFC3125,
"Electronic Signature Policies".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5902

--------------------------------------
Type: Technical
Reported by: Russ Housley <housley@vigilsec.com>

Section: Appendix A.2

Original Text
-------------
CommitmentType ::= SEQUENCE {
        identifier                      CommitmentTypeIdentifier,
        fieldOfApplication      [0] FieldOfApplication OPTIONAL,
        semantics               [1] DirectoryString OPTIONAL }

Corrected Text
--------------
CommitmentType ::= SEQUENCE {
        identifier                      CommitmentTypeIdentifier,
        fieldOfApplication      [0] FieldOfApplication OPTIONAL,
        semantics               [1] DirectoryString OPTIONAL }

CommitmentTypeIdentifier ::= OBJECT IDENTIFIER


Notes
-----
The CommitmentTypeIdentifier definition is missing from the ASN.1 module.  RFC 3126 shows that it is an object identifier.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3125 (draft-ietf-smime-espolicies-00)
--------------------------------------
Title               : Electronic Signature Policies
Publication Date    : September 2001
Author(s)           : J. Ross, D. Pinkas, N. Pope
Category            : EXPERIMENTAL
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG


From nobody Mon Nov 18 19:48:20 2019
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id AA288120810 for <smime@ietfa.amsl.com>; Mon, 18 Nov 2019 19:48:18 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.2
X-Spam-Level: 
X-Spam-Status: No, score=-4.2 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id LVZItSUjvFvX for <smime@ietfa.amsl.com>; Mon, 18 Nov 2019 19:48:13 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id CCEF6120044 for <smime@ietf.org>; Mon, 18 Nov 2019 19:48:13 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id D3084F4073A; Mon, 18 Nov 2019 19:47:59 -0800 (PST)
To: stephan.teiwes@it-sec.com, peter.hartmann@it-sec.com, dkuenzi@724.com, rdd@cert.org, kaduk@mit.edu, paul.hoffman@vpnc.org, blaker@gmail.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: housley@vigilsec.com, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20191119034759.D3084F4073A@rfc-editor.org>
Date: Mon, 18 Nov 2019 19:47:59 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/SLG2QkOY2ryaSljJYi58NxVuKGg>
Subject: [smime] [Editorial Errata Reported] RFC3058 (5913)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 19 Nov 2019 03:48:19 -0000

The following errata report has been submitted for RFC3058,
"Use of the IDEA Encryption Algorithm in CMS".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5913

--------------------------------------
Type: Editorial
Reported by: Russ Housley <housley@vigilsec.com>

Section: 2

Original Text
-------------
     IDEA-CBC OBJECT IDENTIFIER
       ::= { iso(1) identified-organization(3)
           usdod(6) oid(1) private(4) enterprises(1)
           ascom(188) systec(7) security(1) algorithms(1) 2 }

Corrected Text
--------------
     id-IDEA-CBC OBJECT IDENTIFIER
       ::= { iso(1) identified-organization(3)
           usdod(6) oid(1) private(4) enterprises(1)
           ascom(188) systec(7) security(1) algorithms(1) 2 }

Notes
-----
ASN.1 requires that such an identifier begin with a lower case letter.  The prefix of "id-" is a common approach to meeting this requirement for an OBJECT IDENTIFIER.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC3058 (draft-ietf-smime-idea-08)
--------------------------------------
Title               : Use of the IDEA Encryption Algorithm in CMS
Publication Date    : February 2001
Author(s)           : S. Teiwes, P. Hartmann, D. Kuenzi
Category            : INFORMATIONAL
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG


From nobody Mon Nov 18 21:36:53 2019
Return-Path: <sean@sn3rd.com>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 408F6120255 for <smime@ietfa.amsl.com>; Mon, 18 Nov 2019 21:36:51 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.999
X-Spam-Level: 
X-Spam-Status: No, score=-1.999 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=sn3rd.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id iOTzMFyFRKml for <smime@ietfa.amsl.com>; Mon, 18 Nov 2019 21:36:46 -0800 (PST)
Received: from mail-qk1-x734.google.com (mail-qk1-x734.google.com [IPv6:2607:f8b0:4864:20::734]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id CC7B1120013 for <smime@ietf.org>; Mon, 18 Nov 2019 21:36:45 -0800 (PST)
Received: by mail-qk1-x734.google.com with SMTP id e187so16767740qkf.4 for <smime@ietf.org>; Mon, 18 Nov 2019 21:36:45 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=sn3rd.com; s=google; h=mime-version:subject:from:in-reply-to:date:cc :content-transfer-encoding:message-id:references:to; bh=YFgbY7svbuwgQ+nxUtz7yzIgdDxh2AIy+pre08s8+tQ=; b=OLaeL6V5QVSYFTHFZLid9u9Uovfk2XvZX36uMgiNikDa8YU0QUmjsYVn/NZEimiV5P aTyxhYT2coL+37tElk8RHOixhYx5lBdHoXQjs+SccsLDOVdIorXWtE79A4P5jFRS7PU4 Uga66uspILpZ0kg+8i00Mj9Dj3/LLsHZ1RD0Y=
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:subject:from:in-reply-to:date:cc :content-transfer-encoding:message-id:references:to; bh=YFgbY7svbuwgQ+nxUtz7yzIgdDxh2AIy+pre08s8+tQ=; b=FNGk7ylnY3LtxZauk+AqBRYdG9llZtRTgBCbA8DpDmhc/6ArPcHYc2bu8japswd5NN BMpjBXXp97NDVjPgwk9mCCv39ZC0/0heojrsfqsSb8M2PiPpZdzGpEdDqVZelhY8wJMK X9RXyyxZIKUWfpzP+yCdbaWK5nVw4xdSRseGST02QNOEYlO96DhWMxQMEUI9PUkYMOc7 dN51CQhMvKieUpW7nkaMr+PU50oH7Ec8KMgAcblq1FRLi+eD7GlwzToU3xBAPnc6UNiV BsPbvCmgOaxfn89Qgd76xbvnXIfJ0SbakIL2upUwrcwZAvHZ4bBA9ydR9pzBl+d74WH2 RTzg==
X-Gm-Message-State: APjAAAURDAZgHDJYzm9Dr6YfmSNjpmKq4485WuWlkcCe9TdC29X2JAAb W8HXWJcWVV7o7l+PxLMctagl6Q==
X-Google-Smtp-Source: APXvYqwURtTCdUCmnRJFwC1HI749GBKGYHYYaHcYcAei0QmxsBnaozDCVr5808vXwhFJkFicSY2rVA==
X-Received: by 2002:a37:414:: with SMTP id 20mr6710847qke.402.1574141804767; Mon, 18 Nov 2019 21:36:44 -0800 (PST)
Received: from ?IPv6:2001:67c:370:128:a9c9:1625:2953:9b6d? ([2001:67c:370:128:a9c9:1625:2953:9b6d]) by smtp.gmail.com with ESMTPSA id k3sm11689237qtf.68.2019.11.18.21.36.41 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Mon, 18 Nov 2019 21:36:44 -0800 (PST)
Content-Type: text/plain; charset=us-ascii
Mime-Version: 1.0 (Mac OS X Mail 12.4 \(3445.104.11\))
From: Sean Turner <sean@sn3rd.com>
In-Reply-To: <55A81408-6571-4EC9-A403-FC9ECCECBBA4@iii.ca>
Date: Tue, 19 Nov 2019 13:36:36 +0800
Cc: RFC Editor <rfc-editor@rfc-editor.org>, Roman Danyliw <rdd@cert.org>, Eric Rescorla <ekr@rtfm.com>, smime@ietf.org, Paul Hoffman <paul.hoffman@vpnc.org>, Benjamin Kaduk <kaduk@mit.edu>
Content-Transfer-Encoding: quoted-printable
Message-Id: <D6797A4C-2E82-4AEE-B33C-DF088468D393@sn3rd.com>
References: <20191107220401.521BBF40741@rfc-editor.org> <55A81408-6571-4EC9-A403-FC9ECCECBBA4@iii.ca>
To: Cullen Jennings <fluffy@iii.ca>
X-Mailer: Apple Mail (2.3445.104.11)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/bc7fNvUmM_gnr0Y40aift_3HFhU>
Subject: Re: [smime] [Technical Errata Reported] RFC2631 (5897)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 19 Nov 2019 05:36:51 -0000

+1

> On Nov 8, 2019, at 06:21, Cullen Jennings <fluffy@iii.ca> wrote:
>=20
>=20
> I reviewed this and believe this errata is correct and should be =
approved.=20
>=20
>=20
>> On Nov 7, 2019, at 2:04 PM, RFC Errata System =
<rfc-editor@rfc-editor.org> wrote:
>>=20
>> The following errata report has been submitted for RFC2631,
>> "Diffie-Hellman Key Agreement Method".
>>=20
>> --------------------------------------
>> You may review the report below and at:
>> https://www.rfc-editor.org/errata/eid5897
>>=20
>> --------------------------------------
>> Type: Technical
>> Reported by: Russ Housley <housley@vigilsec.com>
>>=20
>> Section: 2.1.2
>>=20
>> Original Text
>> -------------
>>   KeySpecificInfo ::=3D SEQUENCE {
>>     algorithm OBJECT IDENTIFIER,
>>     counter OCTET STRING SIZE (4..4) }
>>=20
>> Corrected Text
>> --------------
>>   KeySpecificInfo ::=3D SEQUENCE {
>>     algorithm OBJECT IDENTIFIER,
>>     counter OCTET STRING (SIZE (4..4)) }
>>=20
>> Notes
>> -----
>> The addition of '(' and ')' are needed for an ASN.1 compiler to =
accept the syntax without raising an error.
>>=20
>> Instructions:
>> -------------
>> This erratum is currently posted as "Reported". If necessary, please
>> use "Reply All" to discuss whether it should be verified or
>> rejected. When a decision is reached, the verifying party =20
>> can log in to change the status and edit the report, if necessary.=20
>>=20
>> --------------------------------------
>> RFC2631 (draft-ietf-smime-x942-07)
>> --------------------------------------
>> Title               : Diffie-Hellman Key Agreement Method
>> Publication Date    : June 1999
>> Author(s)           : E. Rescorla
>> Category            : PROPOSED STANDARD
>> Source              : S/MIME Mail Security
>> Area                : Security
>> Stream              : IETF
>> Verifying Party     : IESG
>>=20
>> _______________________________________________
>> smime mailing list
>> smime@ietf.org
>> https://www.ietf.org/mailman/listinfo/smime
>=20
> _______________________________________________
> smime mailing list
> smime@ietf.org
> https://www.ietf.org/mailman/listinfo/smime


From nobody Mon Nov 18 21:38:36 2019
Return-Path: <sean@sn3rd.com>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 327D6120255 for <smime@ietfa.amsl.com>; Mon, 18 Nov 2019 21:38:34 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.999
X-Spam-Level: 
X-Spam-Status: No, score=-1.999 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=sn3rd.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id bXLG3THHwd5q for <smime@ietfa.amsl.com>; Mon, 18 Nov 2019 21:38:29 -0800 (PST)
Received: from mail-qt1-x82a.google.com (mail-qt1-x82a.google.com [IPv6:2607:f8b0:4864:20::82a]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id CA68C120013 for <smime@ietf.org>; Mon, 18 Nov 2019 21:38:28 -0800 (PST)
Received: by mail-qt1-x82a.google.com with SMTP id n4so23310278qte.2 for <smime@ietf.org>; Mon, 18 Nov 2019 21:38:28 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=sn3rd.com; s=google; h=mime-version:subject:from:in-reply-to:date:cc :content-transfer-encoding:message-id:references:to; bh=HBJ3EgLrbDfCpIaYu64Q5fO2sbDNyDnYtXTqHIPwrUk=; b=lbdR25YMMNdh8rj4lFuaV3jCfn2ddPCAjF02ctkFR301+EP1jOi3s/JruaU43/ouoQ sC/YddQvfgWXeL0Q8L8irbXaD2d3GuIsF/gPmOZHZXchN+q/z2cr+7LH7mKyG0/Ik8HH G+IrMN1HNdNYZyLI+MeO9G98sGz/eLO9UHkQk=
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:subject:from:in-reply-to:date:cc :content-transfer-encoding:message-id:references:to; bh=HBJ3EgLrbDfCpIaYu64Q5fO2sbDNyDnYtXTqHIPwrUk=; b=E8bgzjqzYRz0pj+pPqCjXDae39Nc40EKkDA0i1fAcHv6/ZXFVyvgK9qVeTORrpiDZQ YuLlMkxUwg74bZjQNJ0uyZeHi+0Y8kGC1+IczWnunBN2zWEVOq7eRti0I7FEFz6OeM6H /ddybIZbBeQxlC0Sfu7yTAukYl8scEu3geaSMEBGOppqFZnNiBp1pmlV4O2Aov4xMoEM Hcgn01zwjmd1+QsWjcr9nLN6iNwmKjn0ELQpYNXiBAm0WoLDnp069dDXLjykngbT9Ibq BhBMFGEjp+yrRD51/ufas4TAJAYY9+oSNKR8Cshx4VS8vC+WHDTOyA/Wm9bKC3Hn02mx v34A==
X-Gm-Message-State: APjAAAVFlVeO863oiA8fjlr7X7JxKMW0O7uVaFJey+zlfmRr6jwo1VTx pjp9tCksYTHcEwRjI87K4KHWlQ==
X-Google-Smtp-Source: APXvYqz8FW1A0cTxrmJbpV6mLTd/MRfNq4g9knJR8jMWe8i9JUfYLg+McSKoIEdvbwo5iXxHhQirfg==
X-Received: by 2002:ac8:73c6:: with SMTP id v6mr31278097qtp.137.1574141907632;  Mon, 18 Nov 2019 21:38:27 -0800 (PST)
Received: from ?IPv6:2001:67c:370:128:a9c9:1625:2953:9b6d? ([2001:67c:370:128:a9c9:1625:2953:9b6d]) by smtp.gmail.com with ESMTPSA id r4sm9060339qkd.9.2019.11.18.21.38.24 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Mon, 18 Nov 2019 21:38:27 -0800 (PST)
Content-Type: text/plain; charset=us-ascii
Mime-Version: 1.0 (Mac OS X Mail 12.4 \(3445.104.11\))
From: Sean Turner <sean@sn3rd.com>
In-Reply-To: <20191112160525.0BA7FF4072C@rfc-editor.org>
Date: Tue, 19 Nov 2019 13:38:21 +0800
Cc: harri.rasilainen@etsi.fr, ross@secstan.com, Denis.Pinkas@bull.net, pope@secstan.com, Paul Hoffman <paul.hoffman@vpnc.org>, Blake Ramsdell <blaker@gmail.com>, smime@ietf.org
Content-Transfer-Encoding: quoted-printable
Message-Id: <F2BB4876-21C5-4531-B460-6DAE8B06C2EB@sn3rd.com>
References: <20191112160525.0BA7FF4072C@rfc-editor.org>
To: Roman Danyliw <rdd@cert.org>, Benjamin Kaduk <kaduk@mit.edu>
X-Mailer: Apple Mail (2.3445.104.11)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/bXq_4-t4xEHZ7R9rvZBT06jAtH8>
Subject: Re: [smime] [Technical Errata Reported] RFC3125 (5901)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 19 Nov 2019 05:38:34 -0000

Option B is to import CommitmentTypeIdentifier from FROM PKIXTSP, but =
these seems like the easier approach.

I reviewed this and believe this errata is correct and should be =
approved.=20

spt

> On Nov 13, 2019, at 00:05, RFC Errata System =
<rfc-editor@rfc-editor.org> wrote:
>=20
> The following errata report has been submitted for RFC3125,
> "Electronic Signature Policies".
>=20
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid5901
>=20
> --------------------------------------
> Type: Technical
> Reported by: Russ Housley <housley@vigilsec.com>
>=20
> Section: Appendix A.1
>=20
> Original Text
> -------------
> CommitmentType ::=3D SEQUENCE {
>        identifier                      CommitmentTypeIdentifier,
>        fieldOfApplication      [0] FieldOfApplication OPTIONAL,
>        semantics                       [1] DirectoryString OPTIONAL }
>=20
> Corrected Text
> --------------
> CommitmentType ::=3D SEQUENCE {
>        identifier                      CommitmentTypeIdentifier,
>        fieldOfApplication      [0] FieldOfApplication OPTIONAL,
>        semantics                       [1] DirectoryString OPTIONAL }
>=20
> CommitmentTypeIdentifier ::=3D OBJECT IDENTIFIER
>=20
> Notes
> -----
> The definition of CommitmentTypeIdentifier is missing from the ASN.1 =
module.  RFC 3126 shows that it is an object identifier.
>=20
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party =20
> can log in to change the status and edit the report, if necessary.=20
>=20
> --------------------------------------
> RFC3125 (draft-ietf-smime-espolicies-00)
> --------------------------------------
> Title               : Electronic Signature Policies
> Publication Date    : September 2001
> Author(s)           : J. Ross, D. Pinkas, N. Pope
> Category            : EXPERIMENTAL
> Source              : S/MIME Mail Security
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
>=20
> _______________________________________________
> smime mailing list
> smime@ietf.org
> https://www.ietf.org/mailman/listinfo/smime


From nobody Mon Nov 18 22:05:32 2019
Return-Path: <sean@sn3rd.com>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id A565412082B for <smime@ietfa.amsl.com>; Mon, 18 Nov 2019 22:05:29 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.999
X-Spam-Level: 
X-Spam-Status: No, score=-1.999 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=sn3rd.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id bGG6_F8mORAO for <smime@ietfa.amsl.com>; Mon, 18 Nov 2019 22:05:24 -0800 (PST)
Received: from mail-qk1-x72d.google.com (mail-qk1-x72d.google.com [IPv6:2607:f8b0:4864:20::72d]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id A2C59120829 for <smime@ietf.org>; Mon, 18 Nov 2019 22:05:23 -0800 (PST)
Received: by mail-qk1-x72d.google.com with SMTP id m16so16789106qki.11 for <smime@ietf.org>; Mon, 18 Nov 2019 22:05:23 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=sn3rd.com; s=google; h=mime-version:subject:from:in-reply-to:date:cc :content-transfer-encoding:message-id:references:to; bh=0pLlKTekDgJU/TyChocmww7BPIkgeOVkdz7s3Isf5Gk=; b=LXWTLT+zOI3LjrGQPjGl6WlHlItd9H+qOhJ6++sU0hkD8OX+zWij3e7op5lTAfOYec krsHYff1jgCmnC+doEGcDkwsXmYQCvVdBgMfIjeLXna+Sdn4qf4WQauTKsfkwhxeAfJS xGYQTi/dt0Dy+sM4cQ703jx7w4ura1CMtTyRc=
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:subject:from:in-reply-to:date:cc :content-transfer-encoding:message-id:references:to; bh=0pLlKTekDgJU/TyChocmww7BPIkgeOVkdz7s3Isf5Gk=; b=EPaoDPwuS4GWWSsV+h7ihG0ywoHHf8LmsUVnhvBPs2975nb/CNQtPq+81RVAYJd9MP wfD442gGKDUpPCBb7Ak1u6B9MZEpQMoERPLXRsFX7sHU+aBTW+UA1T0AFZl9zol9QtpY KR11YGBORidkCT2shfZZ8uVLZIxNiMsD3pyn20cq+4vgciLvW5J8z1Jv8QGrR/PJbP9O cm3M9qcjsI6LeEYy46syXGW5bqi32X33wNRclgTUHBbMkVP5HYrpGW5RXYGn1+6sfvJX 5zR7TZnX3y+RKCul1cPzbcWuUfH26g1VwZQ5zoMh5qsY9W4Kwz6yphnH/QiBrR70FRCD dmHg==
X-Gm-Message-State: APjAAAVhXSKfviRE5WVQmnV1OjaLqqp4tr667i1oup51nDOX3+ZwP8UA lQgnxu70VhRUv9oUqnx3DI9gWw==
X-Google-Smtp-Source: APXvYqxynHYnJFdz1I7tsS+W+feHhSz5tNpa5GgPtj/xc9/uXwSUyCxWJji14l9PM+Q6yV4RlrQsfg==
X-Received: by 2002:a37:4a97:: with SMTP id x145mr28264257qka.65.1574143522723;  Mon, 18 Nov 2019 22:05:22 -0800 (PST)
Received: from ?IPv6:2001:67c:370:128:a9c9:1625:2953:9b6d? ([2001:67c:370:128:a9c9:1625:2953:9b6d]) by smtp.gmail.com with ESMTPSA id z17sm10994784qtq.69.2019.11.18.22.05.18 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Mon, 18 Nov 2019 22:05:22 -0800 (PST)
Content-Type: text/plain; charset=utf-8
Mime-Version: 1.0 (Mac OS X Mail 12.4 \(3445.104.11\))
From: Sean Turner <sean@sn3rd.com>
In-Reply-To: <20191119034759.D3084F4073A@rfc-editor.org>
Date: Tue, 19 Nov 2019 14:05:15 +0800
Cc: stephan.teiwes@it-sec.com, peter.hartmann@it-sec.com, dkuenzi@724.com, Paul Hoffman <paul.hoffman@vpnc.org>, Blake Ramsdell <blaker@gmail.com>, smime@ietf.org
Content-Transfer-Encoding: quoted-printable
Message-Id: <52C1BE69-AE34-4E87-B655-C58ABD10E63C@sn3rd.com>
References: <20191119034759.D3084F4073A@rfc-editor.org>
To: Benjamin Kaduk <kaduk@mit.edu>, Roman Danyliw <rdd@cert.org>
X-Mailer: Apple Mail (2.3445.104.11)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/u8tDun__kxZc0xcpTI92J6FvDvM>
Subject: Re: [smime] [Editorial Errata Reported] RFC3058 (5913)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Tue, 19 Nov 2019 06:05:30 -0000

There are other protocols that specify a cipher suite for IBEA-CBC =
(e.g., TLS, IPSec), but they do not use this OID.  Further, I can=E2=80=99=
t find anyplace where the string =E2=80=9CIDEA-CBC=E2=80=9D would have =
been imported (PKCS#1/8/11/12) and I can=E2=80=99t find an example of =
where they were. So, I reviewed this and believe this errata is correct =
and should be approved.=20

spt

> On Nov 19, 2019, at 11:47, RFC Errata System =
<rfc-editor@rfc-editor.org> wrote:
>=20
> The following errata report has been submitted for RFC3058,
> "Use of the IDEA Encryption Algorithm in CMS".
>=20
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid5913
>=20
> --------------------------------------
> Type: Editorial
> Reported by: Russ Housley <housley@vigilsec.com>
>=20
> Section: 2
>=20
> Original Text
> -------------
>     IDEA-CBC OBJECT IDENTIFIER
>       ::=3D { iso(1) identified-organization(3)
>           usdod(6) oid(1) private(4) enterprises(1)
>           ascom(188) systec(7) security(1) algorithms(1) 2 }
>=20
> Corrected Text
> --------------
>     id-IDEA-CBC OBJECT IDENTIFIER
>       ::=3D { iso(1) identified-organization(3)
>           usdod(6) oid(1) private(4) enterprises(1)
>           ascom(188) systec(7) security(1) algorithms(1) 2 }
>=20
> Notes
> -----
> ASN.1 requires that such an identifier begin with a lower case letter. =
 The prefix of "id-" is a common approach to meeting this requirement =
for an OBJECT IDENTIFIER.
>=20
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party =20
> can log in to change the status and edit the report, if necessary.=20
>=20
> --------------------------------------
> RFC3058 (draft-ietf-smime-idea-08)
> --------------------------------------
> Title               : Use of the IDEA Encryption Algorithm in CMS
> Publication Date    : February 2001
> Author(s)           : S. Teiwes, P. Hartmann, D. Kuenzi
> Category            : INFORMATIONAL
> Source              : S/MIME Mail Security
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
>=20
> _______________________________________________
> smime mailing list
> smime@ietf.org
> https://www.ietf.org/mailman/listinfo/smime


From nobody Fri Nov 22 20:02:02 2019
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id DC70312010F; Fri, 22 Nov 2019 20:01:53 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.201
X-Spam-Level: 
X-Spam-Status: No, score=-4.201 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id rJnQiZ5NE4_W; Fri, 22 Nov 2019 20:01:52 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 805AF120071; Fri, 22 Nov 2019 20:01:52 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id 75B72F406D6; Fri, 22 Nov 2019 20:01:32 -0800 (PST)
To: housley@vigilsec.com, stephan.teiwes@it-sec.com, peter.hartmann@it-sec.com, dkuenzi@724.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: kaduk@mit.edu, iesg@ietf.org, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20191123040132.75B72F406D6@rfc-editor.org>
Date: Fri, 22 Nov 2019 20:01:32 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/2k3wF2SeD-t3W34BI3ICHjdyhr8>
Subject: [smime] [Errata Held for Document Update] RFC3058 (5913)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 23 Nov 2019 04:01:54 -0000

The following errata report has been held for document update 
for RFC3058, "Use of the IDEA Encryption Algorithm in CMS". 

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5913

--------------------------------------
Status: Held for Document Update
Type: Editorial

Reported by: Russ Housley <housley@vigilsec.com>
Date Reported: 2019-11-19
Held by: Benjamin Kaduk (IESG)

Section: 2

Original Text
-------------
     IDEA-CBC OBJECT IDENTIFIER
       ::= { iso(1) identified-organization(3)
           usdod(6) oid(1) private(4) enterprises(1)
           ascom(188) systec(7) security(1) algorithms(1) 2 }

Corrected Text
--------------
     id-IDEA-CBC OBJECT IDENTIFIER
       ::= { iso(1) identified-organization(3)
           usdod(6) oid(1) private(4) enterprises(1)
           ascom(188) systec(7) security(1) algorithms(1) 2 }

Notes
-----
ASN.1 requires that such an identifier begin with a lower case letter.  The prefix of "id-" is a common approach to meeting this requirement for an OBJECT IDENTIFIER.

--------------------------------------
RFC3058 (draft-ietf-smime-idea-08)
--------------------------------------
Title               : Use of the IDEA Encryption Algorithm in CMS
Publication Date    : February 2001
Author(s)           : S. Teiwes, P. Hartmann, D. Kuenzi
Category            : INFORMATIONAL
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG


From nobody Fri Nov 22 20:02:11 2019
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 23B2F120071; Fri, 22 Nov 2019 20:01:55 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.201
X-Spam-Level: 
X-Spam-Status: No, score=-4.201 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id mf1zWu3AOpKK; Fri, 22 Nov 2019 20:01:53 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id D829E120077; Fri, 22 Nov 2019 20:01:53 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id D3CFCF40710; Fri, 22 Nov 2019 20:01:33 -0800 (PST)
To: housley@vigilsec.com, stephan.teiwes@it-sec.com, peter.hartmann@it-sec.com, dkuenzi@724.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: kaduk@mit.edu, iesg@ietf.org, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20191123040133.D3CFCF40710@rfc-editor.org>
Date: Fri, 22 Nov 2019 20:01:33 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/NjHWIg80VA8jxmnCBRn8nExN7s4>
Subject: [smime] [Errata Held for Document Update] RFC3058 (5913)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Sat, 23 Nov 2019 04:01:55 -0000

The following errata report has been held for document update 
for RFC3058, "Use of the IDEA Encryption Algorithm in CMS". 

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5913

--------------------------------------
Status: Held for Document Update
Type: Editorial

Reported by: Russ Housley <housley@vigilsec.com>
Date Reported: 2019-11-19
Held by: Benjamin Kaduk (IESG)

Section: 2

Original Text
-------------
     IDEA-CBC OBJECT IDENTIFIER
       ::= { iso(1) identified-organization(3)
           usdod(6) oid(1) private(4) enterprises(1)
           ascom(188) systec(7) security(1) algorithms(1) 2 }

Corrected Text
--------------
     id-IDEA-CBC OBJECT IDENTIFIER
       ::= { iso(1) identified-organization(3)
           usdod(6) oid(1) private(4) enterprises(1)
           ascom(188) systec(7) security(1) algorithms(1) 2 }

Notes
-----
ASN.1 requires that such an identifier begin with a lower case letter.  The prefix of "id-" is a common approach to meeting this requirement for an OBJECT IDENTIFIER.

--------------------------------------
RFC3058 (draft-ietf-smime-idea-08)
--------------------------------------
Title               : Use of the IDEA Encryption Algorithm in CMS
Publication Date    : February 2001
Author(s)           : S. Teiwes, P. Hartmann, D. Kuenzi
Category            : INFORMATIONAL
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

