
From nobody Thu Jan  2 12:42:43 2020
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 80EEC120137 for <smime@ietfa.amsl.com>; Thu,  2 Jan 2020 12:42:41 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.2
X-Spam-Level: 
X-Spam-Status: No, score=-4.2 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id HaQNF4TCNblP for <smime@ietfa.amsl.com>; Thu,  2 Jan 2020 12:42:40 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id F042E120103 for <smime@ietf.org>; Thu,  2 Jan 2020 12:42:39 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id C652DF40707; Thu,  2 Jan 2020 12:42:20 -0800 (PST)
To: ekr@rtfm.com, rdd@cert.org, kaduk@mit.edu, paul.hoffman@vpnc.org, blaker@gmail.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: silversplash@gmx.com, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20200102204220.C652DF40707@rfc-editor.org>
Date: Thu,  2 Jan 2020 12:42:20 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/uU_YoFEfJrNysH8AkLVENUDjJ5k>
Subject: [smime] [Technical Errata Reported] RFC2631 (5954)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Thu, 02 Jan 2020 20:42:41 -0000

The following errata report has been submitted for RFC2631,
"Diffie-Hellman Key Agreement Method".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5954

--------------------------------------
Type: Technical
Reported by: Paul Janson <silversplash@gmx.com>

Section: 2.1.5.

Original Text
-------------
     1. Verify that y lies within the interval [2,p-1]. If it does not,
        the key is invalid.
     2. Compute y^q mod p. If the result == 1, the key is valid.
        Otherwise the key is invalid.


Corrected Text
--------------
     1. Verify that y lies within the interval [2,p-1]. If it does not,
        the key is invalid.
     2. Compute y^q mod p. If the result == 1, the key is valid.
        Otherwise the key is invalid.
|    3. Verify that y does not match g.


Notes
-----
Validating that (g == received y) needs to be an additional exclusion to the valid range [2,p-1]. If party 'a' accepts received public key 'yb' matching 'g', then ZZ matches  public key 'ya'. i.e. if yb = 2, then xb = 1, therefore ZZ = ya^1 = ya

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC2631 (draft-ietf-smime-x942-07)
--------------------------------------
Title               : Diffie-Hellman Key Agreement Method
Publication Date    : June 1999
Author(s)           : E. Rescorla
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG


From nobody Fri Jan  3 08:44:25 2020
Return-Path: <sean@sn3rd.com>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id C8C30120091 for <smime@ietfa.amsl.com>; Fri,  3 Jan 2020 08:44:23 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -2
X-Spam-Level: 
X-Spam-Status: No, score=-2 tagged_above=-999 required=5 tests=[BAYES_00=-1.9,  DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (1024-bit key) header.d=sn3rd.com
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 3wCSqKdRZIbw for <smime@ietfa.amsl.com>; Fri,  3 Jan 2020 08:44:21 -0800 (PST)
Received: from mail-qk1-x734.google.com (mail-qk1-x734.google.com [IPv6:2607:f8b0:4864:20::734]) (using TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id E162512008F for <smime@ietf.org>; Fri,  3 Jan 2020 08:44:20 -0800 (PST)
Received: by mail-qk1-x734.google.com with SMTP id j9so34607065qkk.1 for <smime@ietf.org>; Fri, 03 Jan 2020 08:44:20 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=sn3rd.com; s=google; h=mime-version:subject:from:in-reply-to:date:cc :content-transfer-encoding:message-id:references:to; bh=Q8CQipCF6tNluy5bwo7ar1m8S20s29NmqUZTLaP/5vU=; b=f00I4J3ZtpqMm2h33Hw9HtZR/VCt+OEnl8DObpS680nAQEvtGdkkx90Zsj/S9hHqCg o/99xZuscvaS+aIXVWXSulPPvCMxqagMLJ88ebdeD7RL2+v6UF4+86qiXJ8MxY68SUQd L16ivlkIXVljJhktobqenmO52Srz4vW2JPg1I=
X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:subject:from:in-reply-to:date:cc :content-transfer-encoding:message-id:references:to; bh=Q8CQipCF6tNluy5bwo7ar1m8S20s29NmqUZTLaP/5vU=; b=ZBdXwmoBWkBd46mwuDDBGjE6fzvX3+q+4al4BJiTGtQXgXWqdV5QSR3Ao6bLqsZzoj UeoG3ejoKNH8NbMjgk/ubWuv4hX87LZPC0DGT3ZksUwU3NLHSkYDEo3bhOXdla4hLDfo SUWD8yh7dk67to7X43xUUlqs5zbBalVJS5vmXakrmRvCIcsq5SE3ak1N+4mFjUA3FvgG /L9nWL5Gjk+C33fA4agaPkwW/zpaOUZ1ru/VZcIbZIxGvIkNFu0W3N76CLGGW7fP/PqX CBmxpnobfzNMwTyt64cTC+PiD1etY0oPJAjXnU9Gzr02B47r5BOhdN5EmEmgzxXk+3QF XsnQ==
X-Gm-Message-State: APjAAAXcZCUkdpgj5ngrNu5bM+Y60AL2uwRxuS18Ey3S676mrAQsQP/2 Yv1vYZK9yt16VljZai9O7CDvZg==
X-Google-Smtp-Source: APXvYqzl7+V3BWfCw0bRTqy8qe6RCXKo09djJ+4zi6/9m3h494gys6Sf1PYh7NSpEVxvpqJHgxDkLw==
X-Received: by 2002:a37:63c7:: with SMTP id x190mr70922468qkb.232.1578069860043;  Fri, 03 Jan 2020 08:44:20 -0800 (PST)
Received: from sn3rd.lan ([75.102.131.36]) by smtp.gmail.com with ESMTPSA id g16sm16653306qkk.61.2020.01.03.08.44.19 (version=TLS1_2 cipher=ECDHE-RSA-AES128-GCM-SHA256 bits=128/128); Fri, 03 Jan 2020 08:44:19 -0800 (PST)
Content-Type: text/plain; charset=us-ascii
Mime-Version: 1.0 (Mac OS X Mail 12.4 \(3445.104.11\))
From: Sean Turner <sean@sn3rd.com>
In-Reply-To: <20191221162156.B4D17F406D2@rfc-editor.org>
Date: Fri, 3 Jan 2020 11:44:18 -0500
Cc: turners@ieca.com, Roman Danyliw <rdd@cert.org>, Benjamin Kaduk <kaduk@mit.edu>, Paul Hoffman <paul.hoffman@vpnc.org>, Blake Ramsdell <blaker@gmail.com>, smime@ietf.org
Content-Transfer-Encoding: quoted-printable
Message-Id: <20838907-0823-4D70-9A3C-F5A06AFEBFF9@sn3rd.com>
References: <20191221162156.B4D17F406D2@rfc-editor.org>
To: RFC Errata System <rfc-editor@rfc-editor.org>
X-Mailer: Apple Mail (2.3445.104.11)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/oQufq2oTcv-YHi8ZXRekSI9N4Qw>
Subject: Re: [smime] [Editorial Errata Reported] RFC5275 (5943)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 03 Jan 2020 16:44:24 -0000

This should be approved.  The text in the section includes =
certificates.* and this change matches ASN.1 in the module (which is =
normative).

spt

> On Dec 21, 2019, at 11:21, RFC Errata System =
<rfc-editor@rfc-editor.org> wrote:
>=20
> The following errata report has been submitted for RFC5275,
> "CMS Symmetric Key Management and Distribution".
>=20
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid5943
>=20
> --------------------------------------
> Type: Editorial
> Reported by: Russ Housley <housley@vigilsec.com>
>=20
> Section: 3.1.1
>=20
> Original Text
> -------------
>   GLOwnerInfo ::=3D SEQUENCE {
>     glOwnerName     GeneralName,
>     glOwnerAddress  GeneralName,
>     certificate     Certificates OPTIONAL }
>=20
> Corrected Text
> --------------
>   GLOwnerInfo ::=3D SEQUENCE {
>     glOwnerName     GeneralName,
>     glOwnerAddress  GeneralName,
>     certificates    Certificates OPTIONAL }
>=20
> Notes
> -----
> The definition of GLOwnerInfo in Section 3.1.1 does not match the =
ASN.1 module or the discussion that follows.  Changing "certificate" to =
"certificates" resolves this problem.
>=20
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party =20
> can log in to change the status and edit the report, if necessary.=20
>=20
> --------------------------------------
> RFC5275 (draft-ietf-smime-symkeydist-10)
> --------------------------------------
> Title               : CMS Symmetric Key Management and Distribution
> Publication Date    : June 2008
> Author(s)           : S. Turner
> Category            : PROPOSED STANDARD
> Source              : S/MIME Mail Security
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG
>=20
> _______________________________________________
> smime mailing list
> smime@ietf.org
> https://www.ietf.org/mailman/listinfo/smime


From nobody Tue Jan  7 19:37:02 2020
Return-Path: <kaduk@mit.edu>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 9F44C120041 for <smime@ietfa.amsl.com>; Tue,  7 Jan 2020 19:37:00 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.199
X-Spam-Level: 
X-Spam-Status: No, score=-4.199 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_HELO_NONE=0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id 6QgXlo0IRBYg for <smime@ietfa.amsl.com>; Tue,  7 Jan 2020 19:36:58 -0800 (PST)
Received: from outgoing.mit.edu (outgoing-auth-1.mit.edu [18.9.28.11]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 1532A12002E for <smime@ietf.org>; Tue,  7 Jan 2020 19:36:57 -0800 (PST)
Received: from kduck.mit.edu ([24.16.140.251]) (authenticated bits=56) (User authenticated as kaduk@ATHENA.MIT.EDU) by outgoing.mit.edu (8.14.7/8.12.4) with ESMTP id 0083ajjK031140 (version=TLSv1/SSLv3 cipher=DHE-RSA-AES256-GCM-SHA384 bits=256 verify=NOT); Tue, 7 Jan 2020 22:36:47 -0500
Date: Tue, 7 Jan 2020 19:36:45 -0800
From: Benjamin Kaduk <kaduk@mit.edu>
To: smime@ietf.org
Cc: ekr@rtfm.com, rdd@cert.org, paul.hoffman@vpnc.org, blaker@gmail.com, silversplash@gmx.com
Message-ID: <20200108033645.GA57294@kduck.mit.edu>
References: <20200102204220.C652DF40707@rfc-editor.org>
MIME-Version: 1.0
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
In-Reply-To: <20200102204220.C652DF40707@rfc-editor.org>
User-Agent: Mutt/1.12.1 (2019-06-15)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/RaSRbghG0490ZPKANlWD9X7AMqM>
Subject: Re: [smime] [Technical Errata Reported] RFC2631 (5954)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 08 Jan 2020 03:37:01 -0000

I could maybe see making this Hold For Document Update, as it would
probably require some discussion, and it's hard to say that this was an
omission at the time of original publication.

-Ben

On Thu, Jan 02, 2020 at 12:42:20PM -0800, RFC Errata System wrote:
> The following errata report has been submitted for RFC2631,
> "Diffie-Hellman Key Agreement Method".
> 
> --------------------------------------
> You may review the report below and at:
> https://www.rfc-editor.org/errata/eid5954
> 
> --------------------------------------
> Type: Technical
> Reported by: Paul Janson <silversplash@gmx.com>
> 
> Section: 2.1.5.
> 
> Original Text
> -------------
>      1. Verify that y lies within the interval [2,p-1]. If it does not,
>         the key is invalid.
>      2. Compute y^q mod p. If the result == 1, the key is valid.
>         Otherwise the key is invalid.
> 
> 
> Corrected Text
> --------------
>      1. Verify that y lies within the interval [2,p-1]. If it does not,
>         the key is invalid.
>      2. Compute y^q mod p. If the result == 1, the key is valid.
>         Otherwise the key is invalid.
> |    3. Verify that y does not match g.
> 
> 
> Notes
> -----
> Validating that (g == received y) needs to be an additional exclusion to the valid range [2,p-1]. If party 'a' accepts received public key 'yb' matching 'g', then ZZ matches  public key 'ya'. i.e. if yb = 2, then xb = 1, therefore ZZ = ya^1 = ya
> 
> Instructions:
> -------------
> This erratum is currently posted as "Reported". If necessary, please
> use "Reply All" to discuss whether it should be verified or
> rejected. When a decision is reached, the verifying party  
> can log in to change the status and edit the report, if necessary. 
> 
> --------------------------------------
> RFC2631 (draft-ietf-smime-x942-07)
> --------------------------------------
> Title               : Diffie-Hellman Key Agreement Method
> Publication Date    : June 1999
> Author(s)           : E. Rescorla
> Category            : PROPOSED STANDARD
> Source              : S/MIME Mail Security
> Area                : Security
> Stream              : IETF
> Verifying Party     : IESG


From nobody Wed Jan  8 07:17:37 2020
Return-Path: <housley@vigilsec.com>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id BA4EE120180 for <smime@ietfa.amsl.com>; Wed,  8 Jan 2020 07:17:34 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -1.897
X-Spam-Level: 
X-Spam-Status: No, score=-1.897 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_NONE=0.001, SPF_NONE=0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id Tar5T4162Jbo for <smime@ietfa.amsl.com>; Wed,  8 Jan 2020 07:17:33 -0800 (PST)
Received: from mail.smeinc.net (mail.smeinc.net [209.135.209.11]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 038D8120127 for <smime@ietf.org>; Wed,  8 Jan 2020 07:17:33 -0800 (PST)
Received: from localhost (localhost [127.0.0.1]) by mail.smeinc.net (Postfix) with ESMTP id 66348300AE1 for <smime@ietf.org>; Wed,  8 Jan 2020 10:17:31 -0500 (EST)
X-Virus-Scanned: amavisd-new at mail.smeinc.net
Received: from mail.smeinc.net ([127.0.0.1]) by localhost (mail.smeinc.net [127.0.0.1]) (amavisd-new, port 10026) with ESMTP id 0cCFkuXVr4E6 for <smime@ietf.org>; Wed,  8 Jan 2020 10:17:28 -0500 (EST)
Received: from [5.5.33.19] (unknown [204.194.23.17]) by mail.smeinc.net (Postfix) with ESMTPSA id 2F2AE30078C; Wed,  8 Jan 2020 10:17:28 -0500 (EST)
Content-Type: text/plain; charset=us-ascii
Mime-Version: 1.0 (Mac OS X Mail 12.4 \(3445.104.11\))
From: Russ Housley <housley@vigilsec.com>
In-Reply-To: <20200108033645.GA57294@kduck.mit.edu>
Date: Wed, 8 Jan 2020 10:17:28 -0500
Cc: IETF SMIME <smime@ietf.org>, "Roman D. Danyliw" <rdd@cert.org>, Eric Rescorla <ekr@rtfm.com>, silversplash@gmx.com, paul.hoffman@vpnc.org
Content-Transfer-Encoding: quoted-printable
Message-Id: <875F9475-2444-472E-9B1B-AF8C8691163B@vigilsec.com>
References: <20200102204220.C652DF40707@rfc-editor.org> <20200108033645.GA57294@kduck.mit.edu>
To: Ben Kaduk <kaduk@mit.edu>
X-Mailer: Apple Mail (2.3445.104.11)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/Z5zjmwmbT6KVbAd9LAvw5BnJhxg>
Subject: Re: [smime] [Technical Errata Reported] RFC2631 (5954)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Wed, 08 Jan 2020 15:17:35 -0000

Ben:

It sounds like Hold for Document Update is the best way to handle this =
one.

Russ

> On Jan 7, 2020, at 10:36 PM, Benjamin Kaduk <kaduk@mit.edu> wrote:
>=20
> I could maybe see making this Hold For Document Update, as it would
> probably require some discussion, and it's hard to say that this was =
an
> omission at the time of original publication.
>=20
> -Ben
>=20
> On Thu, Jan 02, 2020 at 12:42:20PM -0800, RFC Errata System wrote:
>> The following errata report has been submitted for RFC2631,
>> "Diffie-Hellman Key Agreement Method".
>>=20
>> --------------------------------------
>> You may review the report below and at:
>> https://www.rfc-editor.org/errata/eid5954
>>=20
>> --------------------------------------
>> Type: Technical
>> Reported by: Paul Janson <silversplash@gmx.com>
>>=20
>> Section: 2.1.5.
>>=20
>> Original Text
>> -------------
>>     1. Verify that y lies within the interval [2,p-1]. If it does =
not,
>>        the key is invalid.
>>     2. Compute y^q mod p. If the result =3D=3D 1, the key is valid.
>>        Otherwise the key is invalid.
>>=20
>>=20
>> Corrected Text
>> --------------
>>     1. Verify that y lies within the interval [2,p-1]. If it does =
not,
>>        the key is invalid.
>>     2. Compute y^q mod p. If the result =3D=3D 1, the key is valid.
>>        Otherwise the key is invalid.
>> |    3. Verify that y does not match g.
>>=20
>>=20
>> Notes
>> -----
>> Validating that (g =3D=3D received y) needs to be an additional =
exclusion to the valid range [2,p-1]. If party 'a' accepts received =
public key 'yb' matching 'g', then ZZ matches  public key 'ya'. i.e. if =
yb =3D 2, then xb =3D 1, therefore ZZ =3D ya^1 =3D ya
>>=20
>> Instructions:
>> -------------
>> This erratum is currently posted as "Reported". If necessary, please
>> use "Reply All" to discuss whether it should be verified or
>> rejected. When a decision is reached, the verifying party =20
>> can log in to change the status and edit the report, if necessary.=20
>>=20
>> --------------------------------------
>> RFC2631 (draft-ietf-smime-x942-07)
>> --------------------------------------
>> Title               : Diffie-Hellman Key Agreement Method
>> Publication Date    : June 1999
>> Author(s)           : E. Rescorla
>> Category            : PROPOSED STANDARD
>> Source              : S/MIME Mail Security
>> Area                : Security
>> Stream              : IETF
>> Verifying Party     : IESG
>=20
> _______________________________________________
> smime mailing list
> smime@ietf.org
> https://www.ietf.org/mailman/listinfo/smime


From nobody Thu Jan  9 17:42:05 2020
Return-Path: <pgut001@cs.auckland.ac.nz>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id E916C120288 for <smime@ietfa.amsl.com>; Thu,  9 Jan 2020 17:42:03 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.197
X-Spam-Level: 
X-Spam-Status: No, score=-4.197 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, DKIM_SIGNED=0.1, DKIM_VALID=-0.1, RCVD_IN_DNSWL_MED=-2.3, SPF_HELO_NONE=0.001, SPF_NONE=0.001, URIBL_BLOCKED=0.001] autolearn=ham autolearn_force=no
Authentication-Results: ietfa.amsl.com (amavisd-new); dkim=pass (2048-bit key) header.d=auckland.ac.nz
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id GqusdVIXNget for <smime@ietfa.amsl.com>; Thu,  9 Jan 2020 17:42:02 -0800 (PST)
Received: from mx4-int.auckland.ac.nz (mx4-int.auckland.ac.nz [130.216.125.246]) (using TLSv1.2 with cipher ECDHE-RSA-AES256-GCM-SHA384 (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 3C99F120830 for <smime@ietf.org>; Thu,  9 Jan 2020 17:42:00 -0800 (PST)
DKIM-Signature: v=1; a=rsa-sha256; c=simple/simple; d=auckland.ac.nz; i=@auckland.ac.nz; q=dns/txt; s=mail; t=1578620520; x=1610156520; h=from:to:cc:subject:date:message-id:references: in-reply-to:content-transfer-encoding:mime-version; bh=AGj/xJpLFWVugzc7+DfL0ePZcPqfdFQI4wJOd4kSkpE=; b=payx1IONzLGpqdrSa3Wqa/PsEqmba4Dk0o/ALQ8C/icDLtwWoRDbjsgT 3jG4DQiG4itJfbosg9LPvbVRzU0iUMzkkFrEEppb1U+c+PlLYGdtR2zgp sii5o9DMh4op876iIOvWAhpibVpGp4JOSfYXMOYeipbl5SNnYIqIaMn+5 8nl1BioNg5O86xiaB+5qR9UFmCLzGIuUbw4LoKo4ia58MzbIn+aw8NOHg KjhzR9qYqJq1rQ//hFJHqdIoDvzvTsb1Cuu1zFqwYKSeMuSgXbBHkpncz v3F9Y98y1O4Q0MMjXSdFd8tJVkoiWiSXU63wGIfWzcBIknG6C4ZuNG8sn Q==;
X-IronPort-AV: E=Sophos;i="5.69,414,1571655600"; d="scan'208";a="109022725"
X-Ironport-HAT: MAIL-SERVERS - $RELAYED
X-Ironport-Source: 10.6.2.4 - Outgoing - Outgoing
Received: from exchangemx.uoa.auckland.ac.nz (HELO uxcn13-ogg-c.UoA.auckland.ac.nz) ([10.6.2.4]) by mx4-int.auckland.ac.nz with ESMTP/TLS/AES256-SHA; 10 Jan 2020 14:41:58 +1300
Received: from uxcn13-ogg-d.UoA.auckland.ac.nz (10.6.2.5) by uxcn13-ogg-c.UoA.auckland.ac.nz (10.6.2.4) with Microsoft SMTP Server (TLS) id 15.0.1395.4; Fri, 10 Jan 2020 14:41:57 +1300
Received: from uxcn13-ogg-d.UoA.auckland.ac.nz ([10.6.2.5]) by uxcn13-ogg-d.UoA.auckland.ac.nz ([10.6.2.5]) with mapi id 15.00.1395.000; Fri, 10 Jan 2020 14:41:57 +1300
From: Peter Gutmann <pgut001@cs.auckland.ac.nz>
To: Russ Housley <housley@vigilsec.com>, Ben Kaduk <kaduk@mit.edu>
CC: "Roman D. Danyliw" <rdd@cert.org>, Eric Rescorla <ekr@rtfm.com>, "silversplash@gmx.com" <silversplash@gmx.com>, "paul.hoffman@vpnc.org" <paul.hoffman@vpnc.org>, IETF SMIME <smime@ietf.org>
Thread-Topic: [smime] [Technical Errata Reported] RFC2631 (5954)
Thread-Index: AQHVwa03GucJciL21U6Q49JWbzSZuaffTGqAgADDxwCAAxqFWg==
Date: Fri, 10 Jan 2020 01:41:56 +0000
Message-ID: <1578620520308.60959@cs.auckland.ac.nz>
References: <20200102204220.C652DF40707@rfc-editor.org> <20200108033645.GA57294@kduck.mit.edu>, <875F9475-2444-472E-9B1B-AF8C8691163B@vigilsec.com>
In-Reply-To: <875F9475-2444-472E-9B1B-AF8C8691163B@vigilsec.com>
Accept-Language: en-NZ, en-GB, en-US
Content-Language: en-NZ
X-MS-Has-Attach: 
X-MS-TNEF-Correlator: 
x-ms-exchange-transport-fromentityheader: Hosted
x-originating-ip: [130.216.158.4]
Content-Type: text/plain; charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/BKg1jvZX9n0PFDFPuQdo5nTkEE0>
Subject: Re: [smime] [Technical Errata Reported] RFC2631 (5954)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Fri, 10 Jan 2020 01:42:04 -0000

Russ Housley <housley@vigilsec.com> writes:=0A=
=0A=
>It sounds like Hold for Document Update is the best way to handle this one=
.=0A=
=0A=
The urgency would also depend on what's affected by it, since it only affec=
ts=0A=
FIPS 186-style keys which AFAIK nothing uses for DH, everything uses PKCS #=
3=0A=
keys with g=3D2 (see e.g. RFC 2409, RFC 3526, and RFC 7919).=0A=
=0A=
Peter.=0A=


From nobody Sun Jan 12 20:44:19 2020
Return-Path: <wwwrun@rfc-editor.org>
X-Original-To: smime@ietfa.amsl.com
Delivered-To: smime@ietfa.amsl.com
Received: from localhost (localhost [127.0.0.1]) by ietfa.amsl.com (Postfix) with ESMTP id 34B5D12004D; Sun, 12 Jan 2020 20:44:12 -0800 (PST)
X-Virus-Scanned: amavisd-new at amsl.com
X-Spam-Flag: NO
X-Spam-Score: -4.201
X-Spam-Level: 
X-Spam-Status: No, score=-4.201 tagged_above=-999 required=5 tests=[BAYES_00=-1.9, RCVD_IN_DNSWL_MED=-2.3, SPF_PASS=-0.001] autolearn=ham autolearn_force=no
Received: from mail.ietf.org ([4.31.198.44]) by localhost (ietfa.amsl.com [127.0.0.1]) (amavisd-new, port 10024) with ESMTP id p_EZYuysV-sT; Sun, 12 Jan 2020 20:44:10 -0800 (PST)
Received: from rfc-editor.org (rfc-editor.org [4.31.198.49]) (using TLSv1.2 with cipher AECDH-AES256-SHA (256/256 bits)) (No client certificate requested) by ietfa.amsl.com (Postfix) with ESMTPS id 876F3120013; Sun, 12 Jan 2020 20:44:10 -0800 (PST)
Received: by rfc-editor.org (Postfix, from userid 30) id B43E1F40712; Sun, 12 Jan 2020 20:44:09 -0800 (PST)
To: silversplash@gmx.com,  ekr@rtfm.com
X-PHP-Originating-Script: 30:errata_mail_lib.php
From: RFC Errata System <rfc-editor@rfc-editor.org>
Cc: kaduk@mit.edu, iesg@ietf.org, smime@ietf.org, rfc-editor@rfc-editor.org
Content-Type: text/plain; charset=UTF-8
Message-Id: <20200113044409.B43E1F40712@rfc-editor.org>
Date: Sun, 12 Jan 2020 20:44:09 -0800 (PST)
Archived-At: <https://mailarchive.ietf.org/arch/msg/smime/GV2g6Jb2XVP6fi8Uc9De3VCDQFo>
Subject: [smime] [Errata Held for Document Update] RFC2631 (5954)
X-BeenThere: smime@ietf.org
X-Mailman-Version: 2.1.29
Precedence: list
List-Id: SMIME Working Group <smime.ietf.org>
List-Unsubscribe: <https://www.ietf.org/mailman/options/smime>, <mailto:smime-request@ietf.org?subject=unsubscribe>
List-Archive: <https://mailarchive.ietf.org/arch/browse/smime/>
List-Post: <mailto:smime@ietf.org>
List-Help: <mailto:smime-request@ietf.org?subject=help>
List-Subscribe: <https://www.ietf.org/mailman/listinfo/smime>, <mailto:smime-request@ietf.org?subject=subscribe>
X-List-Received-Date: Mon, 13 Jan 2020 04:44:12 -0000

The following errata report has been held for document update 
for RFC2631, "Diffie-Hellman Key Agreement Method". 

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5954

--------------------------------------
Status: Held for Document Update
Type: Technical

Reported by: Paul Janson <silversplash@gmx.com>
Date Reported: 2020-01-02
Held by: Benjamin Kaduk (IESG)

Section: 2.1.5.

Original Text
-------------
     1. Verify that y lies within the interval [2,p-1]. If it does not,
        the key is invalid.
     2. Compute y^q mod p. If the result == 1, the key is valid.
        Otherwise the key is invalid.


Corrected Text
--------------
     1. Verify that y lies within the interval [2,p-1]. If it does not,
        the key is invalid.
     2. Compute y^q mod p. If the result == 1, the key is valid.
        Otherwise the key is invalid.
     3. Verify that y does not match g.


Notes
-----
Validating that (g == received y) needs to be an additional exclusion to the valid range [2,p-1]. If party 'a' accepts received public key 'yb' matching 'g', then ZZ matches  public key 'ya'. i.e. if yb = 2, then xb = 1, therefore ZZ = ya^1 = ya

--------------------------------------
RFC2631 (draft-ietf-smime-x942-07)
--------------------------------------
Title               : Diffie-Hellman Key Agreement Method
Publication Date    : June 1999
Author(s)           : E. Rescorla
Category            : PROPOSED STANDARD
Source              : S/MIME Mail Security
Area                : Security
Stream              : IETF
Verifying Party     : IESG

