Subject: [lamps] I-D Action: draft-ietf-lamps-pkix-shake-01.txt

From: [email-masked]
Date: Fri, 16 Feb 2018 06:54:04 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Limited Additional Mechanisms for PKIX and SMIME WG of the IETF.

        Title           : Internet X.509 Public Key Infrastructure: Additional SHAKE Algorithms and Identifiers for RSA and ECDSA
        Authors         : Panos Kampanakis
                          Quynh Dang
	Filename        : draft-ietf-lamps-pkix-shake-01.txt
	Pages           : 10
	Date            : 2018-02-16

Abstract:
   This document describes the conventions for using the SHAKE family of
   hash functions in the Internet X.509 as one-way hash functions with
   the RSA and ECDSA signature algorithms; the conventions for the
   associated subject public keys are also described.  Digital
   signatures are used to sign messages, certificates and CRLs
   (Certificate Revocation Lists).

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lamps-pkix-shake/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lamps-pkix-shake-01
https://datatracker.ietf.org/doc/html/draft-ietf-lamps-pkix-shake-01

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-pkix-shake-01

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Fri, 16 Feb 2018 14:57:11 +0000

Hello all, 

This draft updates the previous -00 version, based on group feedback. The updates include 
      *  Removed DSA after WG discussions.
      *  Updated shake OID names and parameters, added MGF1 section.
      *  Changed titles and section names.
      *  Updated RSASSA-PSS section.
      *  Added Public key algorithm OIDs.
      *  Populated Introduction and IANA sections.

Rgs,
Panos

-----Original Message-----
From: Spasm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, February 16, 2018 9:54 AM
To: [email-masked]
Cc: [email-masked]
Subject: [lamps] I-D Action: draft-ietf-lamps-pkix-shake-01.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Spasm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spasm

---

From: Russ Housley <[email-masked]>
Date: Fri, 16 Feb 2018 11:59:04 -0500

In Section 5, the closing curly brace in the ASN.1 fragment is part of the comment.

OLD

   ECParameters ::= CHOICE {	
      namedCurve OBJECT IDENTIFIER	
      -- implicitCurve NULL	
      -- specifiedCurve SpecifiedECDomain }

NEW

   ECParameters ::= CHOICE {	
      namedCurve OBJECT IDENTIFIER	
      -- implicitCurve NULL	
      -- specifiedCurve SpecifiedECDomain -- }

Russ

> On Feb 16, 2018, at 9:54 AM, [email-masked] wrote:
> 
>

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Fri, 16 Feb 2018 17:14:53 +0000

Ah right, good catch Russ. I updated the xml and it will be fixed in the next iteration.
Thank you

From: Spasm [mailto:[email-masked]] On Behalf Of Russ Housley
Sent: Friday, February 16, 2018 11:59 AM
To: SPASM <[email-masked]>
Subject: Re: [lamps] I-D Action: draft-ietf-lamps-pkix-shake-01.txt

OLD

NEW

Russ

On Feb 16, 2018, at 9:54 AM, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

_______________________________________________
Spasm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spasm