Subject: [lamps] Adam Roach's Yes on draft-ietf-lamps-rfc5750-bis-06: (with COMMENT)

From: Adam Roach <[email-masked]>
Date: Mon, 18 Jun 2018 19:38:16 -0700

Adam Roach has entered the following ballot position for
draft-ietf-lamps-rfc5750-bis-06: Yes

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lamps-rfc5750-bis/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thanks to everyone for the work put into updating this document. I reviewed
the diffs from the previous RFC, and the changes all seem to make sense.  I
found a couple of minor editorial nits.

---------------------------------------------------------------------------

§2.2.1:

>  Receiving agents MUST be able to parser and process a message
>  containing PKCS #6 extended certificates although ignoring those
>  certificates is expected behavior.

Nit: "...be able to parse..."

---------------------------------------------------------------------------

§A.1:

>  -  Hash functions used to validate signatures on historic messages
>     may longer be considered to be secure (see below).

Nit: "...may no longer..."

>     While there
>     are not currently any known practical pre-image or second pre-
>     image attacks against MD5 or SHA-1, the fact they are no longer
>     considered to be collision resistant the security levels of the
>     signatures are generally considered suspect.

This final clause appears to be missing some words. Consider rephrasing.

---

From: Jim Schaad <[email-masked]>
Date: Mon, 18 Jun 2018 19:54:31 -0700

> -----Original Message-----
> From: Adam Roach <[email-masked]>
> Sent: Monday, June 18, 2018 7:38 PM
> To: The IESG <[email-masked]>
> Cc: [email-masked]; Russ Housley
> <[email-masked]>; [email-masked]; [email-masked];
> [email-masked]
> Subject: Adam Roach's Yes on draft-ietf-lamps-rfc5750-bis-06: (with
> COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> Thanks to everyone for the work put into updating this document. I
> reviewed the diffs from the previous RFC, and the changes all seem to make
> sense.  I found a couple of minor editorial nits.
> 

          While there are not currently any known practical pre-image or second pre-image attacks against MD5 or SHA&nbhy;1, the fact they are no longer considered to be collision resistant implies that the security level of any signature that is created with that these hash algorithms should also be considered as suspect.

---

From: Adam Roach <[email-masked]>
Date: Mon, 18 Jun 2018 21:56:28 -0500

>            While there are not currently any known practical pre-image or second pre-image attacks against MD5 or SHA&nbhy;1, the fact they are no longer considered to be collision resistant implie…

Sounds good to me. Thanks!

/a