Subject: [lamps] I-D Action: draft-ietf-lamps-cms-shakes-11.txt

From: [email-masked]
Date: Mon, 17 Jun 2019 21:07:48 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Limited Additional Mechanisms for PKIX and SMIME WG of the IETF.

        Title           : Use of the SHAKE One-way Hash Functions in the Cryptographic Message Syntax (CMS)
        Authors         : Panos Kampanakis
                          Quynh Dang
	Filename        : draft-ietf-lamps-cms-shakes-11.txt
	Pages           : 17
	Date            : 2019-06-17

Abstract:
   This document describes the conventions for using the SHAKE family of
   hash functions with the Cryptographic Message Syntax (CMS) as one-way
   hash functions with the RSA Probabilistic signature and ECDSA
   signature algorithms, as message digests and message authentication
   codes.  The conventions for the associated signer public keys in CMS
   are also described.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-lamps-cms-shakes/

There are also htmlized versions available at:
https://tools.ietf.org/html/draft-ietf-lamps-cms-shakes-11
https://datatracker.ietf.org/doc/html/draft-ietf-lamps-cms-shakes-11

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-lamps-cms-shakes-11

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Tue, 18 Jun 2019 04:17:38 +0000

Hi all, 

This update addresses Roman's AD review from last week. 

The summary of the review and the fixes is here https://github.com/csosto-pk/adding-shake-to-pkix/issues/45#issuecomment-501801167 . 

The diff from the previous version is here https://tools.ietf.org/rfcdiff?url2=draft-ietf-lamps-cms-shakes-11.txt 

The goal is to standardize the PKIX SHAKEs draft first so we don't need to keep the OIDs in the IANA considerations of this draft as well. 

Thanks,
Panos

-----Original Message-----
From: Spasm <[email-masked]> On Behalf Of [email-masked]
Sent: Tuesday, June 18, 2019 12:08 AM
To: [email-masked]
Cc: [email-masked]
Subject: [lamps] I-D Action: draft-ietf-lamps-cms-shakes-11.txt

Abstract:

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

_______________________________________________
Spasm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spasm

---

From: Roman Danyliw <[email-masked]>
Date: Wed, 19 Jun 2019 11:53:35 +0000

Hi Panos!

Thanks for this quick revision.  One final questions based on this recent update.

-10 said: 
   This section defines six new object identifiers (OIDs) for using
   SHAKE128 and SHAKE256 in CMS.

-11 said: 
   This section defines four new object identifiers (OIDs) for using
   SHAKE128 and SHAKE256 in CMS.

Final nit.  I'm not tracking the change from four to six.  As I read the IANA section, only one new OID is being defined by this draft for the new CMS module (i.e., "TBD" per Appendix B).  TBD1 - TBD4 as referenced in Section 1 are actually being defined by draft-ietf-lamps-pkix-shake.  The other four OIDs come from [shake-nist-oids].  Therefore, I don't see how "this section defines" anything.  Doesn't this section "identify _eight_ OIDs for using ... in CMS"? Also, I say eight because I'm not sure why OIDs in [shake-nist-oids] are different than the yet to be defined OIDs from draft-ietf-lamps-pkix-shake.

Roman 

> From: Spasm [mailto:[email-masked]] On Behalf Of Panos
> Kampanakis (pkampana)
> Sent: Tuesday, June 18, 2019 12:18 AM
> To: [email-masked]
> Subject: Re: [lamps] I-D Action: draft-ietf-lamps-cms-shakes-11.txt
> 
> Hi all,
> 
> The summary of the review and the fixes is here https://github.com/csosto-
> pk/adding-shake-to-pkix/issues/45#issuecomment-501801167 .
> 
> The diff from the previous version is here
> https://tools.ietf.org/rfcdiff?url2=draft-ietf-lamps-cms-shakes-11.txt
> 
> The goal is to standardize the PKIX SHAKEs draft first so we don't need to
> keep the OIDs in the IANA considerations of this draft as well.
> 
> Thanks,
> Panos
> 
>

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Thu, 20 Jun 2019 03:45:52 +0000

You are right Roman. I thought I went back and addressed all similar nits, but I missed that. Yes, were not defining the eight OIDS, we are identifying them. 
"           This section identifies eight new object identifiers (OIDs) 
            for using SHAKE128 and SHAKE256 in CMS."

I updated it, but I will wait a bit before I upload again. 

Panos

-----Original Message-----
From: Roman Danyliw <[email-masked]> 
Sent: Wednesday, June 19, 2019 7:54 AM
To: Panos Kampanakis (pkampana) <[email-masked]>; [email-masked]
Subject: RE: [lamps] I-D Action: draft-ietf-lamps-cms-shakes-11.txt

Hi Panos!

-10 said: 

-11 said: 

Roman 

> The goal is to standardize the PKIX SHAKEs draft first so we don't 
> need to keep the OIDs in the IANA considerations of this draft as well.
> 
> Thanks,
> Panos
> 
> 
> Please note that it may take a couple of minutes from the time of 
> submission until the htmlized version and diff are available at tools.ietf.org.
>