Subject: [lamps] Éric Vyncke's No Objection on draft-ietf-lamps-pkix-shake-11: (with COMMENT)

From: Éric Vyncke via Datatracker <[email-masked]>
Date: Tue, 25 Jun 2019 00:43:42 -0700

Éric Vyncke has entered the following ballot position for
draft-ietf-lamps-pkix-shake-11: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-lamps-pkix-shake/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you all for the work put into this document.

== COMMENTS ==

-- Section 1 / Change log --

May I assume that the issues by the two reviews of -08 are solved in -11 ?

-- Section 4 --

== NITS ==

-- Abstract --

Just wondering why CRL acronym is expanded while SHAKE & ECDSA are not.

-- section 6 --

Also wondering why in some IANA entries "SHAKE" is in lower case while in others in upper case.

---

From: "Panos Kampanakis (pkampana)" <[email-masked]>
Date: Tue, 25 Jun 2019 21:29:01 +0000

Thanks for the review Eric. 

Your feedback and the answers below are also in https://github.com/csosto-pk/adding-shake-to-pkix/issues/48 

> May I assume that the issues by the two reviews of -08 are solved in -11 ?

Yes. And the upcoming update -12 will include all the fixes for the last 3 ballot position reviews. 

> Just wondering why CRL acronym is expanded while SHAKE & ECDSA are not.

Good point. Since we are in the abstract I made a change and kept CRL in there without expanding the acronym. But I made sure it is expanded in the first occurrence of the acronym in the Introduction section. We don't expand the SHAKE and ECDSA or RSASSA-PSS because these are algorithm names, not exactly abbreviated acronyms. 

> Also wondering why in some IANA entries "SHAKE" is in lower case while in others in upper case.

The RSASSA-PSS OIDs kept SHAKE in capitals because it seemed unnatural to put them lowercase after the capitals of RSASSA-PSS. For ecdsa we kept it lowercase because that is how the OIDs looked in the past for ecdsa-sha2. It is a little arbitrary, but that is why we made them look like that. 

The next iteration will be uploaded at the end of this week probably. 

Rgs,
Panos

-----Original Message-----
From: Spasm <[email-masked]> On Behalf Of Éric Vyncke via Datatracker
Sent: Tuesday, June 25, 2019 3:44 AM
To: The IESG <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: [lamps] Éric Vyncke's No Objection on draft-ietf-lamps-pkix-shake-11: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

== COMMENTS ==

-- Section 4 --

== NITS ==

-- Abstract --

-- section 6 --

_______________________________________________
Spasm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spasm