Subject: [Speechsc] Channel Identifiers in Requests and Responses

From: "Eric Burger" <[email-masked]>
Date: Fri, 6 Jun 2003 11:19:23 -0400

The SPEECHSC protocol often states (sections 3.4, 5.1, 5.3) that the Channel-Identifier header field SHOULD be used in requests and responses.

I would offer that requests and responses MUST use the Channel-Identifier.  That way, multiple resources, multiple streams, and pipelined requests/responses will ALWAYS work.

More importantly, from an implementer's perspective, parsing responses becomes considerably easier.  I don't need to keep special state sometimes depending on the request, what requests are outstanding, etc.

Disagreements?

_______________________________________________
Speechsc mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/speechsc

---

From: Sarvi Shanmugham <[email-masked]>
Date: Fri, 06 Jun 2003 09:28:34 -0700

Agreed.
My intention here was a MUST. :-) must have mistyped it.

Sarvi