Subject: [Speechsc] Proposal for HTTP State Management (cookies) in MRCP

From: "Dave Burke" <[email-masked]>
Date: Sun, 4 Apr 2004 17:27:51 +0100

Hi, Sarvi.

Attached is a proposal for handling cookies in MRCPv2. The text is intended for addition to Section 6.1 ("Generic Message Headers"). Thanks to Jeff for giving the proposal a "once over".

- Dave

---

From: "Dave Burke" <[email-masked]>
Date: Fri, 9 Apr 2004 13:04:56 +0100

Hi, Sarvi.

Attached is an update to the cookie proposal. 

Change log:
(1) Now specifies the behaviour in the event an origin server omits the Domain or Path attributes
(2) Removed optimisation comment (for only supplying cookie information relevant to a specific MRCP request). This would have often required recursive introspection to discover domain and path information (e.g. a referenced SSML document with embedded <audio> or a dynamic SRGS documents with external rulerefs etc)

Thanks to Jeff Bergan (Nuance) for spotting these issues!

- Dave
  ----- Original Message ----- 
  From: Dave Burke 
  To: Sarvi Shanmugham 
  Cc: IETF SPEECHSC (E-mail) 
  Sent: Sunday, April 04, 2004 5:27 PM
  Subject: [Speechsc] Proposal for HTTP State Management (cookies) in MRCP

  Hi, Sarvi.

  - Dave