Subject: [spfbis] Issue: Mixed use of RFC2119 words

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 6 Feb 2012 22:05:33 -0800

In scanning RFC4408, I see a number of places where "may" is used, but in all-lowercase, presumably to avoid invoking its RFC2119 meaning.  We have other words like "can", "might", "could" that do a better job of avoiding ambiguity.  I suggest this be revisited in production of the -bis version.

---

From: Dave CROCKER <[email-masked]>
Date: Tue, 07 Feb 2012 08:03:41 -0800

On 2/6/2012 10:05 PM, Murray S. Kucherawy wrote:
> In scanning RFC4408, I see a number of places where “may” is used, but in
> all-lowercase, presumably to avoid invoking its RFC2119 meaning. We have other
> words like “can”, “might”, “could” that do a better job of avoiding ambiguity. I
> suggest this be revisited in production of the –bis version.

In case folks missed this, this is a general RFC-style issue that finally 
prompted a draft set of suggestions:

    <http://datatracker.ietf.org/doc/draft-hansen-nonkeywords-non2119/>

d/

-- 

   Dave Crocker
   Brandenburg InternetWorking
   bbiw.net