Subject: [spfbis] Call for intermediate consensus on SPF RRTYPE (issue #9)

From: Arthur Thisell <[email-masked]>
Date: Sat, 25 Feb 2012 19:39:07 -0800 (PST)

If a tree falls in the middle of a forest, does it make a sound?

SPF is a protocol, a way of communicating between people.   SPF uses two channels for this communication, TXT and type 99 records.

It doesn't matter if there are giga-packets per second querying type 99 records, if there are very few type 99 records published, then that channel isn't being used to communicate.   There may be noise on that channel, but that's irrelevant.

It doesn't matter if there are millions of SPF records publish (TXT and type 99) and millions of queries for SPF records.   If all the queries actually go to domains that do not publish SPF records, then there isn't any communication going on and the whole SPF experiment is a failure and should be abandoned. 

I'm not being flippant here. One of the original complaints about SPF (even before MARID was created) was that there would be a lot of extra DNS traffic with no real way of even opting out, let alone opting in.  The worst case is some small domain gets joe-jobbed to a very wide number of other domains and all these domains do SPF queries, swamping the small domain.  There isn't anything the small domain can really do either, caching doesn't help because all the requests are coming from different sources.

Based on everything I've seen posted, the type 99 record is not used, it is just noise

As far published records, I'm surprised no one has mentioned the results on http://www.openspf.net/Statistics and The Masurement Factory in particular.  There newest survey of SPF records is from Oct 2010, but it documents rates of changes in publishing over the years.

---

From: Arthur Thisell <[email-masked]>
Date: Tue, 28 Feb 2012 12:03:44 -0800 (PST)

Too much hand waving debates, not enough data.

Again,the measurement factory's surveys give some information:

Note, these percentages appear to be of domains that responded to them
2006-08 5% have TXT SPF, 0 (not just 0% rounded) have type 99 SPF
2007-10 12.5% of working zones have TXT SPF, 46 (0.0022%) have type 99 SPF
2008-10 16.72% have some form of SPF record, the type was not broken down
2009-10 12.0% have TXT, 0.2% have SPF
2010-10 15.9% have TXT, 0.4% have SPF

in http://www.ietf.org/mail-archive/web/spfbis/current/msg00617.html
a preliminary survey of 1000 domains randomly chosen from Hotmail's SPF record cache does not find a single DNS type 99 record.

I seem to recall other stats posted, but I could not find them easily.

The measurement factory surveys change quite a bit from year to year in what they choose to look at, and the results bounce around a lot more than I would expect.   This might be explained by differences in methodology that I didn't notice, or that the random set of domain names resulted in a larger margin of error than I would expect.

In any case, the measurement factory's results show that type 99 records are a couple of percent of the TXT records.   If the results people are seeing now are only 1% or less, that gives evidence that deployment of type 99 records may be decreasing.  Or, maybe the people who publish type 99 records aren't really active in email and show up in great numbers of random domains than random emails.  No matter what, I can't see any evidence that the percentage of type 99 records is making enough of an increase to close the gap in the next several decades.