Subject: Re: [spfbis] #24: RFC 4408: Reasonable DNS error limits

From: Arthur Thisell <[email-masked]>
Date: Wed, 7 Mar 2012 03:47:52 -0800 (PST)

> Section 10 says:
>
>  SPF implementations MUST limit the number of mechanisms and modifiers
>  that do DNS lookups to at most 10 per SPF check, including any
>  lookups caused by the use of the "include" mechanism or the
>  "redirect" modifier. 

Good catch, Aleessandro.   That "lookups" should be "mechanisms or modifiers".   Can anyone think of a shorter/better term for the unwieldy "mechanism and/or modifier"?

---

From: Scott Kitterman <[email-masked]>
Date: Wed, 07 Mar 2012 07:24:50 -0500

On Wednesday, March 07, 2012 03:47:52 AM Arthur Thisell wrote:
> Good catch, Aleessandro.   That "lookups" should be "mechanisms or
> modifiers".   Can anyone think of a shorter/better term for the unwieldy
> "mechanism and/or modifier"?

FWIW, I think mechanisms and modifiers is correct.  You always have to count 
both, but sometimes the quantity of one of them is zero.  and/or just makes it 
more uncertain.

Scott K