Subject: Re: [spfbis] Possible new issue: deprecate ptr/%{p}

From: Arthur Thisell <[email-masked]>
Date: Wed, 7 Mar 2012 07:54:49 -0800 (PST)

> Given the backward compatibility requirements in the charter (this feature is 
> used), I don't think removal is in scope. 

A backward compatible change would be for ptr:/%{p} to always act as if there were network problems causing all DNS queries for this evaluation to be dropped.  This is a pretty common result anyway.   In effect, ptr: would never match and %{p} would always evaluate to "unknown".

I still lean toward moving the current note to the beginning of the ptr: description section and changing it to "SHOULD NOT publish", but I think we could effectively remove it if we wanted to.

---

From: "John Levine" <[email-masked]>
Date: 7 Mar 2012 17:16:58 -0000

>A backward compatible change would be for ptr:/%{p} to always act as if there were network
>problems causing all DNS queries for this evaluation to be dropped.

No, it wouldn't.  For people who use PTR and whose rDNS is set up
correctly (there is plenty of rDNS that works correctly), it would
break records that work now.

SHOULD NOT is fine.

R's,
John