Subject: Re: [spfbis] #7: RFC 4408 Downcase result names in spec text and ABNF

From: S Moonesamy <[email-masked]>
Date: Tue, 26 Jun 2012 10:38:32 -0700

At 22:29 17-02-2012, spfbis issue tracker wrote:
>#7: RFC 4408 Downcase result names in spec text and ABNF
>
>Comment (by sm+ietf@…):
>  Comment from MARF WG Chairs:
>
>  If SPFbis decides to change all the SPF result codes to all-lowercase
>  rather than the current camel case, then SPFbis will want to announce that
>  it updates draft-ietf-marf-spf-reporting

This issue is related to the comment from Scott 
Kitterman about RFC 6652 ( 
http://www.ietf.org/mail-archive/web/spfbis/current/msg01630.html ).

Regards,
S. Moonesamy

---

From: Scott Kitterman <[email-masked]>
Date: Tue, 26 Jun 2012 13:46:46 -0400

> http://www.ietf.org/mail-archive/web/spfbis/current/msg01630.html ).

I don't get this issue.  The result names are, and have always been, case 
insensitive, so I think the downcasing is purely stylistic.  Why does 4408bis 
need to update 6652 for this?

I do wonder if it makes sense to replicate the IANA registry information in 
6652 into 4408bis and then have 4408bis update 6652, but that's (AFAICT) 
unrelated to the downcasing question.

Scott K

---

From: S Moonesamy <[email-masked]>
Date: Tue, 26 Jun 2012 11:19:31 -0700

Hi Scott,
>need to update 6652 for this?

That was a comment from Murray Kucherawy as MARF WG Chair during the 
work on RFC 6652.

>unrelated to the downcasing question.

The Modifier Names registry has already been created.  I suggest 
waiting for Murray to comment as he may have a better recollection of 
the discussion in MARF.

Regards,
S. Moonesamy

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Tue, 26 Jun 2012 13:03:53 -0700

On Tue, Jun 26, 2012 at 11:19 AM, S Moonesamy <[email-masked]> wrote:

> That was a comment from Murray Kucherawy as MARF WG Chair during the work
> on RFC 6652.
>
>
> The Modifier Names registry has already been created.  I suggest waiting
> for Murray to comment as he may have a better recollection of the
> discussion in MARF.
>
>
It is entirely stylistic.  Things like Authentication-Results and even
Received-SPF use all-lowercase, so I thought it might be good to be
consistent even if the documents also say matching is to be
case-insensitive.

In particular, I think presenting in documents things in mixed case
suggests that case is important more than all-caps and all-lowercase do.

-MSK

---

From: Barry Leiba <[email-masked]>
Date: Wed, 27 Jun 2012 09:55:10 -0400

> In particular, I think presenting in documents things in mixed case suggests that
> case is important more than all-caps and all-lowercase do.

I think that is absolutely true.  For example, when I used "IMAPSieve"
as a keyword in draft-ietf-sieve-imap-sieve, I got multiple comments
that because that syntax element is defined as case-insensitive, I
should make it "imapsieve".  When I reminded them that
"case-insensitive" means that both are fine, people thought that the
mixed-case version invited confusion.

Barry