Subject: Re: [spfbis] #24: RFC 4408: Reasonable DNS error limits

From: S Moonesamy <[email-masked]>
Date: Wed, 22 Aug 2012 14:05:06 -0700

Hi Scott,

Issue #24 is based on the message at 
http://www.ietf.org/mail-archive/web/spfbis/current/msg00501.html

Could you suggest a resolution?

Thanks,
S. Moonesamy

---

From: Scott Kitterman <[email-masked]>
Date: Wed, 22 Aug 2012 18:45:34 -0400

> Could you suggest a resolution?

In general, I think that the current processing limits are reasonable and well 
documented and the text in the security considerations is appropriate.  It 
might be prudent to provide some additional constraint, provided we can do it 
in a backward compatible way.  This is discussed in:

http://www.ietf.org/mail-archive/web/spfbis/current/msg00850.html

It would be good to know if the information that's needed to assess the impact 
of such a void lookup limit can be garnered from the existing surveys and if 
the authors of one or more of the surveys would be up for gathering the data 
for us?

Scott K

---

From: S Moonesamy <[email-masked]>
Date: Wed, 22 Aug 2012 15:59:02 -0700

Hello,

I am addressing this message to the persons who did the surveys for RFC 6686.

>the authors of one or more of the surveys would be up for gathering the data

Could you please help with the above?

SPFBIS WG participants are also welcome to comment on this issue.

Regards.
S. Moonesamy
SPFBIS WG co-chair

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Wed, 22 Aug 2012 16:58:43 -0700

> I am addressing this message to the persons who did the surveys for RFC

I guess that's just me.  I think Philip has dropped off the list,
although I do have his original database available for anyone to
query.

> Could you please help with the above?

I don't think I have the background to know what a "void lookup" is.
Can someone explain?

Or even easier, what specific query do you need me to run?

I can also export the database to a MySQL script if someone wants to
run it without the intermediary.

-MSK

---

From: Scott Kitterman <[email-masked]>
Date: Wed, 22 Aug 2012 20:27:05 -0400

"Murray S. Kucherawy" <[email-masked]> wrote:

>> I am addressing this message to the persons who did the surveys for
>RFC
>> 6686.
>
It's a lookup for a mechanism/modifier that returns NXDOMAIN.  For example, the A lookup for example.com that results from a:example.com.  

The goal is to determine if we can set a maximum number without impacting existing records.  I suspect the impact will be low or nil since Mail:: SPF has had such a limit for some time without issue.

Scott K