Subject: Re: [spfbis] #39: Temporary errors implied as only caused by DNS errors

From: Arthur Thisell <[email-masked]>
Date: Thu, 30 Aug 2012 05:06:55 -0700 (PDT)

>>> but timeouts could be
>>>  caused by local problems unrelated to the DNS.

> Every time 4408 specifies returning a TempError it is because of a DNS error.

Again, timeouts do not need to be caused by DNS errors.  RFC 4408 was equally vague, saying only that temperror were transient errors while performing the SPF check.

---

From: Scott Kitterman <[email-masked]>
Date: Thu, 30 Aug 2012 08:07:40 -0500

Arthur Thisell <[email-masked]> wrote:

>Again, timeouts do not need to be caused by DNS errors.  RFC 4408 was
>equally vague, saying only that temperror were transient errors while
>performing the SPF check.

A timeout is a type of error that can occur with a DNS lookup.  You''re certainly correct it can happen for a variety of reasons, but I think it's still a DNS error.

Scott K