Subject: Re: [spfbis] review of 4408bis-06

From: Arthur Thisell <[email-masked]>
Date: Sun, 26 Aug 2012 15:39:25 -0700 (PDT)

>> I can not ever see version 1 of SPF having such an incompatible
>> change as getting rid of ptr:/%{p}. 
>
> Incompatible creates massive interoperability problems,

Agreed, which is why removing features in version 1 of SPF is so bad.

> absent a different port number of some other equally massive separation;
> version numbers don't get seen soon enough.

Which is why one of my suggestions was to go to exclusively type 99 SPF records for SPF3.0

(Oh, and Meng was very amused by IETF people forcing the sub version number, since no one could explain how it could ever be used.  Incompatible changes would be a major version, compatible stuff doesn't need a new version.)

>> Declaring something as deprecated in this I-D seems contrary to the
>> WG charter and contrary to version 1 of SPF.
>
> Not really, since it doesn't remove anything.  Rather, it's a marker for
> the future.

That's not true.  We have half-removed ptr:/%{p}.  Publishers SHOULD NOT use them.  OK, sure, publishers can make up an excuse to use them anyway and receivers still have to support it, so maybe say that it is 40% removed.

Given enough revisions that "do not remove any features", we can remove 99.999% of that feature!

I hate ptr:/%{p} for many of the reasons listed in 4408, but it isn't broken.

---

From: Dave Crocker <[email-masked]>
Date: Sun, 26 Aug 2012 15:49:24 -0700

> Which is why one of my suggestions was to go to exclusively type 99

Wow.

Why should we go exclusively with something that has received such poor
adoption and for which there are still adoption barriers.  (New DNS RRs
remain a challenge, for end-to-end interoperability.

d/
-- 
 Dave Crocker
 Brandenburg InternetWorking
 bbiw.net

---

From: Scott Kitterman <[email-masked]>
Date: Mon, 27 Aug 2012 17:13:07 -0400

> remain a challenge, for end-to-end interoperability.

That's true, but any SPF 3.0 proposal is a long ways off.  Since it will break 
from the current installed base, doing it in the new RR type is probably the 
way to go.

Scott K