Subject: [spfbis] Are "unknown modifiers" ever used?

From: Arthur Thisell <[email-masked]>
Date: Mon, 20 Aug 2012 08:54:56 -0700 (PDT)

Pardon my ignorance, I have done a very poor job keeping up on this list, but has there been any discussion about "unknown modifiers"?   Are they actually used by anyone, or are they misspellings of redirect=/exp=?

For those that don't know about them, RFC4408 didn't allow new/unknown mechanisms to be added, but did allow future expansion via new/unknown modifiers.   The idea was that you could create an SPF record that said "v=spf1 dkim=always", as your sender policy, and SPF would become the accepted sender policy framework.   To the best of my knowledge, no one ever used this feature and I suspect it reduces the reliability of SPF records by allow typos such as redir= to be silently ignored.

---

From: "Murray S. Kucherawy" <[email-masked]>
Date: Mon, 20 Aug 2012 10:31:04 -0700

> For those that don't know about them, RFC4408 didn't allow new/unknown mechanisms to be added, but did allow future expansion via new/unknown modifiers.   The idea was that you could create an SPF…

There was one proposed when this working group was chartered, but we
opted to remove it from the charter for the sake of simplicity through
the first round.

That's the only one of which I am aware.

-MSK

---

From: Scott Kitterman <[email-masked]>
Date: Mon, 20 Aug 2012 16:34:16 -0400

On Monday, August 20, 2012 08:54:56 AM Arthur Thisell wrote:
> Pardon my ignorance, I have done a very poor job keeping up on this list,
> but has there been any discussion about "unknown modifiers"?   Are they
> actually used by anyone, or are they misspellings of redirect=/exp=?
> 
> For those that don't know about them, RFC4408 didn't allow new/unknown
> mechanisms to be added, but did allow future expansion via new/unknown
> modifiers.   The idea was that you could create an SPF record that said
> "v=spf1 dkim=always", as your sender policy, and SPF would become the
> accepted sender policy framework.   To the best of my knowledge, no one
> ever used this feature and I suspect it reduces the reliability of SPF
> records by allow typos such as redir= to be silently ignored.

Up until recently I would have agreed with you.  However, thanks to RFC 6652 
there is now an IANA registry for modifiers and the first new modifiers officially 
defined.

Scott K