Subject: Re: [spfbis] #35: authorized_spf domain name - Section 9.1.1

From: S Moonesamy <[email-masked]>
Date: Wed, 29 Aug 2012 23:09:09 -0700

At 18:01 26-08-2012, spfbis issue tracker wrote:
>#35: authorized_spf domain name - Section 9.1.1
>
>  Message posted by Arthur Thisell on 22 Aug 2012:
>
>  Last, in section 9.1.1, an A record domain name "authorized_spf" is used,
>  which isn't a valid host name.  I'm not sure if that was intentional or
>  not, but most real SPF records would use a real host name.
>
>  http://www.ietf.org/mail-archive/web/spfbis/current/msg02199.html

The "authorized_spf" is not a valid.

Regards,
S. Moonesamy

---

From: Alessandro Vesely <[email-masked]>
Date: Thu, 30 Aug 2012 13:01:01 +0200

On Thu 30/Aug/2012 08:09:09 +0200 S Moonesamy wrote:
>> Last, in section 9.1.1, an A record domain name "authorized_spf"
>> is used, which isn't a valid host name.  I'm not sure if that
>> was intentional or not, but most real SPF records would use a
>> real host name.
>>

That's not an LDH name.  In the example, that label is used to
demonstrate an SPF trick, and breaking host names' preferred syntax is
a way to hint that it is not a label that already existed for some
other reason.  In real life, zone file writers can use non-LDH labels
to avoid cluttering their host name space.

If the above sounds nasty, or requires too much discussion, conversion
to LDH is straightforward and harmless.

---

From: Scott Kitterman <[email-masked]>
Date: Thu, 30 Aug 2012 09:42:36 -0500

>The "authorized_spf" is not a valid.

I changed the underscore to a hyphen locally.

Scott K