Subject: [spring] Lack of progress in SPRING WG

From: Stewart Bryant <[email-masked]>
Date: Tue, 28 Jan 2014 17:05:32 +0000

All,

We understood when the SPRING WG was formed that it was
addressing a problem of importance to both the network
operators and the equipment vendors.

We are therefore surprised that there seems to have been
no progress on setting out the requirements and architecture.

We are worried to see no apparent progress and we want to
understand what the problem is. If there is no interest in
continuing with this work in the IETF then we can close
the working group, but we suspect that there is actually
a lot of interest.

Stewart & Adrian

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Thu, 30 Jan 2014 10:31:02 +0000

Stewart,
 
There has been extended amount of work on segment routing, as clearly 
evidenced by the number of operator requirements, the vendors 
commitments to support the technology, the public demo’s, the operator 
presentations at open forums and the planned released of the technology 
by vendors.
 
In the IETF context, the work has also been impressive. We have 
produced 14 IETF drafts to date (http://www.segment-routing.net/home/ietf) 
among which the following protocol extensions:
 
. draft-previdi-isis-segment-routing-extensions
. draft-psenak-ospf-segment-routing-extensions
. draft-psenak-ospf-segment-routing-ospfv3-extension
. draft-sivabalan-pce-segment-routing
. draft-filsfils-spring-segment-routing-mpls
. draft-filsfils-spring-segment-routing-ldp-interop
 
have a clear consensus from all operators and vendors. We have made 
explicit effort to restructure our texts such that we had clear 
solutions documents specific to each protocol extension, separated 
from use-case documents. A lot of effort has been put in this. This 
should be recognized.
 
At the last IETF, there was wide consensus to adopt the segment 
routing use-cases draft. The only request that was made was to remove 
the illustrations based on segment routing such as to have a more 
generic problem statement document. We took that AI and we are about 
to release a 15th document to support spring work in London.
 
The amount of interest for Segment Routing is clear in the industry. 
The amount of energy spent to support the IETF process is clear. There 
is great consensus on the key elements as reflected by all the feedback 
provided at IETF meetings or on the list.
 
In this context, a smooth standardization process is to be expected. 
Don't you think so ?

Thanks.
s.

On Jan 28, 2014, at 6:05 PM, Stewart Bryant wrote:

> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: <[email-masked]>
Date: Thu, 30 Jan 2014 13:29:20 +0100

Stewart,

a new version of the OAM use case is ready for publication. I'm waiting for an IPR statement.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: spring [mailto:[email-masked]] Im Auftrag von Stewart Bryant
Gesendet: Dienstag, 28. Januar 2014 18:06
An: [email-masked]; [email-masked]
Cc: [email-masked]
Betreff: [spring] Lack of progress in SPRING WG

All,

We understood when the SPRING WG was formed that it was addressing a problem of importance to both the network operators and the equipment vendors.

We are therefore surprised that there seems to have been no progress on setting out the requirements and architecture.

We are worried to see no apparent progress and we want to understand what the problem is. If there is no interest in continuing with this work in the IETF then we can close the working group, but we suspect that there is actually a lot of interest.

Stewart & Adrian