Subject: Re: [spring] draft-previdi-isis-segment-routing-04

From: Xuxiaohu <[email-masked]>
Date: Mon, 27 Jan 2014 08:41:53 +0000

Hi Stefano and all,

It seems that the choice of using global MPLS labels or global SIDs to indicate prefix segments has been completely discarded by the Segment Routing. Instead, it used the global index allocated to a given prefix segment to determine the actual (local) SID/label value associated with that prefix segment.

I have two questions on this change as follows:

1) Is it infeasible to allocate the same SRGB label block throughout the SR domain in practice? Or it's no problem to do that allocation but this usage conflicts with the traditional usage of MPLS labels?
2) Provided that the usage of global labels is not acceptable anyway, why not directly use global SIDs to represent the prefix segments since the new SID space should have no such limitation as that for MPLS? In other words, if the SID space is used in the same way as that of MPLS labels (i.e., locally significant), what's the real meaning of introducing such a new SID space? 

Best regards,
Xiaohu

> -----邮件原件-----
> 发件人: Isis-wg [mailto:[email-masked]] 代表 Stefano Previdi
> (sprevidi)
> 发送时间: 2014年1月14日 17:16
> 收件人: Hannes Gredler; Chris Hopps (chopps); [email-masked]
> 主题: [Isis-wg] draft-previdi-isis-segment-routing-04
> 
> WG, Chris, Hannes,
> 
> As discussed during last meeting in Vancouver, I'd like you to consider
> draft-previdi-isis-segment-routing-extensions-04 as WG document.
> 
> Thanks.
> s.
> 
> _______________________________________________
> Isis-wg mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/isis-wg

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Mon, 27 Jan 2014 09:47:39 +0000

Hi Xiaohu,

On Jan 27, 2014, at 9:41 AM, Xuxiaohu wrote:
> Hi Stefano and all,
> 
> It seems that the choice of using global MPLS labels or global SIDs to indicate prefix segments has been completely discarded by the Segment Routing.

not exactly. An implementation may allow all routers to advertise the 
same range, starting from 0. This, de facto, is global labels/SIDs.

> Instead, it used the global index allocated to a given prefix segment to determine the actual (local) SID/label value associated with that prefix segment.

yes, and this allows you to have both modes: local and global.

> 1) Is it infeasible to allocate the same SRGB label block throughout the SR domain in practice? Or it's no problem to do that allocation but this usage conflicts with the traditional usage of MPLS…

Well, I think there may be inconsistencies between HW platforms on 
the label space capabilities so an easy way out is to use an indexed 
way of allocating SIDs. It allows complete transparency on the mpls 
dataplane (i.e.: not violating one of the strongest dogma: labels MUST 
be local ;-).

> 2) Provided that the usage of global labels is not acceptable anyway, why not directly use global SIDs to represent the prefix segments since the new SID space should have no such limitation as tha…

Have a look at the architecture. Segment Routing provides a new signaling 
plane for IPv[4|6]/MPLS networks, SR does not change MPLS dataplane.

So, if MPLS requires local labels, that's fine for SR. Now, if you have a 
network able to configure global labels, well, it's fine too.

The point is that the architecture and protocol extensions work for both 
models.

s.

> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Xuxiaohu <[email-masked]>
Date: Mon, 27 Jan 2014 10:06:47 +0000

Hi Stefano,

> -----邮件原件-----
> 发件人: Stefano Previdi (sprevidi) [mailto:[email-masked]]
> 发送时间: 2014年1月27日 17:48
> 收件人: Xuxiaohu
> 抄送: Hannes Gredler; Chris Hopps (chopps); [email-masked]; [email-masked]
> 主题: Re: [spring] draft-previdi-isis-segment-routing-04
> 
> Hi Xiaohu,
> 
> 
> > It seems that the choice of using global MPLS labels or global SIDs to indicate
> prefix segments has been completely discarded by the Segment Routing.
> 
> 
> not exactly. An implementation may allow all routers to advertise the same
> range, starting from 0. This, de facto, is global labels/SIDs.

Sure. However, that would make the architecture seems complex.

> > Instead, it used the global index allocated to a given prefix segment to
> determine the actual (local) SID/label value associated with that prefix segment.
> 
> 
> > 1) Is it infeasible to allocate the same SRGB label block throughout the SR
> domain in practice? Or it's no problem to do that allocation but this usage
> conflicts with the traditional usage of MPLS labels?
> 
> 
> > 2) Provided that the usage of global labels is not acceptable anyway, why not
> directly use global SIDs to represent the prefix segments since the new SID space
> should have no such limitation as that for MPLS? In other words, if the SID space
> is used in the same way as that of MPLS labels (i.e., locally significant), what's the
> real meaning of introducing such a new SID space?
> 
> 

My point is why not directly use the global SID to determine the actual label associated with a given prefix segment?

Best regards,
Xiaohu