Subject: [spring] FW: New Version Notification for draft-kim-source-routing-use-cases-01.txt

From: 김성수(Cloud SDN Project) <[email-masked]>
Date: Thu, 20 Feb 2014 08:03:49 +0000

Hi All,

  Just uploaded an updated version of the draft.
  We added more use cases, such as CDN and dual homing.
  Comments are welcomed.

Regards,

Sungsu Kim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Saturday, February 15, 2014 8:33 AM
To: 백은경(Cloud SDN Project); Jaewoo Park; Jaewoo Park; 백은경(Cloud SDN Project); 김성수(Cloud SDN Project); 김성수(Cloud SDN Project); Luis M. Contreras; Luis M. Contreras
Subject: New Version Notification for draft-kim-source-routing-use-cases-01.txt

A new version of I-D, draft-kim-source-routing-use-cases-01.txt
has been successfully submitted by Sungsu Kim and posted to the IETF repository.

Name:           draft-kim-source-routing-use-cases
Revision:       01
Title:          SPRING Use Cases for Software-defined Networking
Document date:  2014-02-14
Group:          Individual Submission
Pages:          9
URL:            http://www.ietf.org/internet-drafts/draft-kim-source-routing-use-cases-01.txt
Status:         https://datatracker.ietf.org/doc/draft-kim-source-routing-use-cases/
Htmlized:       http://tools.ietf.org/html/draft-kim-source-routing-use-cases-01
Diff:           http://www.ietf.org/rfcdiff?url2=draft-kim-source-routing-use-cases-01

Abstract:
   In the Software-Defined Networking (SDN) architecture, an SDN
   controller establishes flow paths.  An SDN controller provides global
   optimization of paths by controlling all managed switches.  However,
   long flow setup time and failure recovery problems arise due to
   control overhead of an SDN controller.  Segment routing provides
   source routing function by designating an explicit path.  SDN and
   segment routing can be combined to provide both global optimization
   and performance enhancement.  In this document, we illustrate SDN
   segment routing use cases of flow setup, failure recovery, Content
   Distribution Network(CDN), and dual homing.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

이 메일은 지정된 수취인만을 위해 작성되었으며, 중요한 정보나 저작권을 포함하고 있을 수 있습니다. 어떠한 권한 없이, 본 문서에 포함된 정보의 전부 또는 일부를 무단으로 제3자에게 공개, 배포, 복사 또는 사용하는 것을 엄격히 금지합니다. 만약, 본 메일이 잘못 전송된 경우, 발신인 또는 당사에 알려주시고, 본 메일을 즉시 삭제하여 주시기 바랍니다.
This E-mail may contain confidential information and/or copyright material. This email is intended for the use of the addressee only. If you receive this email by mistake, please either delete it without reproducing, distributing or retaining copies thereof or notify the sender immediately.

---

From: AshwoodsmithPeter <[email-masked]>
Date: Thu, 20 Feb 2014 16:41:45 +0000

Sungsu,

Just read over your draft. There is a lot of similarity with the draft we wrote (and presented) on SDN optimization using source routing last year. http://tools.ietf.org/html/draft-ashwood-sdnrg-state-reduction-00

You may be interested in the simulation work done by my co-author Mourand who looked at the reduction in messaging that occurs and the boost in performance that results in the SDN controller as a result. The benefits are dramatic as the diameter grows. This was presented also as:
http://www.ietf.org/proceedings/87/slides/slides-87-status-9.pdf

Recently we started looking at make-before-break for SDN and there again source routing has a huge advantage in reducing the load/complexity on the controller. This is especially important if the controller or an app is doing any kind of global optimization where small changes in flow patterns can result in substantial movement in flow/route assignments (i.e. make-before-break is a must or you cannot do global optimization without frequent interruptions to a lot of traffic).

We would certainly be open to collaborating on this use case if that is of interest to you.

Regards,

Peter Ashwood-Smith

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of ???(Cloud SDN Project)
Sent: Thursday, February 20, 2014 3:04 AM
To: [email-masked]
Subject: [spring] FW: New Version Notification for draft-kim-source-routing-use-cases-01.txt

Hi All,

Regards,

Sungsu Kim

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Saturday, February 15, 2014 8:33 AM
To: 백은경(Cloud SDN Project); Jaewoo Park; Jaewoo Park; 백은경(Cloud SDN Project); 김성수(Cloud SDN Project); 김성수(Cloud SDN Project); Luis M. Contreras; Luis M. Contreras
Subject: New Version Notification for draft-kim-source-routing-use-cases-01.txt

Abstract:

The IETF Secretariat

이 메일은 지정된 수취인만을 위해 작성되었으며, 중요한 정보나 저작권을 포함하고 있을 수 있습니다. 어떠한 권한 없이, 본 문서에 포함된 정보의 전부 또는 일부를 무단으로 제3자에게 공개, 배포, 복사 또는 사용하는 것을 엄격히 금지합니다. 만약, 본 메일이 잘못 전송된 경우, 발신인 또는 당사에 알려주시고, 본 메일을 즉시 삭제하여 주시기 바랍니다.
This E-mail may contain confidential information and/or copyright material. This email is intended for the use of the addressee only. If you receive this email by mistake, please either delete it without reproducing, distributing or retaining copies thereof or notify the sender immediately.
_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring