Subject: [spring] Comments on draft-kini-mpls-spring-entropy-label-00

From: Xuxiaohu <[email-masked]>
Date: Wed, 5 Mar 2014 14:31:26 +0000

Hi all,

The following are some of my comments on draft-kini-mpls-spring-entropy-label-00.

For option 4 - EL at specific depths of stack, it requires that ingress LSR determines depth to insert ELs for that LSP via labeldepthreading capability advertised (e.g. IGP) by each LSR. Since stacked LSPs are used in the SR paradigm to construct an explicit route, to achieve the above goal, it would require the ingress LSR to compute the shortest path from the egress node of each LSP point of view. Is it a bit heavyweight?

For option 3 and option 3', it requires change to the normal label operations, therefore,  I believe these two options are not much worthwhile to implement.

For option 2, if the ingress LSR has the capability to insert a lot of labels, and there is no MTU issue in a particular deployment case, this option is fine.

For option 1, it has the least side-effects compared to the other options.  Besides, this option follows the similar logic as that the entropy label concept: if intermediate LSRs could recongize the ELI, they could benefit from the EL. In the SR-MPLS case, if intermediate LSRs could read the ELI and recongize it, they could benefit from the EL.

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 5 Mar 2014 17:20:00 -0500

I liked the sliding option 3. In fact, this solution should not be limited to SPRING, but be applicable to
regular MPLS data plane per say. Not sure if entropy at each hierarchy is useful.

Regards,
himanshu

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: Wednesday, March 05, 2014 9:31 AM
To: [email-masked]
Subject: [spring] Comments on draft-kini-mpls-spring-entropy-label-00

Hi all,

For option 1, it has the least side-effects compared to the other options.  Besides, this option follows the similar logic as that the entropy label concept: if intermediate LSRs could recongize the ELI, they could benefit from the EL. In the SR-MPLS case, if intermediate LSRs could read the ELI and recongize it, they could benefit from the EL.
_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 6 Mar 2014 10:13:53 +0000

Hi Himanshu,

R1---R2---R3---R5
          |
         R4

Take the above figure as an example, assume there is a target LDP (or BGP) session running between R1 and R3, and there is a LDP (or BGP) session betwen R3 and R5. R5 is the egress of the LDP (or BGP) LSP and it use LDP (or BGP) to signal its ELC to the ingress of that LSP (say R1). The above LDP (or BGP) LSP will be encapsulted into another two-hierarchy SR LSP tunnel from R1 to R3 which is indicated as {SID(R4), SID (R3)}. Now assume R4 support ELC while R3 don't support ELC, once the MPLS packet belonging to the above hierarchical LSP tunnel arrives at R4, how could R4 reuse the EL in option 3?

Best regards,
Xiaohu

__________________________________
发件人: Shah, Himanshu [[email-masked]]
发送时间: 2014年3月6日 6:20
收件人: Xuxiaohu; [email-masked]
主题: RE: Comments on draft-kini-mpls-spring-entropy-label-00

Regards,
himanshu

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: Wednesday, March 05, 2014 9:31 AM
To: [email-masked]
Subject: [spring] Comments on draft-kini-mpls-spring-entropy-label-00

Hi all,