Subject: [spring] 答复: Comments on Section 2// WG Adoption Call for draft-martin-spring-segment-routing-ipv6-use-cases

From: Lizhenbin <[email-masked]>
Date: Thu, 27 Mar 2014 17:13:09 +0000

Alvaro,

Section 2 of draft-martin-spring-segment-routing-ipv6-use-cases presents as follows:

"

     4.  There is a need to connect millions of addressable segment
       endpoints, thus high routing scalability is a requirement.  IPv6
       addresses are inherently summarizable: a very large operator
       could scale by summarizing IPv6 subnets at various internal
       boundaries.  This is very simple and is a basic property of IP
       routing.  MPLS node segments are not summarizable.  To reach the
       same scale, an operator would need to introduce additional
       complexity, such as mechanisms described in
       [I-D.ietf-mpls-seamless-mpls]

"

Comments is as follows:

1. I wonder why here mention the comparison with seamless MPLS. They are totally different scenarios. Do authors think that if the whole seamless MPLS network changes to only use IPv6, there will not be addtional complexitiy comparing with seamless MPLS?

2. MPLS label can also be allocated to the subnet IP address. In my opinion, it is summarizable. MPLS is not summarized because the service need the LSP to host IP address. But this does not mean MPLS are not summarizable. Could you please clarify what it mean "MPLS node segments are not summarizable"?

Regards,

Zhenbin(Robin)

> Hi!
>
> This message officially starts the call for adoption for
> draft-martin-spring-segment-routing-ipv6-use-cases.
>
> Please indicate your position about adopting this use cases
> draft by end-of-day on March 27, 2014.
>
> http://tools.ietf.org/html/draft-martin-spring-segment-routing-ipv6-use-ca
ses
> Thanks!

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 27 Mar 2014 18:58:31 +0100

Hi Robin,

> Comments is as follows:
>
> 1. I wonder why here mention the comparison with seamless MPLS. They are
> totally different scenarios. Do authors think that if the whole seamless
> MPLS network changes to only use IPv6, there will not be addtional
> complexitiy comparing with seamless MPLS?

It is common to see dual stack networks end to end. It is also real to
see v6 only networks today.

> 2. MPLS label can also be allocated to the subnet IP address. In my opinion,
> it is summarizable. MPLS is not summarized because the service need the LSP
> to host IP address. But this does not mean MPLS are not summarizable. Could
> you please clarify what it mean "MPLS node segments are not summarizable"?

How do you summarize subnet 10.1.1.0/24 with label 1001 through subnet
10.1.254.0/24 with label 1254 at any given point in the network ? What
is the resulting label for 10.1.0.0/16 ? And how does the resulting
label lookup provides sufficient information for swap operation
without additional IP lookup ?

That's what industry means by stating that MPLS scaling is limited due
to inherent lack of summarization.

Best,
R.