Subject: [spring] Comments on Section 2.4//WG Adoption Call for draft-martin-spring-segment-routing-ipv6-use-cases

From: Lizhenbin <[email-masked]>
Date: Thu, 10 Apr 2014 16:40:42 +0000

Alvaro,

Regarding the section IPv6 Segment Routing in the Core networks, I have following comments:
In order to justify the requirement, I think it tries to romove all possible options for the designed core network:
-- MPLS: it is definitely be removed firstly.
-- L2VPN/L3VPN: it is related with MPLS. I think it is naturally removed. Then the designed core network has no purpose to bear L2VPN/L3VPN service. The network is only for IP routing.
-- IPv4: it is removed for the reason clarified by the text's self. That is, there should be no co-existence of IPv4 and IPv6. Or else, the use cases described for segment routing can only apply to IPv6. The network is only for IPv6 routing.
-- Multicast: Segment routing cannot cover the use case. The multicast service should be removed. Then network is only for IPv6 unicast routing.
Then I do not think the debates on the draft should not be simply blamed on the choice between IPv6 or MPLS. I wonder how many operators perfers the designed core network for IPv6 segment routing and whether it is necessary to introduce complex IPv6 segment routing fowarding for the limited scenarios.

Regards,
Zhenbin(Robin)

> Hi!
>
> This message officially starts the call for adoption for
> draft-martin-spring-segment-routing-ipv6-use-cases.
>
> Please indicate your position about adopting this use cases draft by
> end-of-day on March 27, 2014.
>
> http://tools.ietf.org/html/draft-martin-spring-segment-routing-ipv6-us
> e-ca
ses
> Thanks!

>From section 2.5:

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

_______________________________________________
spring mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/spring

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 11 Apr 2014 00:38:07 +0200

Hello Robin,

> -- MPLS: it is definitely be removed firstly.

No - no one is suggesting to get rid of MPLS. Please observed that
some government networks and obligated by law  to run only IPv6.
Moreover please also note that new networks architecture *ONLY* assume
that core is IPv6 .. example TeraStream

Ref: https://ripe67.ripe.net/presentations/131-ripe2-2.pdf

> -- L2VPN/L3VPN: it is related with MPLS. I think it is naturally removed.
> Then the designed core network has no purpose to bear L2VPN/L3VPN
> service. The network is only for IP routing.

Completely wrong.

L2VPN and L3VPN run fine over pure IP network. You need to distinguish
transport from application. MPLS is great demux for applications.
However as far as transport I would argue IP is a better choice.

As you know MPLS over GRE is widely used today in many environments
running MPLS less transport.

So your above statement for services is dead wrong.

> -- IPv4: it is removed for the reason clarified by the text's self. That is,
> there should be no co-existence of IPv4 and IPv6. Or else, the use
> cases described for segment routing can only apply to IPv6. The
> network is only for IPv6 routing.

No .. you have got this sentence wrong as well - sorry :(

Document first lists number of requirements then says:

   "IPv4 protocol does not provide such functionalities today and it is
   not the intent of this document to address the IPv4 scenario, both
   because this may create a lot of backward compatibility issues with
   currently deployed networks and for the security issues that may
   raise."

It does not say that IPv4 should be removed nor it says that there
should be no co-existance of IPv4 and IPv6.

> -- Multicast: Segment routing cannot cover the use case. The multicast
> service should be removed. Then network is only for IPv6 unicast routing.

As mentioned already there are few other protocols today other then
mLDP and p2mp & mp2mp RSVP-TE to handle multicast quite well.

That includes controlled tree constructions via different network topologies.

Those tools are widely known and used so claim that multicast service
should be removed is dead wrong again. No one claims that.

> Then I do not think the debates on the draft should not be simply
> blamed on the choice between IPv6 or MPLS. I wonder how many
> operators perfers the designed core network for IPv6 segment
> routing and whether it is necessary to introduce complex IPv6
> segment routing fowarding for the limited scenarios.

I would recommend to allow actual operators to make the design choice
for their networks rather then allow vendors to decide for them.

Please notice that main editors of this document are actually folks
running networks so even if one would like to have an inter-operable
solution it should be more then sufficient for this WG to work on it.

Best regards,
R.

---

From: Stewart Bryant <[email-masked]>
Date: Sun, 20 Apr 2014 22:43:32 +0100

On 10/04/2014 23:38, Robert Raszuk wrote:
> Please observed that some government networks and obligated by law to 
> run only IPv6.

That remark reminds be of the government directive that all departments 
would run the
Government OSI Protocol and communications with government would use same.

Stewart