Subject: [spring] Mail regarding draft-francois-spring-resiliency-use-case

From: Gregory Mirsky <[email-masked]>
Date: Tue, 1 Apr 2014 19:34:30 +0000

Dear Authors, et. al,
please find my comments and questions to the latest version below. Thank you for your kind consideration.

*         Would you agree that use case document is more appropriate on Informational rather than Standard track

*         Introduction, second para

o   Precomputation and instantiation of protection/backup paths is characteristic of all protection mechanisms, local, segment and end-to-end.

o   "The term "protection" is often used as a synonym for FRR." I think that it is "local protection" that is being equated and used interchangeably with FRR. End-to-end protection, whether linear or ring, equally supports 10msec fault detection as fault detection latency is not characteristic of protection mechanism but of interval used in continuity check OAM.

*         Section 3

o   first sentence s/in/of/

o   Does local protection in SPRING network domain takes into consideration SID labels. If SID labels are not being considered when pre-calculating backup tunnels then it is possible that after the switchover end-to-end path fails. On the other hand, if SID labels being considered, then, in general case, intermediate node must maintain path information, which is not as Segment Routing paradigm being defined at this time.

Regards,
                Greg

---

From: Pierre Francois <[email-masked]>
Date: Tue, 1 Apr 2014 21:59:04 +0200

Hello Greg,

Answers inline.

Sent from my iPhone

> On Apr 1, 2014, at 9:34 PM, Gregory Mirsky <[email-masked]> wrote:
> 
> Dear Authors, et. al,
> ·         Would you agree that use case document is more appropriate on Informational rather than Standard track

Indeed. I'll change it for -02.

> ·         Introduction, second para
> o   “The term "protection" is often used as a synonym for FRR.” I think that it is “local protection” that is being equated and used interchangeably with FRR. End-to-end protection, whether linear or ring, equally supports 10msec fault detection as fault detection latency is not characteristic of protection mechanism but of interval used in continuity check OAM

Indeed. I'll fix it in next rev.

> ·         Section 3

Thanks for the catch.

> o   Does local protection in SPRING network domain takes into consideration SID labels. If SID labels are not being considered when pre-calculating backup tunnels then it is possible that after the…

Well now that the draft is not about solutions or specifics of SR, this is not a problem anymore :) 

More seriously, yes, in SR, you have to pay attention to label allocation when installing your failover entries in the FIB. However I do not see why it leads to having intermediate nodes maintain path information. 
Can you expand on this part of your comment?

Cheers,

Pierre.

> Regards,
>                 Greg
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Gregory Mirsky <[email-masked]>
Date: Thu, 3 Apr 2014 20:48:50 +0000

Hi Pierre,
clipped things we’ve already agreed on. Added note under GIM>> tag.

                Regards,
                                Greg

[snip]

GIM>> Link mode of local protection does not require any special consideration as the MP is the same next-hop node of the protected link. But for node mode of local protection special consideration must be given if SID functionality to be used. Consider case when the next-hop node has advertised SID that is used by some e2e paths that traverse the PLR and this node. As result, IMO, selection of the MP depends not only on next-next-hop node of the SR path but on availability of particular SID as well. Now we can make it more complex if the protected node owns not one but several SIDs. I think that we may easily avoid this complexity/mess by stating that only link mode local protection is applicable to SPRING domains and leave service protection/redundancy to Service/SFC OAM layer.

Cheers,

Pierre.

Regards,
                Greg
_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 3 Apr 2014 23:01:58 +0200

Hi Greg & Pierre,

 More seriously, yes, in SR, you have to pay attention to label allocation
> when installing your failover entries in the FIB. However I do not see why
> it leads to having intermediate nodes maintain path information.
>
> GIM>> Link mode of local protection does not require any special
> consideration as the MP is the same next-hop node of the protected link.
> But for node mode of local protection special consideration must be given
> if SID functionality to be used. Consider case when the next-hop node has
> advertised SID that is used by some e2e paths that traverse the PLR and
> this node. As result, IMO, selection of the MP depends not only on
> next-next-hop node of the SR path but on availability of particular SID as
> well. Now we can make it more complex if the protected node owns not one
> but several SIDs. I think that we may easily avoid this complexity/mess by
> stating that only link mode local protection is applicable to SPRING
> domains and leave service protection/redundancy to Service/SFC OAM layer.
>

I think you are both right :)

I think what Greg you are refering to is state of the repair "paths" in
regards to IGP topology which clearly is required by all node protection
solutions.

Contrary what I think Pierre consider as "path" is the end to end traffic
flow paths which would normally result in 100s or 1000s LSPs state - that
clearly is not required in SR node protection.

So what may be helpful is to rather then overloading term "path" here
redefine it for the purpose of this discussion into IGP topology state (as
example).

Cheers,
R.

---

From: Pierre Francois <[email-masked]>
Date: Fri, 4 Apr 2014 11:17:23 +0200

Robert, 

Thanks for the clarification :)

Greg, 

There are operators who want to have the network provide such protection. 
You mind if I leave such approaches in the use-case doc, and we re-raise such very relevant complexity/mess questions
when solution drafts are discussed?

Cheers, 

Pierre.

On Apr 3, 2014, at 11:01 PM, Robert Raszuk <[email-masked]> wrote:

> I think what Greg you are refering to is state of the repair "paths" in regards to IGP topology which clearly is required by all node protection solutions. 
> 
> Contrary what I think Pierre consider as "path" is the end to end traffic flow paths which would normally result in 100s or 1000s LSPs state - that clearly is not required in SR node protection. 
> 
> So what may be helpful is to rather then overloading term "path" here redefine it for the purpose of this discussion into IGP topology state (as example).
> 
> Cheers,
> R.
> 
> 
> 
> 
> 
>

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 4 Apr 2014 17:11:36 +0000

Hi Pierre,
agree, it does make sense to have local protection use case(s). We can get into more details in requirements and draw conclusions with gap analysis doc.

                Regards,
                                Greg

From: Pierre Francois [mailto:[email-masked]]
Sent: Friday, April 04, 2014 2:17 AM
To: Robert Raszuk
Cc: Gregory Mirsky; [email-masked]; [email-masked]
Subject: Re: [spring] Mail regarding draft-francois-spring-resiliency-use-case

Robert,

Greg,

Cheers,

Pierre.

On Apr 3, 2014, at 11:01 PM, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:

Hi Greg & Pierre,

Cheers,
R.