Subject: [spring] carrying IPv6 and IPv4 packets using SPRING/SR with MPLS dataplane

From: Chris Bowers <[email-masked]>
Date: Tue, 2 Sep 2014 15:12:18 +0000

Has there been any discussion about how to carry both IPv6 and IPv4 packets with SPRING/SR MPLS labels?  From what I can tell, neither draft-filsfils-spring-segment-routing-04 nor draft-filsfils-spring-segment-routing-mpls-03 addresses this scenario.

In the context of shortest-path forwarding using Node-SID labels, there would seem to be two main approaches to consider.  One could distinguish between IPv6 and IPv4 packets by using two different Node-SID labels for the same node.  Or one could use IPv6 and/or IPv4 Explicit Null labels pushed on the bottom of the label stack by the SR ingress router.

Do the authors of these drafts or other working group participants have an opinion on the best way to address this scenario?

Thanks,
Chris

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Tue, 2 Sep 2014 15:21:01 +0000

Hi Chris,

> Has there been any discussion about how to carry both IPv6 and IPv4 packets with SPRING/SR MPLS labels?  From what I can tell, neither draft-filsfils-spring-segment-routing-04 nor draft-filsfils-sp…

sid's are assigned to ip addresses (e.g. intf addresses). A node having two loopbacks (v4/v6) will have a sid for the ipv4 address and another one for the ipv6.

Then you compute your spt's or explicit paths based on your af-topology and you pick the right sid's stack.

> In the context of shortest-path forwarding using Node-SID labels, there would seem to be two main approaches to consider.  One could distinguish between IPv6 and IPv4 packets by using two different Node-SID labels for the same node.

correct. this is same as above: one sid per address (one for v4 and one for v6).

s.

>  Or one could use IPv6 and/or IPv4 Explicit Null labels pushed on the bottom of the label stack by the SR ingress router.
>  
> _______________________________________________
> spring mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/spring

---

From: Chris Bowers <[email-masked]>
Date: Tue, 2 Sep 2014 16:17:01 +0000

Stefano,

Thanks.  Is there a mechanism to advertise different label blocks for v4 and v6 and have a single unique index value associated with the node?  This would still result in different label values being used for v4 and v6 packets destined for the same node, but the network operator only has to assign a single unique index value to each node.

Chris

-----Original Message-----
From: Stefano Previdi (sprevidi) [mailto:[email-masked]] 
Sent: Tuesday, September 02, 2014 10:21 AM
To: Chris Bowers
Cc: [email-masked]; [email-masked]
Subject: Re: [spring] carrying IPv6 and IPv4 packets using SPRING/SR with MPLS dataplane

Hi Chris,

s.

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Tue, 2 Sep 2014 16:39:26 +0000

On Sep 2, 2014, at 6:17 PM, Chris Bowers wrote:
> Stefano,
> 
> Thanks.  Is there a mechanism to advertise different label blocks for v4 and v6 and have a single unique index value associated with the node?

there's a mechanism that allows you to advertise multiple label blocks and the index is used across all of them (see isis/ospf sr extensions drafts). Not sure if you need to explicitly advertise the af of the label block knowing that a sid corresponds to a prefix which implies its af.

s.

>  This would still result in different label values being used for v4 and v6 packets destined for the same node, but the network operator only has to assign a single unique index value to each node.
> 
> Chris
>

---

From: Gregory Mirsky <[email-masked]>
Date: Tue, 2 Sep 2014 16:50:54 +0000

Hi,
another method been used to differentiate IPv4 and IPv6 payload over MPLS LSP by LERs:
*       IPv4 Explicit Null label for IPv4 payload;
*       IPv6 Explicit Null label for IPv6 payload.

        Regards,
                Greg

-----Original Message-----
From: spring [mailto:[email-masked]] On Behalf Of Stefano Previdi (sprevidi)
Sent: Tuesday, September 02, 2014 9:39 AM
To: Chris Bowers
Cc: [email-masked]; [email-masked]
Subject: Re: [spring] carrying IPv6 and IPv4 packets using SPRING/SR with MPLS dataplane

s.

> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
>> [email-masked]<mailto:[email-masked]>

_______________________________________________
spring mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/spring