Subject: Re: [spring] Regarding SID/Lable distributed by IGPs

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Sun, 28 Sep 2014 06:28:56 +0000

In the OSPF/ISIS drafts on SR we scoped an algorithm field which could be used for this purpose. So besides shortest path you could use a different algorithm.

From: Veerendranatha Reddy Vallem <[email-masked]<mailto:[email-masked]>>
Date: Sunday 28 September 2014 08:15
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [spring] Regarding SID/Lable distributed by IGPs

Hi,
I have a small query related to SID distributed by IGPs in the SR. Can anybody help me to clarify this.
The SID/Label distributed by IGPs (OSPF or ISIS) for the prefixes/Nodes   should represent Shortest Path to the given prefix or  node?
We can use same Labels for other representation like Best Effort Path also ? (The label distribution done by OSPF, but the next-hop  for the node is calculated by other IGPs based on administrative decision)

Regards,
Veerendranath

---

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Sun, 28 Sep 2014 06:47:57 +0000

Hi Henderick,
Thanks for your reply.
Yes, I found algorithm filed in TLVs. While constructing LSP , whether we need to provide the algorithm  mapping information along with label/SID ?
I think for construction of label stack ,it required to know  what label represents (whether it is shortest path or best path to the given node/prefix),
so we should have algorithm mapping information also along with label in SIDB.
Please let me know if my understanding is wrong .

Whether we can use multiple algorithms to represent same Node SID ?

Regards,
Veerendranath

From: Henderickx, Wim (Wim) [mailto:[email-masked]]
Sent: 28 September 2014 14:29
To: Veerendranatha Reddy Vallem; [email-masked]
Subject: Re: [spring] Regarding SID/Lable distributed by IGPs

Hi,

Regards,
Veerendranath

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Sun, 28 Sep 2014 06:52:54 +0000

At this stage we defined the solution such that a given SID/Label is associated with 1 algorithm.

From: Veerendranatha Reddy Vallem <[email-masked]<mailto:[email-masked]>>
Date: Sunday 28 September 2014 08:47
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [spring] Regarding SID/Lable distributed by IGPs

Hi Henderick,
Thanks for your reply.

Regards,
Veerendranath

From: Henderickx, Wim (Wim) [mailto:[email-masked]]
Sent: 28 September 2014 14:29
To: Veerendranatha Reddy Vallem; [email-masked]<mailto:[email-masked]>
Subject: Re: [spring] Regarding SID/Lable distributed by IGPs

Hi,

Regards,
Veerendranath

---

From: Veerendranatha Reddy Vallem <[email-masked]>
Date: Sun, 28 Sep 2014 07:02:03 +0000

Hi Henderick,
Thanks for your reply.
If I use OSPF/ ISIS SID in my label/SID stack for data forwarding, by default the label represents shortest path for the given prefix/node?
If I use different algorithm for the same label/SID, I must notify which algorithm I used to for this label/SID while constructing label stack for specific path?

Regards,
Veerendranath

From: Henderickx, Wim (Wim) [mailto:[email-masked]]
Sent: 28 September 2014 14:53
To: Veerendranatha Reddy Vallem; [email-masked]
Subject: Re: [spring] Regarding SID/Lable distributed by IGPs

Hi Henderick,
Thanks for your reply.

Regards,
Veerendranath

Hi,

Regards,
Veerendranath

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Sun, 28 Sep 2014 07:08:58 +0000

Yes you should advertise the Node-SID with the algorithm you want to use for this prefix
On top you should advertise the algorithm in the capability TLV for ISIS/OSPF

From: Veerendranatha Reddy Vallem <[email-masked]<mailto:[email-masked]>>
Date: Sunday 28 September 2014 09:02
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [spring] Regarding SID/Lable distributed by IGPs

Hi Henderick,
Thanks for your reply.

Regards,
Veerendranath

Hi Henderick,
Thanks for your reply.

Regards,
Veerendranath

Hi,

Regards,
Veerendranath