Subject: Re: [spring] Do we really need such a diversity

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Thu, 13 Nov 2014 23:32:30 +0000

-----Original Message-----
> From: Stefano Previdi (sprevidi) [[email-masked]]
> Received: Thursday, 13 Nov 2014, 13:13
> To: [email-masked] [[email-masked]]; [email-masked] [[email-masked]]
> Subject: RE: [spring] Do we really need such a diversity
>
> Xiaohu,
>
>At this stage there's no need to have shorter sid 's for ipv6 also because the current use
> cases afdressed by existing implementations do not require any igp anyway.

I meant "igp extensions" of course...

s.

> IOW, segments
> do not represent igp shortest paths but rather application/service instances.
>
> We MAY want to consider other sid formats but that would be another use case.

-----Original Message-----

From: Xuxiaohu [[email-masked]]

Received: Thursday, 13 Nov 2014, 10:21

To: [email-masked] [[email-masked]]

Subject: [spring] Do we really need such a diversity

Hi,

As I had mentioned at the mic, the IPv6-SR-header draft proposes to use an ordered list of IPv6 addresses to represent an explicit path. In this way, there is no need for any IGP extension. That’s fine although I don’t
know whether such a trade-off is much worthwhile (i.e., encapsulation overhead vs control plane change). However, in the IGP extension for SR drafts, there are still some descriptions about the 32-bit SID. Does it mean we may come back someday to consider
how to use an ordered list of SIDs instead of an ordered list of IPv6 addresses to represent an explicit path. If so, I wonder why not directly use an ordered list of (MPLS) labels rather than an order list of 32-bit SIDs. By using an ordered list of labels
(i.e., a label stack) in the packet, the underlay could be IPv4, IPv6 and even MPLS. In other words, such an SR header is transport-independent. In a word, I just wonder whether we do need so many various solutions.

Best regards,

Xiaohu

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 18 Nov 2014 21:59:35 +0000

Hi Stefano,

===============
=================

We have IGP extensions for MPLS data plane (even for IPv6) but I saw some extensions for IPv6 data plane?
https://tools.ietf.org/html/draft-ietf-isis-segment-routing-extensions-03

Section 2.2

  An ipv6 address SID is encoded in 16 octets (IPv6 Adj-SID is defined
   in [I-D.previdi-6man-segment-routing-header]).

Could you please clarify? I presume this is only for IPv6 ADJ SIDs?

--
Uma C.

---

From: "Stefano Previdi (sprevidi)" <[email-masked]>
Date: Tue, 18 Nov 2014 22:26:28 +0000

> Hi Stefano,

correct. As I stated in my original email, the use-case we are working at does not require any igp extension because it's more about using sr as an overlay on top of an infrastructure.

s.